Subject: RE: [Ecrit] LUMP and mapping architecture documents

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 7 Nov 2005 23:05:40 -0600

My apologies Henning, that last statement was an outright falsehood.

There was a mismatch between my expectations and the actual implementation.  "gml:position" isn't part of any substitution groups - it is a GML "property" which means that it is not a "GML Object".  I was distracted by the reference to feature.xsd in PIDF-LO - GML features are (currently) not used at all.

For that reason, if you want to use GML, you are given two choices:

  <xs:any namespace="http://www.opengis.net/gml" processContents="lax|strict"/>

Or just be even more liberal any allow any content:

  <xs:any namespace="##any" processContents="lax|strict"/>

For the time being either is good enough.  Further discussion on geodetic location representation might have to continue on the GEOPRIV list.

Martin

> -----Original Message-----
> From: Thomson, Martin
> Sent: Wednesday, 26 October 2005 11:42 AM
> To: 'Henning Schulzrinne'; Winterbottom, James; [email-masked]
> Subject: RE: [Ecrit] LUMP and mapping architecture documents
> 
> I can answer that one.
> 
> gml:_Feature is the correct object, based on the PIDF-LO spec.  This
> element is the abstract head of a substitution group that includes
> gml:position.
> 
> Cheers,
> Martin
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Henning Schulzrinne
> Sent: Wednesday, 26 October 2005 11:38 AM
> To: Winterbottom, James; [email-masked]
> Subject: Re: [Ecrit] LUMP and mapping architecture documents
> 
> Thanks - yes, the dangers of relying too much on XMLspy rather than
> validation by human inspection :-)
> 
> More seriously: What would be the appropriate XML object for geo only?
> gml:position?
> 
> Thanks.
> 
> Henning
> 
> Winterbottom, James wrote:
> > Hi Henning,
> >
> > I will have more comments on this draft later.
> > But for now there is a clear mistake in the XML in that your geo option
> > is using a type of "ca:civicAddress"
> >
> > *8)
> >
> > Cheers
> > James
> >
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 08 Nov 2005 11:21:26 -0500

Thanks for checking up on this. Having a schema-recognizable geo 
representation for both points and polygons would be helpful, I think.