Subject: [Ecrit] Dial Strings...

From: "Marc Linsner" <[email-masked]>
Date: Wed, 22 Mar 2006 12:12:03 -0500

I want to float an idea wrt dial strings.

We had some conversation for some time as to the value of the UA
understanding local emergency dial strings.  Since we're at the end of the
requirements for LoST, please express opinion on whether distributing local
dial strings via LoST is feasible and worthy of adding to our requirements
draft.

One example: UA boots --> UA launches LoST query and receives location
validation, PSAP uri (for fallback), and local dial strings.

Thanks,

-Marc-

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 22 Mar 2006 12:19:39 -0500

Note that this works for both local and home dial strings. The UA makes 
two queries to LoST in this model if home country != visited country:

(1) one with country=home country

(2) another one with country=visited country

In both cases, they can either get back a single dial string for the 
service indicated or possibly a list of all dial strings if these differ 
across emergency services (fire, police, etc.).

Henning

---

From: "Marc Linsner" <[email-masked]>
Date: Wed, 22 Mar 2006 12:22:57 -0500

Home dials strings *could* also be user-input-to-new-phone hardcoded.

-Marc-

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]] 
> Sent: Wednesday, March 22, 2006 12:20 PM
> To: Marc Linsner
> Cc: [email-masked]
> Subject: Re: [Ecrit] Dial Strings...
> 
> Note that this works for both local and home dial strings. 
> The UA makes two queries to LoST in this model if home 
> country != visited country:
> 
> In both cases, they can either get back a single dial string 
> for the service indicated or possibly a list of all dial 
> strings if these differ across emergency services (fire, 
> police, etc.).
> 
> Henning
> 
> Marc Linsner wrote:
> > understanding local emergency dial strings.  Since we're at 
> the end of 
> > the requirements for LoST, please express opinion on whether 
> > distributing local dial strings via LoST is feasible and worthy of 
> > adding to our requirements draft.
> >

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 22 Mar 2006 12:29:30 -0500

Certainly. I prefer a slightly more dynamic solution since dial strings 
do change in some jurisdictions, particularly as countries converge 
towards 112, for example. Also, as devices are passed around, inherited 
and sold, I'd rather not rely on the configuration choices of the 
previous owner. Also, in some cases, users may actually have difficulty 
remembering the right number, particularly for some of the more obscure 
services such as mountain rescue. I always had difficulty in Germany 
remembering whether 110 was police and 112 was fire or the other way around.