Subject: RE: [Ecrit] Dial Strings...

From: "Perry Prozeniuk" <[email-masked]>
Date: Wed, 22 Mar 2006 12:49:22 -0500

The result, even with the special processing approach is that some
numbers may change meaning if overridden with local emergency dial
strings.  The user may not be aware of this occurring and being
unfamiliar with the local emergency dial strings make accidental calls
to emergency services and won't be able to reach the service they
wanted.  As Brian indicated, this is a very ugly area due to the
variation in dial plans and local emergency dial strings (enterprise
networks with their own dial plans can make it even worse).

Perry Prozeniuk

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 12:32 PM
To: 'Stastny Richard'; 'Marc Linsner'; [email-masked]
Subject: RE: [Ecrit] Dial Strings...

The intersection of a local emergency dialstring with a home dialplan
are ugly.  We looked at this in PacketCable 2.0 work.  I believe the
conclusion is that with any of the methods people have for representing
dialplans that can be automatically processed by a phone or proxy, that
inserting the local dialstring into those dialplans is way too hard.
What you probably have to do is to just have a list of local dialstrings
and have the interpreter have special processing that looks for them
independently of the dial plan interpretation.

The home dial string can be imbedded in the dial plan, and almost always
is.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 12:30 PM
To: Marc Linsner; [email-masked]
Subject: RE: [Ecrit] Dial Strings...

I consider this very useful, and
not much additional effort
 
It requires also on location infromation based on country
It could be given back with the country default PSAP(s)
if only the country is known
 
I think this was also in the original cc.sos.arpa proposal from Brian
 
The basic question is what happens if the local dialstring is clashing
with other local numbers. THis may be left to the user client, but we
should give some guidance here.
 
Richard

________________________________

Von: Marc Linsner [mailto:[email-masked]]
Gesendet: Mi 22.03.2006 18:12
An: [email-masked]
Betreff: [Ecrit] Dial Strings...

I want to float an idea wrt dial strings.

We had some conversation for some time as to the value of the UA
understanding local emergency dial strings.  Since we're at the end of
the requirements for LoST, please express opinion on whether
distributing local dial strings via LoST is feasible and worthy of
adding to our requirements draft.

One example: UA boots --> UA launches LoST query and receives location
validation, PSAP uri (for fallback), and local dial strings.

Thanks,

-Marc-

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 22 Mar 2006 14:05:55 -0500

We've looked over the issue of 
	Do you HAVE to support the local/visited dialstring
	Should you support the local dialstring
	Do you HAVE to support the home dialstring
	Should you support the home dialstring

The result is
	1. There are regulations in most countries that REQUIRE you to
support the local dialstring
	2. There are no requirements to support the home dialstring
	3. Nearly everyone thinks it would be good to support the home
dialstring
	4. Opinions on whether you should support the local dialstring are
mixed.  Some think it screws up the dialplan so much it shouldn't be done

Of course, #1 above rules.  So, #4 doesn't matter; you MUST support the
local/visited dialstring.  There is a lot of support for #3, so I think we
MUST have a mechanism to support both home and local/visited dialstrings.
Use of local/visited is a MUST.  Use of home is a MAY.

Brian

-----Original Message-----
From: Perry Prozeniuk [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 12:49 PM
To: [email-masked]
Subject: RE: [Ecrit] Dial Strings...

Perry Prozeniuk

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 12:32 PM
To: 'Stastny Richard'; 'Marc Linsner'; [email-masked]
Subject: RE: [Ecrit] Dial Strings...

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 12:30 PM
To: Marc Linsner; [email-masked]
Subject: RE: [Ecrit] Dial Strings...

 

Richard

Thanks,

-Marc-