Subject: RE: [Ecrit] Dial Strings...

From: "Roger Marshall" <[email-masked]>
Date: Wed, 22 Mar 2006 09:28:04 -0800

I think this does solve the problem of a nomadic or mobile UA getting
the appropriate dial string.

The requirement could be that, upon boot, the UA launches various
flagged LoST request(s):

E.G. something like,
"-v", to request validation of a given location,
"-u", for PSAP uri
"-d", for dialstring (whether home or visited)

This would cut down on extra information not being always wanted/needed.

I agree with Marc, that this ability should be made to be turned ON|OFF,
based on whether a UA provider/service provider wants to deploy
hardcoded values for static use case deployments.

Roger Marshall. 

>-----Original Message-----
>From: Stastny Richard [mailto:[email-masked]] 
>Sent: Wednesday, March 22, 2006 9:30 AM
>To: Marc Linsner; [email-masked]
>Subject: RE: [Ecrit] Dial Strings...
>
>I consider this very useful, and
>not much additional effort
> 
>It requires also on location infromation based on country It 
>could be given back with the country default PSAP(s) if only 
>the country is known
> 
>I think this was also in the original cc.sos.arpa proposal from Brian
> 
>The basic question is what happens if the local dialstring is 
>clashing with other local numbers. THis may be left to the 
>user client, but we should give some guidance here.
> 
>Richard
>
>________________________________
>
>Von: Marc Linsner [mailto:[email-masked]]
>Gesendet: Mi 22.03.2006 18:12
>An: [email-masked]
>Betreff: [Ecrit] Dial Strings...
>
>
>
>I want to float an idea wrt dial strings.
>
>We had some conversation for some time as to the value of the 
>UA understanding local emergency dial strings.  Since we're at 
>the end of the requirements for LoST, please express opinion 
>on whether distributing local dial strings via LoST is 
>feasible and worthy of adding to our requirements draft.
>
>One example: UA boots --> UA launches LoST query and receives 
>location validation, PSAP uri (for fallback), and local dial strings.
>
>Thanks,
>
>-Marc-
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 22 Mar 2006 21:44:11 +0100

>Are you really arguing that support of local dialstring is not a MUST?

Could you please point out where I said said in my mail?

I know it is within the scope of IETF to give advice to regulatry bodies,
and I have learned in session today (or was it yesterday?) that a MUST in an 
RFC  is only a must for the protocol. 
 
A regularory MUST is something else.

The question is only, who MUST (regulatory-wise) support a local dialstring?

Not the VoIP provider if he is not involved in an emergency call

Richard

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Mi 22.03.2006 21:28
An: Stastny Richard; 'Stark, Barbara'; [email-masked]
Betreff: RE: [Ecrit] Dial Strings...

Are you really arguing that support of local dialstring is not a MUST?

After all, the regulation comes from the local public safety folks.  They
WANT the phones to do it.  You can have a personal opinion, but should your
opinion override theirs?

Look at the actual argument: your local emergency number screws up my dial
plan.  The consequences of error are a call not intended to be an emergency
call is turned into an emergency call.  If you don't do it, you have a
pristine dial plan, and someone who picks up the phone and dials the local
emergency number doesn't get help, AND DOESN'T KNOW HOW to get it.

My favorite foil for emergency call opt out is the baby sitter situation.
You have some kind of weird behavior phone on your home office desk, which
you know how to work.  You go out to dinner and your kid starts choking.
The babysitter picks up the phone and dials 9-1-1 (or 9-9-9 or 1-1-6).

Now, what is right, and what is wrong in that scenario?  Does it matter that
it's rare?  What is the liability for supporting local dialstring and having
calls turned into emergency calls that shouldn't have been?  What is the
liability for not supporting local dialstrings?

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Wednesday, March 22, 2006 3:16 PM
To: Stark, Barbara; [email-masked]; [email-masked]
Subject: Re: [Ecrit] Dial Strings...

Good point, but ...

As I understand ECRIT, you may not need a VoIP provider at all to
make an emergency call. If somebody is not involved, it is useless to
regulate him

The real question is, who will be regulated? e.g LoST and
the data in LoST are not a VoIP provider issue anymore, it is an
issue of the emergency call takers. It is also they business to provide
and run the database.

I always pointed out that regulation has also to change focus here:

Regulators need to regulate the access providers, device manufactures,
emergency call takers, etc., but nit the VoIP providers, or if the are
involved
in call set up, that they recognize a dialstring and query LoST for a given
location (which they are alo not responsible for anymore

Richard

Von: Stark, Barbara [mailto:[email-masked]]
Gesendet: Mi 22.03.2006 20:52
An: [email-masked]; [email-masked]
Betreff: RE: [Ecrit] Dial Strings...

I suspect it's very hard for a European country to tell US VoIP
providers that they HAVE to support "local" emergency strings for anyone
using the US VoIP service while in that European country. How does the
European country regulate US VoIP providers and their services?
Barbara

> From: Brian Rosen [mailto:[email-masked]]
> Sent: Wednesday, March 22, 2006 2:06 PM
> To: 'Perry Prozeniuk'; [email-masked]
> We've looked over the issue of
>       Do you HAVE to support the local/visited dialstring
>       Should you support the local dialstring
>       Do you HAVE to support the home dialstring
>       Should you support the home dialstring
>
> The result is
>       1. There are regulations in most countries that REQUIRE you to
> support the local dialstring
>       2. There are no requirements to support the home dialstring
>       3. Nearly everyone thinks it would be good to support the home
> dialstring
>       4. Opinions on whether you should support the local
> dialstring are
> mixed.  Some think it screws up the dialplan so much it
> shouldn't be done
>
> Of course, #1 above rules.  So, #4 doesn't matter; you MUST
> support the
> local/visited dialstring.  There is a lot of support for #3,
> so I think we
> MUST have a mechanism to support both home and local/visited
> dialstrings.
> Use of local/visited is a MUST.  Use of home is a MAY.
>
> Brian
>
> From: Perry Prozeniuk [mailto:[email-masked]]
> Sent: Wednesday, March 22, 2006 12:49 PM
> To: [email-masked]
> The result, even with the special processing approach is that some
> numbers may change meaning if overridden with local emergency dial
> strings.  The user may not be aware of this occurring and being
> unfamiliar with the local emergency dial strings make accidental calls
> to emergency services and won't be able to reach the service they
> wanted.  As Brian indicated, this is a very ugly area due to the
> variation in dial plans and local emergency dial strings (enterprise
> networks with their own dial plans can make it even worse).
>
> Perry Prozeniuk
>
>
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Wednesday, March 22, 2006 12:32 PM
> To: 'Stastny Richard'; 'Marc Linsner'; [email-masked]
> The intersection of a local emergency dialstring with a home dialplan
> are ugly.  We looked at this in PacketCable 2.0 work.  I believe the
> conclusion is that with any of the methods people have for
> representing
> dialplans that can be automatically processed by a phone or
> proxy, that
> inserting the local dialstring into those dialplans is way too hard.
> What you probably have to do is to just have a list of local
> dialstrings
> and have the interpreter have special processing that looks for them
> independently of the dial plan interpretation.
>
> The home dial string can be imbedded in the dial plan, and
> almost always
> is.
>
> Brian
>
> Sent: Wednesday, March 22, 2006 12:30 PM
> It requires also on location infromation based on country
> It could be given back with the country default PSAP(s)
> if only the country is known
>
> The basic question is what happens if the local dialstring is clashing
> with other local numbers. THis may be left to the user client, but we
> should give some guidance here.
>
> Richard
>
> We had some conversation for some time as to the value of the UA
> understanding local emergency dial strings.  Since we're at the end of
> the requirements for LoST, please express opinion on whether
> distributing local dial strings via LoST is feasible and worthy of
> adding to our requirements draft.
>
> One example: UA boots --> UA launches LoST query and receives location
> validation, PSAP uri (for fallback), and local dial strings.
>
> Thanks,
>
> -Marc-
>

The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential, proprietary, and/or
privileged material. Any review, retransmission, dissemination or other use
of, or taking of any action in reliance upon this information by persons or
entities other than the intended recipient is prohibited. If you received
this in error, please contact the sender and delete the material from all
computers. 163