Subject: [Ecrit] Service URN

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 04 Sep 2007 22:00:17 +0200

Hi all,

after a chat with Brian and here a short summary of what we discussed:
(I hope I captured it correctly.)

== End Host Procedures ==

* UA does not recognize the emergency call.

To: Dial String
Request URI: Dial String
No Route header
 
* UA runs LoST and determines the PSAP URI:

Request URI: Service URN
To: Service URN
Route Header: PSAP URI

* UA does not run LoST but recognizes the emergency call.

Request URI: Service URN
To: Service URN
No Route header

== Proxy Procedures ==

* Incoming request contains Service URN; Proxy runs LoST and determines 
the PSAP URI

--- Input:

Request URI: Service URN
To: Service URN
No Route header

--- Output:

Request URI: Service URN
To: Service URN
Route Header: PSAP URI

* Incoming request contains Dial String; UA runs LoST and determines the 
PSAP URI:

--- Input:

Request URI: Dial String
To: Dial String
No Route header

--- Output:

Request URI: Service URN
To: Service URN
Route Header: PSAP URI

Please check whether this is correct.

Ciao
Hannes

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Peili Xu" <[email-masked]>
Date: Wed, 5 Sep 2007 23:30:42 +0800

good summary, comments in-line

> * UA runs LoST and determines the PSAP URI:

This case means the UA recognizes the emergency call, right?

> * Incoming request contains Dial String; UA runs LoST and determines the

I guess you actually want to say Proxy in the above sentence.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 05 Sep 2007 17:48:49 +0200

Hi

> This case means the UA recognizes the emergency call, right?
Yes. You cannot start LoST when you don't recognize the emergency call.

> I guess you actually want to say Proxy in the above sentence.
Correct.
 
Ciao
Hannes