Subject: [Ecrit] Phone BCP: HELD Discovery

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 30 Mar 2008 22:55:45 +0300

"
   ED-47 Endpoints MUST support one or more mechanisms that allow them
   to determine their public IP address.  Examples include ICE
   [I-D.ietf-mmusic-ice] and HTTP get.
"

This functionality is inherited by the HELD discovery mechanism.
The reference to ICE is not needed since HELD discovery does not use
ICE and HTTP get is not used at all.

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Sun, 30 Mar 2008 16:21:27 -0400

I think you are correct.  This was a left over from some previous notions of
how HELD worked.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Hannes Tschofenig
Sent: Sunday, March 30, 2008 3:56 PM
To: [email-masked]
Subject: [Ecrit] Phone BCP: HELD Discovery

"

---

From: "Stark, Barbara" <[email-masked]>
Date: Tue, 1 Apr 2008 09:18:04 -0400

HELD (LIS) discovery
(http://www.ietf.org/internet-drafts/draft-ietf-geopriv-lis-discovery-00
.txt) has a section on "Determining an External IP Address". Being able
to determine the public IP address is an important capability in order
to be able to do reverse DNS for the domain, which enables the ability
to do U-NAPTR. That section mentions several possible methods of
determining the public IP address, including STUN (a subset of ICE),
UPnP, and HTTP GET.

I would like to see the phonebcp requirement remain, as is.
Barbara  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian Rosen
Sent: Sunday, March 30, 2008 4:21 PM
To: 'Hannes Tschofenig'; [email-masked]
Subject: Re: [Ecrit] Phone BCP: HELD Discovery

I think you are correct.  This was a left over from some previous
notions of
how HELD worked.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of
Hannes Tschofenig
Sent: Sunday, March 30, 2008 3:56 PM
To: [email-masked]
Subject: [Ecrit] Phone BCP: HELD Discovery

"

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA621