Subject: Re: [Ecrit] Phone BCP: Default Location

From: "Roger Marshall" <[email-masked]>
Date: Wed, 2 Apr 2008 16:35:18 -0700

Agree with you James. There is with this a nagging 'tell me more' aspect
to this.  

The way <default> is being specified here is more like
<location_of_last_resort>.  It still doesn't tell you whether the last
resort was TDOA, SA-GPS, Wiremap Provisioned, Cellsector-id, or
'manually-input', etc.  Wouldn't it be nice to know?  When the search &
rescue team comes up wanting, the PSAP will want to know.

-roger.

> -----Original Message-----
> From: Winterbottom, James [mailto:[email-masked]] 
> Sent: Monday, March 31, 2008 5:23 PM
> To: Brian Rosen; Roger Marshall; Hannes Tschofenig; [email-masked]
> Subject: RE: [Ecrit] Phone BCP: Default Location
> 
> Let's agree to disagree on this.
> I see method as a means of describing how the location of the 
> Target was determined. What is being described by a value of 
> default is that the location bears no perceivable 
> relationship to the Target, but is being provided because we 
> want the call to be answered. This is a measure of the 
> quality of the location information, and this requires a 
> separate indicator.
> 
> If everybody disagrees me on this then I will let it drop, 
> but I think it is a slippery path to follow.
> 
> Cheers
> James 
> 
> > -----Original Message-----
> > From: Brian Rosen [mailto:[email-masked]]
> > Sent: Tuesday, 1 April 2008 9:14 AM
> > To: 'Roger Marshall'; Winterbottom, James; 'Hannes Tschofenig'; 
> > [email-masked]
> > Subject: RE: [Ecrit] Phone BCP: Default Location
> > 
> > Well, maybe.  I don't want to limit default to manually provisioned,
> but
> > it's probably the most common way you get it.
> > 
> > The point is that every element that handles an emergency 
> call has to
> be
> > prepared to supply a default value.  The closer the element 
> is to the 
> > endpoint, the more likely it is to have a good default 
> value.  In your 
> > list, in most cases, it's <given>.
> > 
> > DHCP is an LCP, not a method.  In most cases, a civic location is a 
> > wiremap and a geo is measured by GPS or triangulated by 
> APs.  It isn't 
> > always
> so,
> > but that's probably good enough.
> > 
> > Default is a method.  You got it some basic way (usually 
> configured).
> We
> > used an example of a CMTS area for a cable system.  If the 
> LIS failed
> to
> > determine a location, or a proxy server needed to add 
> location, using
> some
> > location in the CMTS service area may be a decent default location.
> The
> > "some location" is configured.
> > 
> > When you have a default location, you don't have some other method.
> If
> > you
> > did, you would use it, and you wouldn't need a default.
> > 
> > Brian
> > 
> > -----Original Message-----
> > From: Roger Marshall [mailto:[email-masked]]
> > Sent: Monday, March 31, 2008 5:18 PM
> > To: Brian Rosen; Winterbottom, James; Hannes Tschofenig;
> [email-masked]
> > Subject: RE: [Ecrit] Phone BCP: Default Location
> > 
> > ...Brian Rosen wrote on Monday, March 31, 2008 5:59 AM,
> > 
> > > It was determined by some element who failed to get it by 
> some other 
> > > method,
> > 
> > I'm not sure I get it.  Are you saying "default", in the sense of 
> > "manually provisioned" only?
> > 
> > Locations in their most basic form are either 1. <given> (e.g., 
> > wiremap), 2. <measured> (e.g., agps), or 3. <derived> 
> (e.g., geocoded)
> > 
> > Configuration mechanisms have been talked about, such as 
> using a DHCP 
> > server for location acquisition.  I just want to make sure 
> folks don't 
> > think that the answer as to what to put in the PIDF-LO's method
> element
> > would be something like <by_dhcp>.  If so, then any info relating to
> the
> > 3 methods above is gone.  If not, then we need another value in
> PIDF-LO,
> > something like:
> > 
> > <configured_by>dhcp</configured_by>
> > 
> > Mostly though, the method value <default> doesn't tell me anything
> about
> > the how the location should be characterized.
> > 
> > -roger.
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Brian Rosen
> > > Sent: Monday, March 31, 2008 5:59 AM
> > > To: 'Winterbottom, James'; 'Hannes Tschofenig'; [email-masked]
> > > Subject: Re: [Ecrit] Phone BCP: Default Location
> > >
> > > No, it represents the best available location of the user.
> > >
> > > It was determined by some element who failed to get it by 
> some other 
> > > method, and is using a default value which was predefined for that
> > > purpose.   The
> > > best available location is the default value, and the 
> method used to 
> > > determine it was the 'default' method.
> > >
> > > I think it's appropriate as defined.
> > >
> > > Brian
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Winterbottom, James
> > > Sent: Sunday, March 30, 2008 4:34 PM
> > > To: Hannes Tschofenig; [email-masked]
> > > Subject: Re: [Ecrit] Phone BCP: Default Location
> > >
> > > Actually this is a misuse of the method token.
> > > The method token says how location was determined for 
> inclusion in 
> > > the PIDF-LO.
> > > The intent I read from this requirement is that the method is 
> > > attempting to say that the location doesn't represent 
> where the end 
> > > point is at all, but is what they have registered as a default 
> > > location.
> > >
> > > I think you need a new element in the PIDF-LO to represent this.
> > > Something like:
> > > <defaultLocation>yes</defaultLocation>
> > >
> > > or
> > >
> > > <locationRepresents>default</locationRespresents>
> > >
> > > Then it could have a value of "current" or "recent" or 
> other kind of 
> > > subjective things too.
> > >
> > > Cheers
> > > James
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: [email-masked] on behalf of Hannes Tschofenig
> > > Sent: Sun 3/30/2008 2:55 PM
> > > To: [email-masked]
> > > Subject: [Ecrit] Phone BCP: Default Location
> > >
> > > "
> > >    AN-23/SP-22 Default locations MUST be marked with 
> method=Default 
> > > and
> > >    the proxy MUST be identfied in provided-by element of the
> PIDF-LO.
> > > "
> > >
> > > Someone should register the token "default". To my 
> knowledge it is 
> > > not registered.
> > >
> > > _______________________________________________
> > > Ecrit mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/ecrit
> > >
> > >
> > > --------------------------------------------------------------
> > > --------------
> > > --------------------
> > > This message is for the designated recipient only and may contain 
> > > privileged, proprietary, or otherwise private information.
> > > If you have received it in error, please notify the sender 
> > > immediately and delete the original.  Any unauthorized 
> use of this 
> > > email is prohibited.
> > > --------------------------------------------------------------
> > > --------------
> > > --------------------
> > > [mf2]
> > >
> > > _______________________________________________
> > > Ecrit mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/ecrit
> > >
> > > _______________________________________________
> > > Ecrit mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/ecrit
> > >
> > 
> > 
> > CONFIDENTIALITY NOTICE: The information contained in this 
> message may
> be
> > privileged and/or confidential. If you are not the intended 
> recipient,
> or
> > responsible for delivering this message to the intended 
> recipient, any 
> > review, forwarding, dissemination, distribution or copying of this 
> > communication or any attachment(s) is strictly prohibited. 
> If you have 
> > received this message in error, please notify the sender 
> immediately,
> and
> > delete it and all attachments from your computer and network.
> > 
> 
> --------------------------------------------------------------
> ----------------------------------
> This message is for the designated recipient only and may 
> contain privileged, proprietary, or otherwise private information.  
> If you have received it in error, please notify the sender 
> immediately and delete the original.  Any unauthorized use of 
> this email is prohibited.
> --------------------------------------------------------------
> ----------------------------------
> [mf2]
> 
> 
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 2 Apr 2008 19:03:37 -0500

<ducks-for-cover>

If it is the proxy in this case that is essentially getting the PSAP
URI, either because it simply knows it, or because it has picked some
arbitrary location and talked to LoST, I think I am prepared to say that
NO location should be provided with the call. That way the network and
call-taker can't help but treat the call in a more "special" way.

> Sent: Thursday, 3 April 2008 10:35 AM
> To: Winterbottom, James; Brian Rosen; Hannes Tschofenig;
[email-masked]
> > > > Someone should register the token "default". To my
contain
> > > delete it and all attachments from your computer and network.

------------------------------------------------------------------------------------------------
------------------------------------------------------------------------------------------------
[mf2]