Subject: Re: [Ecrit] Comments for draft-robins-ecrit-sub-services-00.txt

From: Robins George <[email-masked]>
Date: Mon, 07 Jul 2008 18:20:14 +0800

Thanks Hannes for your comments.

> Hi Robins,
> Hi Qian,
> 
> thanks for submitting this document.
> 
> I have two questions/comments for your draft.
> 
> * There is a List Services query <listServices> in the LoST 
> specification that allows you to list the services of a LoST server 
> (see Section 10 of LoST). Is this functionality insufficient for your 
> purpose.

In the given section, it says about finding the list of services 
supported by a LoST server.

this draft says the list of sub services supported 
by the particular instance of a service.

> * In your document you suggest to define new URNs that allow 
> further differentiation between the type of service a PSAP might provide. 
> You indicate
> 
>              urn:service:sos.police.terrorist
>              urn:service:sos.police.arson
>              urn:service:sos.police.robbery
> 
> as sub-services for urn:service:sos.police.
> 
> Did you have a chance to talk to PSAP operators whether they 
> believe this functionality is something they would like to expose to the 
> outside  world?
> 

they would like to expose to the outside world.

> When do you expect the user to indicate this type of detail (since 
> there is a user-interface issue associated with this aspect)? 

we can indicate the type detail in the SIP invite,

INVITE sip:[email-masked] SIP/2.0
To: urn:service:sos.police.robbery

>I could  imagine that you could quickly turn the person 
>that reports certain crime into a detective when you, for example,
>allow the following information to be differentiated:
> 
> urn:service:sos.police.robbery
> urn:service:sos.police.homicide
> urn:service:sos.police.homicide.aggravated-assault
> urn:service:sos.police.homicide.manslaughter
> urn:service:sos.police.homicide.manslaughter.avunculicide
> urn:service:sos.police.homicide.manslaughter.democide
> urn:service:sos.police.homicide.manslaughter.familicide
> urn:service:sos.police.homicide.manslaughter.femicide
> urn:service:sos.police.homicide.manslaughter.filicide
> urn:service:sos.police.homicide.manslaughter.fratricide
> urn:service:sos.police.homicide.manslaughter.gendercide
> urn:service:sos.police.homicide.manslaughter.genocide
> urn:service:sos.police.homicide.manslaughter.infanticide
> urn:service:sos.police.homicide.manslaughter.mariticide
> urn:service:sos.police.homicide.manslaughter.matricide
> urn:service:sos.police.homicide.manslaughter.neonaticide
> urn:service:sos.police.homicide.manslaughter.parricide
> urn:service:sos.police.homicide.manslaughter.patricide
> urn:service:sos.police.homicide.manslaughter.regicide
> urn:service:sos.police.homicide.manslaughter.sororicide
> urn:service:sos.police.homicide.manslaughter.suicide
> urn:service:sos.police.homicide.manslaughter.tyrannicide
> urn:service:sos.police.homicide.manslaughter.uxoricide
> urn:service:sos.police.homicide.murder
> urn:service:sos.police.homicide.murder.assassination
> urn:service:sos.police.homicide.murder.child-murder
> urn:service:sos.police.homicide.murder.consensual-homicide
> urn:service:sos.police.homicide.murder.contract-killing
> urn:service:sos.police.homicide.murder.honour-killing
> urn:service:sos.police.homicide.murder.lust-murder
> urn:service:sos.police.homicide.murder.lynching
> urn:service:sos.police.homicide.murder.mass-murder
> urn:service:sos.police.homicide.murder.murder-suicide
> urn:service:sos.police.homicide.murder.proxy-murder
> urn:service:sos.police.homicide.murder.ritual-murder
> urn:service:sos.police.homicide.murder.serial-killer
> urn:service:sos.police.homicide.murder.spree-killer
> urn:service:sos.police.homicide.murder.torture-murder 
> 
> I guess you get the point. I am unsure where to stop with the types 
> of sub-services and the ability of the person to know all these 
> different things. 

we could list only one level of subservices,
implying support for all sub categories.
For example consider the crime classifications
which came from FBI.

Arson
Criminal sexual assault
Gambling
Homicide
Interfere with public officer
Kidnapping
Motor vehicle theft
Narcotics
Prostitution
Public indecency
Robbery
Theft
Traffic accident
Weapons violation

......

> Needless to say that there are persons other than Thomas Mueller 
> and Sherlock Homes out there...
> 

classification could be based on user point of view,
so that they can understand very easily.
and I suspect most users don't 
want to become experts in crime classification.

Regards,
Robins

> 
> Ciao
> Hannes
> 
> -------- Original Message --------
> Subject:  I-D Action:draft-robins-ecrit-sub-services-00.txt
> Date:  Wed, 2 Jul 2008 20:15:01 -0700 (PDT)
> From:  [email-masked]
> Reply-To:  [email-masked]
> To:  [email-masked]
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
>  Title           : Location-to-Service Translation Protocol (LoST) 
> Sub-Services
>  Author(s)       : R. George, Q. Sun
>  Filename        : draft-robins-ecrit-sub-services-00.txt
>  Pages           : 8
>  Date            : 2008-07-02
> 
> This document describes, how a LoST client can ask LoST server for
> the list of sub services that it supports, and to incorporate
> additional information about the service provider in response.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-robins-ecrit-sub-services-
> 00.txt
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 7 Jul 2008 14:46:33 -0400

The only reason to have separate services (sub services) and thus separate
service URNs if it is possible that calls to these services would be routed
differently.  I suspect that this is not the case here.  I think you are
trying to use the service URN to allow the caller to start classifying the
call so that dispatch of the appropriate resources is optimized.  If this is
indeed your intention, then we should use a different mechanism.

In the jurisdictions with which I am familiar, all police calls go to the
same place initially.  Based on what the call taker gleans from the caller,
they may send the call to one of several entities for further handling.
Call classification is one of the tasks that the call taker does.  If the
caller could supply information that began the classification process, that
might be useful.  In North America, any such self-classification would not
be considered definitive, and would always be verified.  

Brian

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Robins George
Sent: Monday, July 07, 2008 6:20 AM
To: Hannes Tschofenig
Cc: [email-masked]
Subject: Re: [Ecrit] Comments for draft-robins-ecrit-sub-services-00.txt

Arson
Criminal sexual assault
Gambling
Homicide

......

Regards,
Robins