Subject: [Ecrit] emergency call termination

From: <[email-masked]>
Date: Mon, 7 Jul 2008 15:31:37 -0400

Dear ECRIT,

NENA wishes to provide comments regarding "emergency call termination"
behavior in -framework-05 and -phonebcp-04.

The UA behavior currently defined disallows a UA engaged in an emergency
communication to release the call and states that only the PSAP should
be able to terminate an emergency call.

NENA wishes to express that this behavior, while desired or mandated in
certain jurisdictions, is undesirable in others. For example, the
majority of the U.S. jurisdictions do not use this feature and prefer to
allow the caller to release an emergency call. 

It is not NENA's intent to revert the current behavior in such a way
that the caller has always the ability to release an emergency call.
NENA would like however that this feature be made optional and
controlled at the PSAP end. This would allow a roaming device to adjust
its behavior according to the rules of the jurisdiction it is currently
in.

Thanks,

Guy Caron
On behalf of NENA
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Ted Hardie <[email-masked]>
Date: Thu, 10 Jul 2008 09:21:37 -0700

>be able to terminate an emergency call.

Sorry for the late comment on this, but having thought about this a bit,
I agree that this should not be mandatory.  If a caller realizes after
starting the call that it is not an emergency (the person choking has
their airway clear; the parent realizes a child has dialed 911, whatever),
they should be able to terminate the call. 

>its behavior according to the rules of the jurisdiction it is currently

Though I am no expert in this, it's my understanding that this is
not behavior supported by the current cellular networks, so I
believe that it would be both simpler and more appropriate to
define user terminated calls as permitted behavior.
			regards,
				Ted

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 13:21:45 -0400

Thank you Ted for taking the time to look at this.

Regardless of the outcome of your proposal within ECRIT, do you agree that this particular UA behavior should be modulated by the requirements/rules of the jurisdictions since it simply reflects today's situation?

Thanks,

Guy Caron
-----Message d'origine-----
De : Ted Hardie [mailto:[email-masked]] 
Envoyé : 10 juillet 2008 12:22
À : Caron, Guy (A162859); [email-masked]
Cc : [email-masked]
Objet : Re: [Ecrit] emergency call termination

---

From: Ted Hardie <[email-masked]>
Date: Thu, 10 Jul 2008 10:54:32 -0700

>Regardless of the outcome of your proposal within ECRIT, do you agree that this particular UA behavior should be modulated by the requirements/rules of the jurisdictions since it simply reflects tod…

I'm not sure I follow the question.  Are you asking whether the UA behavior
should be regulated or requirements placed on it by jurisdictions?  Or are
you asking whether UAs should be location aware and should change their
behavior based on the rules applicable in a location?

				Ted

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 10 Jul 2008 13:56:01 -0400

This is a complex issue, made more complex by current deployments.

First of all, we need to distinguish between a call that is complete, where
a BYE ends the call, and a call that is not complete where a CANCEL ends the
call.  -phonebcp discusses a completed call where BYE would be used to
terminate.  It is currently silent on uncompleted calls.

Your example is an uncompleted call, but you can extend it to include the
case where the caller hangs up just as the call taker answers.  Both of
these are considered "abandoned calls".  In many jurisdictions, they respond
to an abandoned call.  They don't know why the call is abandoned.  So, most
PSAPs I've talked to want to force the call to complete, and have the call
taker hear (or read) that the problem is solved, and they don't need to send
a cop to check it out.  This is one reason why they want this capability.

The basic CPH is for another purpose, which is pre-mature hang up.  It
happens often enough that PSAPs care.  The user, who is stressed, hangs up
before the call taker has enough information.  They want the call to be
reconnected if the user does that and subsequently goes on hook.  They want
to be able to ring and/or send howler tone to alert the user to get back on
the d&*m phone.

It used to be that 9-1-1 in the U.S. had these features.  In Canada, they
still do.  In the U.S. they got lost in the ISDN signaling change, much to
the regret of the PSAPs.  ISDN (and ISUP) didn't retain the feature, and, I
am told, the PSAPs howled, but it didn't get fixed.  Now, some of them are
used to not having it, but many wish they could get it back.  The Canadians
have it still, and don't want to lose it.

It is clear however, that there are circumstances where CPH is not desired.
The best example is where you have a mass calling event and some calls are
answered on an IVR (or "IMR" -- multimedia).  Clearly, you want the caller
to be able to hang up.

Now, Guy Caron has proposed several more features, one of which is the
ability to signal the hook state of the phone.  If we had that, then the
PSAP could return BYE automatically upon receipt of an on-hook state.  That
would allow the PSAP to control CPH without a negotiation of features at the
phone.

So, I propose that we retain the prohibition on BYE, and we add the proposed
hook state signaling (sending SDP with inactive).  PSAPs who don't want CPH
should send BYE upon receipt of inactive.  Note that -phonebcp says hold
should be disabled.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Ted Hardie
> Sent: Thursday, July 10, 2008 12:22 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Ecrit] emergency call termination
>

---

From: Marc Linsner <[email-masked]>
Date: Thu, 10 Jul 2008 14:26:54 -0400

Guy,

Would you please expand on 'today's situation'?

What I've gleaned out of Ted's assertion (which is also my understanding)
and NENA's request (from you) is that PSAPs can 'technically' control the
call on wireline service, but not wireless service.  I also believe that
even if the capability is technically feasible, some jurisdictions don't
have the desire to control the call.

I'm struggling when it's the case where the jurisdiction requires call
control, but it is not technically feasible.  Hence, how do you expect the
IETF to support the feature since your are asking to match today's
situation?   Which situation?  The one where it's not technically feasible?

-Marc-

On 7/10/08 1:21 PM, "[email-masked]" <[email-masked]> wrote:

> Regardless of the outcome of your proposal within ECRIT, do you agree that
> this particular UA behavior should be modulated by the requirements/rules of
> the jurisdictions since it simply reflects today's situation?
> 
> Thanks,
> 
> Guy Caron

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 15:16:49 -0400

Ted,

More of the latter.

Thanks,

Guy Caron
-----Message d'origine-----
De : Ted Hardie [mailto:[email-masked]] 
Envoyé : 10 juillet 2008 13:55
À : Caron, Guy (A162859); [email-masked]
Cc : [email-masked]
Objet : RE: [Ecrit] emergency call termination

				Ted

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 15:42:53 -0400

Certainly Marc.

It is also my understanding that current cellular voice services have not implemented the network capabilities to enable PSAP control over call termination even if the jurisdiction requires/mandates it. The reasons for this are still obscure to me. I note however that those PSAPs using it are very disappointed of this situation in wireless and would like not to repeat it for Next Generation services.

The situation I was referring to was more in line with PSAP requirements than with technical limitations. In that sense, if a PSAP assumes a certain behavior for devices operating in its jurisdiction, it would be up to the device to adjust accordingly.

Thanks,

Guy Caron
-----Message d'origine-----
De : Marc Linsner [mailto:[email-masked]] 
Envoyé : 10 juillet 2008 14:27
À : Caron, Guy (A162859); [email-masked]
Cc : [email-masked]
Objet : Re: [Ecrit] emergency call termination

Guy,

-Marc-

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 10 Jul 2008 15:19:04 -0500

>allow the caller to release an emergency call.

Guy --

First off, IETF is not all about the US or North America, , so just 
because some US jurisdictions practice a capability one way, doesn't 
mean the whole proposal needs to change.

Second, if the caller wants to hang up the phone, the call taker is 
going to hang up also.  Why can't the call taker be the one in charge 
of this BYE?

Didn't Canada just have a bad situation occur in which the location 
of a caller resulted in the death of a boy?  The case involved a 
family that was using residential VoIP, and the call taker didn't ask 
where they lived; instead relying on "the system" to tell the call 
taker where the call originated. The family had moved to Calgary from 
the Winnipeg or Toronto area (I can't remember which) and the first 
responders went to their old location. The one from the form they had 
to fill out by hand, informing anyone who called in on IP, that this 
is where to send the responders.

Personally, I think the call taker shouldn't have relied on the 
system, and simply asked where the caller was located.  But I'm sure 
if that information hadn't been given, and the call taker wanted it 
(but for some reason delayed asking for it), they would want to have 
the ability to prevent the caller from hanging up.  This is one way 
for that not to occur.

At the end of the day, if both caller and call taker want the call to 
end, does it make a difference who's hang-up or <end> button sends 
the BYE?  It's gonna happen at about the same time, give or take a 
half a second.

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 17:00:12 -0400

Thanks John for your comments.

Please find some replies inline.

Guy Caron
-----Message d'origine-----
De : James M. Polk [mailto:[email-masked]] 
Envoyé : 10 juillet 2008 16:19
À : Caron, Guy (A162859); [email-masked]
Cc : [email-masked]
Objet : Re: [Ecrit] emergency call termination

Guy --

[GC] I do appreciate the global scope of the IETF. I simply wanted to give one tangible example where the PSAP do not want to enforce PSAP control over call termination. There may be others that I'm not aware of. It is my understanding that other countries require it. Japan (http://tools.ietf.org/html/draft-arai-ecrit-japan-req-01) and Canada are known examples.

going to hang up also.

[GC] The call taker may in fact hang-up if he feels it is the appropriate thing to do. It may however decide to pursue the conversation if, for example, he was not able to confirm all the information required to properly process that call. Please refer to the previous post (http://www.ietf.org/mail-archive/web/ecrit/current/msg05276.html) that describes some features that can be invoked by the call taker in this situation. Comments are also welcome on this one :-).

  Why can't the call taker be the one in charge of this BYE?

[GC] He definitively should if that's the PSAP's normal operation to keep control over call termination. But this may not be the case for all PSAPs.

[GC] Indeed, a very unfortunate and dramatic event that we all wish would never happen. My understanding of the series of events is not exactly as you described. You are right though that the location information "on file" was wrong. The "system" in this case was not the E9-1-1 infrastructure though.

Personally, I think the call taker shouldn't have relied on the 
system, and simply asked where the caller was located.

[GC] My understanding is that he did ask verbally for the location. Apparently because of a language barrier, it did not get acknowledged before the call was dropped.

  But I'm sure if that information hadn't been given, and the call taker wanted it (but for some reason delayed asking for it), they would want to have the ability to prevent the caller from hanging up.  This is one way 
for that not to occur.

[GC] Absolutely.

[GC] In normal circumstances, I agree.

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Jul 2008 17:20:10 -0400

I assume that preventing BYE from the caller side is mainly meant to  
deal with accidental disconnect. Nothing prevents a caller from  
turning off the cell phone, removing its battery or unplugging the  
land-line phone (or simply muting the microphone).

On Jul 10, 2008, at 3:42 PM, <[email-masked]> <[email-masked]> wrote:

> Certainly Marc.
>
> It is also my understanding that current cellular voice services  
> have not implemented the network capabilities to enable PSAP control  
> over call termination even if the jurisdiction requires/mandates it.  
> The reasons for this are still obscure to me. I note however that  
> those PSAPs using it are very disappointed of this situation in  
> wireless and would like not to repeat it for Next Generation services.
>
> The situation I was referring to was more in line with PSAP  
> requirements than with technical limitations. In that sense, if a  
> PSAP assumes a certain behavior for devices operating in its  
> jurisdiction, it would be up to the device to adjust accordingly.
>
> Thanks,

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 17:41:23 -0400

Henning,

Yes, accidental disconnects is one case including where the caller thinks he had given enough info but the call taker does not.

Drastic actions such as the one you mentioned are indeed a challenge. For the PSTN phone though, if there is more than one phone in the house (as it is usually the case), the other sets could be used to re-invite the caller into a conversation since it is the "line" that is kept alive.

Thanks,

Guy Caron
-----Message d'origine-----
De : Henning Schulzrinne [mailto:[email-masked]] 
Envoyé : 10 juillet 2008 17:20
À : Caron, Guy (A162859)
Cc : [email-masked]; [email-masked]; [email-masked]
Objet : Re: [Ecrit] emergency call termination

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 10 Jul 2008 16:26:43 -0500

Guy

in-line below

At 04:00 PM 7/10/2008, [email-masked] wrote:
>[GC] Indeed, a very unfortunate and dramatic event that we all wish 
>would never happen. My understanding of the series of events is not 
>exactly as you described. You are right though that the location 
>information "on file" was wrong. The "system" in this case was not 
>the E9-1-1 infrastructure though.

[JMP] I didn't mean to imply it was.

>  But I'm sure if that information hadn't been given, and the call 
> taker wanted it (but for some reason delayed asking for it), they 
> would want to have the ability to prevent the caller from hanging 
> up.  This is one way
>for that not to occur.
>
>[GC] Absolutely.
>

[JMP] so, what are the non-normal circumstances you want this 
specified feature removed for, and how common (i.e., at what 
frequency) do they occur?

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 10 Jul 2008 16:58:35 -0500

>land-line phone (or simply muting the microphone).

I agree with that

---

From: <[email-masked]>
Date: Thu, 10 Jul 2008 18:03:41 -0400

James,

I'm not sure I understand the question but let me try this answer:

By "normal circumstances" I meant an emergency call being processed by a call taker until such time both agrees the call is over. In that plain vanilla case, both hang-ups would happen almost synchronously.

In other cases, both the caller and the call taker may not have the same notion of "the call is over". For some PSAPs, they want to rely on the ability to retain the connection. For other PSAPs, they don't use that.

The initial post was asking that the ability for a PSAP to control call termination be made optional and modulated by the location the device is currently in.

Let me know if I'm in the left field here.

Thanks,
                                                       
Guy Caron
-----Message d'origine-----
Envoyé : 10 juillet 2008 17:27

Guy

in-line below