Subject: Re: [Ecrit] I-D Action:draft-ietf-ecrit-lost-10.txt

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 05 Jul 2008 22:23:16 +0300

Hi Karl Heinz,

I am currently addressing your comments as part of the AUTH48. Thanks 
for reading the draft so carefully. Nobody doing the implementation work 
has noticed these issues so far. Very good.

Karl Heinz Wolf wrote:
> I just had a look at the new LoST document, and I remembered that I
> had some questions concerning LoST, I still got no answer for.
>
> Here are the points that still confuse me:
>
> 1) listServices and path indication: The draft says: "Since the query
> is answered by the queried server, there
>    is no notion of recursion or indirection and no path indication."
> But the sample in figure 12 has a <path> element.
>
>   
The <path> element always has to be present according to the XML schema. 
However, it will only contain one <via> element, namely the contacted 
server.
Hence, I removed the "... and no path indication." part of the sentence.

> 2) the serviceNumber is still missing for the sample in figure 18, the
> default mapping sample (as mentioned here last year
> http://www.ietf.org/mail-archive/web/ecrit/current/msg04727.html )
> Although the servieNumber is optional in LoST, I thought the samples
> should contain it since they are emergency call samples and without a
> service number one cannot call the default PSAP.
>
>   
True. For the emergency services cases having the <serviceNumber> 
element there makes a lot of sense.

> 3) how to request a specific location profile for
> <getServiceBoundary>? see
> http://www.ietf.org/mail-archive/web/ecrit/current/msg05226.html
>
>
>   
The location profile is essentially pre-set when the initial query was 
created. Hence, in this example the response to the getServiceBoundary 
should actually be geodetic location info rather than civic.

I will fix the example -- good catch!

> And I just noticed something new:
>
> profile="urn:ietf:params:lost:location-profile:basic-civic" is used
> once, all the other examples use profile="civic".
>
>   
Fixed.

> editorial: there is a "s" missing in ListServicesResponse: "Figure 12:
> Example of <ListServiceResponse>"
>
>   
Fixed.

Ciao
Hannes

> I hope someone can clarify my concerns! Thanks in advance.
>
> karl heinz
>
>
> 2008/5/28  <[email-masked]>:
>   
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Emergency Context Resolution with Internet Technologies Working Group of the IETF.
>>
>>
>>        Title           : LoST: A Location-to-Service Translation Protocol
>>        Author(s)       : T. Hardie, et al.
>>        Filename        : draft-ietf-ecrit-lost-10.txt
>>        Pages           : 79
>>        Date            : 2008-05-28
>>
>> This document describes an XML-based protocol for mapping service
>> identifiers and geodetic or civic location information to service
>> contact URIs.  In particular, it can be used to determine the
>> location-appropriate Public Safety Answering Point (PSAP) for
>> emergency services.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-ecrit-lost-10.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>>
>>
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ecrit
>>
>>
>>     
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>   

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Mon, 7 Jul 2008 09:36:23 +0200

Hi Hannes!

good to hear that you are addressing my points.
I hope you did not miss to remove sos.suicide? (figure 12 and 14!)

And also don't forget to correct the examples on your webpage!

> I will fix the example -- good catch!

how is the location profile pre-set? is it somehow done with the key
(the draft does not say this, I'm just guessing)?

cheers
karl heinz

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 7 Jul 2008 10:43:58 +0300

Hi Karl Heinz, 

>I hope you did not miss to remove sos.suicide? (figure 12 and 14!)

I put you on CC when I sent the mail to the RFC Editor 

>And also don't forget to correct the examples on your webpage!

Will do that once the entire process is completed. 

>how is the location profile pre-set? is it somehow done with 
>the key (the draft does not say this, I'm just guessing)?

With the initial <findService> request. The location profile used in the
<location> element is supposed to be the same as the one that is later
returned. 

Ciao
Hannes

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Mon, 7 Jul 2008 10:08:03 +0200

Hi Hannes!

> I put you on CC when I sent the mail to the RFC Editor

Thank you, I read this mail now and it's corrected there.

> <location> element is supposed to be the same as the one that is later

but how should the LoST server know what profile to return when a
client does a getServiceBoundary request (some time after the initial
findService)? Is the LoST Server expected to identify the clients
somehow and to store information what client gets which location
profile?

cheers
karl heinz

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 7 Jul 2008 13:08:30 +0300

>
>but how should the LoST server know what profile to return 
>when a client does a getServiceBoundary request (some time 
>after the initial findService)? Is the LoST Server expected to 
>identify the clients somehow and to store information what 
>client gets which location profile?

When the LoST server creates the reference for later retrieval then it
needs to store information, namely the respective location info
elements, behind that reference. 

Ciao
Hannes

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Mon, 7 Jul 2008 12:30:16 +0200

> elements, behind that reference.

the reference is the "key" in LoST, isn't it?
so the assumption is that there is a seperate key for the civic,
geodetic and for civic+geodetic location profile (and for every
possible future combination of new profiles) for every service
boundary? I'm asking again because I couldn't find any information on
this in the draft.
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 11 Jul 2008 13:15:21 +0300

> boundary? I'm asking again because I couldn't find any information on

Correct. It's a one-to-one mapping.

Ciao
Hannes