Subject: Re: [Ecrit] Request for agenda time to discuss emergency calltermination

From: <[email-masked]>
Date: Tue, 15 Jul 2008 19:34:30 -0400

Marc,

I have to interject here.

First, CPH is supported in SS7 signaling today (see ANSI T1.666) and vendors have implemented it.

Second, the fact that CPH is *currently* used in Canada and Japan (there may be others too!)  should provide enough evidence that the feature is not antiquated.

What was born from technology limitations in the early days has become a very much appreciated feature for some PSAPs while evolving to E9-1-1. They just don't want to loose it if it is technically possible. And this discussion is telling me it could be possible.

Thanks,
______________
Guy Caron 
Bell Canada
(418) 691-1119

----- Message d'origine -----
De : [email-masked] <[email-masked]>
À : Brian Rosen <[email-masked]>; [email-masked] <[email-masked]>
Envoyé : Tue Jul 15 18:23:39 2008
Objet : Re: [Ecrit] Request for agenda time to discuss emergency calltermination

Brian,

On 7/15/08 3:36 PM, "Brian Rosen" <[email-masked]> wrote:

>>> Nah, they don't do it because they didn't have to discuss it with the
>>> emergency guys before they designed the networks.
>> 
>> And your evidence for this is what, exactly? That they patterned
>> the network behavior on the ISDN behavior?  Did the ISDN
>> folks also not talk to the emergency guys?  Or did the emergency
>> guys they talked to say something different from what you
>> think they are saying now?
> 
> I will give you a dozen old timers in the PSAP world who will tell you that
> they howled and screamed when the telcos took away called party hold.

CPH was necessary in the electro-mechanical switch days.  There was no CDR,
no way to post mortem trace a call.  CPH to the PSAPs started to fade as 'E'
9-1-1 was rolled out.  As the PSAPs gained a way to identify the caller, the
need for CPH became less important.  Apparently, some PSAPs have found a use
for CPH in addition to having ANI/ALI.  Of course, they only have this
feature on 35% of the 9-1-1 calls.

Malicious Call Hold used CPH also, but it went by the way of CDRs from
modern digital switches.  Hence, the courts accept switch CDRs as evidence.

I don't believe CPH is supported on SS7, hence this may be the reason
cellular doesn't support it as it's based on a derivative of SS7 (IS41?).

So, my assertion is that CPH is only supported on CAS (channel associated
signaling) trunks.  CCS (common channel signaling) doesn't support such.
SIP is CCS, not CAS.  (I wish it were that easy :^)

Bottom line, CPH is a very antiquated feature.

-Marc-

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Marc Linsner <[email-masked]>
Date: Tue, 15 Jul 2008 19:51:13 -0400

Guy,

Thanks for the update.  I obviously haven't kept up on every national
variant of SS7.  Regardless, I believe the cellular network is based on IS41
which is a derivative of the base CCITT spec.

It depends on what functionality you are believing is possible.  IMO, there
is quite a difference in not responding to SIP BYE and 'taking control' of
the far-end SIP UA.

The fact remains that 65% of 911 calls do not support CPH.

-Marc-

> Second, the fact that CPH is *currently* used in Canada and Japan (there may
> be others too!)  should provide enough evidence that the feature is not
> antiquated.
> 
> What was born from technology limitations in the early days has become a very
> much appreciated feature for some PSAPs while evolving to E9-1-1. They just
> don't want to loose it if it is technically possible. And this discussion is
> telling me it could be possible.
> 
> Thanks,
> ______________
> Guy Caron 
> Bell Canada
> (418) 691-1119
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 15 Jul 2008 18:54:33 -0500

I think that greater question is should those 65% support it?
Without open discussion in the forum I don't think this question can be answered adequately.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marc Linsner
> Sent: Wednesday, 16 July 2008 9:51 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Ecrit] Request for agenda time to discuss emergency
> calltermination
> 
> Guy,
> 
> > First, CPH is supported in SS7 signaling today (see ANSI T1.666) and
> vendors
> > have implemented it.
> >

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Marc Linsner <[email-masked]>
Date: Tue, 15 Jul 2008 19:57:28 -0400

I agree, we need to discuss it.  A draft with detailed requirements is the
first step.

-Marc-

On 7/15/08 7:54 PM, "Winterbottom, James" <[email-masked]>
wrote:

>> variant of SS7.  Regardless, I believe the cellular network is based on
> 
>> IS41
> 
>> It depends on what functionality you are believing is possible.  IMO,
> 
>> there
> 
>>> Second, the fact that CPH is *currently* used in Canada and Japan (there
> 
>> may
> 
>>> What was born from technology limitations in the early days has become a
> 
>> very
> 
>>> much appreciated feature for some PSAPs while evolving to E9-1-1. They
> 
>> just
> 
>>> don't want to loose it if it is technically possible. And this
> 
>> discussion is
> 
>>> Objet : Re: [Ecrit] Request for agenda time to discuss emergency
> 
>>> calltermination
> 
>>> 
> 
>>> Brian,
> 
>>> 
> 
>>> 
> 
>>>> I will give you a dozen old timers in the PSAP world who will tell you
> 
>> that
> 
>>> CPH was necessary in the electro-mechanical switch days.  There was no
> 
>> CDR,
> 
>>> no way to post mortem trace a call.  CPH to the PSAPs started to fade as
> 
>> 'E'
> 
>>> 9-1-1 was rolled out.  As the PSAPs gained a way to identify the caller,
> 
>> the
> 
>>> need for CPH became less important.  Apparently, some PSAPs have found a
> 
>> use
> 
>>> modern digital switches.  Hence, the courts accept switch CDRs as
> 
>> evidence.
> 
>>> 
> 
>>> So, my assertion is that CPH is only supported on CAS (channel
> 
>> associated
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 15 Jul 2008 18:58:32 -0500

I totally agree, but I am not volunteering to write it!

> From: Marc Linsner [mailto:[email-masked]]
> Sent: Wednesday, 16 July 2008 9:57 AM
> To: Winterbottom, James; [email-masked]
> > ------------------------------------------------------------------------
> ------
> > ------------------
> >
> > ------------------------------------------------------------------------
> ------
> > ------------------
> >
> > [mf2]
> >
> >
> 
>

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 16 Jul 2008 01:03:29 -0500

At 06:54 PM 7/15/2008, Winterbottom, James wrote:
>Without open discussion in the forum I don't 
>think this question can be answered adequately.

I think this is a SIP WG question, not an ECRIT question.

An advocate needs to write a draft, it can be 
discussed in ECRIT, but it has to be IMO 
discussed in SIP to fully vet the SIP protocol modification question.

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 16 Jul 2008 01:20:47 -0500

Not that I really mind too much, but wouldn't the requirements come from ECRIT but the solution come SIP?

Cheers
James

> From: James M. Polk [mailto:[email-masked]]
> Sent: Wednesday, 16 July 2008 4:03 PM
> To: Winterbottom, James; Marc Linsner; [email-masked]; [email-masked];
> [email-masked]

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 16 Jul 2008 01:49:17 -0500

At 01:20 AM 7/16/2008, Winterbottom, James wrote:
>Not that I really mind too much, but wouldn't 
>the requirements come from ECRIT but the solution come SIP?

I think this would work, understanding that SIP 
might not think this is a good idea.

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Wed, 16 Jul 2008 11:31:45 +0200

I think everyone is agreed that we need to get requirements that elucidate what problem is actually solved for these PSAPs.

SIP does not draft requirements except for security issues.

Therefore I think it is appropriate for ECRIT to identify and achieve consensus on a list of requirements. Once we have that, a allocation of work on a solution to those requirements can be discussed between the various involved WG chairs and the ADs.

Regards

Keith

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of James M. Polk
> Sent: Wednesday, July 16, 2008 7:03 AM
> To: Winterbottom, James; Marc Linsner; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [Ecrit] Request for agenda time to discuss 
> emergency calltermination
> 
> >Without open discussion in the forum I don't think this 
> question can be 
> >answered adequately.
> 
> An advocate needs to write a draft, it can be discussed in 
> ECRIT, but it has to be IMO discussed in SIP to fully vet the 
> SIP protocol modification question.
> 
> 
> >Cheers
> >James
> >
> >
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Marc Linsner
> > > Thanks for the update.  I obviously haven't kept up on every 
> > > national variant of SS7.  Regardless, I believe the 
> cellular network 
> > > is based on
> > > IS41
> > > It depends on what functionality you are believing is possible.  
> > > IMO, there is quite a difference in not responding to SIP BYE and 
> > > 'taking control' of the far-end SIP UA.
> > >
> > > > First, CPH is supported in SS7 signaling today (see 
> ANSI T1.666) 
> > > > and
> > > vendors
> > > > have implemented it.
> > > >
> > > > Second, the fact that CPH is *currently* used in Canada 
> and Japan 
> > > > (there
> > > may
> > > > be others too!)  should provide enough evidence that 
> the feature 
> > > > is not antiquated.
> > > >
> > > > much appreciated feature for some PSAPs while evolving 
> to E9-1-1. 
> > > > They
> > > just
> > > > De : [email-masked] <[email-masked]> À : Brian 
> > > > Rosen <[email-masked]>; [email-masked] 
> <[email-masked]> Envoyé 
> > > > : Tue Jul 15 18:23:39 2008 Objet : Re: [Ecrit] Request 
> for agenda 
> > > > time to discuss emergency calltermination
> > > >
> > > > Brian,
> > > >
> > > >
> > > >>>> Nah, they don't do it because they didn't have to discuss it 
> > > >>>> with the emergency guys before they designed the networks.
> > > >>>
> > > >>> the network behavior on the ISDN behavior?  Did the 
> ISDN folks 
> > > >>> also not talk to the emergency guys?  Or did the 
> emergency guys 
> > > >>> they talked to say something different from what you 
> think they 
> > > >>> are saying now?
> > > >>
> > > > no way to post mortem trace a call.  CPH to the PSAPs 
> started to 
> > > > fade as
> > > 'E'
> > > > 9-1-1 was rolled out.  As the PSAPs gained a way to 
> identify the 
> > > > caller,
> > > the
> > > > need for CPH became less important.  Apparently, some 
> PSAPs have 
> > > > found a
> > > use
> > > > for CPH in addition to having ANI/ALI.  Of course, they 
> only have 
> > > > this feature on 35% of the 9-1-1 calls.
> > > >
> > > > Malicious Call Hold used CPH also, but it went by the 
> way of CDRs 
> > > > from modern digital switches.  Hence, the courts accept switch 
> > > > CDRs as
> > > evidence.
> > > >
> > > > I don't believe CPH is supported on SS7, hence this may be the 
> > > > reason cellular doesn't support it as it's based on a 
> derivative of SS7 (IS41?).
> > > >
> >-------------------------------------------------------------
> ----------
> >------------------------- This message is for the designated 
> recipient 
> >only and may contain privileged, proprietary, or otherwise private 
> >information.
> immediately 
> >and delete the original.  Any unauthorized use of this email is 
> >prohibited.
> >-------------------------------------------------------------
> ----------
> >-------------------------
> >[mf2]
> >