Subject: [Ecrit] New ID:draft-sun-ecrit-unsafe-areas-00

From: Qian Sun <[email-masked]>
Date: Fri, 04 Jul 2008 09:10:40 +0800

Hi, All

I just submitted a new draft, it can be found here:
http://www.ietf.org/internet-drafts/draft-sun-ecrit-unsafe-areas-00.txt  

Filename:	 draft-sun-ecrit-unsafe-areas
Revision:	 00
Title:		 Specifying Unsafe Areas in LoST Service Boundary
Creation_date:	 2008-07-01
WG ID:		 Independent Submission
Number_of_pages: 8

Abstract:
This document describes how to specify unsafe areas in LoST for emergency services, such as police, mountain, marine and fire.

Your comments are welcome!

Thanks!
Qian

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 04 Jul 2008 20:25:00 +0300

Hi Qian,

thanks for the document. Interesting usage of LoST.

A few quick comments:

* I wonder whether it wouldn't be better to define some new service URNs 
for the usage of these "unsafe" areas instead of adding a new attribute.
The reason for this is that the existing service URNs are somewhat 
difficult to use in this context. For example, what does it mean to have 
the unsafe attribute included in the request when the 
"urn:service:sos.poison" URN is used? New URNs are being proposed, such 
as those in 
http://tools.ietf.org/id/draft-forte-ecrit-service-classification-00.txt, 
that make the semantic even more difficult to interpret.

* Would be useful to include an element in the reponse to point to more 
detailed information, such as a URL to a webpage?

* Deployment: Who do you think would want to run such a service? Would 
this be something the PSAP operator would want todo? Tourism office? 
Police departments? (I am trying to figure out where to get some 
feedback from.)

How often do you think the "service boundaries" of these unsafe areas 
change? (Keep constant for years vs. change every day)

Ciao
Hannes

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Mon, 7 Jul 2008 10:20:14 +0200

Hi,

I also read the draft, and like Hannes, my first thought was about a
separate service URN for this propose.

One additional comment:
When the unsafe-Information is included to the Mapping Information of
a particular PSAP, there could be a problem when a PSAP is responsible
for a large area. Assuming a police PSAP is responsible for a whole
federal state, there may be hundreds of unsafe areas inside - and most
of them will be far away from my current location. So it could be more
interesting to query for all unsafe-areas within a radius of 5 km,
regardless of the service boundary of a particular PSAP.

cheers
karl heinz

On Fri, Jul 4, 2008 at 7:25 PM, Hannes Tschofenig
<[email-masked]> wrote:
> * I wonder whether it wouldn't be better to define some new service URNs for
> the usage of these "unsafe" areas instead of adding a new attribute.
> The reason for this is that the existing service URNs are somewhat difficult
> to use in this context. For example, what does it mean to have the unsafe
> attribute included in the request when the "urn:service:sos.poison" URN is
> used? New URNs are being proposed, such as those in
> * Deployment: Who do you think would want to run such a service? Would this
> be something the PSAP operator would want todo? Tourism office? Police
> departments? (I am trying to figure out where to get some feedback from.)
>
>> This document describes how to specify unsafe areas in LoST for emergency
>> services, such as police, mountain, marine and fire.
>>

---

From: Qian Sun <[email-masked]>
Date: Mon, 07 Jul 2008 17:42:24 +0800

Thanks for comments!

In another draft we use this way you suggested to find safe areas:
http://tools.ietf.org/html/draft-sun-ecrit-shelter-service-00

Regards,
Qian
> -----Original Message-----
> From: Karl Heinz Wolf [mailto:[email-masked]]
> Sent: Monday, July 07, 2008 4:20 PM
> To: Hannes Tschofenig
> Cc: Qian Sun; [email-masked]
> Subject: Re: [Ecrit] Comments for draft-sun-ecrit-unsafe-areas-00
> 
> Hi,
>

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 7 Jul 2008 13:10:02 +0300

Correct, and this document also makes far more sense for me. 

>> > * I wonder whether it wouldn't be better to define some 
>new service 
>> > URNs for the usage of these "unsafe" areas instead of 
>adding a new attribute.
>> > difficult to use in this context. For example, what does 
>it mean to 
>> > have the unsafe attribute included in the request when the 
>> > "urn:service:sos.poison" URN is used? New URNs are being proposed, 
>> > such as those in
>> >
>> 
>> > * Would be useful to include an element in the reponse to point to 
>> > more detailed information, such as a URL to a webpage?
>> >
>> > * Deployment: Who do you think would want to run such a service? 
>> > Would this be something the PSAP operator would want todo? Tourism 
>> > office? Police departments? (I am trying to figure out 
>where to get 
>> > some feedback from.)
>> >
>> > How often do you think the "service boundaries" of these unsafe 
>> > areas change? (Keep constant for years vs. change every day)
>> >
>> > Ciao
>> > Hannes
>> >
>> >
>> >
>> > Qian Sun wrote:
>> >>
>> >> Hi, All
>> >>
>> >> This document describes how to specify unsafe areas in LoST for 
>> >> emergency services, such as police, mountain, marine and fire.
>> >>

---

From: Qian Sun <[email-masked]>
Date: Mon, 07 Jul 2008 17:17:36 +0800

Hi, Hannes

Thanks for your comments! Please see inline.

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Saturday, July 05, 2008 1:25 AM
> To: Qian Sun
> Cc: [email-masked]
> Subject: Comments for draft-sun-ecrit-unsafe-areas-00
> 
> Hi Qian,
> 
Good point! Indeed, "unsafe" area is meaningless for some services. Maybe it's better to define some new service URNs for the usage of these "unsafe" areas instead of adding a new attribute.

However, could we use "hotspotArea" attribute instead of "unsafeArea"?  It means the service is frequently requested or provided in these areas. This is meaningful for most services. For example:
For police service, these areas are the regions with high crime report. 
For restaurant service, these areas are the regions with a lot of popular restaurants.
......
Is this more general?

> detailed information, such as a URL to a webpage?
Sure.

> Police departments? (I am trying to figure out where to get some
If we define a new service URN for unsafe area of crime, maybe police departments would want to run such a service.

> change? (Keep constant for years vs. change every day)
It depends on the specific service. For police service, change every month might be appropriate (normally the police departments give a monthly crime report). For marine service, maybe it can keep constant for years (submerged rocks are fixed).

Regards,
Qian