Subject: Re: [Ecrit] Additional text - location mech - wireless & mobilitysupport

From: "Stark, Barbara" <[email-masked]>
Date: Mon, 1 Dec 2008 10:58:33 -0500

I don't understand this proposed sentence: " Requirements for endpoint
location determination vary, 
depending on whether an endpoint's resulting location is based 
on internal (device-based) or external (network-based) 
measurements, or by manual provisioning - for mobile capable, or 
fixed environment endpoints, respectively.  "

That is, I understand the first part, up to the dash "-". I don't
understand the part after the dash "-", specifically the use of the word
"respectively".

Is a Femtocell access point (which connects via Ethernet into the LAN of
a home network that is connected by a broadband connection to the
Internet) mobile capable or fixed? The FAP itself is certainly *not*
mobile. It will be able to use GPS or AGPS (with SUPL) to get its
location determined. It will also need to be able to use other methods
to get its location when it finds itself in a basement, unable to make
use of GPS.

Is a GSM/Wi-Fi PDA that is in someone's basement (where GPS doesn't
work, and they can't get a cellular signal), and is connected via Wi-Fi
into a home network, supposed to use internal or external measurements?
It's definitely mobile capable.
Barbara

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roger Marshall
Sent: Friday, November 28, 2008 5:35 PM
To: Rosen, Brian
Cc: [email-masked]
Subject: [Ecrit] Additional text - location mech - wireless &
mobilitysupport

Brian:
Below is a proposed change in text to the current phonebcp-06 that adds
some background for various requirements later in the draft that specify
"wireless" and "mobile", per remarks made in the 11/20 ECRIT wg meeting.

1. Section 6. Location and its role in emergency calls

change from:

In Internet emergency calling, where the endpoint is located 
is "determined" using a variety of measurement or wiretracing 
methods.  Endpoints may be "configured" with their own location 
by the access network.

change to:

In Internet emergency calling, the endpoint location 
is "determined" using a variety of measurement or wiretracing 
methods.  Requirements for endpoint location determination vary, 
depending on whether an endpoint's resulting location is based 
on internal (device-based) or external (network-based) 
measurements, or by manual provisioning - for mobile capable, or 
fixed environment endpoints, respectively.  Once location has 
been determined, endpoints may then be "configured" with their 
own location by the access network via some Location Configuration 
Protocol (LCP).

-roger marshall.

CONFIDENTIALITY NOTICE: The information contained in this message may be
privileged and/or confidential. If you are not the intended recipient,
or responsible for delivering this message to the intended recipient,
any review, forwarding, dissemination, distribution or copying of this
communication or any attachment(s) is strictly prohibited. If you have
received this message in error, please notify the sender immediately,
and delete it and all attachments from your computer and network.
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA622

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Roger Marshall" <[email-masked]>
Date: Mon, 1 Dec 2008 08:56:46 -0800

Barbara:

I acknowledge the wording problem (and the bigger deployment problem).

How about just shortening the sentence a little by removing the
offending word, "respectively"... as follows:

" Requirements for 
endpoint location determination vary, depending on whether an 
endpoint's resulting location is based on internal 
(device-based) or external (network-based) measurements, or 
by manual provisioning, for mobile capable or fixed 
environment endpoints.  "

-roger.

> From: Stark, Barbara [mailto:[email-masked]] 
> Sent: Monday, December 01, 2008 7:59 AM
> To: Roger Marshall; Rosen, Brian
> Cc: [email-masked]
> Subject: RE: [Ecrit] Additional text - location mech - 
> wireless & mobilitysupport
> 
> I don't understand this proposed sentence: " Requirements for 
> endpoint location determination vary, depending on whether an 
> endpoint's resulting location is based on internal 
> (device-based) or external (network-based) measurements, or 
> by manual provisioning - for mobile capable, or fixed 
> environment endpoints, respectively.  "
> 
> That is, I understand the first part, up to the dash "-". I 
> don't understand the part after the dash "-", specifically 
> the use of the word "respectively".
> 
> Is a Femtocell access point (which connects via Ethernet into 
> the LAN of a home network that is connected by a broadband 
> connection to the
> Internet) mobile capable or fixed? The FAP itself is 
> certainly *not* mobile. It will be able to use GPS or AGPS 
> (with SUPL) to get its location determined. It will also need 
> to be able to use other methods to get its location when it 
> finds itself in a basement, unable to make use of GPS.
> 
> Is a GSM/Wi-Fi PDA that is in someone's basement (where GPS 
> doesn't work, and they can't get a cellular signal), and is 
> connected via Wi-Fi into a home network, supposed to use 
> internal or external measurements?
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Roger Marshall
> Below is a proposed change in text to the current phonebcp-06 
> that adds some background for various requirements later in 
> the draft that specify "wireless" and "mobile", per remarks 
> made in the 11/20 ECRIT wg meeting.
> 
> methods.  Endpoints may be "configured" with their own 
> location by the access network.
> 
> change to:
> 
> In Internet emergency calling, the endpoint location is 
> "determined" using a variety of measurement or wiretracing 
> methods.  Requirements for endpoint location determination 
> vary, depending on whether an endpoint's resulting location 
> is based on internal (device-based) or external 
> (network-based) measurements, or by manual provisioning - for 
> mobile capable, or fixed environment endpoints, respectively. 
>  Once location has been determined, endpoints may then be 
> "configured" with their own location by the access network 
> via some Location Configuration Protocol (LCP).
> 
> 
> -roger marshall.
> 
> CONFIDENTIALITY NOTICE: The information contained in this 
> message may be privileged and/or confidential. If you are not 
> the intended recipient, or responsible for delivering this 
> message to the intended recipient, any review, forwarding, 
> dissemination, distribution or copying of this communication 
> or any attachment(s) is strictly prohibited. If you have 
> received this message in error, please notify the sender 
> immediately, and delete it and all attachments from your 
> computer and network.
> The information transmitted is intended only for the person 
> or entity to which it is addressed and may contain 
> confidential, proprietary, and/or privileged material. Any 
> review, retransmission, dissemination or other use of, or 
> taking of any action in reliance upon this information by 
> persons or entities other than the intended recipient is 
> prohibited. If you received this in error, please contact the 
> sender and delete the material from all computers. GA622
> 
> 
>

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 01 Dec 2008 13:45:24 -0600

Barb

I generally agree with your concerns, as I've been on a kick for the 
last year or so to have anyone that says "wireless" to distinguish 
whether they are referring to cellular or dot11 based radio-link 
tethering.  The two are most often have (very) different properties.

I think this any text changes either need to be more general in 
nature, or painfully explicit (wrt which or each radio-type).

James

At 09:58 AM 12/1/2008, Stark, Barbara wrote:
>The information transmitted is intended only for the person or 
>entity to which it is addressed and may contain confidential, 
>proprietary, and/or privileged material. Any review, retransmission, 
>dissemination or other use of, or taking of any action in reliance 
>upon this information by persons or entities other than the intended 
>recipient is prohibited. If you received this in error, please 
>contact the sender and delete the material from all computers. GA622
>
>

---

From: "Stark, Barbara" <[email-masked]>
Date: Mon, 1 Dec 2008 14:47:58 -0500

Yep. That's fine.
Barbara

-----Original Message-----
From: Roger Marshall [mailto:[email-masked]] 
Sent: Monday, December 01, 2008 11:57 AM
To: Stark, Barbara; Rosen, Brian
Cc: [email-masked]
Subject: RE: [Ecrit] Additional text - location mech - wireless &
mobilitysupport

Barbara:

" Requirements for 

-roger.

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 1 Dec 2008 15:59:51 -0600

I'm not as easy to please as Barbara...

I don't see why there is a continual insistence on distinguishing between "mobile" and "fixed" in relation to how location is generated.  The number of cases where this distinction is confusing or misleading only seems to increase over time.  Location generation methods and mobility should be considered orthogonal.  At least leave that up to the device/LIS.  Be clear on what the discussion requires and focus on that perspective.  Never try to imply some correlation between the two.

Since this is talking about the mechanism involved in location generation, I'd prefer to see this bit removed:  ", for mobile capable or fixed environment endpoints".

Cheers,
Martin

> Of Stark, Barbara
> Sent: Tuesday, 2 December 2008 6:48 AM
> Subject: Re: [Ecrit] Additional text - location mech - wireless
> &mobilitysupport
> 
> Yep. That's fine.
> Barbara
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Roger Marshall" <[email-masked]>
Date: Mon, 1 Dec 2008 14:03:46 -0800

I am ok with the further trimming.

..." Requirements for
endpoint location determination vary, depending on whether an 
endpoint's resulting location is based on internal
(device-based) or external (network-based) measurements, or 
by manual provisioning.  "...

-roger.

> From: Thomson, Martin [mailto:[email-masked]] 
> Sent: Monday, December 01, 2008 2:00 PM
> To: Stark, Barbara; Roger Marshall; Rosen, Brian
> Cc: [email-masked]
> wireless &mobilitysupport
> 
> I don't see why there is a continual insistence on 
> distinguishing between "mobile" and "fixed" in relation to 
> how location is generated.  The number of cases where this 
> distinction is confusing or misleading only seems to increase 
> over time.  Location generation methods and mobility should 
> be considered orthogonal.  At least leave that up to the 
> device/LIS.  Be clear on what the discussion requires and 
> focus on that perspective.  Never try to imply some 
> correlation between the two.
> 
> Since this is talking about the mechanism involved in 
> location generation, I'd prefer to see this bit removed:  ", 
> for mobile capable or fixed environment endpoints".
> 
> Cheers,
> Martin
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Stark, Barbara
> by manual 
> > provisioning, for mobile capable or fixed environment endpoints.  "
> > 
> > -roger.
> > 
> > 
> > 
> > > (device-based) or external (network-based) measurements, or by 
> > > manual provisioning - for mobile capable, or fixed environment 
> > > endpoints, respectively.  "
> > >
> > > understand the part after the dash "-", specifically the 
> use of the 
> > > word "respectively".
> > >
> > > Is a Femtocell access point (which connects via Ethernet into the 
> > > LAN of a home network that is connected by a broadband 
> connection to 
> > > the
> certainly *not* 
> > > location determined. It will also need to be able to use other 
> > > methods to get its location when it finds itself in a basement, 
> > > unable to make use of GPS.
> > >
> > > work, and they can't get a cellular signal), and is connected via 
> > > Wi-Fi into a home network, supposed to use internal or external 
> > > measurements?
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Roger Marshall
> > > Below is a proposed change in text to the current 
> phonebcp-06 that 
> > > adds some background for various requirements later in the draft 
> > > that specify "wireless" and "mobile", per remarks made in 
> the 11/20 
> > > ECRIT wg meeting.
> > >
> > > In Internet emergency calling, where the endpoint is located is 
> > > "determined" using a variety of measurement or 
> wiretracing methods.  
> > > Endpoints may be "configured" with their own location by 
> the access 
> > > network.
> > >
> > > change to:
> > >
> "determined" 
> > > using a variety of measurement or wiretracing methods.  
> Requirements 
> > > for endpoint location determination vary, depending on whether an 
> (device-based) or 
> > > external
> > > (network-based) measurements, or by manual provisioning - 
> for mobile 
> > > capable, or fixed environment endpoints, respectively.
> > > "configured" with their own location by the access 
> network via some 
> > > Location Configuration Protocol (LCP).
> > >
> > >
> > > -roger marshall.
> > >
> > > CONFIDENTIALITY NOTICE: The information contained in this message 
> > > may be privileged and/or confidential. If you are not the 
> intended 
> > > recipient, or responsible for delivering this message to the 
> > > intended recipient, any review, forwarding, dissemination, 
> > > distribution or copying of this communication or any 
> attachment(s) 
> > > is strictly prohibited. If you have received this message 
> in error, 
> > > please notify the sender immediately, and delete it and all 
> > > attachments from your computer and network.

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 01 Dec 2008 17:40:06 -0600

>I'm not as easy to please as Barbara...

<mumble>

;-)

>I don't see why there is a continual insistence on distinguishing 
>between "mobile" and "fixed" in relation to how location is 
>generated.  The number of cases where this distinction is confusing 
>or misleading only seems to increase over time.  Location generation 
>methods and mobility should be considered orthogonal.  At least 
>leave that up to the device/LIS.  Be clear on what the discussion 
>requires and focus on that perspective.  Never try to imply some 

hence the comment earlier that connectivity remain a general issue in 
the whole scheme of things

btw - I generally agree with Martin's little rant here

>Since this is talking about the mechanism involved in location 
>generation, I'd prefer to see this bit removed:  ", for mobile 
>capable or fixed environment endpoints".
>
>Cheers,
>Martin
>