Subject: [Ecrit] New Work

From: Marc Linsner <[email-masked]>
Date: Fri, 13 Aug 2010 10:08:36 -0400

We recently asked for any objections to taking on the following documents as
workgroup items.  We have consensus to take this work on, now we have to
commit to a realistic timeframe for completion.  We're suggesting the
following and would like your comments to include:

1) Are willing to work/contribute on the document?
2) Are willing to commit to the timeframe shown?

The chairs commit to hosting virtual interim meetings at intervals necessary
to meet the timeframes.

Mar 2011 - draft-rosen-ecrit-additional-data
Apr 2011 - draft-rosen-ecrit-data-only-ea
Dec 2011 - draft-schulzrinne-ecrit-unauthenticated-access
Jan 2012 - draft-tschofenig-ecrit-trustworthy-location
Mar 2012 - draft-schulzrinne-ecrit-psap-callback

We realize the timeframes appear to out there but past experience tells us
to be conservative.  There's no penalty for getting them done early.

We MUST have commitment to work on these before the ADs will give us the
milestones.

Please send your comments including which drafts you are willing to work on
by COB Friday, August 20, 2010.

Thanks,

-Marc, Richard, Roger-

---

From: Brian Rosen <[email-masked]>
Date: Fri, 13 Aug 2010 10:41:16 -0400

Seems reasonable to me assuming the work group comments on what they don't like so authors can address issues.

I, of course, am willing to work on -additional-data and -data-only.  I will commit to comment/contribute to -trustworthy and -callback.  I will review -unauthenticated as needed.

Brian

On Aug 13, 2010, at 10:08 AM, Marc Linsner wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 13 Aug 2010 10:35:38 -0700

I will commit to working on -trustworthy and will commit to closely following additional-data and data-only, since both of these documents appear to be useful. 

I'll also commit to review unauthenticated and callback, though I admit to being uneasy about them. 

> From: [email-masked]
> Date: Fri, 13 Aug 2010 10:41:16 -0400
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: [Ecrit] New Work
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 14 Aug 2010 21:19:15 +0300

Hi Marc, Richard, Roger,

I am willing to work on the documents. The milestones are seem to be a 
good estimate.

Ciao
Hannes

---

From: "Patel, Milan" <[email-masked]>
Date: Sun, 15 Aug 2010 08:24:36 -0400

Hi Marc, Richard & Roger,

I will continue to work on the Call Back draft. 
Best regards,
Milan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Hannes Tschofenig
Sent: Saturday, August 14, 2010 7:19 PM
To: Marc Linsner
Cc: 'ecrit'
Subject: Re: [Ecrit] New Work

Hi Marc, Richard, Roger,

Ciao
Hannes

 

Milan Patel 
Consultant
InterDigital Communications, LLC

Tel.: +44 7917 678 250
Fax: 
Email: [email-masked]
http://www.InterDigital.com

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: <[email-masked]>
Date: Mon, 16 Aug 2010 09:38:44 +0200

Dear all,

thanks for sharing the time estimates. This is a very useful discussion for those who are dependent on IETF work!

3GPP is committed to use IETF based solution for callback if one exists. Since regulatory requirements to support callback do exist on some markets, we never removed the requirement from our requirement specifications but 3GPP TS 22.101 in its clause 10.1.3 says that callback must be supported if (=as soon as) there is means to recognise a call as being a callback from PSAP.

This requirement for marking of callback is the main thing 3GPP needs from the protocol solution.

The time line for 3GPP Rel-10 aims at freezing in March 2011 and if callback draft is completed a year later, then it will unfortunately miss the time window for Rel-10.

BR,
Hannu Hietalahti
3GPP TSG CT Chairman
tel: +358 40 5021724

>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of ext Patel, Milan
>Sent: 15 August, 2010 15:25
>To: Hannes Tschofenig; Marc Linsner
>Cc: ecrit
>This e-mail is intended only for the use of the individual or 
>entity to which it is addressed, and may contain information 
>that is privileged, confidential and/or otherwise protected 
>from disclosure to anyone other than its intended recipient. 
>Unintended transmission shall not constitute waiver of any 
>privilege or confidentiality obligation. If you received this 
>communication in error, please do not review, copy or 
>distribute it, notify me immediately by email, and delete the 
>original message and any attachments. Unless expressly stated 
>in this e-mail, nothing in this message or any attachment 
>should be construed as a digital or electronic signature.

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Aug 2010 18:53:05 -0500

I will commit to work on the data-only ID, and possibly psap-callback.

I think I share Hannu's concerns about psap-callback taking so long 
to get done. I mean, in 6 months this WG will have only 3 docs to 
work on, surely we can get this one done sooner if we try.

Otherwise, the proposed milestones appear fine to me.

James

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 17 Aug 2010 17:21:19 -0700

Getting PSAP callback "done" on schedule won't  matter much if the resulting
solution isn't implemented and deployed.   So I wouldn't worry as much about
IETF schedules as much as much as deployability.  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
James M. Polk
Sent: Tuesday, August 17, 2010 4:53 PM
To: Marc Linsner; 'ecrit'
Subject: Re: [Ecrit] New Work

I think I share Hannu's concerns about psap-callback taking so long to get
done. I mean, in 6 months this WG will have only 3 docs to work on, surely
we can get this one done sooner if we try.

James

At 09:08 AM 8/13/2010, Marc Linsner wrote:
>We recently asked for any objections to taking on the following 
>documents as workgroup items.  We have consensus to take this work on, 
>now we have to commit to a realistic timeframe for completion.  We're 
>suggesting the following and would like your comments to include:
>
>The chairs commit to hosting virtual interim meetings at intervals 
>necessary to meet the timeframes.
>
>Mar 2011 - draft-rosen-ecrit-additional-data Apr 2011 - 
>draft-rosen-ecrit-data-only-ea Dec 2011 - 
>draft-schulzrinne-ecrit-unauthenticated-access
>We realize the timeframes appear to out there but past experience tells 
>us to be conservative.  There's no penalty for getting them done early.
>
>We MUST have commitment to work on these before the ADs will give us 
>the milestones.
>
>Please send your comments including which drafts you are willing to 
>work on by COB Friday, August 20, 2010.
>
>Thanks,
>
>-Marc, Richard, Roger-
>
>
>

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Aug 2010 19:28:33 -0500

fair

but Hannu was most likely correct that if this takes as long as till 
spring `12, then it'll miss an entire window into 3GPP for 
deployment, which is (at least one of) the largest group(s) wanting 
this spec`d in the IETF, right?

I'm not always a fan of 3GPP, but their requirements should (i.e., 
can) be a goal for us here, right?

James

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 18 Aug 2010 11:02:04 +0800

I am willing to contribute to the callback and trustworthy items.  I can contribute to other items on an adhoc basis.  I intend to at least provide reviews for all of the work.

The timeframes seem optimistic, but that's OK.

> Of Marc Linsner
> Sent: Saturday, 14 August 2010 12:09 AM
> To: 'ecrit'
> Subject: [Ecrit] New Work
> 
> documents as
> us
> the

---

From: <[email-masked]>
Date: Wed, 18 Aug 2010 09:19:36 +0200

Hi James,

and sorry to corner you to a 3GPP-friendly situation ;-)

In psap-callback (and sos-parameter) 3GPP needs an indication of callback (and special registration) to trigger specific processing of the request.

3GPP would prefer to use generic IETF based mechanisms for such indications, as is already shown by us postponing the question to wait for IETF solution, even at the cost of leaving this critical part out of Rel-9 which is the first release expected to contain a full emergency call support.

Regulatory emergency call requirements and EPC/LTE deployments make the protocol solution for callback and emergency registration more urgent than they used to be in specification drafting phase.

Thanks Martin for volunteering to work on callback!

BR,
Hannu Hietalahti
3GPP TSG CT Chairman
tel: +358 40 5021724

>On Behalf Of ext James M. Polk
>Sent: 18 August, 2010 03:29
>To: Bernard Aboba; 'James M. Polk'; 'Marc Linsner'; 'ecrit'
>On Behalf Of