Subject: Re: [Ecrit] I-D Action: draft-ietf-ecrit-ecall-12.txt - Christer's comments

From: Christer Holmberg <[email-masked]>
Date: Thu, 22 Sep 2016 19:55:42 +0000

Hi,

I gave some comments on the draft to Randall before it was published, and he has addressed much of it.

Apart from some editorial comments that I still have, my main issue is still section 6.

My proposal was that we describe both mechanisms (for INFOs and for non-INFOs). Then, when we describe the mechanism for INFO (i.e., usage of info package) we describe that the Call-Info etc can be used to align etc (that has also been done in Section 10, which defines the info package).

But, section 6 contains 3 paragraphs talking about the additional data mechanism, and then there is one sentence that mentions INFO.

My suggestion is to separate section 6 into sub sections: one general, one describing the additional data mechanism, and one describing the info package mechanism.

Regards,

Christer

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 22 September 2016 02:17
To: [email-masked]
Cc: [email-masked]
Subject: [Ecrit] I-D Action: draft-ietf-ecrit-ecall-12.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Emergency Context Resolution with Internet Technologies of the IETF.

        Title           : Next-Generation Pan-European eCall
        Authors         : Randall Gellens
                          Hannes Tschofenig
	Filename        : draft-ietf-ecrit-ecall-12.txt
	Pages           : 43
	Date            : 2016-09-21

Abstract:
   This document describes how to use IP-based emergency services
   mechanisms to support the next generation of the Pan European in-
   vehicle emergency call service defined under the eSafety initiative
   of the European Commission (generally referred to as "eCall"). eCall
   is a standardized and mandated system for a special form of emergency
   calls placed by vehicles, providing real-time communications and an
   integrated set of related data.

   This document also registers MIME Content Types and an Emergency Call
   Additional Data Blocks for the eCall vehicle data and metadata/
   control data.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-ecall/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ecrit-ecall-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-ecall-12

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Randall Gellens <[email-masked]>
Date: Thu, 22 Sep 2016 15:15:55 -0700

Hi Christer,

At 7:55 PM +0000 9/22/16, Christer Holmberg wrote:

>  Hi,
>
>  I gave some comments on the draft to Randall before it was 
> published, and he has addressed much of it.
>
>  My proposal was that we describe both mechanisms (for INFOs and for 
> non-INFOs). Then, when we describe the mechanism for INFO (i.e., 
> usage of info package) we describe that the Call-Info etc can be 
> used to align etc (that has also been done in Section 10, which 
> defines the info package).
>
>  But, section 6 contains 3 paragraphs talking about the additional 
> data mechanism, and then there is one sentence that mentions INFO.

There are multiple references to INFO.  I think there are more 
references to INFO than without.  More importantly, per your 
suggestion, each place that mentions Call-Info says that the body 
part is sent in INFO using the INFO package defined in 10, per 
RFC6086.

Please have a look at -13, which I will upload soon.  It makes the 
further changes you suggested based on -12, and I did another 
read-through to find other places where transport or Call-Info or 
INFO are mentioned to be sure it is clear that body part are sent in 
INFO per RFC 6086 and using the INFO package.

>
>  My suggestion is to separate section 6 into sub sections: one 
> general, one describing the additional data mechanism, and one 
> describing the info package mechanism.
>
>  Regards,
>
>  Christer
>
>
>  Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Good night to spend with family, but avoid arguments with your
mate's new lover.