Subject: [Ecrit] Review of draft-ietf-ecrit-lost-planned-changes-04

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 14:12:15 -0700

(1) Should the Time to Live information in a validation response be an 
attribute rather than an element?  Logically, it seems more an attribute 
of the response, and also it mirrors the 'expires' attribute on which it 
is modeled.

(2) In the extension schema, are 'invalidAsOf' and 'asOf' swapped? 
('AsOf' should be part of the <plannedChange> element but looks like 
maybe it is part of the response, while 'invalidAsOf' is part of 
<plannedChange>).

(3) I'm not sure that "The server MUST have policy that limits use of 
this mechanism by a given client" is warranted; I think using "SHOULD" 
is more easily justified.

I have a number of suggested edits for clarification or language.  
Attached are four files:

draft-ietf-ecrit-lost-planned-changes-04-rg.xml

The XML uploaded by Brian, with my edits.

draft-ietf-ecrit-lost-planned-changes-04-rg.txt

The TXT generated from the XML with my edits.

Diff-txt.html

An IETF tools diff showing my edits to the TXT, side by side.

Diff-xml.html

An IETF tools diff showing my edits to the XML, side by side.

--Randall

---

From: "Randall Gellens" <[email-masked]>
Date: Tue, 31 Aug 2021 14:01:39 -0700

I haven't seen responses to the numbered items from my review:

> attribute rather than an element? Logically, it seems more an 
> attribute of the response, and also it mirrors the 'expires' attribute 
> on which it is modeled.
>

--Randall

On 23 Aug 2021, at 14:12, Randall Gellens wrote:

> attribute rather than an element?  Logically, it seems more an 
> attribute of the response, and also it mirrors the 'expires' attribute 
> on which it is modeled.
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 31 Aug 2021 17:14:07 -0400

I’ll make TTL an attribute.

I’ll look at the AsOf and InvalidAsOf.  Might be a problem as you suggest.

I really think that there should be limits but I can soften the requirement to SHOULD.

Brian

> On Aug 31, 2021, at 5:01 PM, Randall Gellens <[email-masked]> wrote:
> 
>> (1) Should the Time to Live information in a validation response be an attribute rather than an element? Logically, it seems more an attribute of the response, and also it mirrors the 'expires' attribute on which it is modeled.
>> 
>> (2) In the extension schema, are 'invalidAsOf' and 'asOf' swapped? ('AsOf' should be part of the <plannedChange> element but looks like maybe it is part of the response, while 'invalidAsOf' is part of <plannedChange>).
>> 
>> (3) I'm not sure that "The server MUST have policy that limits use of this mechanism by a given client" is warranted; I think using "SHOULD" is more easily justified.
> 
> --Randall
> 
>> (1) Should the Time to Live information in a validation response be an attribute rather than an element?  Logically, it seems more an attribute of the response, and also it mirrors the 'expires' attribute on which it is modeled.
>> 
>> (2) In the extension schema, are 'invalidAsOf' and 'asOf' swapped? ('AsOf' should be part of the <plannedChange> element but looks like maybe it is part of the response, while 'invalidAsOf' is part of <plannedChange>).
>> 
>> (3) I'm not sure that "The server MUST have policy that limits use of this mechanism by a given client" is warranted; I think using "SHOULD" is more easily justified.
>> 
>> I have a number of suggested edits for clarification or language.  Attached are four files:
>>