Subject: [Ecrit] lost-planned-changes-04: plannedChange bound to validateLocation?

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 21:07:32 +0000

Not all LoST server implementations perform location validations. When location validation is requested by the client, it adds the “validateLocation” attribute to the <findService> element.

So the question is: Should “plannedChange” be bound to “validateLocation”?

If you believe not, what would be the expected behaviour of a LoST server receiving a <plannedChange> element outside of a validation request?

Thanks,

Guy

---

From: Brian Rosen <[email-masked]>
Date: Mon, 23 Aug 2021 17:21:47 -0400

validateLocation is an attribute, not an element, so I can’t extend it.  

There isn’t an actual requirement to tie plannedChange to validateLocation.  It may not make a lot of sense, but if you did it, the LoST server would not return validation data, would retain the URI and would send the notification if the record changed.  Note my text that the LoST server doesn’t store the LI - the notification is “something changed” not “what you sent is guaranteed to be invalid” or even “one or more of the elements you sent changed".  I thought about changing the name of the notification, but I didn’t do that.  The practical use case remains the same.

Brian

> On Aug 23, 2021, at 5:07 PM, Caron, Guy <[email-masked]> wrote:
>

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 14:26:51 -0700

In my suggested edits, I added clarifying text that the extension is 
only useful when validating.

--Randall

On 23 Aug 2021, at 14:21, Brian Rosen wrote:

> There isn’t an actual requirement to tie plannedChange to 
> validateLocation.  It may not make a lot of sense, but if you did it, 
> the LoST server would not return validation data, would retain the URI 
> and would send the notification if the record changed.  Note my text 
> that the LoST server doesn’t store the LI - the notification is 
> “something changed” not “what you sent is guaranteed to be 
> invalid” or even “one or more of the elements you sent changed".  
> I thought about changing the name of the notification, but I didn’t 
> do that.  The practical use case remains the same.
>
> Brian
>
>> Not all LoST server implementations perform location validations. 
>> When location validation is requested by the client, it adds the 
>> “validateLocation” attribute to the <findService> element.
>>
>> If you believe not, what would be the expected behaviour of a LoST 
>> server receiving a <plannedChange> element outside of a validation 
>> request?
>>
>> Thanks,
>>
>> Guy

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 21:44:08 +0000

I agree that accommodating this comment would require deeper XML changes.

If we do not want to go there, I think the draft should be clear that there is no usecase for sending <plannedChange> outside of a location validation request and as such, should normatively recommend not doing so.

I do not agree that a LoST server receiving <plannedChange> outside of a location validation request would retain the URI and send notification if the record changed afterward. I think this would create havoc on the client’ side.

Thanks,

Guy

De : Brian Rosen <[email-masked]>
Envoyé : 23 août 2021 17:22
À : Caron, Guy <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: lost-planned-changes-04: plannedChange bound to validateLocation?

Brian

On Aug 23, 2021, at 5:07 PM, Caron, Guy <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Guy

________________________________
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 14:47:29 -0700

As I mentioned, my suggested edits make it clear that the extension is 
only useful in the context of validation.

--Randall

On 23 Aug 2021, at 14:44, Caron, Guy wrote:

> If we do not want to go there, I think the draft should be clear that 
> there is no usecase for sending <plannedChange> outside of a location 
> validation request and as such, should normatively recommend not doing 
> so.
>
> I do not agree that a LoST server receiving <plannedChange> outside of 
> a location validation request would retain the URI and send 
> notification if the record changed afterward. I think this would 
> create havoc on the client’ side.
>
> Thanks,
>
> Guy
>
> On Aug 23, 2021, at 5:07 PM, Caron, Guy 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
> Not all LoST server implementations perform location validations. When 
> location validation is requested by the client, it adds the 
> External Email: Please use caution when opening links and attachments 
> / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 21:50:34 +0000

I haven’t seen your edits since they are not posted on the list but what you suggested seems not strong enough language to me.

Thanks,

Guy

De : Randall Gellens <[email-masked]>
Envoyé : 23 août 2021 17:47
À : Caron, Guy <[email-masked]>
Cc : Brian Rosen <[email-masked]>; [email-masked]
Objet : [EXT]Re: [Ecrit] lost-planned-changes-04: plannedChange bound to validateLocation?

As I mentioned, my suggested edits make it clear that the extension is only useful in the context of validation.

--Randall

Thanks,

Guy

De : Brian Rosen <[email-masked]<mailto:[email-masked]>>
Envoyé : 23 août 2021 17:22
À : Caron, Guy <[email-masked]<mailto:[email-masked]>>
Cc : [email-masked]<mailto:[email-masked]>
Objet : [EXT]Re: lost-planned-changes-04: plannedChange bound to validateLocation?

Brian

Thanks,

Guy

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 14:53:17 -0700

I think the list is slow.  The message was stuck but Roger released it.  
Once you see the changes, if you want to make the language stronger, we 
can do that.

--Randall

On 23 Aug 2021, at 14:50, Caron, Guy wrote:

> I haven’t seen your edits since they are not posted on the list but 
> what you suggested seems not strong enough language to me.
>
> Thanks,
>
> Guy
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 23 Aug 2021 17:55:13 -0400

I don’t understand the reasoning on “creating havoc”.  I don’t know why a client would ever do it, but it “works” in that the server doesn’t have to validate to save the URI.  If I client sends the URI and doesn’t validate, it’s weird, but not wrong.

We can decide to prohibit it.  But we don’t really have a justification.

Brian

> On Aug 23, 2021, at 5:44 PM, Caron, Guy <[email-masked]> wrote:
> 
> On Aug 23, 2021, at 5:07 PM, Caron, Guy <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 22:01:15 +0000

A LoST client that sends routing requests to the server would receive, way after calls have been delivered, a notification with a <locationInvalid> body. What would it do with this?

Makes no sense to me.

Guy

De : Brian Rosen <[email-masked]>
Envoyé : 23 août 2021 17:55
À : Caron, Guy <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: lost-planned-changes-04: plannedChange bound to validateLocation?

Brian

On Aug 23, 2021, at 5:44 PM, Caron, Guy <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Guy

Brian

Thanks,

Guy

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 22:06:04 +0000

I further think that a server should ignore <plannedChange> if sent outside a location validation request or, at the minimum, send a “uriNotStored” in the response.

Thanks,

Guy

De : Ecrit <[email-masked]> De la part de Caron, Guy
Envoyé : 23 août 2021 18:01
À : Brian Rosen <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: [Ecrit] lost-planned-changes-04: plannedChange bound to validateLocation?

Makes no sense to me.

Guy

Brian

Thanks,

Guy

Brian

Thanks,

Guy

---

From: Brian Rosen <[email-masked]>
Date: Mon, 23 Aug 2021 18:06:23 -0400

Only if it asked for it, per location.  It asked for it, it got it.

It has NOTHING to do with actual calls.  It’s just an alternative to periodic revalidation for records in the LIS.

A more interesting issue is what does a LIS do when it deletes a record for which a URI is stored in the server.  Probably it marks that URI is OBE. Another possibility is that it stores a new URI that is a catch-all “ignore me”

Hmmm.  I wonder if we should have an explicit delete.  Null URI = delete.

Brian

> On Aug 23, 2021, at 6:01 PM, Caron, Guy <[email-masked]> wrote:
> 
> On Aug 23, 2021, at 5:44 PM, Caron, Guy <[email-masked] <mailto:[email-masked]>> wrote:
>  
> De : Brian Rosen <[email-masked] <mailto:[email-masked]>> 
> À : Caron, Guy <[email-masked] <mailto:[email-masked]>>
> Cc : [email-masked] <mailto:[email-masked]>

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 22:10:30 +0000

You miss my point. The LoST client may not be a LIS. If we make it explicit that only LISes are LoST clients in the context of this draft, I may not have as strong objections.

Guy

De : Brian Rosen <[email-masked]>
Envoyé : 23 août 2021 18:06
À : Caron, Guy <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: lost-planned-changes-04: plannedChange bound to validateLocation?

Brian

On Aug 23, 2021, at 6:01 PM, Caron, Guy <[email-masked]<mailto:[email-masked]>> wrote:

Makes no sense to me.

Guy

Brian

Thanks,

Guy

Brian

Thanks,

Guy

---

From: Brian Rosen <[email-masked]>
Date: Mon, 23 Aug 2021 18:13:40 -0400

Sure, PSAPs could be a LoST client for example.  A routing proxy can be a LoST client.  But they wouldn’t ask to store the URI.  You have to ask for it to get the notification. 

Brian

> On Aug 23, 2021, at 6:10 PM, Caron, Guy <[email-masked]> wrote:
> 
> On Aug 23, 2021, at 6:01 PM, Caron, Guy <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 15:14:43 -0700

It would only receive a notification if it asked for one.  Normally, it 
wouldn't.

--Randall

On 23 Aug 2021, at 15:01, Caron, Guy wrote:

> A LoST client that sends routing requests to the server would receive, 
> way after calls have been delivered, a notification with a 
> <locationInvalid> body. What would it do with this?
>
> Makes no sense to me.
>
> Guy
>
> I don’t understand the reasoning on “creating havoc”.  I don’t 
> know why a client would ever do it, but it “works” in that the 
> server doesn’t have to validate to save the URI.  If I client sends 
> the URI and doesn’t validate, it’s weird, but not wrong.
>
> On Aug 23, 2021, at 5:44 PM, Caron, Guy

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 15:17:03 -0700

If the attribute exists but with an empty value, it means delete?  That 
could work.  We could also add an explicit "delete" value as an 
alternative, but that's more schema work.

--Randall

On 23 Aug 2021, at 15:06, Brian Rosen wrote:

> It has NOTHING to do with actual calls.  It’s just an alternative to 
> periodic revalidation for records in the LIS.
>
> A more interesting issue is what does a LIS do when it deletes a 
> record for which a URI is stored in the server.  Probably it marks 
> that URI is OBE. Another possibility is that it stores a new URI that 
> is a catch-all “ignore me”
>
>> A LoST client that sends routing requests to the server would 
>> receive, way after calls have been delivered, a notification with a 
>> I don’t understand the reasoning on “creating havoc”.  I 
>> don’t know why a client would ever do it, but it “works” in 
>> that the server doesn’t have to validate to save the URI.  If I 
>> client sends the URI and doesn’t validate, it’s weird, but not 
>> wrong.
>>
>> validation request and as such, should normatively recommend not 
>> doing so.
>>
>> I do not agree that a LoST server receiving <plannedChange> outside 
>> of a location validation request would retain the URI and send 
>> the LoST server would not return validation data, would retain the 
>> URI and would send the notification if the record changed.  Note my 
>> text that the LoST server doesn’t store the LI - the notification 
>> is “something changed” not “what you sent is guaranteed to be

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 22:26:37 +0000

I understand and what I’m suggesting is to be clear about what LoST clients are expected to do. We do not want a leasy implementation sending <plannedChange> across the board, don’t we? I think it is easy and cheep to fix in the draft rather to try to fix implementations later.

Guy

De : Brian Rosen <[email-masked]>
Envoyé : 23 août 2021 18:14
À : Caron, Guy <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: lost-planned-changes-04: plannedChange bound to validateLocation?

Brian

On Aug 23, 2021, at 6:10 PM, Caron, Guy <[email-masked]<mailto:[email-masked]>> wrote:

Guy

Brian

Makes no sense to me.

Guy

Brian

Thanks,

Guy

Brian

Thanks,

Guy

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 23 Aug 2021 22:34:13 +0000

I’m not concerned about a client that willfully and knowingly asks for it.

This whole draft revolves around location validation. I’m not understanding the pushback here.

Guy

Envoyé : 23 août 2021 18:31

If a client wants to get notified that a location may have become invalidated, why do we care why or what type of client it is?

--Randall

On 23 Aug 2021, at 15:26, Caron, Guy wrote:

Guy

Brian

Guy

Brian

Makes no sense to me.

Guy

Brian

Thanks,

Guy

Brian

Thanks,

Guy

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 15:17:50 -0700

It doesn't matter if the client is a LIS or not.  The client won't get a 
notification unless it asks for one.

--Randall

On 23 Aug 2021, at 15:10, Caron, Guy wrote:

> You miss my point. The LoST client may not be a LIS. If we make it 
> explicit that only LISes are LoST clients in the context of this 
> draft, I may not have as strong objections.
>
> Guy
>
> On Aug 23, 2021, at 6:01 PM, Caron, Guy

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 15:31:01 -0700

If a client wants to get notified that a location may have become 
invalidated, why do we care why or what type of client it is?

--Randall

On 23 Aug 2021, at 15:26, Caron, Guy wrote:

> I understand and what I’m suggesting is to be clear about what LoST 
> clients are expected to do. We do not want a leasy implementation 
> sending <plannedChange> across the board, don’t we? I think it is 
> easy and cheep to fix in the draft rather to try to fix 
> implementations later.
>
> Guy
>
> Sure, PSAPs could be a LoST client for example.  A routing proxy can 
> be a LoST client.  But they wouldn’t ask to store the URI.  You have 
> to ask for it to get the notification.
>
> Brian
>
>
> On Aug 23, 2021, at 6:10 PM, Caron, Guy

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 23 Aug 2021 15:39:47 -0700

I'm trying to understand the harm of allowing a client to request 
notification whether it is asking for validation or not.  We already say 
that server policy can refuse to store a URI for any reason, so a server 
could prohibit this if it wants to (e.g., to save resources).  If a 
server is OK providing this server, what do we care?  It doesn't harm 
interoperability.

--Randall

---

From: "Caron, Guy" <[email-masked]>
Date: Tue, 24 Aug 2021 18:24:59 +0000

But you are advocating for a model that is useless. Why not be clear on what this is doing and what it is not?

Guy

Envoyé : 23 août 2021 18:40

I'm trying to understand the harm of allowing a client to request notification whether it is asking for validation or not. We already say that server policy can refuse to store a URI for any reason, so a server could prohibit this if it wants to (e.g., to save resources). If a server is OK providing this server, what do we care? It doesn't harm interoperability.

--Randall

Guy

De : Randall Gellens <[email-masked]<mailto:[email-masked]>>
Envoyé : 23 août 2021 18:31
À : Caron, Guy <[email-masked]<mailto:[email-masked]>>
Cc : Brian Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Objet : [EXT]Re: [Ecrit] lost-planned-changes-04: plannedChange bound to validateLocation?

--Randall

Guy

Brian

Guy

Brian

Makes no sense to me.

Guy

Brian

Thanks,

Guy

Brian

Thanks,

Guy

---

From: "Randall Gellens" <[email-masked]>
Date: Tue, 24 Aug 2021 11:50:14 -0700

In my suggested wording edits I make it clear.

--Randall

On 24 Aug 2021, at 11:24, Caron, Guy wrote:

> But you are advocating for a model that is useless. Why not be clear 
> on what this is doing and what it is not?
>
> Guy
>
> notification whether it is asking for validation or not. We already 
> say that server policy can refuse to store a URI for any reason, so a 
> server could prohibit this if it wants to (e.g., to save resources). 
> If a server is OK providing this server, what do we care? It doesn't 
> harm interoperability.
>
> --Randall
>
> De : Randall Gellens 
> <[email-masked]<mailto:[email-masked]>>