Subject: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-09.txt

From: [email-masked]
Date: Wed, 18 Aug 2021 17:02:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Emergency Context Resolution with Internet Technologies WG of the IETF.

        Title           : A LoST extension to return complete and similar location info
        Authors         : Brian Rosen
                          Roger Marshall
                          Jeff Martin
	Filename        : draft-ietf-ecrit-similar-location-09.txt
	Pages           : 18
	Date            : 2021-08-18

Abstract:
   This document introduces a new way to provide returned location
   information in LoST responses that is either of a completed or
   similar form to the original input civic location, based on whether
   valid or invalid civic address elements are returned within the
   findServiceResponse message.  This document defines a new extension
   to the findServiceResponse message within the LoST protocol [RFC5222]
   that enables the LoST protocol to return a completed civic address
   element set for a valid location response, and one or more suggested
   sets of similar location information for invalid LoST responses.
   These two types of civic addresses are referred to as either
   "complete location" or "similar location", and are included as a
   compilation of CAtype xml elements within the existing LoST
   findServiceResponse message structure.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-similar-location/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-similar-location-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-similar-location-09

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Rosen <[email-masked]>
Date: Thu, 19 Aug 2021 17:08:48 -0400

At long last, I have updated this draft.  I have hopefully captured all comments made against prior revisions and I have tried to get the xml correct.  

Thanks to Randall for looking over an advance copy of the doc and making some suggestions for improvement.

Hopefully we can progress it swiftly now.

I have no good excuse for not completing this task earlier.

Brian

> On Aug 18, 2021, at 8:02 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Dwight Purtle <[email-masked]>
Date: Fri, 20 Aug 2021 11:57:49 -0500

New group member here.  I suggest three minor changes to the similar
location document.

1.  On page 6, fourth paragraph, the second sentence beginning with the
word "Because" is an incomplete sentence.  I think it can be fixed by
simply deleting the word "Because".

2.  In that same sentence, the word "element" should be "elements", to read
"these additional elements had been included".

3.  On page 7, in section 4, second paragraph, fourth sentence, the word
"suppose" should be "supposed", to read "what the intended location
information was supposed to be".

Thanks!

Dwight Purtle - retired PSAP tech guy

---

From: Brian Rosen <[email-masked]>
Date: Fri, 20 Aug 2021 13:31:41 -0400

Happy to make these changes.  Thanks for the review.

Brian

> On Aug 20, 2021, at 12:57 PM, Dwight Purtle <[email-masked]> wrote:
> 
> New group member here.  I suggest three minor changes to the similar location document.
> 
> 1.  On page 6, fourth paragraph, the second sentence beginning with the word "Because" is an incomplete sentence.  I think it can be fixed by simply deleting the word "Because".
> 
> 2.  In that same sentence, the word "element" should be "elements", to read "these additional elements had been included".
> 
> 3.  On page 7, in section 4, second paragraph, fourth sentence, the word "suppose" should be "supposed", to read "what the intended location information was supposed to be".
> 
> Thanks!
> 
> On Wed, Aug 18, 2021 at 7:04 PM <[email-masked] <mailto:[email-masked]>> wrote:
> 
> https://datatracker.ietf.org/doc/draft-ietf-ecrit-similar-location/ <https://datatracker.ietf.org/doc/draft-ietf-ecrit-similar-location/>
> 
> https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-similar-location-09 <https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-similar-location-09>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-similar-location-09 <https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-similar-location-09>
> 
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>