Subject: MAPI and EDIINT

From: John Hitchins <[email-masked]>
Date: Tue, 10 Nov 1998 17:12:54 -0000

Hi,

Just a small question about the CommerceNet Interoperability tests -

The problem -

When using Microsoft MAPI to create an Internet mail message containing EDI
data you end up with a Multipart/Mixed message with one of the body parts
being the rfc1767 application/edi????

i.e. -

To: <[email-masked]>
From: <[email-masked]>
Content-Type: Multipart/Mixed; boundary=b1

--b1
Content-Type: Application/EDIFACT
..
..<EDI Data>
..
--b1

Is this format of message, multipart/mixed, allowed by the CommerceNet
Interoperability tests and do any/all of the Applications being tested
support it?

Cheers for your help.

/jh

--
John Hitchins                  | Harbinger UK,
[email-masked]      | Quay West. Trafford Wharf Road,
http://www.harbinger.co.uk     | Manchester, M17 1HH, England.
                               | Tel: +44 161 872 2022
                               | Fax: +44 161 872 2024
    The views represented here are mine and not necessarily
                     those of Harbinger UK.

---

From: "Jim Reitz (Exchange)" <[email-masked]>
Date: Tue, 10 Nov 1998 10:43:35 -0800

What you are seeing is likely a default mapping being performed by some
MAPI<->MIME gateway, not "MAPI" itself. What mail server/gateway and/or MAPI
service provider are you using? Exchange Server using the Internet Mail
Connector?  Outlook with the POP3/SMTP IMEP provider installed locally?

Also -- how are you creating the application/edi using MAPI? Creating a MAPI
message with a single attachment and no body?

-----Original Message-----
From: John Hitchins [mailto:[email-masked]]
Sent: Tuesday, November 10, 1998 9:13 AM
To: 'CNet EDIPilot'; 'IETF EDIINT'
Subject: MAPI and EDIINT

Hi,

The problem -

i.e. -

--b1

Cheers for your help.

/jh

---

From: John Hitchins <[email-masked]>
Date: Mon, 16 Nov 1998 11:56:29 -0000

Hi,

The problem actually came from another company who are trying to implement
EDIINT on Win32 using MAPI and came to light when we tried to set up a live
demo at a trade show here in the UK.

The details I have are that they developed code, using MAPI, to create
EDIINT messages and send them out through an Exchange box and the problem
they encountered is that they were unable to create a mail message of type
Application/EDIFACT using MAPI. If my understanding is correct they create a
mail message and then attach the EDI file specifying the content type which
gives them a Multipart/Mixed message with the Application/EDIFACT as one of
the body parts, but they are unable to create a message with only the single
bodypart of type Application/EDIFACT. 

This has raised concerns at the E-Centre, formerly the Electronic Commerce
Association, as it would seem to imply that MAPI cannot be used to create an
EDIINT compliant message?

Cheers.

/jh

> From:	Jim Reitz (Exchange) [SMTP:[email-masked]]
> Sent:	Tuesday, November 10, 1998 6:44 PM
> To:	'John Hitchins'
> Cc:	[email-masked]'
> Subject:	RE: MAPI and EDIINT
>

---

From: John Hitchins <[email-masked]>
Date: Mon, 16 Nov 1998 12:06:01 -0000

Hi,

At this point no signatures have been involved, just plain EDI data, with
the Application/EDIFACT as an attachment within a Multipart/Mixed rather
than as the sole bodypart. Looking forward this would indicate that when
signatures are added, the message would be a Multipart/Mixed with a
Multipart/Signed as one of the bodyparts.

Anyway, the main reason I was asking was to get a clarification of the CNet
pilot and as1 as to whether the EDIINT MIME constructs, Application/EDI???,
Multipart/Signed etc, are allowed to be attachments within a Multipart/Mixed
message or have to be the sole bodypart in the message?

Cheers.

/jh

> From:	Dale Moberg [SMTP:[email-masked]]
> Sent:	Wednesday, November 11, 1998 4:49 PM
> To:	'CNet EDIPilot'; John Hitchins
> Subject:	Re: MAPI and EDIINT
> 
> Hi John,
> 
> If the MIME type is "multipart/mixed", the application does not have any
> clue
> that it should process the message body as a "multipart/signed." So the
> response
> would most likely be to handle the included MIME types in whatever manner
> those types are handled. For example, EDI would possibly go into the
> insecure
>  EDI hopper, the signature file would probably just be stored as an
> attachment,
>  if I understand what you are saying.
> 
>  No one during the test, to my recollection anyway,
> has sent that particular MIME format;.
> 
> The format does not conform to  what the applicability
> statement specifies as the convention for EDI transport. So I guess the
> application
> behavior is undefined in terms of an EDIINT application, and just the
> normal MIME
> handling would come into play.
> 
> Others?
> 
> Bye
> Dale Moberg
> 
> 
> 
> 
> 
> 
> 
> John Hitchins <[email-masked]> on 11/10/98 12:12:54 PM
> Ext: Unknown
> 
> To:   "'CNet EDIPilot'" <[email-masked]>, "'IETF EDIINT'"
>       <[email-masked]>
> cc:    (bcc: Dale Moberg/Sterling Commerce)
> Subject:  MAPI and EDIINT
> 
> 
> 
> 
> Hi,
> -----------------------------------------------------------------------
> Message addressed to: [email-masked]
> Archive available at: http://lists.commerce.net/archives/edipilot/
> To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> body to: [email-masked]
> 
> 
> 
> 
> -----------------------------------------------------------------------
> Message addressed to: [email-masked]
> Archive available at: http://lists.commerce.net/archives/edipilot/
> To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> body to: [email-masked]

---

From: "Jim Reitz (Exchange)" <[email-masked]>
Date: Mon, 16 Nov 1998 08:19:18 -0800

If they are using Exchange Server's Internet Mail Connector as their
MAPI->MIME gateway (you say they "send them out through an Exchange box"),
then this sounds like a bug that we fixed over two years ago in Exchange 4.0
Service Pack 2 (and all subsequent releases).

This company should make sure their software is up to date. For details on
this bug, please see our KnowledgeBase article Q152863, which can be found
at:

http://support.microsoft.com/support/kb/articles/q152/8/63.asp

-----Original Message-----
From: John Hitchins [mailto:[email-masked]]
Sent: Monday, November 16, 1998 3:56 AM
To: Jim Reitz (Exchange)
Cc: 'IETF EDIINT'
Subject: RE: MAPI and EDIINT

Hi,

Cheers.

/jh