Subject: EDIINT MIME Constructs within Multipart/Mixed Messages

From: John Hitchins <[email-masked]>
Date: Mon, 16 Nov 1998 17:39:57 -0000

Hi,

As you may know, in the UK the E-Centre, formerly the Electronic Commerce
Association, is currently promoting EDI over the Internet and is adopting
the EDIINT Standards as the way forward. As part of this promotion the
E-Centre is looking at providing a list of approved interoperable software
along the lines of the CommerceNet pilot scheme.

To aid in interoperability can we get clarification as to whether including
the EDIINT MIME constructs within a Multipart/Mixed message is allowed under
as1 and/or the CommerceNet pilot.

i.e. Is the following construct allowed? -

To: <recipient>
From: <sender>
MIME-Version: 1.0
Content-Type: Multipart/Mixed; boundary=boundary1

--boundary1
Content-Type: Application/EDIFACT
Content-Transfer-Encoding: base64

HGFGKGFL
...
KJHFHGRKHR

--boundary1

Cheers.

/jh

--
John Hitchins                  | Harbinger UK,
[email-masked]      | Quay West. Trafford Wharf Road,
http://www.harbinger.co.uk     | Manchester, M17 1HH, England.
                               | Tel: +44 161 872 2022
                               | Fax: +44 161 872 2024
    The views represented here are mine and not necessarily
                     those of Harbinger UK.

---

From: John Mani <[email-masked]>
Date: Mon, 16 Nov 1998 12:27:39 -0800 (PST)

> i.e. Is the following construct allowed? -

Hmm .. why wouldn't it be ? It needs a valid terminating boundary and/or
more bodyparts, but other than that it looks valid MIME

-john

---

From: John Hitchins <[email-masked]>
Date: Tue, 17 Nov 1998 13:24:46 -0000

Hi,

Yes, fix the trailing boundary and it is valid MIME but would it be accepted
in the CommerceNet Interop Tests?

I.e. Will all the Apps tested by CommerceNet accept and correctly process
this construct?

Cheers.

/jh 

> -----Original Message-----
> From:	John Mani [SMTP:[email-masked]]
> Sent:	Monday, November 16, 1998 8:28 PM
> To:	[email-masked]; [email-masked]
> Cc:	[email-masked]; [email-masked]
> Subject:	Re: EDIINT MIME Constructs within Multipart/Mixed Messages
> 
> 
> > 
> -----------------------------------------------------------------------
> Message addressed to: [email-masked]
> Archive available at: http://lists.commerce.net/archives/edipilot/
> To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
> body to: [email-masked]

---

From: John Mani <[email-masked]>
Date: Tue, 17 Nov 1998 10:03:53 -0800 (PST)

> I.e. Will all the Apps tested by CommerceNet accept and correctly process

If not, the apps are buggy :)

btw, I don't see any discussions about using XML to represent EDI objects and
transferring them via email/http-post here. Is this not relevant in this
working group, is it more appropriate in some other forum ?

thanx
-john