Subject: AS#1, Section 5.2

From: Andrew Paterson <[email-masked]>
Date: Wed, 10 Mar 1999 12:27:06 -0000

I have been lurking on the fringes of EDIINT for some time now but I have
finally had chance to look into things in more detail. I believe there is a
small error in AS#1, section 5.2, Requesting a signed receipt; it says:

> Disposition-notification-options = "Disposition-notification-options" ":"
>                                     disposition-notification-parameters
>
>where 
>
> disposition-notification-parameters = parameter *(";" parameter)
>
>where 
>
>>>> parameter = attribute "=" importance ", " 1#value "
>
>where
>
> importance = "required" | "optional "
>
>So the the Disposition-notification-options string could be either
>
> optional, signed-receipt-protocol, <protocol symbol>;  
>
> optional, signed-receipt-micalg, <micalg1>, <micalg2>,...; 

I think that the line marked >>>> above should read:

 parameter = importance ", " attribute ", " 1#value

i.e. importance and attribute are swapped, they are separated by a comma
(not "="), and the quotes at the end of the line are erroneous. I hope that
I have not misunderstood!

Thank you all for your excellent work.

Regards,
Andrew Paterson
[email-masked]
All opinions are strictly my own (not that anyone else would take credit for
them anyway!)

---

From: "Shih,Chuck" <[email-masked]>
Date: Mon, 15 Mar 1999 18:28:22 -0500

Andrew,

Actually the syntax is correct and the example is incorrect. So the
Dispostion-notification-options string is as follows:

Disposition-notification-options: signed-receipt-protocol=optional, 
          pkcs7-signature;  signed-receipt-micalg=optional, md5;

Rik how can we change AS#1 to reflect this?
> -----Original Message-----
> From:	Andrew Paterson [SMTP:[email-masked]]
> Sent:	Wednesday, March 10, 1999 4:27 AM
> To:	'IETF EDIINT Mailing List'
> Subject:	AS#1, Section 5.2
>