Subject: RE: EDIINT and HIPAA

From: "K.W. Chan" <[email-masked]>
Date: Fri, 3 Nov 2000 08:57:20 +0800

Hi,

I am a new comer to this group. Can anyone kindly point to me some useful
sources to study how XML influences the development of Internet EDI? In
various places, I see mentioning that EDI is dead because of the
proliferation of XML. I don't understand this. Conventional EDI requires
translators to integrate with backend applications. XML will not do away
with this, but will perhaps make it easier for organizations to write their
own translators.

Is XML a hype or really a catalyst for next generation of EDI?

K. W. 

-----Original Message-----
From: Dick Brooks [mailto:[email-masked]]
Sent: Friday, November 03, 2000 7:55 AM
To: Terry Harding; Gunther Schadow
Cc: Rik Drummond; Kepa Zubeldia; CLEM; Gary Crough; Beth Morrow;
David@Drummondgroup. Com; [email-masked]; [email-masked]
Subject: RE: EDIINT and HIPAA

Terry, my answers are inline:

> This may have been mentioned in your email, but i must ask.
>
> You mentioned within your email, that AS2 supports two distinct types of
> packaging,
> a  GISB style and an AS1 style. EDIINT(AS1) also specifies two packaging
> standards,
> one based around S/MIME(RSA) and another around openPGP(PGP).
>
> Will the gas industry support an AS2 compliant product which
> produces a GISB
> style message using RSA security, or must the security layer be PGP as in
> your example...

GISB has been using PGP to encrypt and sign EDI data since 1997 so this will
remain their "crypto" standard. GISB REQUIRES the use of RSA public key
algorithms to process EDI data. RSA algorithms are supported in PGP.

The GISB/AS2 interoperability profile packages "PGP processed" data inside a
multipart/signed or multipart/encrypted MIME envelope, in accordance with
AS2 specifications. The entire multipart/* MIME envelope and encrypted data
is then placed inside a multipart/form-data package. Here is what the entire
package looks like when it's all put together (indention used to indicate
layering only):

Content-Type: multipart/form-data; boundary="foo"

  message headers are packaged here (To=XXX, From=YYY, etc.)

  Content-Type: multipart/encrypted; boundary="foo2";
  protocol="application/pgp-encrypted"

     Content-Type: application/pgp-encrypted

     Content-Type: application/octet-stream

         Content-Type: application/EDI-X12 (signed/encrypted using PGP)

		ISA*.....X12 data              (signed/encrypted using PGP)

With regard to an earlier reference to the AS1 packaging style within AS2; I
believe the new AS2-To and AS2-From header fields are incompatible with AS1
so we might want to refer to this "new packaging style" as the AS2/email
packaging style in the next version of the AS2 spec and remove references to
AS1. Would you agree?

Regards,

Dick Brooks
Group 8760
110 12th Street North
Birmingham, AL 35203
[email-masked]
205-250-8053
Fax: 205-250-8057
http://www.8760.com/

InsideAgent - Empowering e-commerce solutions

---

From: [email-masked] (Chris Davenport)
Date: Thu, 16 Nov 2000 11:33:12 +0100 (BST)

Could we not come up with some more meaningful names for these new headers?
I'm thinking that in 10 years time no-one will remember what "AS2-To" means.

Just a thought.

Chris.

>
>I agree, the original AS2 spec was based on AS1, but there were problems
>discovered during AS2 interoperability testing (using RFC 822 (email) style
>packaging)  related to "To" and "From" headers, which resulted in the
>creation
>of two new headers specific to AS2, "AS2-To" and "AS2-From".  We (as the
>authors
>of AS2) will have to provide details of  these new routing headers and
>cannot
>depend entirely on AS1, as we had originally.
>
--
Chris Davenport              [email-masked]
Davros Computer Systems

---

From: "Moberg, Dale" <[email-masked]>
Date: Thu, 16 Nov 2000 09:27:22 -0500

Suggest them now!

Dale Moberg

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, November 16, 2000 5:33 AM
> To: [email-masked]

---

From: Manny Horani <[email-masked]>
Date: Thu, 16 Nov 2000 13:31:11 -0800

I think "as2-from" and "as2-to" naming is adequate.  These two header lines
are used and meaningful in AS2 context and they are not seen outside AS2.
Therefore, they should not cause any confusion.

Thanks,
Manny 

-----Original Message-----
From: Terry Harding [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 10:02 AM
To: [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: Re: EDIINT and HIPAA

How about.

senderId and receiverId.

Terry
----- Original Message -----
From: "Chris Davenport" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, November 16, 2000 8:19 AM
Subject: RE: EDIINT and HIPAA

> I was afraid you might say that!  Actually I'm not clued up on why it was
> considered necessary to introduce these headers.  The answer does not
appear
> to be in the AS2 revision in internet-drafts.  Perhaps I missed it being
> discussed on this list?
>
> How about: "EDI-To" and "EDI-From"
>
> Be happy,
>
> Chris.
>
> ---------- Original Message ----------
> From   : "Moberg, Dale" <[email-masked]>
> To     : "[email-masked]'"
<[email-masked]>,[email-masked]
> Date   : Thu, 16 Nov 2000 09:27:22 -0500

---

From: "Moberg, Dale" <[email-masked]>
Date: Fri, 17 Nov 2000 09:08:51 -0500

Thanks Manny. Any other people wish to
comment on this to see what consensus 
exists on whether header string changes
are needed, and if so, what to change to?

I sense that people are far from convinced
that a change is needed. Human readability
is not a real concern here because most AS2
agents are for automated systems, right?
And it might be better to indicate that
these headers have a very restricted
applicability (AS2) and leave it to a later
standard to straighten out the variety
of namespaces used in identifying persons
or organizations in XML and EDI messaging
contexts. After all we are leaving the
values for these headers very unconstrained
and subject to bilateral trading partner
agreements...

Other angles?

> From: Manny Horani [mailto:[email-masked]]
> Sent: Thursday, November 16, 2000 4:31 PM
> To: 'Terry Harding'; [email-masked]; Moberg, Dale;
> [email-masked]

---

From: [email-masked] (Chris Davenport)
Date: Fri, 17 Nov 2000 18:09:56 +0000 (GMT)

senderID and receiverID sound good to me too, but perhaps Sender-ID and
Receiver-ID (ie. with hyphens) would be more in keeping with the syntax
of SMTP and HTTP headers?

These seem to be very generic, like they may have been used somewhere
else.  Has anyone checked that this will not conflict with any current
or planned usage by other groups?

Be happy,

Chris.

---------- Original Message ----------
From   : "Dick Brooks" <[email-masked]>
To     : "Moberg, Dale" <[email-masked]>,"'Terry Harding'" <[email-masked]>,
Date   : Fri, 17 Nov 2000 07:22:01 -0600
Subject: RE: EDIINT and HIPAA
>I like senderId and receiverId.
>
>Rik, will the EDIINT workgroup hold a session to discuss the new AS2 draft
>at the next IETF meeting in San Diego?
>
>Dick Brooks
>http://www.8760.com/
>
>
>From: Moberg, Dale [mailto:[email-masked]]
>Sent: Thursday, November 16, 2000 12:22 PM
>To: 'Terry Harding'; [email-masked]; [email-masked]
>List-Subscribe:
> <mailto:[email-masked]?body=subscribe>
>List-Unsubscribe:
> <mailto:[email-masked]?body=unsubscribe>
>List-Archive: <http://lists.drummondgroup.com/archives/b2b_int_as2>
>List-Help: <http://lists.drummondgroup.com/doc/email-manage.html>,
> <mailto:[email-masked]?body=help>
>
>OK by me.
>
>Anybody not like these?
>Please respond quickly
>so we can get this
>settled.
>
>
>> Sent: Thursday, November 16, 2000 1:02 PM
>> To: [email-masked]; Moberg, Dale; [email-masked]