Subject: Header names for sender and receiver identiifiers...Was RE: EDII NT and HIPAA

From: "Moberg, Dale" <[email-masked]>
Date: Thu, 16 Nov 2000 13:12:18 -0500

I would not like to suggest that the identifiers are EDI
specific and therefore would not favor your initial suggestion.
Got others?

On the second issue, before too long changes will be made
in the draft to explain the usage of the headers.

One basic problems stems from the fact that in SMTP and HTTP
the "From" headers have restrictions on values and usages.
In HTTP it points to an admistrative contact of 
sorts -- the email address
"on whose behalf" the request has been made.
There are privacy and other caveats not found in an email 
context.

In SMTP, "From" is normally the sender's email address,
sometimes used for replies... I here omit a long story.
In both cases it is restricted to be an email 
address. (RFCs 822/1123)

For some b2b applications,
different identifier schemes are used to indicate requester
and responder. DUNS numbers might be used or other namespaces
might supply identifiers-- some groups are considering URIs &
URNs for business identifiers, e.g. These identifiers have
"back-end" integration significance and are
independent of the RFC822 email address namespace. Middleware 
layers (containing automated user-agents and beyond)
can benefit greatly by customizing configurations,
looked up on the basis of different identity namespaces.
The identity namespaces used for authentication will remain tied
to the trust model's treatment of identity for digital
signatures (for SMIME, certificates; for openPGP, the
various keyrings and extensions to accomodate certificates)

For these reasons, among others, we are introducing new
extension headers to label the values for identifiers in
other namespaces.  It has created unnecesary confusion and
potential interoperability obstacles by attempting to
shoehorn different usages into the existing slots. Glad
we found this out now. 

Hope that helps.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, November 16, 2000 10:20 AM
> To: Moberg, Dale; [email-masked]
> Subject: RE: EDIINT and HIPAA
> 
> 
> I was afraid you might say that!  Actually I'm not clued up 
> on why it was
> considered necessary to introduce these headers.  The answer 
> does not appear
> to be in the AS2 revision in internet-drafts.  Perhaps I 
> missed it being
> discussed on this list?
> 
> How about: "EDI-To" and "EDI-From"
> 
> Be happy,
> 
> Chris.
> 
> ---------- Original Message ----------
> From   : "Moberg, Dale" <[email-masked]>
> To     : "[email-masked]'" 
> <[email-masked]>,[email-masked]
> Date   : Thu, 16 Nov 2000 09:27:22 -0500
> Subject: RE: EDIINT and HIPAA
> >Suggest them now!
> >
> >Dale Moberg
> >
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]]
> >> Sent: Thursday, November 16, 2000 5:33 AM
> >> To: [email-masked]
> >> Subject: RE: EDIINT and HIPAA
> >>
> >>
> >> Could we not come up with some more meaningful names for
> >> these new headers?
> >> I'm thinking that in 10 years time no-one will remember what
> >> "AS2-To" means.
> >>
> >> Just a thought.
> >>
> >> Chris.
> >>
> >> >
> >> >I agree, the original AS2 spec was based on AS1, but there
> >> were problems
> >> >discovered during AS2 interoperability testing (using RFC
> >> 822 (email) style
> >> >packaging)  related to "To" and "From" headers, which 
> resulted in the
> >> >creation
> >> >of two new headers specific to AS2, "AS2-To" and "AS2-From".
> >>  We (as the
> >> >authors
> >> >of AS2) will have to provide details of  these new routing
> >> headers and
> >> >cannot
> >> >depend entirely on AS1, as we had originally.
> >> >
> >> --
> >> Chris Davenport              [email-masked]
> >> Davros Computer Systems
> >>
> --
> Chris Davenport              [email-masked]
> Davros Computer Systems
>

---

From: "David Fischer" <[email-masked]>
Date: Thu, 16 Nov 2000 15:07:28 -0600

This was discussed in our conference call this morning and one of the AS2
Interop participants has already committed their code for release.  This
change at this late date would mean a significant hardship for them.

David Fischer
Drummond Group
AS2 Interop Project
[email-masked]
817.371.8422

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Moberg, Dale
Sent: Thursday, November 16, 2000 12:12 PM
To: [email-masked]'; [email-masked]
Subject: Header names for sender and receiver identiifiers...Was RE:
EDIINT and HIPAA

Hope that helps.

---

From: "Santanu De" <[email-masked]>
Date: Fri, 17 Nov 2000 09:48:04 +0530

Hi,

We have a middleware product which uses HTTP as one of its comm agents, and
for secure EDI, we have been using GISB which we now need to upgrade towards
AS2.

We recently subscribed to the EDIINT mailing list and found that quite some
work have been already done in order to implement AS2. Now thats a rich
harvest, but we'd like someone to pitch in with a little help.

I have got the IETF draft with me (I guess there's no RFC yet), but looks
like we'll have to get hold of even a few more things. Can any of you guys
help me a little?

Also, looks like a few of you are discussing about changing the headers from
what is there in the draft, citing implementation and interoperability
issues. (AT&T guys are discussing testing, right?) So it turns out that
quite some work has already been done in this direction, and I won't like to
be missed out on that as well.

I'll appreciate every bit of cooperation. Right now, I just need to know how
much work has alerady been done towards implementting AS2, and how to go
about doing it.

Thanks,
Santanu.

---

From: "Dick Brooks" <[email-masked]>
Date: Fri, 17 Nov 2000 08:17:42 -0600

Santanu,

The AS2 changes coming out of the interoperability testing conducted by the
Drummond Group DO NOT affect the GISB profile within AS2.  In fact, there
are several Energy companies in New York and Pennsylvania that are
implementing AS2/GISB now. The implementations are based on the current AS2
draft.

Let me know if you would like to conduct interoperability testing on the
AS2/GISB profile. I've started discussions with a couple organizations that
expressed an interest in sponsoring the next set of AS2 interoperability
tests, which will be based on the AS2/GISB profile.

Regards,

Dick Brooks
http://www.8760.com/

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Santanu De
Sent: Thursday, November 16, 2000 10:18 PM
To: [email-masked]
Cc: [email-masked]; Manoj Kamani
Subject: AS2 implementation.

Hi,

Thanks,
Santanu.