Subject: MIME-based Secure EDI -- AS1

From: David Fischer <[email-masked]>
Date: Thu, 20 Dec 2001 14:27:37 -0600

After reading the comments from the Last Call on AS1, it seems there are two
concerns:

1)  The name might suggest that all EDI on the Internet would be done this way.

Solution:  Add the words Peer-to-Peer in the title.

2)  There is some dissent to the way in which security is applied in this spec.

Solution:  Changing the security methods in AS1 would not align with the
original functional specification of this group.  Support for VANs was not part
of the functional spec.  No change.

A new Draft IETF specification will be issued today with the change in title as
in (1) above.

http://www.ietf.org/internet-drafts/draft-ietf-ediint-as1-15.txt

Best Regards,

David Fischer
Drummond Group.

---

From: "Pae Choi" <[email-masked]>
Date: Fri, 21 Dec 2001 01:50:56 -0800

My appolgies again.

Typos:
> My appologies to stepping
<snip/>
> It seems to me we have duplicated efforts going on. I am here to express

Correction:
My appologies for stepping
It seems to me we have duplicated efforts going on. I am *NOT* here to
express

Thank you.

Pae

----- Original Message -----
From: "Pae Choi" <[email-masked]>
To: "Gary Crough" <[email-masked]>; "David Fischer"
<[email-masked]>; <[email-masked]>
Cc: "Ned Freed" <[email-masked]>; "Rik Drummond"
<[email-masked]>
Sent: Friday, December 21, 2001 1:46 AM
Subject: Re: MIME-based Secure EDI -- AS1

> Hello,
>
> My appologies to stepping into you folks' conversation. Jut FYI,
> there is no
> http://www.ietf.org/internet-drafts/draft-ietf-ediint-as1-15.txt.
> The latest one I can find is "...-14.txt".
>
> Also, would someone or some people share some visions and relationships
> between EDIINT and ebXML standard specification, ebMS[1], which is also
> covering the MIME part as SOAP Attachment[2].
>
> In addition to some similarity, the OASIS consortium just announced a news
> that is saying about the XML and the related security as well as others.
>
> It seems to me we have duplicated efforts going on. I am here to express
> which is better to what nor lobbing for something. I am just trying to
> understand and minimize our duplicated efforts.
>
> Again, my appolgies for this foray.
>
> Best regards,
>
>
> Pae
>
>
> [1] ebXML Specification "Message Service Specification";
>      http://www.ebxml.org/specs/index.htm
> [2] W3C Note "SOAP Messages with Attachments";
>      http://www.w3.org/TR/SOAP-attachments
> [3] OASIS News " XML Standards Converge at OASIS";
>      http://www.oasis-open.org/news/oasis_news_12_19_01.shtml
>
>
> ----- Original Message -----
> From: "Gary Crough" <[email-masked]>
> To: "David Fischer" <[email-masked]>; <[email-masked]>
> Cc: "Ned Freed" <[email-masked]>; "Rik Drummond"
> <[email-masked]>
> Sent: Thursday, December 20, 2001 1:56 PM
> Subject: RE: MIME-based Secure EDI -- AS1
>
>
> >
> > David,
> > As you indicate EDIINT AS1 is not used for all EDI transported
> > over the Internet ... but just as important not all data being
> > transported via EDIINT AS1 is EDI data.  Here is my 2 cents...
> >
> > I believe the UCC asked for XML data to be used in the testing
> > of EDIINT AS2 to insure there was no marriage to X12 etc.  If neither
> > AS1 nor AS2 is married to EDI data, ideally the title of the
> > specification would not make such an inference.    In its broadest sense
> > EDI means "Electronic Data Interchange" which is fine ... but in common
> > usage EDI has come to be closely associated with X12 and readers assume
> > something called "EDIINT" cannot handle other data structures such as
> > XML.
> > EDIINT AS1 and EDIINT AS2 are both "Secure Peer-to-Peer Business
> > Quality Data Transports".  Right?
> >
> > -----Original Message-----
> > From: David Fischer [mailto:[email-masked]]
> > Sent: Thursday, December 20, 2001 1:28 PM
> > To: [email-masked]
> > Cc: Ned Freed; Rik Drummond
> > Subject: MIME-based Secure EDI -- AS1
> >
> >
> >
> >

---

From: "Paul R. Morin" <[email-masked]>
Date: Fri, 21 Dec 2001 10:23:45 -0500

Pae,

As an outside observer with a primary interest in the work of the
Automotive Industry Action Group (AIAG) and their messaging guideline
(E-5) I can tell you that these "duplicated efforts" go far beyond
EDIINT and ebXML.  To put it in perspective, you must look at the
timelines involved in these projects.  I checked my archives and the
oldest rev of AS1 I could find was 9 and it had a date of December 1998.
I'm not sure of the exact dates for AS1 but I do know that the AIAG and
the Gas Industry (GISB) have been working on this stuff since 1996.  I
assume AS1 dates back that far as well.  In the past there have been
differences in opinion on messaging methodologies.  AS1 was originally
email (SMTP) based, GISB was HTTP/MIME with PGP, AIAG was HTTP/MIME
without PGP, etc...  We all had (and still do in some cases) different
ideas about security, authentication, protocols and what constitutes
reliable messaging.  We've all been through multiple revisions of our
work to improve on our original assumptions.  Each of the existing
methodologies has its merits and a formidable installed base.  New
efforts like ebXML continue to pop up (I assure you that its not the
last) ensuring that duplicate work will (unfortunately) continue for
some time.  I forget who said it first, but "the greatest thing about
standards is that there are so many to choose from..."  

 - Paul

-----Original Message-----
From: Pae Choi [mailto:[email-masked]]
Sent: Friday, December 21, 2001 4:47 AM
To: Gary Crough; David Fischer; [email-masked]
Cc: Ned Freed; Rik Drummond
Subject: Re: MIME-based Secure EDI -- AS1

Hello,

In addition to some similarity, the OASIS consortium just announced a
news
that is saying about the XML and the related security as well as others.

Best regards,

Pae

----- Original Message -----
From: "Gary Crough" <[email-masked]>
To: "David Fischer" <[email-masked]>; <[email-masked]>
Cc: "Ned Freed" <[email-masked]>; "Rik Drummond"
<[email-masked]>

> After reading the comments from the Last Call on AS1, it seems there
are
> two