Subject: [edu-team] Re: [Fwd: Re: website for education team]

From: Margaret Wasserman <[email-masked]>
Date: Tue, 23 Sep 2003 09:03:54 -0400

[Added the edu-team, for their opinions.]

Hi James,

I already have the tentative pages set-up on my psg.com site, and
that is probably okay for a temporary location.  We need to find a
permanent (highly-available, backed-up, supported) location before
we can hook it into the IETF site, though.

I could also talk to Randy...  I am not sure if his objection
was to the idea of hosting the education web site, or to the
idea of running one of the multi-access services that you
suggested.  I'm not sure of the security properties of those
services, and I know that Randy is very security conscious.

I suppose that we could also talk to the secretariat about
hosting the site on the IETF server...  Harald, do you know
what would be involved in that?

I don't remember if I've told you folks yet, but I will be leaving
Wind River on Friday and starting at Nokia on Monday.  I have been
told that Nokia has web resources available for IETF-related pages,
so we may be able to host it there...  Although the server is in
Helsinki, I've been assured that there is reasonable world-wide
access.

I don't think that it is _as_ important that we set this up so
that multiple people an access it, as it is that we have a
solid, reliable place to put it.  What do you guys think?

Margaret

At 12:31 PM 9/23/2003 +0800, James Seng wrote:
>Margarent,
>
>Have you sort this out with Randy? If not, I could help host it on my site 
>first while we works things out.
>
>If it is okay with you, I will proceed to setup it up.
>
>-James Seng
>
>James Seng wrote:
>
>>Hi Margaret,
>>I dont mind helping to setup the engine. I know quite a few which will 
>>allow us to do this and they are pretty easy to setup. e.g. wiki etc.
>>-James Seng
>>Margaret Wasserman wrote:
>>
>>>
>>>Hi James,
>>>
>>>I'll see what I can do...
>>>
>>>If Randy doesn't want to do this, Harald or I will
>>>find something else.
>>>
>>>Margaret
>>>
>>>At 10:22 AM 9/12/2003 +0800, you wrote:
>>>
>>>>Margarent,
>>>>
>>>>You want to talk to Randy?
>>>>
>>>>-James Seng
>>>>
>>>>-------- Original Message --------
>>>>Subject: Re: website for education team
>>>>Date: Thu, 11 Sep 2003 09:13:51 -0700
>>>>From: Randy Bush <[email-masked]>
>>>>To: James Seng <[email-masked]>
>>>>CC: Margaret Wasserman <[email-masked]>
>>>>References: <[email-masked]>
>>>>
>>>>>I volunteered to talk to about the website for the education team.
>>>>>I understand you gave margaret a website but the problem only she have 
>>>>>access. What the team need is a common area where all of us (and the # 
>>>>>may increase in future) have access to put up content for the site.
>>>>>I was thinking of putting up some site content engine (e.g. php-nuke 
>>>>>or node etc) so we can manage the site without logging onto your 
>>>>>machine (nor do you need to give each of us an acct or a share acct).
>>>>>what do you think?
>>>>
>>>>
>>>>
>>>>sounds like a good idea.  please host it elsewhere.
>>>>
>>>>randy
>>>>
>>>>
>>>

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 24 Sep 2003 12:36:32 -0700

there's an IETF server has some ssh access, but they're locking it down as 
hard as they can - only sftp access, with public-key logins, and even then 
they only allow access from limited IP ranges, and copying stuff to the 
production webservers via a cron job.

Offhand, I'd think that Helsinki should be checked out. John Loughney is 
over there, so he could help if onsite inspections are warranted .-)

most people who run professional IT and aren't full-time webhosters are 
very skeptical of allowing software they don't know personally. So one 
thing to check out is how Helsinki feels about that (wikis and so on).

                  Harald

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 24 Sep 2003 16:17:34 -0400

Harald,

>solid, reliable place to put it.  What do you guys think?

In other words, if Nokia can provide a stable home, but
wouldn't allow access by anyone but me (or perhaps other
Nokia employees) would that work?  Other folks could work
on the web pages, and just submit them to me for posting.

I am fairly skeptical about the security of most of the
software that allows shared access (wikis and so forth),
so I'm not even sure that I'd even want to suggest that
Nokia run one...

If we absolutely need shared access, then I will try to
find some organization that can provide that...  and that
probably means the IETF??

Margaret

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 24 Sep 2003 13:31:07 -0700

> on the web pages, and just submit them to me for posting.

another option is to separate "work" and "release" web pages - get a pc on 
someone's DSL to be the "work" server, with wikis, medium/low security, no 
backup and so on, and then have some kind of "publish" script that dumped 
the stuff that needs to be published into a "publish" webserver - which 
could be in Helsinki or in Reston without stretching the security rules of 
either host.

> probably means the IETF??

or someone's PC.

                 Harald

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 24 Sep 2003 16:42:08 -0400

Hi Harald,

>could be in Helsinki or in Reston without stretching the security rules of 

I don't suppose that you have an old PC lying around that you'd
like to use for this purpose?  Or, do we have any other
volunteers?

I don't have stable IP addresses at home (Comcast Cable Modem),
so it isn't easy to run a server there...  Unless of course
folks want to use IPv6 to access it :-).

The good thing about this plan, though, is that we can phase
it in, since the shared machine won't be visible to people
using the web pages.

At this point, we need to find some way to get the first version
of this web site visible fairly quickly, since we promised
end-of-September...

Harald, we also need to do something to move the charter
forward.  What is the next step?  I have one minor update to
make based on Randy's feedback.  Have you seen any other
feedback?

Margaret

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 24 Sep 2003 14:10:50 -0700

> make based on Randy's feedback.  Have you seen any other

I haven't seen any other feedback, or indeed any feedback on the real 
content of the charter - so I suggest you send me the updated charter, and 
I put it on the agenda under Management Items next week.

               Harald

---

From: James Seng <[email-masked]>
Date: Thu, 25 Sep 2003 09:06:02 +0800

My offer to use my machine still stands. I have no issues if you use it 
as a development site for the main site hosted else where.

-James Seng

Margaret Wasserman wrote:

>> another option is to separate "work" and "release" web pages - get a 
>> pc on someone's DSL to be the "work" server, with wikis, medium/low 
>> security, no backup and so on, and then have some kind of "publish" 
>> script that dumped the stuff that needs to be published into a 
>> "publish" webserver - which could be in Helsinki or in Reston without 
>> stretching the security rules of either host.
> 
>

---

From: Margaret Wasserman <[email-masked]>
Date: Thu, 25 Sep 2003 15:53:06 -0400

At 09:06 AM 9/25/2003 +0800, James Seng wrote:
>My offer to use my machine still stands. I have no issues if you use it as 
>a development site for the main site hosted else where.
>
>-James Seng

That sounds good, James.

Is your machine stable/available/supported enough to use as
the permanent home for the page?  Or is this just a personal
system that we could use for development?

What about this plan:

         1) I get the first version of the site together.
         2) We put it up the first version publicly ASAP.
         3) In the meantime, you set-up a multi-access
                 development system, we get that working,
                 etc...

Do you think that would work?

Margaret

>>>another option is to separate "work" and "release" web pages - get a pc 
>>>on someone's DSL to be the "work" server, with wikis, medium/low 
>>>script that dumped the stuff that needs to be published into a "publish" 
>>>webserver - which could be in Helsinki or in Reston without stretching 
>>>the security rules of either host.
>>

---

From: James Seng <[email-masked]>
Date: Fri, 26 Sep 2003 11:47:40 +0800

Okay, thats fine. I will setup an engine and post the URL soon. :-)

-James Seng

Margaret Wasserman wrote:

>> My offer to use my machine still stands. I have no issues if you use 
>> it as a development site for the main site hosted else where.
>>
>> -James Seng
> 
> 
> That sounds good, James.
> 
>>>> "publish" webserver - which could be in Helsinki or in Reston 
>>>> without stretching the security rules of either host.
>>>
>>>

---

From: James Seng <[email-masked]>
Date: Sat, 27 Sep 2003 01:40:29 +0800

Okay, I setup a CMS for Education Team. Please take a look.

http://james.seng.cc/ietf-edu/

ps: An updated WG chair training slides with ESL Consideration is 
available for download.

This is setup using Movabletype engine. For testing, we will use a share 
account. To login go to http://james.seng.cc/mt/mt.cgi
Login: ietf-edu   Password: ietf8edu

Once you login, you can edit the current "entries" to modify the content.

You can also post new "entries":
- An "About Us" entry will put a link under the "About Us" section.
- A "News" entry will put a link under "Latest News" and also achieved 
by months. This can also be syndicated via RSS.
- A "Downloads" entry will put a link under "Downloads"

You can also upload files to the site.

(Please remember to set them to "publish" when you want it to be seen by 
others)

-James Seng

---

From: James Seng <[email-masked]>
Date: Sat, 27 Sep 2003 20:19:37 +0800

Hi, Harald, Margaret,

I got your feedback and already reply there. See 
http://james.seng.cc/mt/mt-comments.cgi?entry_id=104

(The system is configured to informed the "creator" of the entry of any 
comments posted on the site so I got an email for every comments posted. 
I could hack it so that comments will be posted to the [email-masked] 
if you like).

If there is no objections, I will post the link to the edu-discuss list 
for other people feedback on the "work-in-progress site" to get more 
feedback.

For those who havent try, I encourage you to login and try to create 
some entries, or if you like, modify the existing contents (entries). 
Don't worry, nothing you do can kill the system (..erm...just dont play 
around with the templates tho since I haven't started doing cron backup)

-James Seng

James Seng wrote:

>>>>> another option is to separate "work" and "release" web pages - get 
>>>>> a pc on someone's DSL to be the "work" server, with wikis, 
>>>>> medium/low security, no backup and so on, and then have some kind 
>>>>> of "publish" script that dumped the stuff that needs to be 
>>>>> published into a "publish" webserver - which could be in Helsinki 
>>>>> or in Reston without stretching the security rules of either host.
>>>>
>>>>
>>>>