Subject: [edu-team] Document Lifecycle class proposal for IETF 70

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 25 Jun 2007 11:48:29 -0500

As discussed on previous calls - Alice and I talked last week, and
this is more or less where we ended up. We aren't thinking of large
amounts of new material, so it's mostly combining slide sets and then
deleting the parts we don't want to include immediately.

Our IETF 70 plan is to do a document lifecycle class, based on slides
from WG leadership and from RFC Editor training tutorials. We might
remove these slides from the other tutorials someday, but not before
IETF 70, and we don't expect Document Lifecycle to be offered at the
same IETF as the other tutorials.

SHORT overview of "where RFCs come from" - there are actually *5* streams

SHORT WG process overview, mostly pictures and pointers.

The document lifecycle roadmap, mostly pictures and pointers

Content of a 00 Internet Draft - required and suggested

One slide on XML2RFC and pointer to tutorial

Steps during individual-author draft stage (all the following sections
are explained from
the author's perspective)

Steps during WG draft stage

Steps during IETF Last Call/IESG evaluation stage

Steps during post-approval stage

Please let us know if you think we were supposed to produce a
different concept - if we're good on the concept, please let us know
and we'll start slicing slides.

Spencer

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Alice Hagens <[email-masked]>
Date: Mon, 25 Jun 2007 11:07:02 -0700

Spencer,
My mistake on saying 5. As the individual (AD-sponsored, non-WG)  
submissions are considered part of the IETF stream, there are 4 streams:

1. IETF
2. IAB
3. IRTF
4. Independent Submissions

from  draft-iab-rfc-editor-04:

      5.1.  RFC Approval  
Processes . . . . . . . . . . . . . . . . . . 14
        5.1.1.  IETF Document  
Stream . . . . . . . . . . . . . . . . . 14
        5.1.2.  IAB Document  
Stream  . . . . . . . . . . . . . . . . . 15
        5.1.3.  IRTF Document  
Stream . . . . . . . . . . . . . . . . . 15
        5.1.4.  Independent Submission  
Stream  . . . . . . . . . . . . 15

Alice

---

From: Russ Housley <[email-masked]>
Date: Mon, 25 Jun 2007 15:42:10 -0400

Are April 1st RFCs part of the 4th category?

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 27 Jun 2007 10:29:10 +0200

N(streams) apart, let me say that I think this would
be a great class for new arrivals.

     Brian

---

From: Alice Hagens <[email-masked]>
Date: Wed, 27 Jun 2007 11:33:48 -0700

Yes, we consider them a special case of independent submissions.

Alice