Subject: [edu-team] Fwd: RE: MIB Tutorial at IETF 75

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 16 Apr 2009 15:07:34 +0200

Hi all,

I contacted David and Bert about a MIB tutorial. It looks like neither
of them will be available on Sunday in Stockholm. But Dan Romascanu
said he would be willing to give such a tutorial (see below for
details). What do you all think? Also, does any of you know if there is
material for such a class (apart from the information that is on the
ops pages)?

Regards,
Mirjam

----- Forwarded message from "Romascanu, Dan (Dan)" <[email-masked]> -----

From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "Bert Wijnen (IETF)" <[email-masked]>,
	"Mirjam Kuehne" <[email-masked]>,
	"Margaret Wasserman" <[email-masked]>
Cc: <[email-masked]>
Date: Tue, 14 Apr 2009 17:38:32 +0200
Subject: RE: MIB Tutorial at IETF 75
Thread-Topic: MIB Tutorial at IETF 75
Thread-index: Acm57msIkws7iB3lQIaPyAwPWwlEJQDJ19og

I actually believe that doing a MIB tutorial is still a good idea,
especially taking into account that we are in Europe and we may reach
different audiences. We still do MIB modules in different WGs and they
are still not perfect, on the other hand we are still one cycle or two
ahead of a 'write-a-YANG' tutorial. We can add however a slide about
multiple protocol and hint that YANG is approaching. Then prepare for a
first YANG tutorial at IETF-77 or IETF-78, when we should also have a
4181-like document. 
 
If neither Bret or David are available on Sunday I can also give the
tutorial, I assume the material is ready or almost. 
 
Dan

________________________________

	From: Bert Wijnen (IETF) [mailto:[email-masked]] 
	Sent: Friday, April 10, 2009 6:09 PM
	To: Mirjam Kuehne; Margaret Wasserman
	Cc: [email-masked]; Romascanu, Dan (Dan)
	Subject: Re: MIB Tutorial at IETF 75

	Mirjam/Margaret,
	 
	I chatted a bit with David about this. Summary:
	- We're not so sure that MIB is a good topic anymore
	- I suggested YANG. David thinks it is a bit too early
	- David suggested: the change from the old "write-a-MIB" 
	  approach to tthe new multiprotocol approach (syslog, 
	  snmp, netconf, MIBs, SDEs, YANG, etc) might help 
	  them better understand the emerging trends.
	  I am not sure I could give such a tutorial (I am not a big
	  fan of multiple technologies inetrmixed, even though I 
	  understand that such is often the practice).
	  David is not sure he has time.
	- For YANG you could have probably several speakers 
	  from the "YANG GANG". 
	 
	We think it is best if Dan also has a word in the decision 
	as to what would be a good NM topic for a tutorial; 
	he will be back Monday or Tuesday.
	 
	Personally, I am not sure yet that I will be in Stockhold on the
Sunday afternoon.
	I may in fact fly in on Monday morning.
	 
	Bert

		----- Original Message ----- 
		From: Mirjam Kuehne <mailto:[email-masked]>  
		To: Bert Wijnen <mailto:[email-masked]>  ;
[email-masked] 
		Cc: Margaret Wasserman <mailto:[email-masked]>  
		Sent: Friday, April 10, 2009 8:52 AM
		Subject: MIB Tutorial at IETF 75

		Dear David, Dear Bert,
		
		I am not sure if Margaret already contacted you abou
this:
		
		The IETF EDU Team thought it might be useful to offer a
MIB Tutorial
		at IETF 75 in Stockholm. We thought of a tutorial along
the lines of
		the guideliens described on ops.ietf.org and in RFC
4181.
		
		Would you be available and willing to put together and
deliver such 
		a tutorial in Stockholm? And if so, would the 15:00 be
OK?
		
		There is still time to discuss the details, I just
wanted to check 
		if you would like to do this in general.
		
		Kind Regards,
		Mirjam 

----- End forwarded message -----

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Apr 2009 09:38:51 +1200

I think it's a useful topic (but I hope it includes a section
on when a MIB module is or isn't a good idea). I've no idea
about existing material though. Certainly, Dan is too busy as an
AD to prepare it.

    Brian

On 2009-04-17 01:07, Mirjam Kuehne wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>