Subject: [edu-team] Tutorials for IETF 87 Berlin

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 02 Apr 2013 11:48:31 +0200

Hi,

The secretariat asked us to submit the list of tutorials for IETF 87 by 
mid April, so they can include them on the web site when registration opens.

So, what do we want to do in Berlin?

1. Newcomers Tutorial
Scott, will you be in Berlin?

A number of people suggested that the Edu-Team would thoroughly review 
the newcomers slides from time to time. Shall we do this before Berlin?

I asked a few German participants during the IETF in Orlando if we 
should provide the newcomers tutorial in German, but most of them said 
that won't be necessary.

2. Alice had offered to do "Tools for Creating IDs & RFCs" in Berlin. 
Any objections? Alice, are you still willing to do that?

3. Shall we offer the RAI tutorial once more, possibly at the other time 
slot to allow other people to attend (and then we can also make sure it 
gets recorded)? Radia, you suggested to cover two different areas in one 
time slot. Which other area did you have in mind?

4. Benoit suggested to do a tutorial on IPFIX (speaker Brian Trammel). 
Are there any objections? Shall we ask him to send the slides for review?

Radia, you also suggested to organise a tutorial on Multipath TCP?

Cheers,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Apr 2013 11:03:31 +0100

That looks good.

> 4. Benoit suggested to do a tutorial on IPFIX (speaker Brian Trammel). Are there any objections? Shall we ask him to send the slides for review? 

I think it's a useful cross-area topic; if you set it up, tell him
to aim at people who don't know that they need IPFIX in their lives.
The title and abstract should convey that too: "You need IPFIX because..."

Regards
   Brian

On 02/04/2013 10:48, Mirjam Kuehne wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Alice Russo <[email-masked]>
Date: Tue, 2 Apr 2013 09:33:08 -0400

Yes. Typically this tutorial would cover NroffEdit and xml2rfc (and a brief summary of the Word template). The past slides are here: http://www.rfc-editor.org/rfc-editor/tools_83.pdf

Additions for IETF 87 would include demo of xml2rfc v2 (GUI and CLI) and how to handle common quirks/errors encountered with v2.

Suggestions on improving this tutorial are welcome.

Thanks,
Alice

On Apr 2, 2013, at 5:48 AM, Mirjam Kuehne wrote:

> 
> 2. Alice had offered to do "Tools for Creating IDs & RFCs" in Berlin. Any objections? Alice, are you still willing to do that?

---

From: Radia Perlman <[email-masked]>
Date: Tue, 2 Apr 2013 08:31:39 -0700

I might like to do either the security tutorial or the layers 2/3 tutorial.

And I still think IPFIX is too narrow a topic...it should be expanded to
put it into context, and include more of the "what problem is being
solved", etc.

The mutlipath TCP tutorial that I saw was specifically interesting because
it wasn't just focused on the bits and bytes of one protocol...it started
with "what problem did we want to solve", then "what's weird about the
Internet that wouldn't allow the obvious approach to work", and then
"here's the ways we needed to design it in order for it to work".  I don't
believe it ever showed packet formats.

It is way more difficult to prepare something like that, but it's well
worth it for both the audience and the speaker.

Radia

On Tue, Apr 2, 2013 at 2:48 AM, Mirjam Kuehne <[email-masked]> wrote:

> A number of people suggested that the Edu-Team would thoroughly review the
> newcomers slides from time to time. Shall we do this before Berlin?
>
> I asked a few German participants during the IETF in Orlando if we should
> provide the newcomers tutorial in German, but most of them said that won't
> be necessary.
>
> 2. Alice had offered to do "Tools for Creating IDs & RFCs" in Berlin. Any
> objections? Alice, are you still willing to do that?
>
> 4. Benoit suggested to do a tutorial on IPFIX (speaker Brian Trammel). Are
> there any objections? Shall we ask him to send the slides for review?
>
> ______________________________**_________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/edu-team<https://www.ietf.org/mailman/listinfo/edu-team>
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 2 Apr 2013 12:17:29 -0400

I think it would be most excellent to do Multipath TCP.

Russ

On Apr 2, 2013, at 5:48 AM, Mirjam Kuehne wrote:

> Hi,
> 
> The secretariat asked us to submit the list of tutorials for IETF 87 by mid April, so they can include them on the web site when registration opens.
> 
> A number of people suggested that the Edu-Team would thoroughly review the newcomers slides from time to time. Shall we do this before Berlin?
> 
> I asked a few German participants during the IETF in Orlando if we should provide the newcomers tutorial in German, but most of them said that won't be necessary.
> 
> 3. Shall we offer the RAI tutorial once more, possibly at the other time slot to allow other people to attend (and then we can also make sure it gets recorded)? Radia, you suggested to cover two different areas in one time slot. Which other area did you have in mind?
>

---

From: Radia Perlman <[email-masked]>
Date: Tue, 2 Apr 2013 11:31:11 -0700

Let me try to ping Mark Handley again.  Are there any other potential
presenters in case he's not going to the next IETF?

Radia

On Tue, Apr 2, 2013 at 9:17 AM, Russ Housley <[email-masked]> wrote:

> should provide the newcomers tutorial in German, but most of them said that
> won't be necessary.
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 03 Apr 2013 07:54:18 +0100

Possibly Alan Ford, Bob Briscoe or Phil Eardley?

Regards
   Brian Carpenter

On 02/04/2013 19:31, Radia Perlman wrote:
> ------------------------------------------------------------------------
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 11 Apr 2013 12:29:07 +0200

Hi again,

We have agreement on three tutorials: Newcomers (Scott), Tools (Alice) 
and IPFIX (Benoit/Brian Trammell).

For the fourth one, we have a number of options:

- RAI area overview, possibly together with another area

- Multipath TCP (Radia, did you find someone who could teach that topic?)

- Radia also offered to give the security or the layer 2/3 tutorial

So, what shall we do?

And for the WG Chairs lunch, it was suggested to talk about the WG chair 
portion of the datatracker (speaker: Margaret).

Mirjam

---

From: "Bradner, Scott" <[email-masked]>
Date: Thu, 11 Apr 2013 11:54:42 +0000

I am also revising the presentation based on some of the feedback I have received

Scott

On Apr 11, 2013, at 6:09 AM, Mirjam Kuehne <[email-masked]> wrote:

> Hi Scott,
> 
> Will you be in Berlin to give the Newcomers Tutorial?
> 
> Regards,
> Mirjam
> 
> -------- Original Message --------
> Subject: Tutorials for IETF 87 Berlin
> Date: Tue, 02 Apr 2013 11:48:31 +0200
> From: Mirjam Kuehne <[email-masked]>
> To: EDU Team <[email-masked]>
> 
> Hi,
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 11 Apr 2013 13:56:55 +0200

Excellent. Thanks, Scott.

Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Apr 2013 14:17:36 +0100

> - Radia also offered to give the security or the layer 2/3 tutorial

I would go for MPTCP if we have a speaker, only on the grounds that
it's new. If not, probably RAI because it's relatively new. otoh
I would have be fine with either of Radia's talks too.

   Brian

---

From: Radia Perlman <[email-masked]>
Date: Thu, 11 Apr 2013 08:02:59 -0700

On MPTCP, Mark Handley did not respond to my email at either of the email
addresses I sent to him.  I was assuming it would be likely for him to go
to Germany for IETF because he lives in Europe.

If someone can look up email addresses of other MPTCP people that might be
able to do a similar job (again, not just focusing on bits and bytes of one
protocol, but the context for the problem and the design), I'll try sending
to them.

We need people who are enthusiastic about teaching tutorials I think.

Radia

On Thu, Apr 11, 2013 at 3:29 AM, Mirjam Kuehne <[email-masked]> wrote:

> Hi again,
>
> We have agreement on three tutorials: Newcomers (Scott), Tools (Alice) and
> IPFIX (Benoit/Brian Trammell).
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 12 Apr 2013 09:55:38 +0200

Hi,

Are we confident we will get a MPTCP tutorial off the ground before the 
Berlin meeting? Or shall we try to organise this for IETF 88 and use an 
existing tutorial for Berlin? Personally I think it would be good to 
give the RAI overview again, so that people can attend who couldn't make 
it last time. And that would also give us a chance to record it this time.

Mirjam

On 11/4/13 5:02 PM, Radia Perlman wrote:
> On MPTCP, Mark Handley did not respond to my email at either of the
> email addresses I sent to him.  I was assuming it would be likely for
> him to go to Germany for IETF because he lives in Europe.
>
> If someone can look up email addresses of other MPTCP people that might
> be able to do a similar job (again, not just focusing on bits and bytes
> of one protocol, but the context for the problem and the design), I'll
> try sending to them.
>
> On Thu, Apr 11, 2013 at 3:29 AM, Mirjam Kuehne <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi again,
>
>     We have agreement on three tutorials: Newcomers (Scott), Tools
>     (Alice) and IPFIX (Benoit/Brian Trammell).
>
>     And for the WG Chairs lunch, it was suggested to talk about the WG
>     chair portion of the datatracker (speaker: Margaret).
>
>     Mirjam
>
>
>
>         mid April, so they can include them on the web site when
>         registration
>         opens.
>
>     _________________________________________________
>     edu-team mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/edu-team
>     <https://www.ietf.org/mailman/listinfo/edu-team>
>
>

---

From: Radia Perlman <[email-masked]>
Date: Fri, 12 Apr 2013 08:22:57 -0700

I think we should redo the RAI one and make sure it's recorded.  The only
reason to push for MPTCP this time was that I thought a European venue
might be convenient for Mark.

Traditionally we do 4 (2 in the 1 PM slot, 2 in the 3 PM slot).  Might we
want to expand these at some point?

Radia

On Fri, Apr 12, 2013 at 12:55 AM, Mirjam Kuehne <[email-masked]> wrote:

> existing tutorial for Berlin? Personally I think it would be good to give
> the RAI overview again, so that people can attend who couldn't make it last
> time. And that would also give us a chance to record it this time.
>
> Mirjam
>
>
>>     ______________________________**___________________
>>     edu-team mailing list
>>     https://www.ietf.org/mailman/_**_listinfo/edu-team<https://www.ietf.org/mailman/__listinfo/edu-team>
>>     <https://www.ietf.org/mailman/**listinfo/edu-team<https://www.ietf.org/mailman/listinfo/edu-team>
>> >
>>
>>
>>
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 15 Apr 2013 15:48:39 +0200

Hi,

Looks like we have a decision. I'll pass the list of tutorials on to the 
secretariat.

The question about expanding the number of tutorials came up before. In 
theory I guess we could offer more tutorials (if there are enough 
rooms). I am just a little worried that there won't be enough people in 
each room if we offer too many tutorials in parallel. Especially now we 
also have to compete with the open IAOC meeting on Sunday afternoon.

Regards,
Mirjam

On 12/4/13 5:22 PM, Radia Perlman wrote:
> I think we should redo the RAI one and make sure it's recorded.  The
> only reason to push for MPTCP this time was that I thought a European
> venue might be convenient for Mark.
>
> Traditionally we do 4 (2 in the 1 PM slot, 2 in the 3 PM slot).  Might
> we want to expand these at some point?
>
> Radia
>
> On Fri, Apr 12, 2013 at 12:55 AM, Mirjam Kuehne <[email-masked]
>     Are we confident we will get a MPTCP tutorial off the ground before
>     the Berlin meeting? Or shall we try to organise this for IETF 88 and
>     use an existing tutorial for Berlin? Personally I think it would be
>     good to give the RAI overview again, so that people can attend who
>     couldn't make it last time. And that would also give us a chance to
>     record it this time.
>
>     Mirjam
>
>
>         <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>
>              Hi again,
>
>              - Multipath TCP (Radia, did you find someone who could
>         teach that
>              topic?)
>
>                  The secretariat asked us to submit the list of
>         tutorials for
>                  IETF 87 by
>                  A number of people suggested that the Edu-Team would
>         thoroughly
>                  review
>                  the newcomers slides from time to time. Shall we do
>         this before
>                  Berlin?
>
>                  should provide the newcomers tutorial in German, but
>         most of
>                  them said
>                  that won't be necessary.
>
>                  2. Alice had offered to do "Tools for Creating IDs &
>         RFCs" in
>                  Berlin.
>                  3. Shall we offer the RAI tutorial once more, possibly
>         at the
>                  other time
>                  slot to allow other people to attend (and then we can
>         also make
>                  sure it
>                  4. Benoit suggested to do a tutorial on IPFIX (speaker
>         Brian
>                  Trammel).
>                  Are there any objections? Shall we ask him to send the
>         slides
>                  for review?
>
>              ___________________________________________________
>              edu-team mailing list
>         <mailto:[email-masked] <mailto:[email-masked]>>
>         https://www.ietf.org/mailman/____listinfo/edu-team
>         <https://www.ietf.org/mailman/__listinfo/edu-team>
>              <https://www.ietf.org/mailman/__listinfo/edu-team
>         <https://www.ietf.org/mailman/listinfo/edu-team>>
>
>
>
>