Subject: [edu-team] Tutorials for IETF 90 Toronto

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 04 Apr 2014 14:06:26 +0200

Hi,

Stephanie needs to know soon which tutorials we would like to offer at
IETF 90. In London we decided the following:

13:00
1. Newcomers (Scott)
2. Tools for creating IDs & RFCs combined with Intro to xml2rfc (Alice,
Henrik)

15:00
3. Overview of the OPS Area (Lee Howard)
4. Wireless Tutorial (Donald Eastlake)

Is everyone OK with that?

Then there was the idea of a hands-on netconf/yang workshop, but I
haven't heard anything more about this (and it would probably have to be
in parallel with the regular tutorials anyway).

We were also discussing to do the WG Leadership tutorial again soon and
possibly add things we identified in the meantime such as the English
language mentoring project. I had asked Margaret in passing if she could
do this at IETF 90, but I think it might make more sense to schedule
this for IETF 91 and spend some more time on reviewing the material. OK?

Regards,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 05 Apr 2014 07:45:16 +1300

> Is everyone OK with that?

wfm

> in parallel with the regular tutorials anyway).

Maybe you should politely remind the proponents that EDU would
like to be kept aware.

> this for IETF 91 and spend some more time on reviewing the material. OK?

Yes. Did anyone have thoughts about my suggestion of English as
a second language for the WG chairs lunch topic?

   Brian
> 
> Regards,
> Mirjam
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Radia Perlman <[email-masked]>
Date: Fri, 4 Apr 2014 11:52:38 -0700

Seems like a great list.

Radia

---

From: Alice Russo <[email-masked]>
Date: Fri, 18 Apr 2014 12:23:00 -0400

Hi Mirjam,

Actually, I think this would be the IETF Tools tutorial followed by xml2rfc material (which is partly from 'Tools for Creating I-Ds' and 'Intro to xml2rfc'). The addition is to more completely fill the time slot and to provide more detail on one tool that is often used to create I-Ds.  Perhaps the title would be 'IETF Tools and an Introduction to xml2rfc' or 'Overview of IETF Tools including xml2rfc'. And to combine the existing descriptions:

> This tutorial is intended to help IETF participants to make use of the tools provided by the IETF tools team. There will be a short overview of each tool plus a demo of the essential functionality.
> 
> In addition, this tutorial will provide an introduction to xml2rfc, a popular to way to create Internet-Drafts. It will cover the basics for using xml2rfc and answer some common questions. Using xml2rfc relieves draft authors of the need to think about getting the boilerplate and overall format right, and provides citation libraries that reduce the pain of generating references to I-Ds, RFCs, and other document series.

Henrik had the idea of reorganizing the IETF Tools tutorial into more of a narrative (e.g., the lifecycle of a document in terms the tools that are helpful at each stage). I should have some time to work on that reorganization before Toronto.

Side note: perhaps on http://www.ietf.org/proceedings/88/train-6.html
a link to http://tools.ietf.org/pres/88/tools-tutorial/ could be added? (It's an HTML presentation, not PDF.)

Thanks,
Alice