Subject: Re: [edu-team] Fwd: Re: Hands-on netconf/yang workshop

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 01 May 2014 09:39:06 +0200

On 30/4/14 10:01 PM, Brian E Carpenter wrote:
> I see no objection. It's sufficiently specialised that
> I don't think it competes with the regular tutorials, and it's
> good that we are in the loop.
> 
> BTW, did we decide on a WG Chairs lunch topic yet?

No, we didn't. Any suggestion?

Regards,
Mirjam

> Regards
>    Brian
> 
> On 30/04/2014 21:13, Mirjam Kuehne wrote:
>> Hi,
>>
>> I assume there are no objections to support this workshop? So, I'll ask
>> the secretariat to organise a room and put it on the agenda, OK?
>>
>> Cheers,
>> Mirjam
>>
>>
>> -------- Original Message --------
>> Subject: Re: Hands-on netconf/yang workshop
>> Date: Tue, 29 Apr 2014 16:44:40 +0200
>> From: Benoit Claise <[email-masked]>
>> To: Mirjam Kuehne <[email-masked]>
>> CC: EDU Team <[email-masked]>, YANG Doctors <[email-masked]>
>>
>> Hi Mirjam,
>>
>> YANG-doctors, feel free to chime in.
>>> Hi Benoit,
>>>
>>> Is there a specific time this will take place?
>> What about 2PM to 6PM.
>>> Is this planned for
>>> Sunday in parallel with the other tutorials?
>> Yes.
>>> Should this be listed on
>>> the agenda/registration form?
>> Yes.
>>> Or is it by invitation only? Do you need a
>>> room? How big?
>> What about 20 persons?
>>
>> I could send the invite in a near future, and ask for some sort of
>> confirmation before attending, just to evaluate the required capacity.
>>
>> Regards, Benoit
>>> Cheers,
>>> Mirjam
>>>
>>> On 29/4/14 12:05 PM, Benoit Claise wrote:
>>>> Hi Mirjam,
>>>>
>>>> Yes. Copying the YANG doctors.
>>>> The session should be called  "YANG Advice and Editing Session"
>>>> What we offer is to have a place where people can go to get feedback
>>>> about YANG their data modeling questions, language usage, questions,
>>>> tools to use, etc.
>>>>
>>>> Practically, what are the next steps?
>>>>
>>>> Regards, Benoit
>>>>> Hi Benoit,
>>>>>
>>>>> Are you still planning to hold this workshop?
>>>>>
>>>>> Kind regards,
>>>>> Mirjam
>>>>>
>>>>> On 6/3/14 5:46 PM, Mirjam Kuehne wrote:
>>>>>> Hi all,
>>>>>>
>>>>>> Benoit Claise approached me and told me that he was interested in
>>>>>> organising a hands-on workshop about NETCONF & YANG modules on Sunday
>>>>>> afternoon. He is planning to reach out to some individuals, but will
>>>>>> also send an announcement to the IETF list, and expects about 10 - 20
>>>>>> people to participate.
>>>>>>
>>>>>> It is a bit unfortunate that we have the OPS area overview at the same
>>>>>> time, but the hope is that the hands-on tutorial will attract a certain
>>>>>> set of people that might not necessarily be interested in the general
>>>>>> overview tutorial.
>>>>>>
>>>>>> What would be needed is a room and an announcement on the IETF agenda.
>>>>>>
>>>>>> Benoit, please add to it or correct me if I got anything wrong.
>>>>>>
>>>>>> Regards,
>>>>>> Mirjam
>>>>> .
>>>>>
>>> .
>>>
>>
>>
>>
>> _______________________________________________
>> edu-team mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/edu-team
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 02 May 2014 08:22:02 +1200

> No, we didn't. Any suggestion?

English as a 2nd language. Something like a report on the
workshop approach and maybe a report from the RFC Editor side
of commonly observed problems. And maybe get somebody like
Deng Hui (aka Hui Deng) to speak about it from his point of
view.

    Brian

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 05 May 2014 10:44:44 +0200

Hi Brian,

Good idea.

Alice, you were at the workshop together with Joel and Ted, right? Would
you like to prepare a short report and present it to the WG chairs? I
would imagine the bulk of the meeting could be an exchange of
experiences and a discussion of ideas.

And yes, maybe someone who participated in the workshop could be there
and talk about their experiences?

Mirjam

---

From: Alice Russo <[email-masked]>
Date: Tue, 6 May 2014 14:02:50 -0700

Hi Mirjam,

Heather (the RFC Series Editor, who is CC'ed here) would be good for talking to the WG chairs on Wed. 7/23 about efforts to support authors who speak English as a second+ language. Scheduling is tricky b/c of a standing Wed. lunch during IETF week, but I think it's been moved.

Thanks,
Alice

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 07 May 2014 10:33:52 +1200

Alice,

It would be great to have Heather speak, but I think we
definitely need a report from the workshop itself. These
WG Chair lunches are very nuts-and-bolts occasions (how
to make WGs work better...).

Shall we start to sketch an agenda and contact speakers?

Regards
   Brian

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 07 May 2014 14:49:31 +0200

> to make WGs work better...).

yes, I think a combination of both would be great.

> Shall we start to sketch an agenda and contact speakers?

Sounds like a good plan :-)

Mirjam

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 12 May 2014 10:13:42 -0700

> yes, I think a combination of both would be great.

I was at the last workshop and can speak to what I observed, and have
ideas on specific things that can (should!) be done to help authors who
find written English a challenge.  If we can get the WG chair that
attended to speak as well (I think that was Ning Zong of ppsp), that
would be grand.

> Sounds like a good plan :-)

And I've moved my usual Wednesday lunch so I can attend. 

-Heather

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 13 May 2014 11:41:57 +0200

Hi Heather,

Great that you can participate in the WG Chairs meeting. I'll contact
Ning Zong and see if he is available. Then, maybe the three of you can
agree on the agenda and who's doing it what?

Cheers,
Mirjam

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 13 May 2014 07:45:40 -0400

I was at the IESG Retreat last week. It was co-located with LACNIC 21. I met the LACNIC CTO, Arturo Servin, who told me about their email list on which they discussed IETF Internet drafts in their native language before it was submitted to the IETF as a draft. It served as kind if an "Idea Incubator", my words. 
I think the list was IETF-Lat or Lac. 

This sounds like a good idea to me, folks working on an idea in their native language then translating to English.   Especially if you can get a good translation. 

I note so far one person registered to attend Toronto from LACNIC   

Ray

> On May 12, 2014, at 1:13 PM, "Heather Flanagan (RFC Series Editor)" <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 May 2014 08:47:56 +1200

Sorry, I got Heather and Ning Zong but who is the third?

I believe we need to have a broad scope for this first discussion
WG Chairs have at least six problems to manage, IMHO:

- drafts with poor English written by ESL participants
- drafts with subtle English that are hard to understand for ESL participants
- emails with poor English
- emails using slang/obscure English
- speech in WG sessions with poor English, heavy accent, etc.
- fluent speech in WG sessions using slang or too fast, etc.

We have about an hour available (since we always lose time at the
beginning due to late arrivals and the lunch boxes). And I think we
need to reserve plenty of time to hear back from the room.

So I think we need a general intro introducing all the problem areas,
and maybe 20 minutes on the specific experience with the RFC workshop,
and then a structured discussion with the room.

Regards
   Brian Carpenter
   http://orcid.org/0000-0001-7924-6182

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 14 May 2014 12:27:53 +0200

Hi Brian,

Alice Russo is the third person :-)

Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 May 2014 11:16:29 +1200

OK, excellent. So are we looking at something like this?

1. Introduction and general problem statement (5 min.)

2. RFC Editor approach and experience with the workshop
   (Heather and Alice, dividing the time as they wish) (15 min.)

3. Experiences of a non-native English speaker (Ning Zong
   if he agrees; Deng Hui as a possible backup) (10 min.)

4. Open discussion - collect ideas, what are the best next steps?

Regards
   Brian

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 20 May 2014 10:04:57 +0200

Hi Brian,

Sounds like a plan. Do we need a moderator? Or Alice, do you want to
take that role?

I'll pass this on to the secretariat, so they can send out the invitation.

Regards,
Mirjam

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 20 May 2014 10:09:20 +0200

Oh, and Ning Zong agreed to participate in this session. Alice, Heather,
did he contact you already?

Mirjam

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 20 May 2014 09:35:56 +0100

Hi Mirjam,

I will drop him a note today.

-Heather

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 May 2014 07:56:44 +1200

All good.

> Introduction and general problem statement

Would you like me to draft some slides for this?

Regards
   Brian

---

From: Alice Russo <[email-masked]>
Date: Tue, 20 May 2014 16:02:02 -0400

> Would you like me to draft some slides for this?

Yes, I think that would be useful. I would prefer not to moderate; would you be willing to introduce the speakers and facilitate the open discussion, Brian?

Thanks,
Alice

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 May 2014 08:22:50 +1200

Hi Alice,

> Yes, I think that would be useful. I would prefer not to moderate; would you be willing to introduce the speakers and facilitate the open discussion, Brian?

OK, I'd be glad to if there are no other volunteers. I will put those
slides on my to-do list.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 31 May 2014 13:32:29 +1200

Hi,

I know this is absurdly early, but here's a first cut at my introductory
slides for Wednesday lunch in Toronto. It would be very short. Comments
and suggestions please.

Mirjam, will we have a slot in the Meeting Materials Manager
this time?

     Brian