Subject: [edu-team] How to get a draft passed / How to be a good contributor

From: Nalini Elkins <[email-masked]>
Date: Tue, 28 Jul 2015 15:01:45 +0000 (UTC)

Folks,
Preliminary results from the Mentoring Survey show that people come to IETF to:
1) Contribute to other people's drafts
2) Make progress with their own draft
One question I have - do we have an EDU presentation or video on either topic.   Not that that is all we need.  But a start.   
I want more responses but the trend of responses appears stable. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 12:33:03 -0400

I am doing one on how to get your idea to be a RFC 

Scott

> On Jul 28, 2015, at 11:01 AM, Nalini Elkins <[email-masked]> wrote:
> 
> Folks,
> 
> I want more responses but the trend of responses appears stable.
>  
> Thanks,
> 
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 28 Jul 2015 17:02:03 +0000 (UTC)

> I am doing one on how to get your idea to be a RFC 

Great!  Would be interested in looking at it when you have something.

Thanks,

Nalini

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 13:37:27 -0400

for background

I am co-teaching a Harvard extension school class on “the cyberworld”

https://www.extension.harvard.edu/academics/courses/cyber-world-hardware-software-networks-security-management/14299

as part of this course I have a module on standards development organizations - mostly the ITU & IETF

the IETF part is an expansion of the sunday newcomers tutorial presented a a series of shortish 
videos, each covering a different aspect of the IETF & the IETF standards process

I have requested, and expect to be granted, the permission to provide the videos to the IETF
for use on the eduteam website 

I should know in the next few days, in any case I will be able to provide the slides but might
have to retape the videos 

Scott

> On Jul 28, 2015, at 1:02 PM, Nalini Elkins <[email-masked]> wrote:
> 
> 
>

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 28 Jul 2015 17:54:02 +0000 (UTC)

Wonderful!

I am thinking over how best to achieve the goal of having people be good contributors and get a draft passed.  I was in a mentoring program a while back for CEOs of startups.  It was a forum consisting of other such types with a couple of experienced facilitators.   Each person talked over their problems & all gave feedback on how to proceed.  It was quite valuable.

I am mulling over whether such a forum might not be a good thing to do at the IETF.  The forum would be for people who had a draft & wanted to get it passed.  They could talk over their issues (leaving personalities out of it) and get advice from others.  Do not want to have it turn into a place where people talk badly about other people who are felt to be obstructing their path, though.   I am trying to think of all the things that could go wrong in this scenario.

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

----- Original Message -----
From: Scott O. Bradner <[email-masked]>
To: Nalini Elkins <[email-masked]>
Cc: IETF edu Team <[email-masked]>
Sent: Tuesday, July 28, 2015 10:37 AM
Subject: Re: [edu-team] How to get a draft passed / How to be a good contributor

for background

Scott

---

From: Alice Russo <[email-masked]>
Date: Tue, 28 Jul 2015 10:59:13 -0700

FYI, there is an existing tutorial on that topic: "Bringing New Work into the IETF". The slides are here: https://www6.ietf.org/edu/documents/81IETF-New-Work.pdf
(apparently last given in 2011 by Thomas Narten).

"This session will provide information to IETF participants and leaders on how to bring new work into the IETF, including how to bring a document into an existing WG, how to organize a BoF, and how to form a new IETF WG. Although this information is intended to encourage participants to bring interesting new work into the IETF, the class will also cover the IPR and control implications of pursuing work within the IETF."

Thanks,
Alice

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 28 Jul 2015 22:26:10 +0000 (UTC)

Alice,
The tutorial link is quite good.   It goes into aspects of IETF culture, building consensus, and other aspects of the informal culture as well as the technical aspects.
It may be good to have more on cultural aspects, how to present well, and getting / giving feedback.
I will be waiting to see what Scott has in his slides.   I do think though that it is one thing to hear such things in a tutorial and another to experience them.  So, I am wondering if maybe some small group work on an ongoing basis might be something to try.  
I suspect that many IETFers could use quite explicit help on things which are important.   For example, some people can easily figure out the psychological dynamics of the room.  They can tell who has power and who to talk to about what.  Others, not so much.   IMHO, building allies and learning to listen are key to passing a draft.   And, of course, good engineering!
I will talk this over with my team. 
Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Alice Russo <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Scott O. Bradner <[email-masked]>; IETF edu Team <[email-masked]> 
 Sent: Tuesday, July 28, 2015 10:59 AM
 Subject: Re: [edu-team] How to get a draft passed / How to be a good contributor

Thanks,
Alice

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 18:34:00 -0400

I got permission this afternoon to share the videos themselves, I will have to sign some sort of agreement
which have yet to see 

Scott

> On Jul 28, 2015, at 6:26 PM, Nalini Elkins <[email-masked]> wrote:
> 
> Alice,
> 
> FYI, there is an existing tutorial on that topic: "Bringing New Work into the IETF". The slides are here: https://www6.ietf.org/edu/documents/81IETF-New-Work.pdf <https://urldefense.proofpoint.com/v2/url?u=https-3A__www6.ietf.org_edu_documents_81IETF-2DNew-2DWork.pdf&d=BQMFaQ&c=WO-RGvefibhHBZq3fL85hQ&r=yqfP3H9W5MwHGwfujayvzw&m=5TTiy0UX_X2ZA8PKccfr98mEpKNUapHnT2_eOeyhmLg&s=LrpBk35iFdpyHBR-favePJ4T_qIYswbYg5ucLF8KqZg&e=>
> On Jul 28, 2015, at 10:02 AM, Nalini Elkins <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > 
> > 
> >> On Jul 28, 2015, at 11:01 AM, Nalini Elkins <[email-masked] <mailto:[email-masked]>> wrote:
> >> 
> >> Folks,
> >> 
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/edu-team <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_edu-2Dteam&d=BQMFaQ&c=WO-RGvefibhHBZq3fL85hQ&r=yqfP3H9W5MwHGwfujayvzw&m=5TTiy0UX_X2ZA8PKccfr98mEpKNUapHnT2_eOeyhmLg&s=PK7FqaK3tX94XDOuCeqHBqykJpi6pK45Gu0fM8Qtu_A&e=>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/edu-team <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_edu-2Dteam&d=BQMFaQ&c=WO-RGvefibhHBZq3fL85hQ&r=yqfP3H9W5MwHGwfujayvzw&m=5TTiy0UX_X2ZA8PKccfr98mEpKNUapHnT2_eOeyhmLg&s=PK7FqaK3tX94XDOuCeqHBqykJpi6pK45Gu0fM8Qtu_A&e=>
> > 
> 
>

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 29 Jul 2015 07:25:21 +0200

Nalini
The IETF is a meritocracy. Perhaps we might invite those who have earned their merit to talk about these various subjects, either individually or in groups. 

Each/they could be given a topic and no more than (15?) minutes per topic so the videos could be produced into consumable chunks. 

I added Dan York to the discussion as an expert in many things including production. 

Ray

> On Jul 29, 2015, at 12:26 AM, Nalini Elkins <[email-masked]> wrote:
> 
> Alice,
>

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 29 Jul 2015 13:05:02 +0000 (UTC)

Ray,
Videos are great.   Especially by those who have earned their stripes.  With our crew, that carries weight.
But, I am thinking that a small group setting where we watch a video and then have a discussion led by experienced people (mentors!) may be a good way to really digest the information.   I totally believe in videos but I do think that f2f discussion is really important also.  I am just thinking things over about how best to do mentoring.
Some of the comments I am making come from the fact that I sense frustration from the survey responses.   We have 83 responses to the survey so far & comments.   I will create interim results and then post them to the EDU team list.
Also wanted to get a sense from all of you as to if you feel that it is appropriate to make the survey responses public to all IETF.  I pretty much believe in being transparent so I am on the side of saying "yes" (unless a negative comment is made about a particular individual - which did not happen.)   But would love to hear what you all think. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Ray Pelletier <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Alice Russo <[email-masked]>; IETF edu Team <[email-masked]>; Scott O. Bradner <[email-masked]>; Dan York <[email-masked]> 
 Sent: Tuesday, July 28, 2015 10:25 PM
 Subject: Re: [edu-team] How to get a draft passed / How to be a good contributor
   
NaliniThe IETF is a meritocracy. Perhaps we might invite those who have earned their merit to talk about these various subjects, either individually or in groups. 
Each/they could be given a topic and no more than (15?) minutes per topic so the videos could be produced into consumable chunks. 
I added Dan York to the discussion as an expert in many things including production. 
Ray

Alice,

Thanks,
Alice

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Jul 2015 03:58:15 +1200

Commenting on the subject line...

"get a draft passed" is completely orthogonal to "be a good contributor".
We should focus on the second.

The best outcomes for a draft vary a lot:

- some drafts should die quickly. For the authors, dropping a bad idea
quickly is by far the best thing to do.

- some drafts are intended to serve only as discussion triggers.

- some drafts contain a good idea, but that idea would be better
added to an existing draft.

- some drafts are publishable but were submitted to the wrong WG,
or belong in the IRTF or the Independent stream.

- some drafts are accepted by the WG (at which point the authors
become servants of the WG).

A good contributor will accept any of these outcomes as valid.

Regards
   Brian

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 29 Jul 2015 16:42:43 +0000 (UTC)

The reason that I put "How to be a good contributor" in the title, is that on the Mentoring Survey, when asked the question "Why do you come to IETF?", the biggest category was "To contribute to drafts", followed closely by "To make progress on [my own] draft".
Of course, one can do both.
I was thinking that being a "good contributor" involves listening skills, getting and giving feedback & active involvement in a team.   I don't know that these fall into Mentoring - but I suspect they DO fall into EDU, if you agree. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Brian E Carpenter <[email-masked]>
 To: Nalini Elkins <[email-masked]>; EDU Team <[email-masked]> 
 Sent: Wednesday, July 29, 2015 8:58 AM
 Subject: Re: [edu-team] How to get a draft passed / How to be a good contributor

Regards
  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Jul 2015 19:08:24 +1200

Hi Nalini,

> The reason that I put "How to be a good contributor" in the title, is that on the Mentoring Survey, when asked the question "Why do you come to IETF?", the biggest category was "To contribute to dr…

I hear you. Of course, the IETF's main tangible output is RFCs so I suppose
we shouldn't be too surprised. But I have always found 'learning about future
technology trends' has always been very high on my personal list. That was true
during all three phases of my day-job career (deploying and operating stuff at
CERN, product development strategy at IBM, teaching at U of Auckland).

> I was thinking that being a "good contributor" involves listening skills, getting and giving feedback & active involvement in a team. 

Absolutely.

> I don't know that these fall into Mentoring - but I suspect they DO fall into EDU, if you agree. 

I would say that they fall into both. However, some aspects are generic rather than
specific to the IETF; we (neither mentors nor EDU) can substitute ourselves for
basic training.

Rgds
    Brian

---

From: Nalini Elkins <[email-masked]>
Date: Thu, 30 Jul 2015 13:40:17 +0000 (UTC)

>But I have always found 'learning about future technology trends' has always been very high on my personal list.  
That was also high.  But, I do not think that we need to do anything about that.

>I would say that they fall into both. However, some aspects are generic rather than specific to the IETF; we (neither mentors nor EDU) can substitute ourselves for basic training.
Yes.   But, specifically the way that feedback is given / gotten is somewhat unique to the IETF.  At a large corporation that I worked for which also worked by consensus (not rough!), they did a lot of work with us on personal skills.   Consensus is very good but it can be hard to pull off - easier, actually in engineering, if you pay attention to facts.   That is, if you can show that your technical solution actually works.
What would you guys think of the idea of small groups (10 or less) watching either the videos you put together or a presentation (doesn't matter too much), moderated by 2 -3 highly respected IETFers (mentors!)?   Followed by a discussion of what it all actually means.   I am thinking specifically of the "How to get a draft passed" set of topics.  Scott will have short videos that we can use soon hopefully.   Also think that attendance should be open to all - with priority given to people by number of meeting attended.

Rgds
    Brian