Subject: [edu-team] Intro To the Routing Area

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 19 Jul 2015 00:44:40 +0100

Provisional slides.

Jeff will be reviewing on Sunday morning.

Also happy to have any thoughts from you.

Apologies for tardiness, but in the immortal words of Elwood Blues: "What do you
want for nothing? A rubber biscuit?"

Adrian

---

From: Radia Perlman <[email-masked]>
Date: Sat, 18 Jul 2015 19:23:01 -0700

Looks really good!  I suppose I'd have wanted to give a little more
technical detail about what each things is (link state routing, BGP, MPLS,
LISP, ...).  Not packet formats, but so that someone outside the field
might know what they are technically.

Certainly when I do slides they aren't self-explanatory (without the person
talking about them), but there are sometimes things in your slides I don't
quite know what you mean.  For instance:

•Routes are either known in a distributed fashion
–Each router determines the next hop towards a destination from information
about the network and an algorithm
•Or they are known in a programmed way
–The whole route is pre-determined

I don't understand the above.

Do you mean that there is a distributed algorithm for computing the
forwarding table vs a centralized one?  That's not quite right, because in
either case, each router looks at their own forwarding table to make a
decision, so if the forwarding tables haven't changed, the route is
predetermined (other than path splitting of course).  Or do you mean MPLS
vs routing based on the IP header?  The only way I can imagine that the
whole route is pre-determined is if the actual route is in the header, and
I don't think we do anything like that.

So...just letting you know where you are confusing me.  If it's helpful to
hear details like that, I can find other examples.  Or if you think that
with the words, people will understand it, then that's fine.

Thanks,

Radia

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 19 Jul 2015 18:08:40 +1200

Looks pretty good to me.

(But I still don't know whether HNCP/DNCP should be reviewed as a routing protocol or not.)

Regards
   Brian

On 19/07/2015 11:44, Adrian Farrel wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Sun, 19 Jul 2015 10:38:37 +0200

Thanks, Adrian. Looks good. I uploaded the slides to the Edu Team wiki:

http://wiki.tools.ietf.org/group/edu/wiki/IETF93

They are also on the edu section of the datatracker.

And they will also show up here: http://www.ietf.org/edu/tutorials.html

Just in case people ask.

Regards,
Mirjam

On 19/7/15 01:44, Adrian Farrel wrote:
> This body part will be downloaded on demand.
>

---

From: Jeff Haas <[email-masked]>
Date: Sun, 19 Jul 2015 04:43:14 -0400

Brian,

One of the things that I expect to come up in the narrative portion of the presentation is why things cross into and out-of routing.  For example, state distribution is a core attribute of routing protocols, but there are things that aren't routing protocols that do state distribution.

I think we can all recognize this as things that either have moved in or out of the area or work that migrates across working groups depending on who has expertise on the internal component of a proposal over its lifetime.

Trying to capture the "controversy" as these things happen in slides would probably require its own deck.  So, best to just mention things that have some routing-like properties and then comment that this sort of thing happens.

-- Jeff

> On Jul 19, 2015, at 2:08 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Looks pretty good to me.
>

---

From: Jeff Haas <[email-masked]>
Date: Sun, 19 Jul 2015 04:47:25 -0400

Radia,

> On Jul 18, 2015, at 10:23 PM, Radia Perlman <[email-masked]> wrote:
> 
> Looks really good!  I suppose I'd have wanted to give a little more technical detail about what each things is (link state routing, BGP, MPLS, LISP, ...).  Not packet formats, but so that someone outside the field might know what they are technically.

The fact that Adrian came up with the deck in short time with far more history than I could is to be commended.  I only had about a third of this context from my own experience.  (The wisdom from being an AD, I suppose.)

The longer question is whether there is benefit to the edu team to expand the slides into a standalone tutorial for the wiki is probably the real question you're asking.  If that's something the edu team thinks is reasonable, we could consider that.  (And I could contribute there more than I could to the initial deck.)

> 
> Certainly when I do slides they aren't self-explanatory (without the person talking about them), but there are sometimes things in your slides I don't quite know what you mean.  For instance:
> 
> –Each router determines the next hop towards a destination from information about the network and an algorithm

The narrative would cover distribution via protocol where the protocol might do routing by rumor or distributed map, or via static configuration either via something like a CLI or an API - either in parts or in whole (SDN).

Obviously the points on this slide could cover its own extended topic.
> Do you mean that there is a distributed algorithm for computing the forwarding table vs a centralized one?  That's not quite right, because in either case, each router looks at their own forwarding table to make a decision, so if the forwarding tables haven't changed, the route is predetermined (other than path splitting of course).  Or do you mean MPLS vs routing based on the IP header?  The only way I can imagine that the whole route is pre-determined is if the actual route is in the header, and I don't think we do anything like that.
> 
> So...just letting you know where you are confusing me.  If it's helpful to hear details like that, I can find other examples.  Or if you think that with the words, people will understand it, then that's fine.

For this session, the slides are talking points and may not be 100% clear in a standalone fashion.

-- Jeff

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 19 Jul 2015 20:54:09 +1200

> Trying to capture the "controversy" as these things happen in slides would probably require its own deck.  So, best to just mention things that have some routing-like properties and then comment th…

Understood. Ultimately these things are judgment calls

    Brian

> .