Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 01 Jul 2015 09:38:23 +0200

Hi Evangelos, Hi Yaakov,

Can you please send us your draft slides for the Sunday tutorial as soon
as possible.

Just to let you know: the IESG raised some concerns about offering this
tutorial as part of the IETF tutorial series, so you can probably expect
some detailed feedback.

Kind regards,
Mirjam

On 13/5/15 17:36, Haleplidis Evangelos wrote:
> Greetings Mirjam,
> 
> Many thanks for getting this through.
> 
> Regards,
> Evangelos
> 
>> -----Original Message-----
>> From: Mirjam Kuehne [mailto:[email-masked]]
>> Sent: Wednesday, May 13, 2015 3:50 PM
>> To: Yaakov Stein; Evangelos Haleplidis
>> Cc: Brian E Carpenter; [email-masked]
>> Subject: Re: SDN OpenFlow and ForCES tutorial
>>
>> Thanks, Yaakov. I think this works.
>>
>> Mirjam
>>
>> On 13/5/15 14:45, Yaakov Stein wrote:
>>> That room should be fine.
>>>
>>> We sent the following outline in the past :
>>>
>>> 1. the ideas behind the recent awaking of SDN
>>> 2. how an SDN is different from a conventional (routed) network
>>> 3. the components and interfaces of an SDN (SDN (whitebox) switch,
>> SDN controller, SBI, NBI)
>>> 4. NFV
>>> 5. the southbound interfaces (OpenFlow, ForCES, ...)
>>> 5.1 zoom in on OpenFlow
>>> 5.2 zoom in on ForCES
>>>
>>> If you need a prose description, we could easily prepare one.
>>>
>>> Y(J)S
>>>
>>>
>>> -----Original Message-----
>>> From: Mirjam Kuehne [mailto:[email-masked]]
>>> Sent: 13/05/2015 15:37
>>> To: Evangelos Haleplidis; Yaakov Stein
>>> Cc: Brian E Carpenter; [email-masked]
>>> Subject: Re: SDN OpenFlow and ForCES tutorial
>>>
>>> Hi Evangelos, Hi Yaakov,
>>>
>>> The secretariat can give us a room for 100 people at 15:00 - 17:00. I
>> hope this is OK.
>>>
>>> I cannot remember if you already sent me a short description of the
>> tutorial for the web site. In that case, can you please re-send it.
>>>
>>> Thank you,
>>> Mirjam
>>>
>>> On 11/5/15 13:35, Evangelos Haleplidis wrote:
>>>> Greetings Mirjam and Yaakov,
>>>>
>>>> 15:00 is also fine by me!
>>>>
>>>> Regards,
>>>> Evangelos.
>>>>
>>>> On May 11, 2015 10:38 AM, "Yaakov Stein" <[email-masked]
>>>> <mailto:[email-masked]>> wrote:
>>>>
>>>>      15:00 is fine. I think we need 2 hours which means we would run
>>>>      until 17:00.
>>>>
>>>>      Y(J)S
>>>>
>>>>      -----Original Message-----
>>>>      From: Mirjam Kuehne [mailto:[email-masked] <mailto:[email-masked]>]
>>>>      Sent: 11/05/2015 10:34
>>>>      To: Yaakov Stein; Haleplidis Evangelos; [email-masked]
>>>>      <mailto:[email-masked]>
>>>>      Cc: 'Brian E Carpenter'
>>>>      Subject: Re: SDN OpenFlow and ForCES tutorial
>>>>
>>>>      Hi Yaakov, Hi Evangelos,
>>>>
>>>>      We're currently looking into the possibility to add a third
>> parallel
>>>>      tutorial and have it streamed. Would 15:00 work for you?
>>>>
>>>>      Regards,
>>>>      Mirjam
>>>>
>>>>      On 10/5/15 08:22, Yaakov Stein wrote:
>>>>       > Mirjam and Evangelos,
>>>>       >
>>>>       > I was out of contact while returning home from "UTC Telecom
>> and
>>>>       > Technology 2015" in Atlanta (packet switched networks are
>> still
>>>>      considered novel for electric utilities, but I am already
>> educating
>>>>      them on SDN and NFV).
>>>>       >
>>>>       > I am planning on attending Yokohama and Buenos Aires, but
>> will
>>>>      not be in Berlin.
>>>>       >
>>>>       > I too would prefer having the tutorial in Prague even if
>> there
>>>>      are fewer attendees.
>>>>       > We can always do it again if there is enough demand.
>>>>       >
>>>>       > Y(J)S
>>>>       >
>>>>       > -----Original Message-----
>>>>       > From: Haleplidis Evangelos [mailto:[email-masked]
>>>>      <mailto:[email-masked]>]
>>>>       > Sent: 08/05/2015 17:22
>>>>       > To: 'Mirjam Kuehne'; Yaakov Stein; [email-masked]
>>>>      <mailto:[email-masked]>
>>>>       > Cc: 'Brian E Carpenter'
>>>>       > Subject: RE: SDN OpenFlow and ForCES tutorial
>>>>       >
>>>>       > Greetings Mirjam,
>>>>       >
>>>>       > Thanks for the reply.
>>>>       >
>>>>       > I understand your concern, however it will high likely that
>> I
>>>>      will not be able to attend either Yokohama or Buenos Aires.
>>>>       > The earlier this tutorial (I'm speaking only for my part)
>> can
>>>>      happen is in a year's time in Berlin (assuming I'm in a
>> position to
>>>>      attend).
>>>>       >
>>>>       > So, if possible, I'd really appreciate if we could do the
>>>>      tutorial this time.
>>>>       >
>>>>       > Regards,
>>>>       > Evangelos.
>>>>       >
>>>>       >> -----Original Message-----
>>>>       >> From: Mirjam Kuehne [mailto:[email-masked]
>> <mailto:[email-masked]>]
>>>>       >> Sent: Friday, May 08, 2015 4:45 PM
>>>>       >> To: Yaakov Stein; [email-masked] <mailto:edu-
>> [email-masked]>
>>>>       >> Cc: Haleplidis Evangelos; Brian E Carpenter
>>>>       >> Subject: Re: SDN OpenFlow and ForCES tutorial
>>>>       >>
>>>>       >> Dear Yaakov,
>>>>       >>
>>>>       >> Thanks for letting us know, but I am afraid all tutorial
>> slots are
>>>>       >> full for IETF 93. And if we would add another tutorial, the
>>>>       >> attendance for each of them might be very low. That would
>> be a
>>>>      shame.
>>>>       >>
>>>>       >> Would it be ok if we schedule your tutorial for IETF 94 in
>> Yokohama?
>>>>       >>
>>>>       >> Kind regards,
>>>>       >> Mirjam
>>>>       >>
>>>>       >>
>>>>       >> On 5/5/15 11:55, Yaakov Stein wrote:
>>>>       >>> Edu team,
>>>>       >>>
>>>>       >>> Both Evangelos and I will be in Prague, and would be happy
>> to give
>>>>       >> the
>>>>       >>> SDN (OpenFlow and ForCES) tutorial that we had intended
>> giving in
>>>>       >> Honolulu.
>>>>       >>>
>>>>       >>>
>>>>       >>> Y(J)S
>>>>       >>>
>>>>       >>>
>>>>       >
>>>>
>>>
>

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 1 Jul 2015 12:11:28 +0000

Mirjam,

Evangelos and I plan on having a preliminary version early next week.

Can you give us some hint as to the nature of the IESG's concerns?
Is it related to OpenFlow being a non-IETF protocol,
or is more generally about the impact of SDN on the IP suite ?

I am sure that the IESG is aware of what is going on in the SDNRG and NFVRG.

Y(J)S

-----Original Message-----
From: Mirjam Kuehne [mailto:[email-masked]] 
Sent: 01/07/2015 10:38
To: Haleplidis Evangelos; Yaakov Stein
Cc: [email-masked]
Subject: Re: SDN OpenFlow and ForCES tutorial

Hi Evangelos, Hi Yaakov,

Can you please send us your draft slides for the Sunday tutorial as soon as possible.

Just to let you know: the IESG raised some concerns about offering this tutorial as part of the IETF tutorial series, so you can probably expect some detailed feedback.

Kind regards,
Mirjam

On 13/5/15 17:36, Haleplidis Evangelos wrote:
>>> 1. the ideas behind the recent awaking of SDN 2. how an SDN is 
>>> different from a conventional (routed) network 3. the components and 
>>> interfaces of an SDN (SDN (whitebox) switch,

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 01 Jul 2015 15:35:43 +0200

Hi Yaakov,

I believe the concerns are primarily related to the fact that it's not
an IETF protocol and that the tutorial is scheduled in parallel with the
Routing Area overview (which isn't your fault of course).

In any case, the routing ADs would like to review the slides and provide
you with some feedback, so the earlier you can send them the better.

Thank you,
Mirjam

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 1 Jul 2015 13:40:35 +0000

Mirjam, 

Actually, only a relatively minor portion of the tutorial will be about OpenFlow.
Most will be a general introduction to SDN and NFV, followed by a short discussion of OpenFlow, and then a similar treatment of ForCES.

Y(J)S

-----Original Message-----
From: Mirjam Kuehne [mailto:[email-masked]] 
Sent: 01/07/2015 16:36
To: Yaakov Stein; Haleplidis Evangelos
Cc: [email-masked]
Subject: Re: SDN OpenFlow and ForCES tutorial

Hi Yaakov,

I believe the concerns are primarily related to the fact that it's not an IETF protocol and that the tutorial is scheduled in parallel with the Routing Area overview (which isn't your fault of course).

In any case, the routing ADs would like to review the slides and provide you with some feedback, so the earlier you can send them the better.

Thank you,
Mirjam

On 1/7/15 14:11, Yaakov Stein wrote:
> Is it related to OpenFlow being a non-IETF protocol, or is more 
> generally about the impact of SDN on the IP suite ?
> 
>>>> different from a conventional (routed) network 3. the components 
>>>> and interfaces of an SDN (SDN (whitebox) switch,

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Jul 2015 08:38:05 +1200

Somebody also suggested mentioning i2rs, which is viewed as a form of SDN.

Regards
   Brian

On 02/07/2015 01:40, Yaakov Stein wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 10 Jul 2015 09:56:32 +0200

Hi Yaakov, Hi Evangelos,

How far are you with the slides? Can you please send us what you have so
we can review it.

Thanks,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Jul 2015 11:12:59 +1200

Have I missed these slides? No slides means no tutorial, I suppose?

Regards
   Brian

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 14 Jul 2015 05:34:57 +0000

Mirjam, 

Here are our preliminary slides (the order is SDNFV4IETF, OpenFlow4IETF, ForCES Tutorial).

We still need to do some merging, and to add some summaries.

Y(J)S

-----Original Message-----
From: Mirjam Kuehne [mailto:[email-masked]] 
Sent: 10/07/2015 10:57
To: Yaakov Stein; Haleplidis Evangelos
Cc: [email-masked]
Subject: Re: SDN OpenFlow and ForCES tutorial

Hi Yaakov, Hi Evangelos,

How far are you with the slides? Can you please send us what you have so we can review it.

Thanks,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2015 08:53:25 +1200

Hi,

Thanks. Here are my comments after a very quick review, since I will be on
travel from later today.

1. The SDN & NFV overview is very interesting. I will avoid giving my opinions,
but let's say that not everybody has drunk the SDN and NFV Kool-Aid. However,
I think the presentation is good and should lead to lively discussion. (I wish
I could attend, but I have other meetings on Sunday).

2. The other two presentations are both at least 10 times too long. They really
need to be reduced to about 5 slides each. As they stand, they simply cannot be
used within the time available (and allow for interaction and Q/A).

3. There was a specific request to include mention of I2RS. Actually a short
section on "Related activities in the IETF and IRTF" would be useful.

Regards
   Brian Carpenter

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 14 Jul 2015 22:20:45 +0000

I did not receive the slides - did I miss them, or were they sent only to Brian? Should not all presentations be distributed to all edu-team for review? And MUCH earlier. This is extremely late. 

Thanks and Regards,

Dan

> From: edu-team [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: Tuesday, July 14, 2015 11:53 PM
> To: Yaakov Stein; Mirjam Kuehne; Haleplidis Evangelos
> Cc: [email-masked]
> Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial
> 
> Hi,
> 
> but let's say that not everybody has drunk the SDN and NFV Kool-Aid.
> However, I think the presentation is good and should lead to lively
> discussion. (I wish I could attend, but I have other meetings on Sunday).
> 
> 2. The other two presentations are both at least 10 times too long. They
> really need to be reduced to about 5 slides each. As they stand, they simply
> cannot be used within the time available (and allow for interaction and Q/A).
> 
> >> Most will be a general introduction to SDN and NFV, followed by a short
> discussion of OpenFlow, and then a similar treatment of ForCES.
> >>
> >> Y(J)S
> >>
> >> I believe the concerns are primarily related to the fact that it's not an IETF
> protocol and that the tutorial is scheduled in parallel with the Routing Area
> overview (which isn't your fault of course).
> >>
> tutorial as part of the IETF tutorial series, so you can probably expect some
> detailed feedback.
> >>>
> >>> Kind regards,
> >>> Mirjam
> >>>
> >>>
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_edu-
> 2Dteam&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31O
> >
> cNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=9YvgmtRvjzJq1a91MrEsCdZ_tg0ic
> UPcVe
> > W-lfRTrwM&s=U5oV7Vt5I62-g0hxlRQeGOheH7GH9Qski1V8MR0DWuI&e=
> >
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_edu-
> 2Dteam&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQz
> vlsiLQfucBXRucPvdrphpBsFA&m=9YvgmtRvjzJq1a91MrEsCdZ_tg0icUPcVeW-
> lfRTrwM&s=U5oV7Vt5I62-g0hxlRQeGOheH7GH9Qski1V8MR0DWuI&e=

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Wed, 15 Jul 2015 01:31:01 +0300

Greetings Brian,

Thank you for the review.
In regards to your comments:

#2: We have split the whole presentation three parts. 1hour for the SDN & NFV overview and 1 hour for the OpenFlow/ForCES with OpenFlow occupying 20-25mins and ForCES the rest. We have discussed with Yaakov and we believe it is doable. We believe we'll have enough time for discussion, but we'll try to allocate more.

Just a quick question, how is an IETF tutorial structured in respect to discussion and interaction? Meaning in a tutorial session, should questions be deferred to the end, or questions can be asked any time? Or is this at the presenter's discretion? 

#3: Thank you for this comment. It's not possible to mention everything, but we'll try to see if we can incorporate such an SDN IETF/IRTF map into the presentation.

Regards,
Evangelos.

> From: Brian E Carpenter [mailto:[email-masked]]
> Thanks. Here are my comments after a very quick review, since I will be
> on travel from later today.
> 
> 1. The SDN & NFV overview is very interesting. I will avoid giving my
> opinions, but let's say that not everybody has drunk the SDN and NFV
> Kool-Aid. However, I think the presentation is good and should lead to
> lively discussion. (I wish I could attend, but I have other meetings on
> Sunday).
> 
> 2. The other two presentations are both at least 10 times too long.
> They really need to be reduced to about 5 slides each. As they stand,
> they simply cannot be used within the time available (and allow for
> interaction and Q/A).
> 
> 3. There was a specific request to include mention of I2RS. Actually a
> short section on "Related activities in the IETF and IRTF" would be
> useful.
> 
> Regards
>    Brian Carpenter
> 
> >> Most will be a general introduction to SDN and NFV, followed by a
> short discussion of OpenFlow, and then a similar treatment of ForCES.
> >>
> >> Y(J)S
> >>
> >> I believe the concerns are primarily related to the fact that it's
> not an IETF protocol and that the tutorial is scheduled in parallel
> with the Routing Area overview (which isn't your fault of course).
> >>
> >> In any case, the routing ADs would like to review the slides and
> provide you with some feedback, so the earlier you can send them the
> better.
> >>
> >> Thank you,
> >> Mirjam
> >>
> >>
> >>> Just to let you know: the IESG raised some concerns about offering
> this tutorial as part of the IETF tutorial series, so you can probably
> expect some detailed feedback.
> >>>
> >>> Kind regards,
> >>> Mirjam
> >>>
> >>>
> >>>>>> The secretariat can give us a room for 100 people at 15:00 -
> 17:00.
> >>>>>> I
> >>>>> hope this is OK.
> >>>>>>
> >>>>>>>       >> Would it be ok if we schedule your tutorial for IETF
> 94
> >>>>>>> in
> >>>>> Yokohama?
> >>>>>>>       >>
> >>>>>>>       >> Kind regards,
> >>>>>>>       >> Mirjam
> >>>>>>>       >>
> >>>>>>>       >>

---

From: Radia Perlman <[email-masked]>
Date: Tue, 14 Jul 2015 18:08:56 -0700

The slides were attached to one of the earlier emails, and sent to all of
edu.

Without looking at them in detail, I agree with Brian.  The SDN/NFV one is
conceptual and appropriate level.  The Forces one is wildly too detailed.
Perhaps it would be OK for a full day tutorial for people that need to
implement it, but certainly not appropriate for part of a 90 minute slot.
Likewise for the Openflow one.  You can point people to a spec if they need
details, or a reading list.

You can't take slides from a full day tutorial and try to talk faster, or
whittle them down for the slot available. (though admittedly, that's what
lots of people do...but it makes for a bad talk).  My advice to speakers on
how to be a good speaker is:
"given a topic you know something about, and a level of the audience, and
an amount of time, come up with an appropriate talk".

So...what can you explain to people who don't even know what the acronyms
mean, but just want to hear the concepts and how they fit in with other
IETF work...aren't about to implement it...in, say, 30 minutes (for each of
the topics)

Radia

On Tue, Jul 14, 2015 at 3:20 PM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> I did not receive the slides - did I miss them, or were they sent only to
> Brian? Should not all presentations be distributed to all edu-team for
> review? And MUCH earlier. This is extremely late.
>
> Thanks and Regards,
>
> Dan
>
>
> opinions,
> short
> > > Here are our preliminary slides (the order is SDNFV4IETF,
> OpenFlow4IETF,
> > ForCES Tutorial).
> > >
> > >> Actually, only a relatively minor portion of the tutorial will be
> about
> > OpenFlow.
> short
> not an IETF
> provide
> this
> some

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2015 13:27:35 +1200

On 15/07/2015 10:31, Haleplidis Evangelos wrote:
> #2: We have split the whole presentation three parts. 1hour for the SDN & NFV overview and 1 hour for the OpenFlow/ForCES with OpenFlow occupying 20-25mins and ForCES the rest. We have discussed with Yaakov and we believe it is doable. 

I think Radia has said what I think. When I was teaching, I knew I was in trouble
if I had more than 20 slides for a 50 minute lecture slot. You have one dense slide
per minute and that cannot be done (assuming you want the audience to follow
the material and learn from it).

> We believe we'll have enough time for discussion, but we'll try to allocate more.
> 

Your choice, but from my teaching experience, speaking for 100 minutes and then
inviting questions will really not work in terms of transferring knowledge.

> #3: Thank you for this comment. It's not possible to mention everything, but we'll try to see if we can incorporate such an SDN IETF/IRTF map into the presentation.

For an IETF tutorial intended to help people participate in the
IETF, that is pretty much essential.

Regards
   Brian
>> OpenFlow4IETF, ForCES Tutorial).
>>>
>> about OpenFlow.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 15 Jul 2015 01:56:11 +0000

I found the slides, they were sent earlier today 7/14, which is 5 days before the IETF meeting starts. This is way too late for a proper review. I am new to the edu-team, but having been on the other side, I remember we were asked to provide slides a few weeks in advance.

I agree with all the comments made by Brian and Radia about the number of slides and level of detail. I am also noticing that the SDN4IETF presentation is actually an SDN&NFV presentation. This is interesting, but is it within the announced scope?

Regards,

Dan

From: Radia Perlman [mailto:[email-masked]]
Sent: Wednesday, July 15, 2015 4:09 AM
To: Romascanu, Dan (Dan)
Cc: Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]
Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial

The slides were attached to one of the earlier emails, and sent to all of edu.

Without looking at them in detail, I agree with Brian.  The SDN/NFV one is conceptual and appropriate level.  The Forces one is wildly too detailed.  Perhaps it would be OK for a full day tutorial for people that need to implement it, but certainly not appropriate for part of a 90 minute slot.  Likewise for the Openflow one.  You can point people to a spec if they need details, or a reading list.

You can't take slides from a full day tutorial and try to talk faster, or whittle them down for the slot available. (though admittedly, that's what lots of people do...but it makes for a bad talk).  My advice to speakers on how to be a good speaker is:
"given a topic you know something about, and a level of the audience, and an amount of time, come up with an appropriate talk".

So...what can you explain to people who don't even know what the acronyms mean, but just want to hear the concepts and how they fit in with other IETF work...aren't about to implement it...in, say, 30 minutes (for each of the topics)

Radia

On Tue, Jul 14, 2015 at 3:20 PM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
I did not receive the slides - did I miss them, or were they sent only to Brian? Should not all presentations be distributed to all edu-team for review? And MUCH earlier. This is extremely late.

Thanks and Regards,

Dan

> From: edu-team [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian E
> Carpenter
> Cc: [email-masked]<mailto:[email-masked]>
> > From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
> > Sent: 10/07/2015 10:57
> > Cc: [email-masked]<mailto:[email-masked]>
> >> From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
> >> Sent: 01/07/2015 16:36
> >> Cc: [email-masked]<mailto:[email-masked]>
> >>> From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
> >>> Sent: 01/07/2015 10:38
> >>> Cc: [email-masked]<mailto:[email-masked]>
> >>>>> From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
> >>>>> Cc: Brian E Carpenter; [email-masked]<mailto:[email-masked]>
> >>>>>> From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
> >>>>>> Sent: 13/05/2015 15:37
> >>>>>> Cc: Brian E Carpenter; [email-masked]<mailto:[email-masked]>
> >>>>>>> On May 11, 2015 10:38 AM, "Yaakov Stein" <[email-masked]<mailto:[email-masked]>
> >>>>>>> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
> >>>>>>>
> >>>>>>>      From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>]
> >>>>>>>      Sent: 11/05/2015 10:34
> >>>>>>>      To: Yaakov Stein; Haleplidis Evangelos; [email-masked]<mailto:[email-masked]>
> >>>>>>>      <mailto:[email-masked]<mailto:[email-masked]>>
> >>>>>>>      Cc: 'Brian E Carpenter'
> >>>>>>>       > From: Haleplidis Evangelos [mailto:[email-masked]<mailto:[email-masked]>
> >>>>>>>      <mailto:[email-masked]<mailto:[email-masked]>>]
> >>>>>>>       > Sent: 08/05/2015 17:22
> >>>>>>>       > To: 'Mirjam Kuehne'; Yaakov Stein; [email-masked]<mailto:[email-masked]>
> >>>>>>>      <mailto:[email-masked]<mailto:[email-masked]>>
> >>>>>>>       > Cc: 'Brian E Carpenter'
> >>>>>>>       >> From: Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>
> >>>>> <mailto:[email-masked]<mailto:[email-masked]>>]
> >>>>>>>       >> To: Yaakov Stein; [email-masked]<mailto:[email-masked]> <mailto:edu-<mailto:edu->
> >>>>> [email-masked]<mailto:[email-masked]>>
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_edu-2Dteam&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=naIBziAtUhk4rAcSvqpqcWHjaUMisMvAHzI_HPCkTWA&s=cNHWSDPV3oqK0vW6RwuChbUpz7lxf92_f66EXzSsHSc&e=>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2015 14:05:08 +1200

(Presenters not in CC)

> I found the slides, they were sent earlier today 7/14, which is 5 days before the IETF meeting starts. This is way too late for a proper review. I am new to the edu-team, but having been on the oth…

Indeed. And they were certainly asked to provide them sooner.

> I agree with all the comments made by Brian and Radia about the number of slides and level of detail. I am also noticing that the SDN4IETF presentation is actually an SDN&NFV presentation. This is…

I think the slides make a good case for coupling the two issues, but indeed it
isn't what the presenters announced.

I don't know what to suggest. This is a volunteer effort, so the only sanction
would be to say "Sorry, if those are the slides, we must cancel the tutorial."
That seems very drastic, but I'm worried that participants will just end up more
confused than at the beginning.

   Brian

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 15 Jul 2015 02:10:40 +0000

> > I agree with all the comments made by Brian and Radia about the number
> of slides and level of detail. I am also noticing that the SDN4IETF presentation
> is actually an SDN&NFV presentation. This is interesting, but is it within the
> announced scope?
> 

I agree. 

> That seems very drastic, but I'm worried that participants will just end up
> more confused than at the beginning.
> 

I suggest that we involve the routing ADs in this discussion. 

My personal preference is for holding the tutorial while working with the authors to improve (as much as possible at this point in time) the material - but maybe having one of the ADs in the room for a possible introduction and/or conclusion can help putting things in context. 

Regards,

Dan

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2015 14:53:21 +1200

I will be caught in the taxi/hotel/airline universe 3 hours from now until
I surface in Prague on Friday night - I agree about the ADs but leave
you-all to follow up.

Regards
   Brian

---

From: Radia Perlman <[email-masked]>
Date: Tue, 14 Jul 2015 20:50:47 -0700

Another possibility rather than doing the drastic thing of cancelling it
(which leads to all sorts of questions, embarrasses the presenters, etc.)
is to have them only do the conceptual SDN/NFV one, and tell them not to
bother with the Forces or OpenFlow at all.

And in the future, I think we should not schedule a tutorial until we've
seen at least a draft of the slides.  I'd like to be way ahead, with an
unscheduled pool of tutorials.  Once scheduled, someone can continue
updating the slides...even when it's in limbo, they can give us updated
slides.  But we should have more than a title before we take up a tutorial
slot.

That being said, even if they droned through the slides as is, it wouldn't
be the worst Sunday tutorial that has been given, and there really is
little harm done...the attendees will have an air-conditioned place  to
read email.

But if there are too many bad tutorials, people will stop thinking of
Sunday tutorials as one of the highlights of IETF, and a reason to schedule
arriving early, and a place to learn about things outside the one thing
their company is sending them to IETF for.

Radia

On Tue, Jul 14, 2015 at 7:10 PM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> My personal preference is for holding the tutorial while working with the
> authors to improve (as much as possible at this point in time) the material
> - but maybe having one of the ADs in the room for a possible introduction
> and/or conclusion can help putting things in context.
>
> Regards,
>
> Dan
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 15 Jul 2015 04:18:17 +0000

All these are good proposals, and we may factor them in for the EDUNEXT session. Presenting at least an Abstract and/or outline is a basic requirement for the approval of any contribution to a technical or academic journal, or to industry workshops.

Regards,

Dan

From: Radia Perlman [mailto:[email-masked]]
Sent: Wednesday, July 15, 2015 6:51 AM
To: Romascanu, Dan (Dan)
Cc: Brian E Carpenter; Mirjam Kuehne; [email-masked]
Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial

Another possibility rather than doing the drastic thing of cancelling it (which leads to all sorts of questions, embarrasses the presenters, etc.) is to have them only do the conceptual SDN/NFV one, and tell them not to bother with the Forces or OpenFlow at all.

And in the future, I think we should not schedule a tutorial until we've seen at least a draft of the slides.  I'd like to be way ahead, with an unscheduled pool of tutorials.  Once scheduled, someone can continue updating the slides...even when it's in limbo, they can give us updated slides.  But we should have more than a title before we take up a tutorial slot.

That being said, even if they droned through the slides as is, it wouldn't be the worst Sunday tutorial that has been given, and there really is little harm done...the attendees will have an air-conditioned place  to read email.

But if there are too many bad tutorials, people will stop thinking of Sunday tutorials as one of the highlights of IETF, and a reason to schedule arriving early, and a place to learn about things outside the one thing their company is sending them to IETF for.

Radia

On Tue, Jul 14, 2015 at 7:10 PM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:

> From: Brian E Carpenter [mailto:[email-masked]<mailto:[email-masked]>]

I agree.

Regards,

Dan

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 15 Jul 2015 04:44:03 +0000

Dan

Yes, the intent from the beginning was to give a short overview of both SDN and NFV for people who are not following the subjects.
The two subjects are so intertwined (as I think I demonstrate in my slides) that we often see people saying SDN when they mean NFV and vice versa.

I can only speak for my slides on OpenFlow, but I have done this set in 15 minutes, and we allocate more than that here.
Note that slides like the one with a lists of mandatory and optional-to-support fields are included for people to use as a reference later on.
While presenting I say “here are the fields defined by the spec” and move to the next slide.

I apologize for not having sent these slides earlier.
I sent the base set on which this presentation is based (a half-day course) about 4 months ago.
This set is shortened and modified to match the background I expect from someone attending the IETF.

Brian

Yes, the intention is to arouse discussion.
The approach is my take on the important aspects of what the academics in the SDN field think.
I have removed a lot of the silly stuff, and their claims that are just wrong.
I don’t agree with everything, and in fact have a 2-hour rebuttal talk to this approach
which I believe to be more interesting than this talk, but of course requires hearing this one first.

Y(J)S

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: 15/07/2015 04:56
To: Radia Perlman
Cc: Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]
Subject: RE: [edu-team] SDN OpenFlow and ForCES tutorial

Regards,

Dan

From: Radia Perlman [mailto:[email-masked]]
Sent: Wednesday, July 15, 2015 4:09 AM
To: Romascanu, Dan (Dan)
Cc: Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]<mailto:[email-masked]>
Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial

Radia

Thanks and Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 15 Jul 2015 05:51:51 +0000

Hi Yaakov,

Actually I believe that having profiled the tutorial the way you describe it would be a more interesting path. Maybe it’s not too late to focus the presentation on the architectural principles and the different paths taken by the two approaches in implementations, without entering onto the protocol details. I personally would have renounced even to the ‘here are the protocol fields’ slides, maybe just provide a list of references.

Thanks and Regards,

Dan

From: Yaakov Stein [mailto:[email-masked]]
Sent: Wednesday, July 15, 2015 7:44 AM
To: Romascanu, Dan (Dan); Radia Perlman
Cc: Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]
Subject: RE: [edu-team] SDN OpenFlow and ForCES tutorial

Dan

Brian

Y(J)S

Regards,

Dan

Radia

Thanks and Regards,

Dan

---

From: Radia Perlman <[email-masked]>
Date: Wed, 15 Jul 2015 01:12:14 -0700

Wow, an overview with cheerful rebuttal, at a very high level (so it fits
in the time, and doesn't go over the heads of people that aren't already
immersed in this) sounds really interesting.  Could they co-present?
 (cheerfully...)

It shouldn't need a 2-hour rebuttal, or a 2-hour presentation, to be
conceptual.  Could both points of view fit within the time?

Radia

On Tue, Jul 14, 2015 at 9:44 PM, Yaakov Stein <[email-masked]> wrote:

>  Dan
>
>
>
> Yes, the intent from the beginning was to give a short overview of both
> SDN and NFV for people who are not following the subjects.
>
> The two subjects are so intertwined (as I think I demonstrate in my
> slides) that we often see people saying SDN when they mean NFV and vice
> versa.
>
>
>
> I can only speak for my slides on OpenFlow, but I have done this set in 15
> minutes, and we allocate more than that here.
>
> Note that slides like the one with a lists of mandatory and
> optional-to-support fields are included for people to use as a reference
> later on.
>
> *From:* Romascanu, Dan (Dan) [mailto:[email-masked]]
> *Sent:* 15/07/2015 04:56
> *To:* Radia Perlman
> *Cc:* Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis
> Evangelos; [email-masked]
> *Subject:* RE: [edu-team] SDN OpenFlow and ForCES tutorial
>
>
>
> I found the slides, they were sent earlier today 7/14, which is 5 days
> before the IETF meeting starts. This is way too late for a proper review. I
> am new to the edu-team, but having been on the other side, I remember we
> were asked to provide slides a few weeks in advance.
>
>
>
> I agree with all the comments made by Brian and Radia about the number of
> slides and level of detail. I am also noticing that the SDN4IETF
> presentation is actually an SDN&NFV presentation. This is interesting, but
> is it within the announced scope?
>
>
>
> Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Radia Perlman [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Wednesday, July 15, 2015 4:09 AM
> *To:* Romascanu, Dan (Dan)
> *Cc:* Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis
> Evangelos; [email-masked]
> *Subject:* Re: [edu-team] SDN OpenFlow and ForCES tutorial
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_edu-2Dteam&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=naIBziAtUhk4rAcSvqpqcWHjaUMisMvAHzI_HPCkTWA&s=cNHWSDPV3oqK0vW6RwuChbUpz7lxf92_f66EXzSsHSc&e=>
>
>
>

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 15 Jul 2015 08:55:37 +0000

I don’t think that I could fit both in.
In my original slides there was a final section called “doubts and hype”,
but I removed it as it wouldn’t fit into the one hour allotted for the intro part.

Of course, during the presentation I could make some cheerfully snide remarks ☺

Y(J)S

From: Radia Perlman [mailto:[email-masked]]
Sent: 15/07/2015 11:12
To: Yaakov Stein
Cc: Romascanu, Dan (Dan); Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]
Subject: Re: [edu-team] SDN OpenFlow and ForCES tutorial

Wow, an overview with cheerful rebuttal, at a very high level (so it fits in the time, and doesn't go over the heads of people that aren't already immersed in this) sounds really interesting.  Could they co-present?  (cheerfully...)

It shouldn't need a 2-hour rebuttal, or a 2-hour presentation, to be conceptual.  Could both points of view fit within the time?

Radia

On Tue, Jul 14, 2015 at 9:44 PM, Yaakov Stein <[email-masked]<mailto:[email-masked]>> wrote:
Dan

Brian

Y(J)S

From: Romascanu, Dan (Dan) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 15/07/2015 04:56
To: Radia Perlman
Cc: Brian E Carpenter; Yaakov Stein; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]<mailto:[email-masked]>
Subject: RE: [edu-team] SDN OpenFlow and ForCES tutorial

Regards,

Dan

Radia

Thanks and Regards,

Dan

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Wed, 15 Jul 2015 14:22:51 +0300

Greetings Radia,

Thank you for the review. Just speaking about the ForCES Part.

As I have done a couple of SDN/ForCES tutorials, you’re right, to properly introduce ForCES needs at least a full day (with hands-on as well).

However, while I agree that there are some details in the slides, I tried to put only the essential ones in order to grasp the concepts (without missing something really important). There are a couple of slides that I’m going to pass over very quickly. The concept, similar to Yaakov’s, is to stick to the main concepts of ForCES, and some of the details can be later be seen within the slides for those interested. The slides (currently 29 (with fine tuning) with at least  5-10 that will be passed quickly, is doable with the time frame (of 30-40 minutes) to provide a very basic idea of what ForCES is and how it operates.

The concept, was to first introduce a prominent IETF’s SDN control plane southbound protocol.

Regards,

Evangelos.

Radia

On Tue, Jul 14, 2015 at 3:20 PM, Romascanu, Dan (Dan) <[email-masked]> wrote:

Thanks and Regards,

Dan

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 15 Jul 2015 13:41:15 +0000

Dan - Sorry, I missed this email and answered a later one first.

I think it is too late to completely eliminate the protocol section.
One of the original drivers for this tutorial was to compare OpenFlow and ForCES,
and to summarize ForCES for those who did not take part in the WG.

In any case this time we are limited to a room for 100 people, which I am assuming will be too small to accommodate everyone who may be interested.
So, if there is indeed interest, we can do this again with a modified format.

If we DO do this again, I would love to explain what is wrong with the academic rant against control distributed protocols,
but what the IETF could constructively learn from their opinion.
And I would certainly explain what the CAP theorem tells us about conventional networks as opposed to SDN networks;
I believe that “CAP tradeoff” analysis objectively contrasts the two approaches to networking.

Y(J)S

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: 15/07/2015 08:52
To: Yaakov Stein; Radia Perlman
Cc: Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]
Subject: RE: [edu-team] SDN OpenFlow and ForCES tutorial

Hi Yaakov,

Thanks and Regards,

Dan

Cc: Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos; [email-masked]<mailto:[email-masked]>

Dan

Brian

Y(J)S

Regards,

Dan

Radia

Thanks and Regards,

Dan

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 16 Jul 2015 16:23:24 +0200

[taken authors off the list for now].

Sorry, I was off line for a couple of days and just went though all the
mails on this topic.

It sounds like there was agreement to let this tutorial go ahead.

Dan suggested to invite the ADs so it could be improved for a potential
future version-2 of this tutorial? Since the entire IESG ws involved in
this discussion at an earlier stage, I would assume that the ADs would
try to be there. But do you want to make sure, Dan?

It would be unfortunate if we provide a sub-optimal tutorial just before
the EDUNEXT BoF. On the other hand this could give us good food for
discussion during the BoF.

I'll try to upload the slides to the wiki and the Tutorial pages before
Sunday.

Anything else we need to do at this stage?

Mirjam

On 15/7/15 15:41, Yaakov Stein wrote:
> In any case this time we are limited to a room for 100 people, which I
> am assuming will be too small to accommodate everyone who may be interested.
> 
> If we DO do this again, I would love to explain what is wrong with the
> academic rant against control distributed protocols,
> 
> And I would certainly explain what the CAP theorem tells us about
> conventional networks as opposed to SDN networks;
> 
> *From:*Romascanu, Dan (Dan) [mailto:[email-masked]]
> *Sent:* 15/07/2015 08:52
> *To:* Yaakov Stein; Radia Perlman
> *Cc:* Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos;
> [email-masked]
> Actually I believe that having profiled the tutorial the way you
> describe it would be a more interesting path. Maybe it’s not too late to
> focus the presentation on the architectural principles and the different
> paths taken by the two approaches in implementations, without entering
> onto the protocol details. I personally would have renounced even to the
> ‘here are the protocol fields’ slides, maybe just provide a list of
> references.
> 
>  
> 
> Thanks and Regards,
> 
>  
> 
> Dan
> 
>  
> 
>  
> 
> *From:*Yaakov Stein [mailto:[email-masked]]
> *Sent:* Wednesday, July 15, 2015 7:44 AM
> *To:* Romascanu, Dan (Dan); Radia Perlman
> *Cc:* Brian E Carpenter; Mirjam Kuehne; Haleplidis Evangelos;
> [email-masked] <mailto:[email-masked]>
> I can only speak for my slides on OpenFlow, but I have done this set in
> 15 minutes, and we allocate more than that here.
> 
> *From:*Romascanu, Dan (Dan) [mailto:[email-masked]]
> *Sent:* 15/07/2015 04:56
> *To:* Radia Perlman
> Evangelos; [email-masked] <mailto:[email-masked]>
> before the IETF meeting starts. This is way too late for a proper
> review. I am new to the edu-team, but having been on the other side, I
> remember we were asked to provide slides a few weeks in advance.
> 
>  
> 
> of slides and level of detail. I am also noticing that the SDN4IETF
> presentation is actually an SDN&NFV presentation. This is interesting,
> but is it within the announced scope?
> 
>  
> 
> Regards,
> 
>  
> 
> Dan
> 
>  
> 
>  
> 
> *From:*Radia Perlman [mailto:[email-masked]]
> Evangelos; [email-masked] <mailto:[email-masked]>
> Without looking at them in detail, I agree with Brian.  The SDN/NFV one
> is conceptual and appropriate level.  The Forces one is wildly too
> detailed.  Perhaps it would be OK for a full day tutorial for people
> that need to implement it, but certainly not appropriate for part of a
> 90 minute slot.  Likewise for the Openflow one.  You can point people to
> a spec if they need details, or a reading list.  
> 
>  
> 
> You can't take slides from a full day tutorial and try to talk faster,
> or whittle them down for the slot available. (though admittedly, that's
> what lots of people do...but it makes for a bad talk).  My advice to
> speakers on how to be a good speaker is:
> 
> "given a topic you know something about, and a level of the audience,
> and an amount of time, come up with an appropriate talk".
> 
>  
> 
> So...what can you explain to people who don't even know what the
> acronyms mean, but just want to hear the concepts and how they fit in
> with other IETF work...aren't about to implement it...in, say, 30
> minutes (for each of the topics)
> 
>  
> 
> Radia
> 
>  
> 
> On Tue, Jul 14, 2015 at 3:20 PM, Romascanu, Dan (Dan)
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I did not receive the slides - did I miss them, or were they sent only
> to Brian? Should not all presentations be distributed to all edu-team
> for review? And MUCH earlier. This is extremely late.
> 
> Thanks and Regards,
> 
> Dan
> 
> 
>> From: edu-team [mailto:[email-masked]
> <mailto:[email-masked]>] On Behalf Of Brian E
>> Carpenter
>> Cc: [email-masked] <mailto:[email-masked]>
> 
>> > Cc: [email-masked] <mailto:[email-masked]>
>> >> Cc: [email-masked] <mailto:[email-masked]>
>> >>> Cc: [email-masked] <mailto:[email-masked]>
>> >>>>> Cc: Brian E Carpenter; [email-masked] <mailto:[email-masked]>
>> >>>>>> Cc: Brian E Carpenter; [email-masked] <mailto:[email-masked]>
> <mailto:[email-masked]>
>> >>>>>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>> >>>>>>>
> <mailto:[email-masked]>
>> <mailto:[email-masked] <mailto:[email-masked]>>]
>> >>>>>>>      Sent: 11/05/2015 10:34
>> >>>>>>>      <mailto:[email-masked] <mailto:[email-masked]>>
>> >>>>>>>      Cc: 'Brian E Carpenter'
> <mailto:[email-masked]>
>> >>>>>>>      <mailto:[email-masked] <mailto:[email-masked]>>]
>> >>>>>>>       > Sent: 08/05/2015 17:22
>> >>>>>>>      <mailto:[email-masked] <mailto:[email-masked]>>
>> >>>>>>>       > Cc: 'Brian E Carpenter'
> <mailto:[email-masked]>
>> >>>>> <mailto:[email-masked] <mailto:[email-masked]>>]
>> >>>>>>>       >> To: Yaakov Stein; [email-masked]
> <mailto:[email-masked]> <mailto:edu- <mailto:edu->
>> >>>>> [email-masked] <mailto:[email-masked]>>
>> > [email-masked] <mailto:[email-masked]>
> 
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 16 Jul 2015 21:15:49 +0000

I believe that we would like to make sure that at least one of the routing ADs is in the room. 

Regards,

Dan

> Since the entire IESG ws involved in this discussion
> at an earlier stage, I would assume that the ADs would try to be there. But do
> you want to make sure, Dan?
>