Subject: Re: [edu-team] Tutorial for SDN OpenFlow and ForCES

From: Benoit Claise <[email-masked]>
Date: Wed, 1 Jul 2015 15:12:55 +0200

Radia,

Thanks for the long explanation.
I'm with you wrt "So maybe we should just take this as a lesson for the 
future".
At this point, I'm not in favor of canceling this tutorial 3 weeks 
before the IETF meeting. This would generate more unnecessary 
discussions. However, I believe that the routing ADs should be quickly 
reviewing the slides.

Regards, Benoit

> I thought this tutorial would be OK because I thought enough people 
> would likely be interested.  I didn't think holding a tutorial  means 
> an endorsement.  I wasn't wild about this one...I forget who was 
> pushing it--certainly not me, but I tend to prefer to err on the side 
> of allowing tutorials rather than excluding them...what's the harm, 
> really...for instance, edu invited the IEEE shortest path bridging 
> (SPB) people to do a tutorial.  Not only is SPB not an IETF 
> technology, but it is (not coincidentally, since it's copied the 
> design) conceptually the same as TRILL, which IS an IETF technology. 
> Nobody on IESG complained about that tutorial.
>
>  I think tutorials should be about concepts rather than packet 
> formats...that is what specs are for...I think tutorials are for 
> introducing technology concepts to people somewhat outside the area).  
> So I think when there are competing stardards doing basically the same 
> thing, I'd prefer the tutorial to cover the concepts, and mention 
> variations of the concepts used in different standards, and perhaps 
> why there are multiple standards, and how they fit together or compete.
>
> It's hard enough to have good tutorials...ideally Sunday tutorials 
> will be something people will look forward to, and plan travel 
> accordingly, as a place to learn stuff, especially outside their 
> area.  It's hard to have good speakers, it's hard to make sure they 
> actually show up.  It's hard to ensure that they are not being 
> political rather than technical.
>
> I think that the IESG should be on the edu mailing list (unless they 
> opt out), so they can raise political issues...."that person is 
> volunteering to give a tutorial because what's really going on is...", 
> as well as technical ones "it seems people are really confused about 
> what .xxx means...could we have a tutorial perhaps?", as well as 
> suggest good topics and speakers.
>
> Perhaps because the IESG was not on the mailing list, we could cancel 
> this tutorial, or substitue another one, if people are reallyagainst 
> it.  Attendees are used to schedules changing, and I don't think any 
> of them would be traumatized if we cancelled this.  It could be the 
> speaker would be upset about being invited and then uninvited--so I'd 
> be inclined not to cancel at this point.  So maybe we should just take 
> this as a lesson for the future, and we can be more explicit about 
> what tutorials to allow and disallow in the future.
>
> Radia
>
>
> On Tue, Jun 30, 2015 at 4:00 PM, Brian E Carpenter 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi Alia,
>
>     On 01/07/2015 08:28, Alia Atlas wrote:
>     > On Tue, Jun 30, 2015 at 4:26 PM, Brian E Carpenter <
>     > [email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     >> On 01/07/2015 03:15, Brian Haberman wrote:
>     >>> Hi Brian,
>     >>>
>     >>> On 6/29/15 4:10 PM, Brian E Carpenter wrote:
>     >>>
>     >>>>>> On Mon, Jun 29, 2015 at 8:41 AM, Brian Haberman <
>     >> [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>>>>>
>     >>>>>>     I am with Deborah on this. Who is doing this overview
>     and why?
>     >> The
>     >>>>>>     current liaison statement we have with the ONF seems to
>     be clear
>     >> that
>     >>>>>>     the IETF shouldn't be doing this.
>     >>>>
>     >>>> Huh? That we shouldn't be doing a Sunday tutorial?? The
>     purpose is
>     >>>> educational and says nothing about what the IETF should or
>     shouldn't
>     >>>> be working on. In fact it would be very odd *not* to cover
>     related
>     >>>> work in other SDOs.
>     >>>>
>     >>>
>     >>> The IESG discussed the liaison when it came in and I was left
>     with the
>     >>> impression that we needed to avoid even the appearance of the IETF
>     >>> treading into the ONF domain.  I agree that long-time IETF
>     participants
>     >>> understand the insignificance of Sunday tutorials on actual
>     IETF work.
>     >>> It is not clear if external bodies (of any make or model)
>     understand
>     >>> that separation.
>     >>
>     >> I can see that, but it would easy enough to explain if the
>     question arose.
>     >> This might be a talking point at the WG Chairs Lunch in Prague:
>     >> "Topic: Other Standards Development Organizations (Scott Mansfield,
>     >> Ralph Droms, Suzanne Woolf)"
>     >>
>     >
>     > You are assuming good will and good assumptions of the other
>     organization
>     > on both sides.  My impression for part of why ONF exists as a
>     separate
>     > entity is that this isn't the case.
>     >
>     > I'm concerned that this is sensitive - both in stepping on the
>     ONF's shoes
>
>     If they object to their work being mentioned as one item in a
>     90 minute tutorial, they have remarkably sensitive toes.
>
>     > and in potentially providing legitimacy towards OpenFlow.
>
>     As far as that goes, their legitimacy would come from running
>     code and traffic volume, wouldn't it? But certainly the slides
>     need to be objective and neutral.
>
>     Mirjam, can you ask for the draft slides ASAP?
>
>     Regards,
>          Brian
>     >
>     >  Regards,
>     > Alia
>     >
>     >
>     >
>     >> Rgds
>     >>    Brian C
>     >>
>     >
>
>     _______________________________________________
>     edu-team mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/edu-team
>
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 01 Jul 2015 15:37:18 +0200

Hi,

> discussions. However, I believe that the routing ADs should be quickly

Yaakov promised to send us a preliminary version early next week. I will
then pass them on for review.

Regards,
Mirjam

> [email-masked]

---

From: Radia Perlman <[email-masked]>
Date: Wed, 1 Jul 2015 08:06:52 -0700

It would also help if we could plan potential topics and speakers well into
the future...have a list of at least 20 "wish list" topics that we develop,
plus an open solicitation for volunteers to suggest tutorials they'd like
to see, or tutorials they'd like to present.  Otherwise, edu and IESG
scramble at the last minute to think of what their friends might be able to
put together for the next IETF.  The "potential future tutorials" lists
wouldn't be scheduled for specific IETFs, but it would be the pool from
which we could choose a nice complementary set of tutorials for the next
IETF.

I also am quite in favor of openness, in terms of allowing anyone who is
enthusiastic to suggest topics or volunteer.  We don't have to just allow
an unknown person to present based on topic...we could ask them to do
slides first and let us review it before putting in on the agenda for any
IETF.  We could even let them present it to us over a conference call as
sort of an audition.  And it doesn't have to be yes/no.  It could be we
could help them improve it.  If their English is too bad, then sadly, we
probably don't want to have them present a 90 minute tutorial.  If it's
just packet formats rather than concepts, or just too full of jargon for
anyone outside that WG to understand it, maybe we could help them improve
it.

I'm always enthusiastic about helping people improve their presentation,
help listeners learn things, as well as helping people who feel they aren't
in the in-crowd get opportunities for involvement and exposure,

Radia

On Wed, Jul 1, 2015 at 6:12 AM, Benoit Claise <[email-masked]> wrote:

> At this point, I'm not in favor of canceling this tutorial 3 weeks before
> the IETF meeting. This would generate more unnecessary discussions.
> However, I believe that the routing ADs should be quickly reviewing the
> slides.
>
> Regards, Benoit
>
> would likely be interested.  I didn't think holding a tutorial  means an
> endorsement.  I wasn't wild about this one...I forget who was pushing
> it--certainly not me, but I tend to prefer to err on the side of allowing
> tutorials rather than excluding them...what's the harm, really...for
> instance, edu invited the IEEE shortest path bridging (SPB) people to do a
> tutorial.  Not only is SPB not an IETF technology, but it is (not
> coincidentally, since it's copied the design) conceptually the same as
> TRILL, which IS an IETF technology. Nobody on IESG complained about that
> tutorial.
>
> introducing technology concepts to people somewhat outside the area).  So I
> think when there are competing stardards doing basically the same thing,
> I'd prefer the tutorial to cover the concepts, and mention variations of
> the concepts used in different standards, and perhaps why there are
> multiple standards, and how they fit together or compete.
>
>  It's hard enough to have good tutorials...ideally Sunday tutorials will
> be something people will look forward to, and plan travel accordingly, as a
> place to learn stuff, especially outside their area.  It's hard to have
> good speakers, it's hard to make sure they actually show up.  It's hard to
> ensure that they are not being political rather than technical.
>
>  I think that the IESG should be on the edu mailing list (unless they opt
> out), so they can raise political issues...."that person is volunteering to
> give a tutorial because what's really going on is...", as well as technical
> ones "it seems people are really confused about what .xxx means...could we
> have a tutorial perhaps?", as well as suggest good topics and speakers.
>
> this tutorial, or substitue another one, if people are reallyagainst it.
> Attendees are used to schedules changing, and I don't think any of them
> would be traumatized if we cancelled this.  It could be the speaker would
> be upset about being invited and then uninvited--so I'd be inclined not to
> cancel at this point.  So maybe we should just take this as a lesson for
> the future, and we can be more explicit about what tutorials to allow and
> disallow in the future.
>
>  Radia
>
>
>
> On Tue, Jun 30, 2015 at 4:00 PM, Brian E Carpenter <
> [email-masked]> wrote:
>
>> Hi Alia,
>>
>> > [email-masked]> wrote:
>> >
>> >> [email-masked] <mailto:[email-masked]>> wrote:
>> >>>>>>
>> >>>>>>     I am with Deborah on this.  Who is doing this overview and why?
>> >> The
>> >>>>>>     current liaison statement we have with the ONF seems to be
>> clear
>> >> that
>> >>>> Huh? That we shouldn't be doing a Sunday tutorial?? The purpose is
>> >>>> educational and says nothing about what the IETF should or shouldn't
>> >>>> be working on. In fact it would be very odd *not* to cover related
>> >>>> work in other SDOs.
>> >>>>
>> >>>
>> >>> The IESG discussed the liaison when it came in and I was left with the
>> >>> understand the insignificance of Sunday tutorials on actual IETF work.
>> >>> It is not clear if external bodies (of any make or model) understand
>> >>> that separation.
>> >>
>> >> I can see that, but it would easy enough to explain if the question
>> arose.
>> > on both sides.  My impression for part of why ONF exists as a separate
>> > I'm concerned that this is sensitive - both in stepping on the ONF's
>> shoes
>>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 2 Jul 2015 07:08:04 +0000

Hi,

See in-line.

Regards,

Dan

From: edu-team [mailto:[email-masked]] On Behalf Of Radia Perlman
Sent: Wednesday, July 01, 2015 6:07 PM
To: Benoit Claise
Cc: Brian Haberman; BRUNGARD, DEBORAH A; Alia Atlas; IESG IESG; EDU Team
Subject: Re: [edu-team] Tutorial for SDN OpenFlow and ForCES

It would also help if we could plan potential topics and speakers well into the future...have a list of at least 20 "wish list" topics that we develop, plus an open solicitation for volunteers to suggest tutorials they'd like to see, or tutorials they'd like to present.  Otherwise, edu and IESG scramble at the last minute to think of what their friends might be able to put together for the next IETF.  The "potential future tutorials" lists wouldn't be scheduled for specific IETFs, but it would be the pool from which we could choose a nice complementary set of tutorials for the next IETF.

DR – yes, this would be a good way to manage the future pool of themes. I *thought* that we do have already such a list, but in case this is not true, let us start building it.

I also am quite in favor of openness, in terms of allowing anyone who is enthusiastic to suggest topics or volunteer.  We don't have to just allow an unknown person to present based on topic...we could ask them to do slides first and let us review it before putting in on the agenda for any IETF.  We could even let them present it to us over a conference call as sort of an audition.  And it doesn't have to be yes/no.  It could be we could help them improve it.  If their English is too bad, then sadly, we probably don't want to have them present a 90 minute tutorial.  If it's just packet formats rather than concepts, or just too full of jargon for anyone outside that WG to understand it, maybe we could help them improve it.

DR – yes, but I would be careful about keeping a certain level of quality and some consistency. I believe that this is the responsibility of the edu team. Maybe start with a tutorial about running tutorials.

I'm always enthusiastic about helping people improve their presentation, help listeners learn things, as well as helping people who feel they aren't in the in-crowd get opportunities for involvement and exposure,

Radia

On Wed, Jul 1, 2015 at 6:12 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Radia,

Thanks for the long explanation.
I'm with you wrt "So maybe we should just take this as a lesson for the future".
At this point, I'm not in favor of canceling this tutorial 3 weeks before the IETF meeting. This would generate more unnecessary discussions. However, I believe that the routing ADs should be quickly reviewing the slides.

Regards, Benoit
I thought this tutorial would be OK because I thought enough people would likely be interested.  I didn't think holding a tutorial  means an endorsement.  I wasn't wild about this one...I forget who was pushing it--certainly not me, but I tend to prefer to err on the side of allowing tutorials rather than excluding them...what's the harm, really...for instance, edu invited the IEEE shortest path bridging (SPB) people to do a tutorial.  Not only is SPB not an IETF technology, but it is (not coincidentally, since it's copied the design) conceptually the same as TRILL, which IS an IETF technology. Nobody on IESG complained about that tutorial.

 I think tutorials should be about concepts rather than packet formats...that is what specs are for...I think tutorials are for introducing technology concepts to people somewhat outside the area).  So I think when there are competing stardards doing basically the same thing, I'd prefer the tutorial to cover the concepts, and mention variations of the concepts used in different standards, and perhaps why there are multiple standards, and how they fit together or compete.

It's hard enough to have good tutorials...ideally Sunday tutorials will be something people will look forward to, and plan travel accordingly, as a place to learn stuff, especially outside their area.  It's hard to have good speakers, it's hard to make sure they actually show up.  It's hard to ensure that they are not being political rather than technical.

I think that the IESG should be on the edu mailing list (unless they opt out), so they can raise political issues...."that person is volunteering to give a tutorial because what's really going on is...", as well as technical ones "it seems people are really confused about what .xxx means...could we have a tutorial perhaps?", as well as suggest good topics and speakers.

Perhaps because the IESG was not on the mailing list, we could cancel this tutorial, or substitue another one, if people are reallyagainst it.  Attendees are used to schedules changing, and I don't think any of them would be traumatized if we cancelled this.  It could be the speaker would be upset about being invited and then uninvited--so I'd be inclined not to cancel at this point.  So maybe we should just take this as a lesson for the future, and we can be more explicit about what tutorials to allow and disallow in the future.

Radia

On Tue, Jun 30, 2015 at 4:00 PM, Brian E Carpenter <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alia,

On 01/07/2015 08:28, Alia Atlas wrote:
> [email-masked]<mailto:[email-masked]>> wrote:
>
>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>>>>>
>>>>>>     current liaison statement we have with the ONF seems to be clear
>> that
>>> treading into the ONF domain.  I agree that long-time IETF participants
>> I can see that, but it would easy enough to explain if the question arose.
> You are assuming good will and good assumptions of the other organization
> I'm concerned that this is sensitive - both in stepping on the ONF's shoes

Regards,
     Brian
_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_edu-2Dteam&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=Q_QNRjTZkpsI0aHIs2HlsJPEPkhGZCFAgsi-KcjrMOk&s=QNUDkufj9kLl6qRlqb1V43oRihW0mkXGPcK_0GfwuSg&e=>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 2 Jul 2015 07:12:43 +0000

Can’t we avoid this scheduling conflict? If we move the SDN tutorial to the earlier (1300 – 1500) time slot it conflicts only with the newcomers and editorial tutorials.

Regards,

Dan

From: edu-team [mailto:[email-masked]] On Behalf Of Alia Atlas

However, done as that and done directly against the Routing tutorial (where Adrian and I
were asked about it), it doesn't look like a good combination.

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 02 Jul 2015 16:38:12 +0200

Hi,

I just checked and this is what I had sent to the secretariat for IETF 93:

13:00 Newcomer's Tutorial (Scott Bradner)
13:00 Routing Area Overview (Adrian Farrel, Jeff Haas)
15:00 Document Editing and Shepherding (Barry Leiba)
15:00 Introduction to Performance Measurements and Monitoring (Vinayak
Hegde)

We then added another slot at 15:00 for the SDN tutorial. So, this
shouldn't have conflicted with the routing area tutorial. Not sure why
this is different now on the agenda (and how it looked like on the
registration page).

Stephanie, Alexa, can this still be changed (if this works for the
speakers of course).

Kind regards,
Mirjam

On 2/7/15 09:12, Romascanu, Dan (Dan) wrote:
> Can’t we avoid this scheduling conflict? If we move the SDN tutorial to
> the earlier (1300 – 1500) time slot it conflicts only with the newcomers
> and editorial tutorials.
> 
>  
> 
> Regards,
> 
>  
> 
> Dan
> 
>  
> 
>  
> 
> *From:*edu-team [mailto:[email-masked]] *On Behalf Of *Alia Atlas
>

---

From: Stephanie McCammon <[email-masked]>
Date: Tue, 7 Jul 2015 14:33:36 -0700

Hi Everyone,

I somehow missed this email but actually noticed this error on Friday and it has been corrected on the agenda. My sincere apologies for the mix up. 

Thanks,

Stephanie McCammon
IETF Project Manager
48377 Fremont Blvd, Ste. 117
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com

On Jul 2, 2015, at 07:38 , Mirjam Kuehne <[email-masked]> wrote:

Hi,

Kind regards,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 08 Jul 2015 09:44:04 +1200

Thanks. Announce to the community, perhaps?

Regards
   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Jul 2015 13:40:58 +1200

Hi all,

I'm hoping we will see the draft slides before this weekend???

Stephanie, was the agenda update announced to participants, since
it's a change to the "final" agenda?

Regards
   Brian

---

From: Stephanie McCammon <[email-masked]>
Date: Thu, 9 Jul 2015 19:14:06 -0700

Hi Brian,

I’m pulling together all of the agenda changes since the final agenda was published to send out in an announcement tomorrow.

Thanks,

Stephanie McCammon
IETF Project Manager

On Jul 9, 2015, at 18:40 , Brian E Carpenter <[email-masked]> wrote:

Hi all,

Regards
  Brian