Subject: Re: [edu-team] IETF Website Revamp: Content and EDU team

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 15 Sep 2015 17:15:45 +0200

Hi Greg,

Thanks so much for preparing this list for us and sorry I didn't have
time to look into it yet :-/ I am copying the rest of the Edu Team
hoping that some of the other members will be able to do this quickly.
If in doubt, I would go for Move-as-is.

What is QC (quality control?) and IA?

Mirjam

On 15/9/15 16:54, Greg Wood wrote:
> Hi Mirjam,
> 
> Nearly all the pieces of the content migration plan are in place. We’re hoping to finalize it this week. 
> 
> One item still remaining is how to confirm how the items marked (tentatively) as EDU Team responsibility will be handled:
> 
> https://docs.google.com/spreadsheets/d/1LCk9Fn2kdeJPNPg5z5yIDmHs8KM_HEKbDS4k2PVLNSo/edit#gid=0&fvid=1363504695
> 
> Right now, each existing item on www.ietf.org is marked with one of the following options:
> 
> + Move as-is: Move file from old server to new server - maintain same URL
> 
> + Rewrite: Copy current content into new CMS. QC but no extensive revision. position in IA may change
> 
> + Update: Copy into current CMS. Updating content required
> 
> + Do not move: Does not need to move to the new server
> 
> The ones currently marked with “???-EDU” still need to have one of these actions assigned.
> 
> We need to finalize this week to maintain our schedule. 
> 
> Let me know if you’d like to discuss, or if I can provide more information.
> 
> Thank you,
> -Grerg
> 
>> On Sep 8, 2015, at 4:01 PM, Greg Wood <[email-masked]> wrote:
>>
>> Hi Mirjam,
>>
>> As part of the IETF Website Revamp project, I’ve been reviewing every item in the www.ietf.org site.
>>
>> NOTE: This does *not* include the EDU Team wiki (http://tools.ietf.org/group/edu/)
>>
>> We need to have a plan to move content from the current IETF site to the new one. Based on our previous conversation and the discussions on the EDU Team mail list, I’ve flagged items here as falling under the remit of the EDU Team:
>>
>> https://docs.google.com/spreadsheets/d/1LCk9Fn2kdeJPNPg5z5yIDmHs8KM_HEKbDS4k2PVLNSo/edit#gid=0&fvid=1363504695
>>
>> This includes, for example, the Tao and the newcomers pages.
>>
>> The idea is that the EDU team would then have primary editorial responsibility for these items going forward.
>>
>> I was wondering if you might have some time to review this and/or how you’d like to surface it with the EDU Team more broadly.
>>
>> In addition to moving the content, we also discussed integrating the EDU materials into other, relevant pages on the www.ietf.org site. I expect that to be part of the content development process.
>>
>> We’re aiming to confirm plans in the next few weeks. Thanks for your reply.
>>
>> And, of course, let me know if you’d like to discuss or chat.
>>
>> Thanks,
>> -Greg
>>
>>
>

---

From: Greg Wood <[email-masked]>
Date: Tue, 15 Sep 2015 11:23:08 -0400

Hi Mirjam,

Thank you.

To be clear: content that is moved “as is” means that it will not be placed into the new CMS, visual style. I suspect most of the PDF, TXT, and PPT/PPTX files fit that description, but that most of the HTML files (about 14) will need some other actions.

I’d look forward to input.

Sorry for the shorthand:

QC = Quality Control
IA = Information architecture

Let me know if I can provide more information.

-Greg

> On Sep 15, 2015, at 11:15 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi Greg,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Sep 2015 08:52:51 +1200

I've had a quick look, no guarantees.

Sure, move as-is for the PDF, PPT(X), mp4  and any other complex formats.
I can only see one txt; it probably isn't worth the effort of converting
it to html, so it can be as-is too.

I suppose the html pages all need to be "rewrite".

But I have some concerns:

1. Why doesn't http://www.ietf.org/newcomers.html show up as EDU related?

Also, IMHO it needs URL continuity.

2. IMHO http://www.ietf.org/tao.html needs URL continuity.

3. IMHO http://www.ietf.org/about/ and in particular
   http://www.ietf.org/about/standards-process.html need URL continuity.

3. Why doesn't http://www.ietf.org/about/process-docs.html show up as EDU related?

   (also, it will probably need to be "rewrite" but if you want the
    original XML source I have it right here...)

In general I would argue for URL continuity whenever possible; from a
user point of view, the worst aspect of web site revamps and CMS is
the invalidation of cached or memorable URLs, especially for educational
or tutorial material that you might want to refer back to.

Regards
   Brian

On 16/09/2015 03:23, Greg Wood wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Greg Wood <[email-masked]>
Date: Wed, 16 Sep 2015 13:16:36 -0400

Hi Brian,

Thank you for the helpful review—even a quick one!.

> On Sep 15, 2015, at 4:52 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> I suppose the html pages all need to be “rewrite".

Got it. Unless I hear otherwise, I’ll proceed with that general plan.

> 1. Why doesn’t http://www.ietf.org/newcomers.html show up as EDU related?

To clarify, I was focused asking the EDU Team about what action to take with the items marked '???-EDU’.

There’s a separate column elsewhere to indicate who is responsible for the item. For that, ../newcomers.html is definitely assigned to the EDU Team. Once the items making the move to the new site are identified, there will be another round to ensure the correct folks are lined up as “owners” of that content.

> Also, IMHO it needs URL continuity.

Yes. I tried setting up a function in Google doc to compare the ‘old URL’ with the list of ‘URL Continuity Required’ set forth in the SOW. The item ../newcomers.html (and the items below) are definitely in this list. And, of course, other items can be added.

Unfortunately, that function isn’t working properly right now, but that will be fixed before any actions are taken.

(I think this also covers the items below as well.)

> 3. Why doesn’t http://www.ietf.org/about/process-docs.html show up as EDU related?
> 
>    original XML source I have it right here…)

OK. Great!

> or tutorial material that you might want to refer back to.

Agree. In addition to the “URL Continuity Required” list from the SOW, we can flag the EDU-related items to ensure the URLs continue to work. We will also look at webusage data and make sure highly-visited items are included.

If the EDU Team is open to it, I think a review as the overall content transition plan is being put in place would be very helpful. This would likely be in a few weeks.

In the meantime, let me know if I can provide any additional information.

Regards,
-Greg

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 17 Sep 2015 11:15:44 +0200

Thanks, Brian.

Greg, I didn't hear any objections to this general plan from any of the
Edu Team members.

Mirjam