Subject: [edu-team] Fwd: GitHub Contributors Guide

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 3 Sep 2015 08:49:26 +0200

Hi Jim,

I see there is a discussion on the WG chairs list about this. So, maybe
this would indeed be a good topic for a WG chairs lunch (at IETF 94) as
Brian suggested. We could then turn it into a (short) tutorial for the
IETF meeting after that.

Edu Team, we tentatively had Framework and Architecture Drafts (Linda
Dunbar) scheduled as a WG chairs lunch, but this is not confirmed. What
do you think should have priority?

Regards,
Mirjam

-------- Forwarded Message --------
Subject: 	GitHub Contributors Guide
Date: 	Wed, 2 Sep 2015 15:07:12 -0400
From: 	Justin Richer <[email-masked]>
To: 	[email-masked]

I was just pointed to this article from GitHub about setting up a
contributors guide for a repository:

https://help.github.com/articles/setting-guidelines-for-repository-contributors/

Essentially this creates a link to an in-repository document on the page
every time someone creates a new issue or pull request. I’ve already
added the IETF Note Well to the contribution document for the COSE
repository:

https://github.com/cose-wg/cose-issues/blob/master/CONTRIBUTING.md

https://github.com/cose-wg/cose-issues/issues/new

Those of you using GitHub to track code, specs, or issues for your
groups will probably want to enable this feature. Feel free to steal the
markdown-formatted Note Well from us if you like. :)

 — Justin

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 4 Sep 2015 08:25:33 +1200

> do you think should have priority?

You mean, a running code topic vs a philosophical topic? ;-)

I'd go for GitHub, unless Linda is already preparing materials.

   Brian

> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 3 Sep 2015 19:35:34 -0700

I think that I would tend to go with Brian on this.  There are a number of things that need to be learned and this is probably a good place to start.

Jim

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Thursday, September 03, 2015 1:26 PM
> To: Mirjam Kuehne <[email-masked]>; Jim Schaad <[email-masked]>; EDU
> Team <[email-masked]>
> Subject: Re: [edu-team] Fwd: GitHub Contributors Guide
> 
> > I see there is a discussion on the WG chairs list about this. So,
> > maybe this would indeed be a good topic for a WG chairs lunch (at IETF
> > 94) as Brian suggested. We could then turn it into a (short) tutorial
> > for the IETF meeting after that.
> >
> > Dunbar) scheduled as a WG chairs lunch, but this is not confirmed.
> > What do you think should have priority?
> 
> > Essentially this creates a link to an in-repository document on the
> > page every time someone creates a new issue or pull request. I’ve
> > already added the IETF Note Well to the contribution document for the
> > COSE
> > repository:
> >
> > groups will probably want to enable this feature. Feel free to steal
> > the markdown-formatted Note Well from us if you like. :)
> >
> >  — Justin
> >
> >

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 4 Sep 2015 10:33:41 +0200

Hi,

No, I don't think anyone has approached Linda about it recently, so we
can also do that at a later IETF meeting. So, let's plan the GitHub
Guide for the WG Chairs Lunch on Wednesday in Yokohama.

Jim, you suggested Richard Barnes and Martin Thomson as presenters. Do
you want to contact them?

Regards,
Mirjam

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 5 Sep 2015 12:03:54 -0700

I can contact them, it might be better to come from edu team though.

Jim

> From: Mirjam Kuehne [mailto:[email-masked]]
> Sent: Friday, September 04, 2015 1:34 AM
> To: Jim Schaad <[email-masked]>; 'Brian E Carpenter'
> <[email-masked]>; 'EDU Team' <[email-masked]>
> No, I don't think anyone has approached Linda about it recently, so we can also
> do that at a later IETF meeting. So, let's plan the GitHub Guide for the WG Chairs
> Lunch on Wednesday in Yokohama.
> 
> Jim, you suggested Richard Barnes and Martin Thomson as presenters. Do you
> want to contact them?
> 
> Regards,
> Mirjam
> 
> 
> 
> > I think that I would tend to go with Brian on this.  There are a number of things
> that need to be learned and this is probably a good place to start.
> >
> > Jim
> >
> >
> >> To: Mirjam Kuehne <[email-masked]>; Jim Schaad
> >> <[email-masked]>; EDU Team <[email-masked]>
> >>> 94) as Brian suggested. We could then turn it into a (short)
> >>> tutorial for the IETF meeting after that.
> >>>
> >>> https://help.github.com/articles/setting-guidelines-for-repository-c
> >>> on
> >>> tributors/
> >>>
> >>> already added the IETF Note Well to the contribution document for
> >>> the COSE
> >>> repository:
> >>>

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 17 Sep 2015 16:49:27 +0200

Hi Jim,

> I can contact them, it might be better to come from edu team though.

I am not sure that statement was true ;-) I still haven't heard from
them. Any other suggestions for a speaker?

Mirjam