Subject: [edu-team] YANG tutorial and hackathon at IETF 94

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 3 Sep 2015 10:03:55 +0000

Hi,

Please find below the information about the YANG tutorial and hackathon at IETF 94. As discussed, the team decided on a modular approach, so the tutorial is divided into three segments which could be packaged separately. Outlines for each of the segments is included, as well as a link to the work-in-progress content. 

Please let me and Carl Moberg know if there are any questions or comments. 

Regards,

Dan

> -----Original Message-----
> From: Carl Moberg (camoberg) [mailto:[email-masked]]
> Sent: Thursday, September 03, 2015 12:43 PM
> To: Romascanu, Dan (Dan)
> Cc: Benoit Claise (bclaise); YANG Doctors
> Subject: Re: [yang-doctors] YANG tutorial and hackathon at IETF 94
> 
> Dan,
> 
> 
> 
>  We’re working on three modules:
> 
>   1. An overview of NETCONF and YANG
> 
>   2. A deeper dive into YANG
> 
>   3. A deeper dive into NETCONF
> 
> 
> 
>  The idea being that they can be used in combination or stand-alone as
> needed.
> 
> 
> 
>  For "An overview of NETCONF and YANG”
> 
>   Session Objectives:
> 
>    – Identify the major problems/issues facing network administrators
> 
>    – Describe the NETCONF/YANG protocol and modeling language
> 
>    – Describe how the features of NETCONF/YANG address major problems in
> network administration
> 
>    – Describe a use case for NETCONF/YANG
> 
>   Content Outline:
> 
>    – Problems for Network Managers
> 
>    – NETCONF/YANG
> 
>     + Definitions
> 
>     + Distinction between Protocol and Modeling language
> 
>     + NETCONF Protocol Layers
> 
>     + NETCONF Operations
> 
>    – Solutions for Network Managers
> 
>    – Summary
> 
> 
> 
>  For "A deeper dive into YANG”
> 
>   Session Objectives:
> 
>    – Identify and describe common elements of a YANG model
> 
>    – Examine a YANG model and create an instance data to configure one or
> more network devices
> 
>   Content Outline:
> 
>    – Standard YANG Models
> 
>    – High-level structure of YANG Modules
> 
>    – Presenting the Use Case (MPLS-VPN configuration)
> 
>     + Task 1: Activating an interface on group of devices
> 
>     + Task 2: Assigning addresses to interfaces
> 
>     + Task 3: Configuring an MPLS VPN Tunnel
> 
> 
> 
>  For "A deeper dive into NETCONF"
> 
>   Session Objectives:
> 
>   - Obtain configuration and operational data from a device using NETCONF
> 
>   - Configure a network device using NETCONF
> 
>   Content Outline:
> 
>   - NETCONF Basics
> 
>    + Layers
> 
>    + Sessions
> 
>    + Capabilities
> 
>   - Scenario 1 - Getting Data
> 
>   - Scenario 2 - Configuring
> 
>   - Scenario 3 – Locking
> 
>   - Scenario 4 – Validating, Confirmed Commits, Multiple Devices
> 
>   - Language Binding Examples
> 
>   - Summary
> 
> 
> 
>  Is this enough for the edu team?
> 
> 
> 
>  A snapshot (work in progress) of the content here:
> 
>   https://cisco.app.box.com/s/wnb63kk8rs1lselxojipt5bpawv4mnjz
> 
> 
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 3 Sep 2015 14:17:39 +0200

Thanks, Dan and Benoit.

Naveen, can you please add this as a description to the YANG tutorial
for IETF 94.

Thanks,
Mirjam

On 3/9/15 12:03, Romascanu, Dan (Dan) wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>