Subject: [edu-team] NETCONF/YANG/pyang tutorial on Sunday, posted?

From: Benoit Claise <[email-masked]>
Date: Wed, 4 Nov 2015 22:12:22 +0900

Hi,

I have people asking me already when/where the training will be posted.
Btw, do we still agreement to post them on youtube?

Regards, B.

---

From: Simon Pietro Romano <[email-masked]>
Date: Wed, 4 Nov 2015 16:24:48 +0100

Hello Benoit,

the recording is already on-line:

http://ietf94.conf.meetecho.com/index.php/Recordings <http://ietf94.conf.meetecho.com/index.php/Recordings>

You have two options:

1) view it on-line in the usual web-based format:

http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF94_YANG&chapter=chapter_1 <http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF94_YANG&chapter=chapter_1>

2) Download the webm file (which is ready for YouTube upload —we cannot upload it ourselves on the IETF channel). This can be played with any common media player (e.g., VLC, iTunes, etc.).

http://recs.conf.meetecho.com/ietf94/webm/YANG-Tutorial.webm <http://recs.conf.meetecho.com/ietf94/webm/YANG-Tutorial.webm>

Cheers,

Simon

> On 04/nov/2015, at 14:12, Benoit Claise <[email-masked]> wrote:
> 
> Hi,
> 

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 4 Nov 2015 16:28:49 +0100

Hi Benoit,

I am not sure when the recording will be available, but it should then
be posted here:

http://www.ietf.org/edu/technical-tutorials.html

Do you actually want a new entry for the Yokohama session, or do you
want us to update this entry:

http://www.ietf.org/edu/technical-tutorials.html#yang

If you have slides or any other material, I can make it available on the
Edu Team wiki in the meantime.

Regards,
Mirjam

On 4/11/15 14:12, Benoit Claise wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 4 Nov 2015 16:30:23 +0100

Thanks, Simon.

Naveen, will you also post the recording on the ietf.org/edu pages?

Regards,
Mirjam

On 4/11/15 16:24, Simon Pietro Romano wrote:
> http://ietf94.conf.meetecho.com/index.php/Recordings
> 
> You have two options:
> 
> http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF94_YANG&chapter=chapter_1
> 
> 2) Download the webm file (which is ready for YouTube upload —we cannot
> upload it ourselves on the IETF channel). This can be played with any
> common media player (e.g., VLC, iTunes, etc.).
> 
> http://recs.conf.meetecho.com/ietf94/webm/YANG-Tutorial.webm
> 
> Cheers,
> 
> Simon
> 
> 
>> On 04/nov/2015, at 14:12, Benoit Claise <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> Hi,
>>
> <mailto:[email-masked]>
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Nov 2015 00:52:05 +0900

Thanks Mirjam,

http://www.ietf.org/edu/technical-tutorials.html#yang is fine.

Hi Carl,

Can you share the slides.

thanks and regards, B.

> .

---

From: Naveen Khan <[email-masked]>
Date: Wed, 4 Nov 2015 15:00:41 -0800

Hi Mirjam,

Sure, I will take care of this today.

Sincerely,

Naveen Khan 
IETF Administrative Coordinator
48377 Fremont Blvd. Suite 117 / Fremont, CA 94538
Direct (510) 492-4028 / Fax (510) 492-4001
Email: [email-masked] / URL:  http://www.ietf.org
 
Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
URL: http://www.amsl.com

---

From: "Carl Moberg (camoberg)" <[email-masked]>
Date: Thu, 5 Nov 2015 16:33:39 +0000

Slides.

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 6 Nov 2015 10:47:52 +0100

> Slides.

Thanks, Carl. They are now available on the IETF Edu Team wiki:

http://wiki.tools.ietf.org/group/edu/wiki/IETF94

Naveen, can you please also add them to
http://www.ietf.org/edu/technical-tutorials.html#yang
(but keep the slide set from Prague if possible).

Thank you,
Mirjam

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Nov 2015 10:48:18 +0100

Hi EDU team,

I went from http://ietf.org/edu/
     -> tutorials
     -> Network Configuration Management with NETCONF and YANG 
<http://ietf.org/edu/technical-tutorials.html#netconfandyang>

There is a mix of IETF 84 and IETF 94 trainings.
- Can we please have the IETF 94 training at the top.
- Can we please have the description from the IETF 94 training
- Can we please have a link to the video from IETF 94
- OLD: *Download Recording: *NETCONF and YANG 
<http://ietf.org/edu/tutorials/ietf-84-netconf.mp4>
   NEW: *Download IETF 84 Recording: *NETCONF and YANG 
<http://ietf.org/edu/tutorials/ietf-84-netconf.mp4>
- can we have a link to" download the IETF 94 recording"
- slies -> slides

 From https://datatracker.ietf.org/meeting/94/materials.html, can we 
please a link from "YANG Tutorial and YANG Advice/Editing Session" to 
your edu page

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Nov 2015 11:04:11 +0100

Hi Simon,

Thanks to the meetecho team for the recording.

Some requests about video editing:
- Would it be possible to cut the first 3 min?
- Would it be possible to have a first video for NETCONF cut after 
1:04:45 (minus 3 min)
- A second video for YANG, cut after 1:39:00 (minus 3 min)?
- A third video for pyang, starting at 1:53/45 (minus 3 min) till the end.

Some feedback:
- Viewing the videos from the browser, I see a disconnect between the 
voice and the video.
I downloaded the videos, and see the same issue with VLC.
- Some slides are unreadable. They're just too bright. Just one example: 
see the video at time 17:00 min
     Could it be that the slides are distorted?

Regards, Benoit

> 2) Download the webm file (which is ready for YouTube upload —we 
> cannot upload it ourselves on the IETF channel). This can be played 
> with any common media player (e.g., VLC, iTunes, etc.).
>
>            e-mail: [email-masked] <mailto:[email-masked]>
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 12 Nov 2015 11:31:21 +0100

Hi Benoit,

Sorry, that was my fault. Naveen asked me where to put the new slides
and I suggested to add them to the earlier netconf and yang entry.
Thanks for clarifying. We'll make those changes.

Mirjam

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 12 Nov 2015 13:02:55 +0100

> - A third video for pyang, starting at 1:53/45 (minus 3 min) till the end.

Sure. Will send you the links to the new videos shortly.

> - Viewing the videos from the browser, I see a disconnect between the

The web-based player may suffer of lip sync issues, depending on 
buffering timing of the different contributions. The YouTube-style .webm 
video should not.

> I downloaded the videos, and see the same issue with VLC.

We just checked again and the .webm video looks synced to us: can you 
point us to a specific time where you noticed this not happening?

>      Could it be that the slides are distorted?

The slides are not distorted, but not very "friendly" to either man or 
machine :-). We capture the output of the projector, and Courier text is 
hardly displayed by projectors when it's not bold. The same holds true 
for white text on top of light blue background.

Regards,
the Meetecho team

>>> On 04/nov/2015, at 14:12, Benoit Claise
>>> <<mailto:[email-masked]>[email-masked]> wrote:
>>>
>>> Hi,
>>>
>>            e-mail: <mailto:[email-masked]>[email-masked]
>>

-- 
Meetecho s.r.l.
www.meetecho.com

---

From: Meetecho Team <[email-masked]>
Date: Thu, 12 Nov 2015 15:00:03 +0100

Hi Benoit,
the new videos you requested are available here:

http://recs.conf.meetecho.com/ietf94/webm/yang/1-YANGbyExample.webm

http://recs.conf.meetecho.com/ietf94/webm/yang/2-NETCONFbyExample.webm

http://recs.conf.meetecho.com/ietf94/webm/yang/3-pyang.webm

Best regards,
The Meetecho Team

Il 12/11/2015 13:02, [email-masked] ha scritto:
> buffering timing of the different contributions. The YouTube-style 
> .webm video should not.
>
> machine :-). We capture the output of the projector, and Courier text 
> is hardly displayed by projectors when it's not bold. The same holds 
> true for white text on top of light blue background.
>
> Regards,
> the Meetecho team
>
>>
>> Regards, Benoit
>>
>>> Hello Benoit,
>>>

---

From: "Carl Moberg (camoberg)" <[email-masked]>
Date: Thu, 12 Nov 2015 14:27:58 +0000

> On Nov 12, 2015, at 4:02 AM, [email-masked] wrote:
> 
>> 
> The slides are not distorted, but not very "friendly" to either man or machine :-). We capture the output of the projector, and Courier text is hardly displayed by projectors when it's not bold. The same holds true for white text on top of light blue background.

 This is actually great feedback. Will make sure to improve a little (ok a lot :-) on the contrast in a revised version.

---

From: Naveen Khan <[email-masked]>
Date: Thu, 12 Nov 2015 11:30:14 -0800

Hi All,

I will update these items, and will let you know as soon as it is fixed.

Sincerely,

Naveen Khan

---

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Nov 2015 15:23:43 +0100

Hi Naveen,
> I will update these items, and will let you know as soon as it is fixed.
Thank you.

One more improvement:
OLD: *Link to slides at IETF 94:* NETCONF Slides 
<http://datatracker.ietf.org/doc/slides-edu-network-configuration-with-netconf/>, 
YANG Slides 
<http://datatracker.ietf.org/doc/slides-edu-network-configuration-with-yang/>
<http://ietf.org/edu/documents/YANGbyExample.pdf>NEW: *Link to slides at 
IETF 94:* NETCONF Slides 
<http://datatracker.ietf.org/doc/slides-edu-network-configuration-with-netconf/>, 
YANG Slides 
<http://datatracker.ietf.org/doc/slides-edu-network-configuration-with-yang/>, 
pyang slides
<http://ietf.org/edu/documents/YANGbyExample.pdf>
Wrt the pyang slides, Lada, can you please provide them to the edu team.

OLD: *Download IETF 94 Recording:* NETCONF 
<http://recs.conf.meetecho.com/ietf94/webm/yang/2-NETCONFbyExample.webm>, YANG 
<http://recs.conf.meetecho.com/ietf94/webm/yang/1-YANGbyExample.webm>
NEW: *Download IETF 94 Recording:* NETCONF 
<http://recs.conf.meetecho.com/ietf94/webm/yang/2-NETCONFbyExample.webm>, YANG 
<http://recs.conf.meetecho.com/ietf94/webm/yang/1-YANGbyExample.webm>, 
pyang <http://ietf.org/edu/tutorials/ietf-84-netconf.mp4>

pyang should point to 

thanks and regards, Benoit
<http://ietf.org/edu/tutorials/ietf-84-netconf.mp4><http://ietf.org/edu/tutorials/ietf-84-netconf.mp4> 

> Email: [email-masked] <mailto:[email-masked]> / URL: http://www.ietf.org
>
> On Nov 12, 2015, at 2:31 AM, Mirjam Kuehne <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Hi Benoit,
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Nov 2015 15:26:32 +0100

And from https://datatracker.ietf.org/meeting/94/materials.html,
  you want to point to 
http://ietf.org/edu/technical-tutorials.html#netconfandyang, and not 
only the slides.

Regards, Benoit

> <http://ietf.org/edu/documents/YANGbyExample.pdf>NEW: *Link to slides 
> at IETF 94:* NETCONF Slides 
> <http://recs.conf.meetecho.com/ietf94/webm/yang/2-NETCONFbyExample.webm>, 
> YANG <http://recs.conf.meetecho.com/ietf94/webm/yang/1-YANGbyExample.webm>

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 19 Nov 2015 15:28:46 +0100

One side note: we're just temporarily hosting the videos on our servers. 
They're supposed to be uploaded on YouTube eventually. So, this link:
http://recs.conf.meetecho.com/ietf94/webm/yang/3-pyang.webm
will become unavailable sooner or later.

Best,
the Meetecho team

Il 19/11/2015 15:23, Benoit Claise ha scritto:
>> Email: [email-masked] <mailto:[email-masked]> / URL:
>> <http://www.ietf.org>http://www.ietf.org
>>
>> On Nov 12, 2015, at 2:31 AM, Mirjam Kuehne
>> <<mailto:[email-masked]>[email-masked]> wrote:
>>
>>> Hi Benoit,
>>>

-- 
Meetecho s.r.l.
www.meetecho.com

---

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Nov 2015 15:31:38 +0100

Great.
Let me know when done.
We should not forget to update the edu page links then.

Regards, Benoit
> One side note: we're just temporarily hosting the videos on our 
> servers. They're supposed to be uploaded on YouTube eventually. So, 
> this link:
>> YANG
>> YANG

---

From: Alessandro Amirante <[email-masked]>
Date: Thu, 19 Nov 2015 17:13:51 +0100

EDU team, et al.,

we just uploaded all tutorials held in Yokohama on the IETF YouTube channel.

These are the links:

Newcomers' Orientation
https://www.youtube.com/watch?v=L5D5RwWfQTA

Newcomers' Orientation in Japanese
https://www.youtube.com/watch?v=8U5hamMm-SE

Tools for Creating IDs and RFCs
https://www.youtube.com/watch?v=FTfhcAnPWNw

Internet Area Overview
https://www.youtube.com/watch?v=vjsKfnQX3no

PRECIS and i18n
https://www.youtube.com/watch?v=Gtre39ZU1D0

CBOR
https://www.youtube.com/watch?v=nihSTzbs3fs

YANG by Example
https://www.youtube.com/watch?v=AhYZhbANiwE

NETCONF by Example
https://www.youtube.com/watch?v=N7fb11dLztA

PYANG
https://www.youtube.com/watch?v=aPFTzgdYDw0

Best,
Alessandro

-- 
Ing. Alessandro Amirante, Ph.D.

Meetecho S.r.l.
www.meetecho.com

Via C. Poerio, 89/a
80121 Napoli, Italy

Mobile: +39 329 6178743
E-mail: [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Nov 2015 20:12:08 +0100

Many thanks.

EDU team, you might want to add a link back to the IETF/edu web site in 
the youtube comments.
Like I did for https://www.youtube.com/watch?v=AhYZhbANiwE, as an example.

Regards, Benoit