Subject: Re: [edu-team] Final Final Final newcomers

From: Alice Russo <[email-masked]>
Date: Fri, 1 Jul 2016 13:13:38 -0700

Hi Mike,
Nits, a reminder, and suggestion for the future below.

s12: "Bits N Bytes" -> "Bits-N-Bites" to match the spelling on ietf.org.

s14: "IFF" -> "iff"
It's lowercase in various dictionaries and lists of mathematical notation (e.g., Chicago Manual). Also, lowercase is how it typically appears in RFCs (where, by the way, we agree -- no need to expand it, as indicated by the asterisk in the abbrev list - https://www.rfc-editor.org/materials/abbrev.expansion.txt).

Just a reminder that many people in the audience do not speak English as their first language. Speaking slowly and clearly will maximize the effectiveness of your presentation. Although Newcomers is a unique tutorial, you may find that you have suggestions/additions for the general 'Guidelines for Teachers of IETF EDU Team Tutorials' (http://wiki.tools.ietf.org/group/edu/attachment/wiki/Other/GuidelinesEDU.pdf?format=raw) -- we welcome updates.

FWIW, I agree with Dan re: 'sibling' being an odd word choice for conveying the IETF/IAB relationship. However, I don't have a good replacement. I do suggest (for the future) adding a diagram -- the "big picture" showing the various entities -- similar to s44 of Newcomers @ IETF 95. A picture's worth 1000 words, even if there's debate about its exact content and even if the details of the I* universe are not relevant to newcomers. Alternatively, a useful big picture could be an expansion of Fig. 1 from RFC 6635. (Attached screenshot is the one from Doc Lifecycle @ IETF 82 -slightly updated.)

Thanks,
Alice

---

From: Michael StJohns <[email-masked]>
Date: Fri, 1 Jul 2016 16:45:06 -0400

> Hi Mike,
Hi Alice -

> s12: "Bits N Bytes" -> "Bits-N-Bites" to match the spelling on 
> ietf.org <http://ietf.org>.
Sure
>
> s14: "IFF" -> "iff"
> It's lowercase in various dictionaries and lists of mathematical 
> notation (e.g., Chicago Manual). Also, lowercase is how it typically 
> appears in RFCs (where, by the way, we agree -- no need to expand it, 
> as indicated by the asterisk in the abbrev list - 
> https://www.rfc-editor.org/materials/abbrev.expansion.txt).
Probably not - note that IFF is paired with AND in that sentence for 
emphasis, not as a normal representation.  I'd agree with you otherwise.

>
> Just a reminder that many people in the audience do not speak English 
> as their first language. Speaking slowly and clearly will maximize the 
> effectiveness of your presentation. Although Newcomers is a unique 
> tutorial, you may find that you have suggestions/additions for the 
> general 'Guidelines for Teachers of IETF EDU Team Tutorials' 
> (http://wiki.tools.ietf.org/group/edu/attachment/wiki/Other/GuidelinesEDU.pdf?format=raw) 
> -- we welcome updates.
Yup.  Fortunately, this isn't anywhere close to my first rodeo even with 
non-native speakers.  And I'm not EKR! :-)

>
> FWIW, I agree with Dan re: 'sibling' being an odd word choice for 
> conveying the IETF/IAB relationship. However, I don't have a good 
> replacement. I do suggest (for the future) adding a diagram -- the 
> "big picture" showing the various entities -- similar to s44 of 
> Newcomers @ IETF 95. A picture's worth 1000 words, even if there's 
> debate about its exact content and even if the details of the I* 
> universe are not relevant to newcomers. Alternatively, a useful big 
> picture could be an expansion of Fig. 1 from RFC 6635. (Attached 
> screenshot is the one from Doc Lifecycle @ IETF 82 -slightly updated.)
Mostly no.   This and other information is available elsewhere and is 
mostly not relevant to the "what do I need to know NOW to be effective 
at this current meeting?".   I could have doubled or tripled the size of 
the presentation fitting in every tiny detail. The picture below for 
example is interesting, but mostly won't affect what the folks are doing 
at this meeting unless they're already working through a publication 
issue.    And to be fair, what's below is the RFC editor view of how 
things fit together - which taken together with S44 of the previous 
newcomers would pretty much confuse the hell out of someone that didn't 
already know the nuances.

Lastly, I pretty much hated slide 44 as it really didn't provide any 
useful data.  My problem with the slide is that the relationships 
between the I* and the rest are fraught with nuance and shades of 
obligation and control - and those are difficult to represent in a 
hierarchical organization diagram.  Consider for example the 
relationship between the IAOC, the IESG and the IAB.  Then throw in the 
trust.  Then throw in the "membership" of the IETF.    There are so many 
two-way arrows in who does what to whom that I'd rather just say "You 
may of heard of the IAB.  Its a sibling organization to the IETF and 
most of the IAB members also participate in the IETF. There are more 
details, but they are mostly irrelevant to your getting the most out of 
this first meeting" rather than putting up a big picture and spending a 
half hour walking the arrows.

Let me suggest an alternative:  Let's have each of IANA, RFC Editor, 
Secretariat, IAB, IAOC IESG build a page off of the newcomers website.  
The question they are to answer is:  "In one paragraph and one picture, 
what is the most important thing that a new participant in the IETF 
needs to know about you and where can they find more data if they want 
to dig?"  And be ruthless about keeping it to one paragraph and one picture.

/Je n'ai fait celle-ci plus longue que parce que je n'ai pas eu le 
loisir de la faire plus courte. - (I would have written a shorter 
letter, but I did not have the time.) - Blaise Pascal/

Later, Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 2 Jul 2016 18:49:46 +1200

Mike,
...
> Lastly, I pretty much hated slide 44 as it really didn't provide any useful 
> data.  My problem with the slide is that the relationships between the I* and 
> the rest are fraught with nuance and shades of obligation and control - and 
> those are difficult to represent in a hierarchical organization diagram.  
> Consider for example the relationship between the IAOC, the IESG and the IAB.  
> Then throw in the trust.  Then throw in the "membership" of the IETF.    There 
> are so many two-way arrows in who does what to whom that I'd rather just say 
> "You may of heard of the IAB.  Its a sibling organization to the IETF and most 
> of the IAB members also participate in the IETF. There are more details, but 
> they are mostly irrelevant to your getting the most out of this first meeting" 
> rather than putting up a big picture and spending a half hour walking the arrows.

Yes. Actually I never liked Scott's slide very much, although I gave his presentation
a couple of times. When I was asked to give an overview to a conference in Beijing
in 2005, I used the two slides attached below. Judging by the blank faces, that
didn't work either.

> Secretariat, IAB, IAOC IESG build a page off of the newcomers website.  The 
> question they are to answer is:  "In one paragraph and one picture, what is the 
> most important thing that a new participant in the IETF needs to know about you 
> and where can they find more data if they want to dig?"  And be ruthless about 
> keeping it to one paragraph and one picture.

Yes, good idea. When I originally drafted the newcomers page, I intentionally
did not go into stuff that people don't need on Day 1. So there *are*
a few words about Areas, the IESG and WGs but not the rest.
https://www.ietf.org/newcomers.html#structure
> 
> 
> /Je n'ai fait celle-ci plus longue que parce que je n'ai pas eu le loisir de la 
> faire plus courte. - (I would have written a shorter letter, but I did not have 
> the time.) - Blaise Pascal/
> 

Regards
    Brian