Subject: [edu-team] Proposed tutorial How to do a WG presentation

From: Michael StJohns <[email-masked]>
Date: Mon, 27 Mar 2017 18:18:18 +0000

Over the years I've suffered through mumblers, slide readers, speed daemons
and ah-um-er'ers presenting things to working groups.  I'm wondering if
it's time we started training people to do better presentations?

And people to make more succinct commentary at the microphone.

Thoughts? Mike

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 27 Mar 2017 20:39:15 +0200

Hi Mike,

We've done this some time ago:

https://ietf.org/edu/process-oriented-tutorials.html#presentation

But maybe it is time to do this again (more frequently)?

Mirjam

On 27/03/17 20:18, Michael StJohns wrote:
> Over the years I've suffered through mumblers, slide readers, speed
> daemons and ah-um-er'ers presenting things to working groups.  I'm
> wondering if it's time we started training people to do better
> presentations?
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>