Subject: [edu-team] Fwd: Re: WebRTC tutorial in Singapore

From: Niels ten Oever <[email-masked]>
Date: Thu, 2 Nov 2017 10:45:21 +0100

Hi EDU team,

Please find below the draft slides for the webRTC session, all comments
welcome to Daniel (cc).

Daniel will share description for the session soon.

Best,

Niels

-------- Forwarded Message --------
Subject: 	Re: WebRTC tutorial in Singapore
Date: 	Sun, 29 Oct 2017 22:30:55 -0400
From: 	Daniel Burnett <[email-masked]>
To: 	Niels ten Oever <[email-masked]>
CC: 	Alexandre GOUAILLARD <[email-masked]>

Niels,

Here are my slides.  Alex may have a few separate slides for his piece,
or he may just reference a live website.  I will leave that up to him.

I still owe you a description for the website.  I will send that tomorrow.

-- dan

​
 IETF100WebRTC201711.pdf
<https://drive.google.com/file/d/0By7sZyoGDdAcMUdNOGxnRXp3TTg/view?usp=drive_web>
​

On Mon, Oct 16, 2017 at 5:39 AM, Niels ten Oever <[email-masked]
<mailto:[email-masked]>> wrote:

    That sounds excellent. Looking forward to the description.

    Best,

    Niels

    On Fri, Oct 13, 2017 at 02:01:59PM -0400, Daniel Burnett wrote:
    > Neils,
    >
    > Alex and I have had trouble coordinating (being 12 hours apart
    makes it
    > challenging).  How about this?
    >
    > I will commit to doing the one-hour tutorial.  If Alex and I are
    able to
    > coordinate such that Alex can join me during that time, we will
    let you
    > know.
    >
    > I will send you a short description by Monday (which we can modify
    if Alex
    > joins and it affects the content).
    >
    > Dan Burnett
    >
    >
    >
    >
    > On Wed, Oct 4, 2017 at 10:52 AM, Daniel Burnett
    <[email-masked] <mailto:[email-masked]>>
    > wrote:
    >
    > > I am currently boarding a plane but will coordinate with Alex
    later this
    > > evening.
    > >
    > > -- dan
    > >
    > > On Wed, Oct 4, 2017 at 10:42 AM Niels ten Oever
    <[email-masked] <mailto:[email-masked]>>
    > > wrote:
    > >
    > >> Dear Dr. Alex,
    > >>
    > >> There is only a one hours slot available, currently we have
    planned it
    > >> between 13:45 and 14:45. So I am afraid it can only be
    introductory.
    > >>
    > >> If you have coordinated among yourselves, could you please be
    so kind to
    > >> send me a short description of the tutorial so we can place it
    on the
    > >> agenda and the website?
    > >>
    > >> Thanks in advance,
    > >>
    > >> Niels
    > >>
    > >>
    > >> Niels ten Oever
    > >> Head of Digital
    > >>
    > >> Article 19
    > >> www.article19.org <http://www.article19.org>
    > >>
    > >> PGP fingerprint    2458 0B70 5C4A FD8A 9488
    > >>                    643A 0ED8 3F3A 468A C8B3
    > >>
    > >> On 10/04/2017 04:39 PM, Alexandre GOUAILLARD wrote:
    > >> > dear niels,
    > >> >
    > >> > thanks for the offer, I will sync with Dan/Alan for the detail.
    > >> >
    > >> > I'm concerned about the time. I read from the page you
    pointed us to
    > >> > that the tutorial should fit in an afternoon, and we are
    landing on
    > >> > sunday morning at 7:45am anyway. Dan/Alan tutorial is taking
    two full
    > >> > day in its full form. Mine is an additional 3/4 hours.
    > >> >
    > >> > Can you please confirm how much time we would have available
    in this
    > >> > specific case?
    > >> >
    > >> > Given that Dan/Alan tutorial and mine are targetted at different
    > >> > audiences, JS and generic audience on one side, C++ / native
    app coders
    > >> > on the other, another option is to do them in parallel.
    > >> >
    > >> > If there was not enough time, or if parallel tutorials were not
    > >> > possible, I believe that Dan/Alan tutorial could reach a
    larger audience
    > >> > by default and should be given priority.
    > >> >
    > >> > Best regards,
    > >> >
    > >> > Dr. Alex,
    > >> >
    > >> >
    > >> > On Wed, Oct 4, 2017 at 3:36 PM, Niels ten Oever
    <[email-masked] <mailto:[email-masked]>
    > >> > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
    > >> >
    > >> >     Dear Alexandre and Daniel,
    > >> >
    > >> >     We'd be more than happy to take you up on your offer to
    present as
    > >> part
    > >> >     of the IETF Tutorials on Sunday at IETF 100. A
    combination of your
    > >> two
    > >> >     talks sounds excellent.
    > >> >
    > >> >     We'll let you know your timeslot as soon as possible.
    > >> >
    > >> >     Please find some instructions here:
    > >> >   
     https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters
    <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>
     <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters
    <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>>
    > >> >
    > >> >     It would be very much appreciated if you could share your
    slides at
    > >> >     least two weeks in advance.
    > >> >
    > >> >     Please let me know if you have any questions!
    > >> >
    > >> >     Best,
    > >> >
    > >> >     Niels
    > >> >
    > >> >     Niels ten Oever
    > >> >     Head of Digital
    > >> >
    > >> >     Article 19
    > >> >     www.article19.org <http://www.article19.org>
    <http://www.article19.org>
    > >> >
    > >> >     PGP fingerprint    2458 0B70 5C4A FD8A 9488
    > >> >                        643A 0ED8 3F3A 468A C8B3
    > >> >
    > >> >     On 10/03/2017 06:41 PM, Daniel Burnett wrote:
    > >> >     > Yes.  My tutorial (developed with Alan Johnston)
    presumes very
    > >> little
    > >> >     > background knowledge since it is intended for general
    technical
    > >> >     > audiences.  I am happy to give that tutorial or, as
    Alex says,
    > >> split the
    > >> >     > time with him so he can cover WebRTC from an IoT/C++
    perspective.
    > >> >     >
    > >> >     > -- dan
    > >> >     >
    > >> >     > On Tue, Oct 3, 2017 at 11:54 AM, Alexandre GOUAILLARD
    > >> >     > <[email-masked] <mailto:[email-masked]>
    <mailto:[email-masked] <mailto:[email-masked]>>
    > >> >     <mailto:[email-masked]
    <mailto:[email-masked]> <mailto:[email-masked]
    <mailto:[email-masked]>>>>
    > >> wrote:
    > >> >     >
    > >> >     >     dan and i will land on Sunday morning (12) and
    could do a
    > >> tutorial,
    > >> >     >     either together or separately.
    > >> >     >     Dan has the usual JS slides. I just made an Iot / C++
    > >> tutorial at
    > >> >     >     IIT-RTC in chicago.
    > >> >     >
    > >> >     >     On Tue, Oct 3, 2017 at 5:52 PM, Cullen Jennings <
    > >> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
    <mailto:[email-masked]>>
    > >> >     >     <mailto:[email-masked] <mailto:[email-masked]>
    <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
    > >> >     >
    > >> >     >
    > >> >     >         Connecting everyone together here.
    > >> >     >
    > >> >     >         Dan, Alan, Dr Alex, .... any chance you can
    help with a
    > >> WebRTC
    > >> >     >         tutorial.
    > >> >     >
    > >> >     >         Cullen
    > >> >     >
    > >> >     >
    > >> >     >         > On Oct 3, 2017, at 8:16 AM, Niels ten Oever
    > >> >     >         <[email-masked]
    <mailto:[email-masked]> <mailto:[email-masked]
    <mailto:[email-masked]>>
    > >> >     <mailto:[email-masked] <mailto:[email-masked]>
    <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
    > >> >     >         >
    > >> >     >         > Thanks Cullen, would be great if you could
    make the
    > >> intros!
    > >> >     >         >
    > >> >     >         > Thanks in advance,
    > >> >     >         >
    > >> >     >         > Niels
    > >> >     >         >
    > >> >     >         > Niels ten Oever
    > >> >     >         > Head of Digital
    > >> >     >         >
    > >> >     >         > Article 19
    > >> >     >         > www.article19.org <http://www.article19.org>
    <http://www.article19.org>
    > >> >     <http://www.article19.org>
    > >> >     >         >
    > >> >     >         > PGP fingerprint    2458 0B70 5C4A FD8A 9488
    > >> >     >         >                   643A 0ED8 3F3A 468A C8B3
    > >> >     >         >
    > >> >     >         > On 10/03/2017 05:15 PM, Cullen Jennings wrote:
    > >> >     >         >>
    > >> >     >         >> I'm going to be remote for IETF 100 so I
    don't think I
    > >> can do
    > >> >     >         it. Justin is the other person I know who has
    given some
    > >> >     >         tutorials but I doubt he will be there. Dan
    Burnett and
    > >> Alan
    > >> >     >         Johnson do good presentation on WebRTC. So does
    Alexandr
    > >> >     >         Gouaillard. I think thoses would be the go to
    people for
    > >> me.
    > >> >     >         Glad to introduct to any of them if that helps.
    > >> >     >         >>
    > >> >     >         >>
    > >> >     >         >>> On Oct 3, 2017, at 8:07 AM, Niels ten Oever
    > >> >     >         <[email-masked]
    <mailto:[email-masked]> <mailto:[email-masked]
    <mailto:[email-masked]>>
    > >> >     <mailto:[email-masked] <mailto:[email-masked]>
    <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
    > >> >     >         >>>
    > >> >     >         >>> Hi Cullen,
    > >> >     >         >>>
    > >> >     >         >>> Any chance you would be willing and able to
    give a
    > >> tutorial
    > >> >     >         on webRTC on
    > >> >     >         >>> Sunday during IETF100 in Singapore?
    > >> >     >         >>>
    > >> >     >         >>> If not, would you know of someone else
    willing to do
    > >> so?
    > >> >     >         >>>
    > >> >     >         >>> Best,
    > >> >     >         >>>
    > >> >     >         >>> Niels
    > >> >     >         >>>
    > >> >     >
    > >> >     >
    > >> >     >
    > >> >     >
    > >> >     >     --
    > >> >     >     Alex. Gouaillard, PhD, PhD, MBA
    > >> >     >   
     -----------------------------------------------------------
    > >> -------------------------
    > >> >     >     President - CoSMo Software Consulting, Singapore
    > >> >     >   
     -----------------------------------------------------------
    > >> -------------------------
    > >> >     >     sg.linkedin.com/agouaillard
    <http://sg.linkedin.com/agouaillard>
    > >> >     <http://sg.linkedin.com/agouaillard
    <http://sg.linkedin.com/agouaillard>>
    > >> >     <http://sg.linkedin.com/agouaillard
    <http://sg.linkedin.com/agouaillard>
    > >> >     <http://sg.linkedin.com/agouaillard
    <http://sg.linkedin.com/agouaillard>>>
    > >> >     >
    > >> >     >       *
    > >> >     >
    > >> >     >
    > >> >     >
    > >> >
    > >> >
    > >> >
    > >> >
    > >> > --
    > >> > Alex. Gouaillard, PhD, PhD, MBA
    > >> > ------------------------------------------------------------
    > >> ------------------------
    > >> > President - CoSMo Software Consulting, Singapore
    > >> > ------------------------------------------------------------
    > >> ------------------------
    > >> > sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>
    <http://sg.linkedin.com/agouaillard
    <http://sg.linkedin.com/agouaillard>>
    > >> >   *

    --

    Niels ten Oever
    Head of Digital

    Article 19
    www.article19.org <http://www.article19.org>

    PGP fingerprint    2458 0B70 5C4A FD8A 9488
                       643A 0ED8 3F3A 468A C8B3

---

From: Daniel Burnett <[email-masked]>
Date: Fri, 3 Nov 2017 06:02:18 -0400

Here's the description:

******
WebRTC, Web Real-Time Communications, is revolutionizing the way web users
communicate, both in the consumer and enterprise worlds. WebRTC adds
standard APIs and built-in real-time audio and video capabilities and
codecs to browsers without a plug-in. With just a few lines of JavaScript,
web developers can add high quality peer-to-peer voice, video, and data
channel communications to their collaboration, conferencing, telephony, or
even gaming site or application.

Presented by Dan Burnett, WebRTC Spec editor and co-author of the popular
"WebRTC: APIs and RTCWEB Protocols of the HTML5 Real-Time Web", and "Dr.
Alex" Gouaillard, the king of WebRTC testing, this tutorial rapidly covers
the breadth of topics involved in WebRTC, from STUN and TURN, to
getUserMedia(), to SDP offer/answer and more, finishing with a status check
on today's implementations of the technology.
******

On Thu, Nov 2, 2017 at 5:45 AM, Niels ten Oever <[email-masked]> wrote:

>     > >> >     > Yes.  My tutorial (developed with Alan Johnston)
>     presumes very
>     > >> little
>     > >> >     > background knowledge since it is intended for general
>     technical
>     > >> >     > audiences.  I am happy to give that tutorial or, as
>     Alex says,
>     > >> split the
>     > >> >     > time with him so he can cover WebRTC from an IoT/C++
>     perspective.
>     > >> >     >
>     > >> >     > -- dan
>     > >> >     >
>     > >> >     > On Tue, Oct 3, 2017 at 11:54 AM, Alexandre GOUAILLARD
>     > >> >     > <[email-masked] <mailto:[email-masked]>
>     > >> >     >     dan and i will land on Sunday morning (12) and
>     could do a
>     > >> tutorial,
>     > >> >     >     either together or separately.
>     > >> >     >     Dan has the usual JS slides. I just made an Iot / C++
>     > >> tutorial at
>     > >> >     >     IIT-RTC in chicago.
>     > >> >     >
>     > >> >     >     On Tue, Oct 3, 2017 at 5:52 PM, Cullen Jennings <
>     > >> >     >     <mailto:[email-masked] <mailto:[email-masked]>
>     > >> >     >         Connecting everyone together here.
>     > >> >     >
>     > >> >     >         Dan, Alan, Dr Alex, .... any chance you can
>     help with a
>     > >> WebRTC
>     > >> >     >         tutorial.
>     > >> >     >
>     > >> >     >         Cullen
>     > >> >     >
>     > >> >     >
>     > >> >     >         > On Oct 3, 2017, at 8:16 AM, Niels ten Oever
>     > >> >     >         <[email-masked]
>     > >> >     >         > Thanks Cullen, would be great if you could
>     make the
>     > >> intros!
>     > >> >     >         >
>     > >> >     >         > Thanks in advance,
>     > >> >     >         >
>     > >> >     >         > Niels
>     > >> >     >         >
>     > >> >     >         > Niels ten Oever
>     > >> >     >         > Head of Digital
>     > >> >     >         >
>     > >> >     >         > Article 19
>     > >> >     >         > On 10/03/2017 05:15 PM, Cullen Jennings wrote:
>     > >> >     >         >>
>     > >> >     >         >> I'm going to be remote for IETF 100 so I
>     don't think I
>     > >> can do
>     > >> >     >         it. Justin is the other person I know who has
>     given some
>     > >> >     >         tutorials but I doubt he will be there. Dan
>     Burnett and
>     > >> Alan
>     > >> >     >         Johnson do good presentation on WebRTC. So does
>     Alexandr
>     > >> >     >         Gouaillard. I think thoses would be the go to
>     people for
>     > >> me.
>     > >> >     >         Glad to introduct to any of them if that helps.
>     > >> >     >         >>
>     > >> >     >         >>
>     > >> >     >         >>> On Oct 3, 2017, at 8:07 AM, Niels ten Oever
>     > >> >     >         <[email-masked]
>     > >> >     >         >>> Hi Cullen,
>     > >> >     >         >>> Any chance you would be willing and able to
>     give a
>     > >> tutorial
>     > >> >     >         on webRTC on
>     > >> >     >         >>> Sunday during IETF100 in Singapore?
>     > >> >     >         >>>
>     > >> >     >         >>> If not, would you know of someone else
>     willing to do
>     > >> so?
>     > >> >     >         >>>
>     > >> >     >         >>> Best,
>     > >> >     >         >>>
>     > >> >     >         >>> Niels
>     > >> >     >         >>>
>     > >> >     >
>     > >> >     >
>     > >> >     >
>     > >> >     >
>     > >> >     >     --
>     > >> > sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard
> >

---

From: Alexa Morris <[email-masked]>
Date: Fri, 3 Nov 2017 06:35:57 -0700

Hi Dan,

I’ve uploaded the description to the datatracker. Please let me know when the slides are ready for community consumption and we’ll get those uploaded as well.

Alexa

> On Nov 3, 2017, at 3:02 AM, Daniel Burnett <[email-masked]> wrote:
> 
> Here's the description:
> 
> ******
> WebRTC, Web Real-Time Communications, is revolutionizing the way web users communicate, both in the consumer and enterprise worlds. WebRTC adds standard APIs and built-in real-time audio and video capabilities and codecs to browsers without a plug-in. With just a few lines of JavaScript, web developers can add high quality peer-to-peer voice, video, and data channel communications to their collaboration, conferencing, telephony, or even gaming site or application.
> 
> Presented by Dan Burnett, WebRTC Spec editor and co-author of the popular "WebRTC: APIs and RTCWEB Protocols of the HTML5 Real-Time Web", and "Dr. Alex" Gouaillard, the king of WebRTC testing, this tutorial rapidly covers the breadth of topics involved in WebRTC, from STUN and TURN, to getUserMedia(), to SDP offer/answer and more, finishing with a status check on today's implementations of the technology.
> ******
> 
> On Thu, Nov 2, 2017 at 5:45 AM, Niels ten Oever <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi EDU team,
> 
> From:   Daniel Burnett <[email-masked] <mailto:[email-masked]>>
> To:     Niels ten Oever <[email-masked] <mailto:[email-masked]>>
> CC:     Alexandre GOUAILLARD <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> Niels,
> 
> <https://drive.google.com/file/d/0By7sZyoGDdAcMUdNOGxnRXp3TTg/view?usp=drive_web <https://drive.google.com/file/d/0By7sZyoGDdAcMUdNOGxnRXp3TTg/view?usp=drive_web>>
> ​
> 
> On Mon, Oct 16, 2017 at 5:39 AM, Niels ten Oever <[email-masked] <mailto:[email-masked]>
>     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     > wrote:
>     >
>     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     > > wrote:
>     > >
>     > >> Dear Dr. Alex,
>     > >>
>     > >> www.article19.org <http://www.article19.org/> <http://www.article19.org <http://www.article19.org/>>
>     > >>
>     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     > >> > <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     > >> >
>      https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>
>     <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>>
>     > >> >   
>      <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>
>     <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters <https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters>>>
>     > >> >
>     > >> >     www.article19.org <http://www.article19.org/> <http://www.article19.org <http://www.article19.org/>>
>     <http://www.article19.org <http://www.article19.org/>>
>     > >> >
>     > >> >     > <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     > >> >     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>> <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>>>
>     > >> wrote:
>     > >> >     >
>     > >> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>> <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     > >> >     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>>> wrote:
>     > >> >     >
>     > >> >     >
>     <mailto:[email-masked] <mailto:[email-masked]>> <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     > >> >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>>> wrote:
>     > >> >     >         >
>     > >> >     >         > www.article19.org <http://www.article19.org/> <http://www.article19.org <http://www.article19.org/>>
>     <http://www.article19.org <http://www.article19.org/>>
>     > >> >     <http://www.article19.org <http://www.article19.org/>>
>     > >> >     >         >
>     <mailto:[email-masked] <mailto:[email-masked]>> <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     > >> >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>>> wrote:
>     > >> >     >         >>>
>     > >> >     >         >>> Hi Cullen,
>     > >> >     >         >>>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>
>     > >> >     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>>
>     > >> >     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>
>     > >> >     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>>>
>     > >> >     >
>     > >> >     >       *
>     > >> >     >
>     > >> >     >
>     > >> >     >
>     > >> >
>     > >> >
>     > >> >
>     > >> >
>     > >> > --
>     > >> > sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard> <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>
>     <http://sg.linkedin.com/agouaillard <http://sg.linkedin.com/agouaillard>>>
>     > >> >
>     > >> >   *
>     > >> >
>     > >> >
>     > >>
>     > >>
> 
>     --
> 
>     Niels ten Oever
>     Head of Digital
> 
>     Article 19
>     www.article19.org <http://www.article19.org/> <http://www.article19.org <http://www.article19.org/>>
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Daniel Burnett <[email-masked]>
Date: Fri, 03 Nov 2017 15:03:00 +0000

Hi Alexa.  I am done with the slides (meaning the ones Niels forwarded to
you) unless someone on the EDU team has objections.  I have not heard from
Alex Gouaillard ([email-masked], CC'd) whether he will have any
slides to add or whether his piece will all be live from a website.

-- dan

On Fri, Nov 3, 2017 at 9:35 AM Alexa Morris <[email-masked]> wrote:

> Hi Dan,
>
> I’ve uploaded the description to the datatracker. Please let me know when
> the slides are ready for community consumption and we’ll get those uploaded
> as well.
>
> Alexa
>
>> <
>> https://drive.google.com/file/d/0By7sZyoGDdAcMUdNOGxnRXp3TTg/view?usp=drive_web
>> >
>> ​
>>

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 3 Nov 2017 16:57:22 +0100

Looks good to me!

Best,

Niels

-- 

Niels ten Oever
Head of Digital

Article 19
www.article19.org

---

From: Alexa Morris <[email-masked]>
Date: Fri, 3 Nov 2017 12:48:38 -0700

Is there any way to make the file size smaller? The datatracker won’t let me upload the file because it’s 71.7 MB and the limit is 39.1 MB. 

Alexa

> On Nov 3, 2017, at 8:57 AM, Niels ten Oever <[email-masked]> wrote:
> 
> Looks good to me!
> 
> Best,
> 
> Niels
>

---

From: Greg Wood <[email-masked]>
Date: Fri, 3 Nov 2017 16:10:47 -0400

FYI: I’ve just sent Alexa a reduced version using the Quartz filter in Apple Preview (and not sent it to everyone).

> On Nov 3, 2017, at 3:48 PM, Alexa Morris <[email-masked]> wrote:
>

---

From: Daniel Burnett <[email-masked]>
Date: Fri, 3 Nov 2017 16:25:09 -0400

Thank you.  Sometimes PPT writes out a ridiculously large PDF file.  Also,
I understand that sometimes the Quartz 'Reduce File Size' can result in
crummy quality.  Does the result you have look clear?

-- dan

On Fri, Nov 3, 2017 at 4:10 PM, Greg Wood <[email-masked]> wrote:

> FYI: I’ve just sent Alexa a reduced version using the Quartz filter in
> Apple Preview (and not sent it to everyone).
>
> > Is there any way to make the file size smaller? The datatracker won’t
> let me upload the file because it’s 71.7 MB and the limit is 39.1 MB.
> >
> > Alexa
> >

---

From: Greg Wood <[email-masked]>
Date: Fri, 3 Nov 2017 16:41:40 -0400

Hi,

Yes—I took a look before sending and it seems acceptable to me as a download. But do double check once it is posted.

I’m no expert, but based on my experience my guess would be that it is the background with the subtle gradients that is causing the file to be so large.

-Greg

> On Nov 3, 2017, at 4:25 PM, Daniel Burnett <[email-masked]> wrote:
> 
> Thank you.  Sometimes PPT writes out a ridiculously large PDF file.  Also, I understand that sometimes the Quartz 'Reduce File Size' can result in crummy quality.  Does the result you have look clear?
> 
> -- dan
> 
>

---

From: Alexa Morris <[email-masked]>
Date: Fri, 3 Nov 2017 16:15:49 -0700

It’s uploaded now if you want to take a look: https://datatracker.ietf.org/meeting/agenda/#2017-11-12-090000 <https://datatracker.ietf.org/meeting/agenda/#2017-11-12-090000>.

Alexa

> On Nov 3, 2017, at 1:41 PM, Greg Wood <[email-masked]> wrote:
> 
> Hi,
>

---

From: Alice Russo <[email-masked]>
Date: Wed, 8 Nov 2017 11:50:19 -0800

Dan,

Thanks for your work on this tutorial for IETF 100. I realize the slides are already posted at this point - editorial nits below in case you are updating. (I'm guessing the content has been reviewed by the rtcweb wg chairs.)

Thanks,
Alice

--
s2 
consider adding an outline or overview slide to let the audience know what's going to be covered. consider moving s5 (benefits), s12 (joint effort), s13 (protocols) to provide context earlier.

s32
Source Specific Attributes -> Source-Specific Attributes
[add hyphen]

s40
new RFC 7118 -> RFC 7118 
[new is relative. over 3 years old - published Jan. 2014.]

s45
Bi-directional -> Bidirectional
[to match usage elsewhere]

s47
Third Party Identity Service -> Third-Party Identity Service
[add hyphen]

s48
[in the footer, there's a draft name overlapping existing text]

s52
The standard recently added -> WebRTC 1.0 recently added
[suggest using the name of the standard for precision]

---

From: Daniel Burnett <[email-masked]>
Date: Wed, 8 Nov 2017 20:43:42 -0500

Thanks Alice.  I probably won't update at this point since it has been
uploaded, but these are good catches.  I am not aware of the RTCWEB chairs
having reviewed this, not having sought them out (since this is a WebRTC
tutorial, not an RTCWEB tutorial).  Feel free to ask Cullen Jennings if you
have concerns, though, as he is an RTCWEB chair and is familiar with my
involvement as both the editor of the WebRTC specification and a frequent
speaker on WebRTC at conferences and elsewhere.

-- dan

On Wed, Nov 8, 2017 at 2:50 PM, Alice Russo <[email-masked]> wrote:

> Dan,
>
> Thanks for your work on this tutorial for IETF 100. I realize the slides
> are already posted at this point - editorial nits below in case you are
> updating. (I'm guessing the content has been reviewed by the rtcweb wg
> chairs.)
>
> Thanks,
> Alice
>
> --
> s2
> consider adding an outline or overview slide to let the audience know
> what's going to be covered. consider moving s5 (benefits), s12 (joint
> effort), s13 (protocols) to provide context earlier.
>
> s32

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 9 Nov 2017 02:04:48 +0000

Hi Daniel,

Thanks for your work on the tutorial. It really isn’t a problem to upload a new version of slides if you want to make any changes or corrections. Any clarification to reduce confusion over the various pieces would be helpful. It might help people unfamiliar with the effort to see how all the pieces fit together earlier (or not…)

You probably know this, but we will be recording the tutorial and uploading it to the website as well.

Thanks again,
Karen

On Nov 8, 2017, at 8:43 PM, Daniel Burnett <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Alice.  I probably won't update at this point since it has been uploaded, but these are good catches.  I am not aware of the RTCWEB chairs having reviewed this, not having sought them out (since this is a WebRTC tutorial, not an RTCWEB tutorial).  Feel free to ask Cullen Jennings if you have concerns, though, as he is an RTCWEB chair and is familiar with my involvement as both the editor of the WebRTC specification and a frequent speaker on WebRTC at conferences and elsewhere.

-- dan

On Wed, Nov 8, 2017 at 2:50 PM, Alice Russo <[email-masked]<mailto:[email-masked]>> wrote:
Dan,

Thanks,
Alice

s32

s40
new RFC 7118 -> RFC 7118

s45

s47

s48

s52

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

---

From: Daniel Burnett <[email-masked]>
Date: Wed, 8 Nov 2017 22:35:41 -0500

Thanks Karen.  The problem is on my end.  I am chairing meetings here at
the W3C TPAC meeting in California for the next two days and just have run
out of time to make any changes.  If I end up with time after I land Sunday
morning in Singapore (and can keep my eyes open), I'll see what I can do.
If you decide you need to cancel my tutorial because of concerns over my
slides, I understand and will abide by your decision.

-- dan

On Wed, Nov 8, 2017 at 9:04 PM, Karen O'Donoghue <[email-masked]> wrote:

> Hi Daniel,
>
> Thanks for your work on the tutorial. It really isn’t a problem to upload
> a new version of slides if you want to make any changes or corrections. Any
> clarification to reduce confusion over the various pieces would be helpful.
> It might help people unfamiliar with the effort to see how all the pieces
> fit together earlier (or not…)
>
> On Nov 8, 2017, at 8:43 PM, Daniel Burnett <[email-masked]>
> wrote:
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 9 Nov 2017 03:43:21 +0000

Dan,

Oh no… I definitely don’t feel the need to cancel your tutorial. I was just pointing out you could make changes if you wanted. I completely get the “I have no cycles” at this time problem. I had originally hoped to attend TPAC, but the two meetings back to back is just brutal. Safe travels and see you Sunday.

Regards,
Karen

On Nov 8, 2017, at 10:35 PM, Daniel Burnett <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Karen.  The problem is on my end.  I am chairing meetings here at the W3C TPAC meeting in California for the next two days and just have run out of time to make any changes.  If I end up with time after I land Sunday morning in Singapore (and can keep my eyes open), I'll see what I can do.
If you decide you need to cancel my tutorial because of concerns over my slides, I understand and will abide by your decision.

-- dan

On Wed, Nov 8, 2017 at 9:04 PM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
Hi Daniel,

Thanks again,
Karen

-- dan

Thanks,
Alice

s32

s40
new RFC 7118 -> RFC 7118

s45

s47

s48

s52

---

From: Daniel Burnett <[email-masked]>
Date: Thu, 9 Nov 2017 19:56:18 -0500

Quick question:  when can/should I arrive to be able to just flip through
all the slides you have loaded to make sure everything looks okay?

-- dan

On Wed, Nov 8, 2017 at 10:43 PM, Karen O'Donoghue <[email-masked]>
wrote:

> Dan,
>
> Oh no… I definitely don’t feel the need to cancel your tutorial. I was
> just pointing out you could make changes if you wanted. I completely get
> the “I have no cycles” at this time problem. I had originally hoped to
> attend TPAC, but the two meetings back to back is just brutal. Safe travels
> and see you Sunday.
>
> Regards,
> Karen
>
> On Nov 8, 2017, at 10:35 PM, Daniel Burnett <[email-masked]>
> wrote:
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Fri, 10 Nov 2017 01:28:20 +0000

They are online now…

https://datatracker.ietf.org/meeting/100/materials/slides-100-edu-sessm-webrtc-tutorial/

Karen

On Nov 10, 2017, at 8:56 AM, Daniel Burnett <[email-masked]<mailto:[email-masked]>> wrote:

Quick question:  when can/should I arrive to be able to just flip through all the slides you have loaded to make sure everything looks okay?

-- dan

On Wed, Nov 8, 2017 at 10:43 PM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
Dan,

Regards,
Karen

-- dan

Thanks again,
Karen

-- dan

Thanks,
Alice

s32

s40
new RFC 7118 -> RFC 7118

s45

s47

s48

s52

---

From: Daniel Burnett <[email-masked]>
Date: Sat, 11 Nov 2017 20:31:34 -0500

Well, I was able to do some updates while on the plane (including your
suggestions).  Is it too late to post this updated version for the WebRTC
tutorial?

-- dan

---

From: Karen O'Donoghue <[email-masked]>
Date: Sun, 12 Nov 2017 02:05:06 +0000

I’ve got them uploaded.

Thanks!
Karen

On Nov 12, 2017, at 9:31 AM, Daniel Burnett <[email-masked]<mailto:[email-masked]>> wrote:

Well, I was able to do some updates while on the plane (including your suggestions).  Is it too late to post this updated version for the WebRTC tutorial?

-- dan

Thanks,
Alice

s32

s40
new RFC 7118 -> RFC 7118

s45

s47

s48

s52

> Daniel will share description for the session soon.

<IETF100WebRTC201711comp.pdf>_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

---

From: Karen O'Donoghue <[email-masked]>
Date: Sun, 12 Nov 2017 03:01:01 +0000

Uploaded…

-- dan

Thanks,
Alice

s32

s40
new RFC 7118 -> RFC 7118

s45

s47

s48

s52