Subject: Re: [edu-team] IETF Tutorial on TLS1.3

From: Sean Turner <[email-masked]>
Date: Wed, 8 Nov 2017 20:05:53 -0500

Hi Sean,
Thank you for your work on this tutorial for IETF 100. A couple nits: 
- s1: suggest removing "Newcomer's" because that typically refers to a specific tutorial session. perhaps IETF Newcomer's Tutorial 20171112 -> IETF 100 Singapore 20171112

[spt] sold

- s?: how about adding a list of relevant drafts. e.g., a roadmap of the 1.3-related drafts. If you decide to include ones that aren't WG docs yet, it might help people find what they're interested in. (Searching for 1.3 in the datatracker turns up the list below.)

[spt] Here be dragons!  the main draft is referred to on page 6 - they just need to click the link.  Only two others are really relevant: vectors and DTLS1.3; I’ll add a slide at the end for those.  draft-camwinget, draft-green, and draft-rhdh all want to be TLS1.3-related but the WG is not yet sold - some in the WG are very, violently not sold on them and would probably scream bloody murder if we were to suggest that they are even related.  draft-whyte desperately wants to be “related” but the WG is not yet sold that his solution is the “one” so I think it would not be fair to elevate it in our talk.  tokbind is something really different and is probably worthy of a whole other tutorial.

draft-ietf-tls-tls13-21 
The Transport Layer Security (TLS) Protocol Version 1.3            

draft-ietf-tls-tls13-vectors-02 
Example Handshake Traces for TLS 1.3

draft-ietf-tls-dtls13-02 
The Datagram Transport Layer Security (DTLS) Protocol Version 1.3

draft-ietf-tokbind-tls13-0rtt-02 
Token Binding for 0-RTT TLS 1.3 Connections

draft-camwinget-tls-use-cases-00 
TLS 1.3 Impact on Network-Based Security

draft-green-tls-static-dh-in-tls13-01 
Data Center use of Static Diffie-Hellman in TLS 1.3

draft-nharper-tokbind-tls13-00 
Token Binding for Transport Layer Security (TLS) Version 1.3 Connections            

draft-rhrd-tls-tls13-visibility-00 
TLS 1.3 Option for Negotiation of Visibility in the Datacenter

draft-whyte-qsh-tls13-06 
Quantum-Safe Hybrid (QSH) Key Exchange for Transport Layer Security (TLS) version 1.3

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 9 Nov 2017 01:28:16 +0000

Thanks Sean and Joe,

My (very) quick review didn’t come up with anything substantial. Looks like a fun tutorial… 

Karen

> On Nov 8, 2017, at 8:05 PM, Sean Turner <[email-masked]> wrote:
> 
> Hi Sean,
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Joseph Salowey <[email-masked]>
Date: Thu, 9 Nov 2017 09:19:42 -0800

I agree with Sean that we should probably stick to things that are working
group items.  There are a few other working group items,  such as
draft-ietf-tls-grease-00, that I would include before non adopted drafts.
We will mention some the issues behind these non-wg drafts when we talk
about forward secrecy and privacy.

Cheers,

Joe

On Wed, Nov 8, 2017 at 5:05 PM, Sean Turner <[email-masked]> wrote:

> - s1: suggest removing "Newcomer's" because that typically refers to a
> specific tutorial session. perhaps IETF Newcomer's Tutorial 20171112 ->
> IETF 100 Singapore 20171112
>
> [spt] sold
>
> - s?: how about adding a list of relevant drafts. e.g., a roadmap of the
> 1.3-related drafts. If you decide to include ones that aren't WG docs yet,
> it might help people find what they're interested in. (Searching for 1.3 in
> the datatracker turns up the list below.)
>
> [spt] Here be dragons!  the main draft is referred to on page 6 - they
> just need to click the link.  Only two others are really relevant: vectors
> and DTLS1.3; I’ll add a slide at the end for those.  draft-camwinget,
> draft-green, and draft-rhdh all want to be TLS1.3-related but the WG is not
> yet sold - some in the WG are very, violently not sold on them and would
> probably scream bloody murder if we were to suggest that they are even
> related.  draft-whyte desperately wants to be “related” but the WG is not
> yet sold that his solution is the “one” so I think it would not be fair to
> elevate it in our talk.  tokbind is something really different and is
> probably worthy of a whole other tutorial.
>
> draft-ietf-tls-tls13-21

---

From: Karen O'Donoghue <[email-masked]>
Date: Fri, 10 Nov 2017 01:31:03 +0000

Do you have an updated version of the slides (or can I upload the draft sent by Mirjam?)

Thanks,
Karen

On Nov 10, 2017, at 1:19 AM, Joseph Salowey <[email-masked]<mailto:[email-masked]>> wrote:

I agree with Sean that we should probably stick to things that are working group items.  There are a few other working group items,  such as draft-ietf-tls-grease-00, that I would include before non adopted drafts.  We will mention some the issues behind these non-wg drafts when we talk about forward secrecy and privacy.

Cheers,

Joe

On Wed, Nov 8, 2017 at 5:05 PM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sean,
Thank you for your work on this tutorial for IETF 100. A couple nits:
- s1: suggest removing "Newcomer's" because that typically refers to a specific tutorial session. perhaps IETF Newcomer's Tutorial 20171112 -> IETF 100 Singapore 20171112

[spt] sold

draft-ietf-tls-tls13-21

draft-ietf-tls-dtls13-02

draft-whyte-qsh-tls13-06

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

---

From: Sean Turner <[email-masked]>
Date: Thu, 9 Nov 2017 18:33:50 -0800

Please wait Joe’s got some edits I’d like to talk over.  I suspect we’ll be able to upload them Saturday afternoon.

spt

> On Nov 9, 2017, at 17:31, Karen O'Donoghue <[email-masked]> wrote:
> 
>> On Nov 10, 2017, at 1:19 AM, Joseph Salowey <[email-masked]> wrote:
>>

---

From: Alexa Morris <[email-masked]>
Date: Sun, 12 Nov 2017 10:22:26 +0800

Sean,

When you present your slides, can you also include a link to the tutorial survey that we’ve developed? Also, do you have a version ready for posting to the Datatracker?

https://www.surveymonkey.com/r/100tls <https://www.surveymonkey.com/r/100tls>

Thanks,
Alexa

> On Nov 10, 2017, at 10:33 AM, Sean Turner <[email-masked]> wrote:
>

---

From: Niels ten Oever <[email-masked]>
Date: Sun, 12 Nov 2017 03:25:53 +0100

I'll be also coming to do a v short intro to remind newcomers of our
evaluation session Thursday morning as well as the survey.

Karen will be covering the newcomersession.

Cheers,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

On 11/12/2017 03:22 AM, Alexa Morris wrote:
> Sean,
> 
> When you present your slides, can you also include a link to the
> tutorial survey that we’ve developed? Also, do you have a version ready
> for posting to the Datatracker?
> 
> https://www.surveymonkey.com/r/100tls
> 
> Thanks,
> Alexa
> 
>> On Nov 10, 2017, at 10:33 AM, Sean Turner <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> Please wait Joe’s got some edits I’d like to talk over.  I suspect
>> we’ll be able to upload them Saturday afternoon.
>>
>> spt
>>
>>> On Nov 9, 2017, at 17:31, Karen O'Donoghue <[email-masked]
>>> <mailto:[email-masked]>> wrote:
>>>
>>>> I agree with Sean that we should probably stick to things that are
>>>> working group items.  There are a few other working group items,
>>>>  such as draft-ietf-tls-grease-00, that I would include before non
>>>> adopted drafts.  We will mention some the issues behind these non-wg
>>>> drafts when we talk about forward secrecy and privacy.  
>>>>
>>>> Cheers,
>>>>
>>>> Joe
>>>>
>>>> - s1: suggest removing "Newcomer's" because that typically refers to
>>>> a specific tutorial session. perhaps IETF Newcomer's Tutorial
>>>> 20171112 -> IETF 100 Singapore 20171112
>>>>
>>>> [spt] sold
>>>>
>>>> - s?: how about adding a list of relevant drafts. e.g., a roadmap of
>>>> the 1.3-related drafts. If you decide to include ones that aren't WG
>>>> docs yet, it might help people find what they're interested in.
>>>> (Searching for 1.3 in the datatracker turns up the list below.)
>>>>
>>>> [spt] Here be dragons!  the main draft is referred to on page 6 -
>>>> they just need to click the link.  Only two others are really
>>>> relevant: vectors and DTLS1.3; I’ll add a slide at the end for
>>>> those.  draft-camwinget, draft-green, and draft-rhdh all want to be
>>>> TLS1.3-related but the WG is not yet sold - some in the WG are very,
>>>> violently not sold on them and would probably scream bloody murder
>>>> if we were to suggest that they are even related.  draft-whyte
>>>> desperately wants to be “related” but the WG is not yet sold that
>>>> his solution is the “one” so I think it would not be fair to elevate
>>>> it in our talk.  tokbind is something really different and is
>>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: Sean Turner <[email-masked]>
Date: Sun, 12 Nov 2017 10:52:11 +0800

Here’s an update pdf deck with a link to the tutorial.  Do we get to see the grades after it’s done?

spt

> On Nov 12, 2017, at 10:22, Alexa Morris <[email-masked]> wrote:
> 
> Sean,
>

---

From: Alexa Morris <[email-masked]>
Date: Sun, 12 Nov 2017 10:59:31 +0800

Sean,

Yes, we will share results with you after the meeting. :-)

Thanks for including a link to the survey. If you happen to have time, can you also write out the actual link on the final slide? The way it’s done now someone has to have downloaded the slides in order to follow the link to the survey.

Alexa

> On Nov 12, 2017, at 10:52 AM, Sean Turner <[email-masked]> wrote:
> 
> <tls1.3_tutorial.pdf>

---

From: Sean Turner <[email-masked]>
Date: Sun, 12 Nov 2017 11:00:43 +0800

Anything for our leaders!

spt

> On Nov 12, 2017, at 10:59, Alexa Morris <[email-masked]> wrote:
> 
> Sean,
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Sun, 12 Nov 2017 03:20:09 +0000

Uploaded… and yes…

Karen

On Nov 12, 2017, at 10:52 AM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:

spt

> On Nov 12, 2017, at 10:22, Alexa Morris <[email-masked]<mailto:[email-masked]>> wrote:
>
> Sean,
>
>> On Nov 10, 2017, at 10:33 AM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:
>>
>>> On Nov 9, 2017, at 17:31, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
>>>

<tls1.3_tutorial.pdf>

---

From: Sean Turner <[email-masked]>
Date: Mon, 13 Nov 2017 11:48:25 +0800

A revised version to address two editorial nits noted during the presentation.

spt

> On Nov 12, 2017, at 11:20, Karen O'Donoghue <[email-masked]> wrote:
> 
> Uploaded… and yes…
> 
> Karen
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 13 Nov 2017 04:37:06 +0000

Thanks. I’ve uploaded them.

Karen

> On Nov 13, 2017, at 11:48 AM, Sean Turner <[email-masked]> wrote:
> 
> <tls1.3_tutorial.pdf>