Subject: Re: [edu-team] xml2rfc v3 tutorial for IETF 104

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 4 Feb 2019 14:57:54 +0100

Hi Alice,

I am not sure you received any feedback on this. We would definitely
like to schedule a tools tutorial at IETF 104. Regarding the options
below, the second option sounds "complete", but may be too much for one
hour?

Best regards,
Mirjam

On 10/01/2019 01:32, Alice Russo wrote:
> Hi all,
> 
> We've discussed having a Sunday tutorial at IETF 104 about using xml2rfc v3, the tool for creating the future publication formats of RFCs. Stepping back a bit -- when having a tutorial about tool(s) for creating Internet-Drafts, do you have any preference about its scope? That is, do you think it should be about:
> 
> a) xml2rfc v3 (include quick-start guide; highlight the new vocab & features).  perhaps similar to "Intro to xml2rfc" [1] last given in 2014 - but updated from v2 to v3. 
> 
> or
> 
> b) "Tools for Creating I-Ds" revamped to focus on 2 options: kramdown and xml2rfc v3.
> perhaps similar to Dan York's "Writing I-Ds in Markdown" [2] 
> and the "Tools for Creating I-Ds" tutorial [3] - last given in 2015, when it was focused on xml2rfc and NroffEdit.
> 
> (Of course, any tutorial could mention the many tools [4] available.)
> 
> [1] https://www.rfc-editor.org/materials/intro_xml2rfc_90.pdf
> [2] https://github.com/danyork/writing-internet-drafts-in-markdown/blob/master/writing-internet-drafts-in-markdown.pdf
> [3] https://www.rfc-editor.org/materials/tools_ids_rfcs_94.pdf
> [4] https://www.rfc-editor.org/pubprocess/tools/
> 
> Thanks,
> Alice
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Alice Russo <[email-masked]>
Date: Mon, 4 Feb 2019 10:26:17 -0800

Hi team,

Just an update: I received 2 votes for B, and zero for A. So, proceeding with Paul Hoffman presenting the xml2rfc portion, and Dan York is available to present on markdown (a condensed version of his slides -- [2] below). 

Do you know yet which time slot? If same schedule as IETF 103, 1230-1330 or 1345-1445? As Mirjam pointed out, one hour could be tight (e.g., 5 min intro, 25 min xml2rfc, 20 min markdown, 10 min Q&A.) Open to suggestions.

Draft paragraph below:

"Tools for Creating Internet-Drafts" will give an overview of the tools available and will focus on two of them: xml2rfc v3 and kramdown. This tutorial will highlight how to use the new features of xml2rfc, specifically how to include non-ASCII characters and SVG figures in your I-D. There will be a quick-start guide to using markdown, specifically kramdown. 

Thanks,
Alice

> On Jan 9, 2019, at 4:32 PM, Alice Russo <[email-masked]> wrote:
> 
> Hi all,
>