Subject: [edu-team] Educational RFCs

From: <[email-masked]>
Date: Tue, 22 Jun 2021 18:34:21 +0300

Greetings to the edu-team,

Apologies if this has already been discussed in the past. I searched the
mail archives as much as possible but couldn't find anything similar.

On a course on Internet Protocols at the University of Piraeus
(https://www.ds.unipi.gr/en/courses/internet-protocols-2/), Professor
Rouskas and I, have begun a series of laboratory exercises where we want our
students to become adept at being able to read and implement internet
protocol specification documents, specifically from the IETF. 

With that goal in mind, we wrote a small IETF-like draft (using xml2rfc)
where we outlined a very simple protocol in detail and asked them to read
and implement it. 

That got us thinking whether it makes sense for the IETF and specifically
for the edu-team to create a series of educational RFCs with the goal of
providing material for Universities for preparing students/future-engineers
to be ready to participate in the IETF. 

We do understand that this is not the current focus of the edu-team and the
IETF in particular, but we were thinking whether it makes sense to expand
the charter to allow creating short introductory RFCs, where
attendees/students could be introduced into reading and understanding specs
at a smaller scale.

Regards,

Evangelos Haleplidis.

---

From: Fred Baker <[email-masked]>
Date: Wed, 23 Jun 2021 19:48:55 -0700

Speaking for myself; I think this is a reasonable idea. We once had a related series, the FYI series, and had an entire area fir them, called User Services.

Sent using a machine that autocorrects in interesting ways...

> On Jun 22, 2021, at 8:34 AM, [email-masked] wrote:
> 
> 
> Apologies if this has already been discussed in the past. I searched the mail archives as much as possible but couldn’t find anything similar.
>  
> On a course on Internet Protocols at the University of Piraeus (https://www.ds.unipi.gr/en/courses/internet-protocols-2/), Professor Rouskas and I, have begun a series of laboratory exercises where we want our students to become adept at being able to read and implement internet protocol specification documents, specifically from the IETF.
>  
> With that goal in mind, we wrote a small IETF-like draft (using xml2rfc) where we outlined a very simple protocol in detail and asked them to read and implement it.
>  
> That got us thinking whether it makes sense for the IETF and specifically for the edu-team to create a series of educational RFCs with the goal of providing material for Universities for preparing students/future-engineers to be ready to participate in the IETF.
>  
> We do understand that this is not the current focus of the edu-team and the IETF in particular, but we were thinking whether it makes sense to expand the charter to allow creating short introductory RFCs, where attendees/students could be introduced into reading and understanding specs at a smaller scale.
>  
> Regards,
> Evangelos Haleplidis.
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team