Subject: [Eligibility-discuss] Virtual BoF for draft-moonesamy-recall-rev

From: S Moonesamy <[email-masked]>
Date: Sat, 25 May 2019 14:48:28 -0700

Dear Area Directors,

I would like to propose a virtual BOF to discuss about 
draft-moonesamy-recall-rev.  The issues to be discussed are:

   Problem statement

   The current description of the process for handling recalls of
   NomCom-appointed roles is described in RFC 7437 and is being updated in
   draft-ietf-iasa2-rfc7437bis.  This work seeks to address only two specific
   issues with the process and is not intended to re-open a discussion of other
   aspects of recall procedures. The two issues are:

      - Ineligibility of IAB and IESG Members and other Nomcom Appointees
        to sign a recall petition

      - Ineligibility of remote participants to seek redress through the
        recall process

Regards,
S. Moonesamy

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 May 2019 22:05:17 +0000

The current description of the process for handling recalls of
       NomCom-appointed roles is described in RFC 7437 and is being updated in
       draft-ietf-iasa2-rfc7437bis.  ...

So why is your draft not appropriate to be discussed as part of the 7437bis document?

If your draft becomes an RFC at some point, do you expect it to say "updates 7437bis" ?

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 25 May 2019 23:21:16 +0100

My understanding of 7437bis is that the updates are intended to take account
of the LLC changes only and that "re-opening cans of worms" was off the
agenda.

Of course, 7437bis is transitioning from the IASA2 working group to being an
IAB document, so the scope could change, I suppose. But I would hope that
discussion of NomCom remains a community consensus document, not an IAB
document.

Best,
Adrian

-----Original Message-----
From: Eligibility-discuss <[email-masked]> On Behalf
Of Salz, Rich
Sent: 25 May 2019 23:05
To: S Moonesamy <[email-masked]>; [email-masked]
Subject: Re: [Eligibility-discuss] Virtual BoF for
draft-moonesamy-recall-rev

       The current description of the process for handling recalls of
       NomCom-appointed roles is described in RFC 7437 and is being updated
in
       draft-ietf-iasa2-rfc7437bis.  ...

So why is your draft not appropriate to be discussed as part of the 7437bis
document?

If your draft becomes an RFC at some point, do you expect it to say "updates
7437bis" ?

-- 
Eligibility-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eligibility-discuss

---

From: S Moonesamy <[email-masked]>
Date: Sat, 25 May 2019 15:34:21 -0700

Hi Rich,
>So why is your draft not appropriate to be discussed as part of the 

If I am not mistaken, the Responsible Area Director for IASA2 
determined that drafts which go beyond cosmetic updates are out of 
scope for that working group.

>If your draft becomes an RFC at some point, do you expect it to say 

Please see the first page of the draft.  It has an "Updates: 7437 (if 
approved)".  It is expected to update 7437bis if there is approval for that.

Regards,
S. Moonesamy

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Sun, 26 May 2019 09:58:38 +0000

I like the idea of a BoF on this topic. Were we to task the traditional questions to form a WG, I’m pretty confident that they would all (eventually) be answered in the affirmative.

That doesn’t mean, SM, however, that I would agree that your draft is the correct starting point.  EKR’s draft covers many of my concerns, and from an incremental standpoint that is where I would prefer to start. Not that remote participation isn’t an important issue, but rather we have clear examples of where his draft could have helped, it is well scoped, and probably not THAT controversial. 

Eliot

> On May 26, 2019, at 00:36, S Moonesamy <[email-masked]> wrote:
> 
> Hi Rich,
> If I am not mistaken, the Responsible Area Director for IASA2 determined that drafts which go beyond cosmetic updates are out of scope for that working group.
> 
> Please see the first page of the draft.  It has an "Updates: 7437 (if approved)".  It is expected to update 7437bis if there is approval for that.
> 
> Regards,
> S. Moonesamy
> 
> --

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 26 May 2019 11:23:17 +0100

Well, if a WG is needed/desirable, you have captured the process. Although (of course?) if EKR wants his draft to continue, he would need to request a BoF.

Personally speaking, I am considerably opposed to EKR's proposal. The members of the I* are appointed by NomCom on behalf of the community and their removal should also be by the community. I am not comforted by the suggestion that a NomCom appointee could always be reappointed even after removal by the fellow members of the I*. 

I understand that impeachment is a popular topic in some quarters at the moment, but I believe that recall has served us well for many years and we don't need to replace it, just modify its scope to enable the recent changes in participation.

Again speaking personally, I don't think a working group is necessary to work the issue in SM's draft, and I would like to see some progress made on that work relatively soon. I understand that a face-to-face discussion may provide some focus, but I also think that we could make some progress (as we just did with the thread about whether registered remote participation is an easy attack vector).

Best,
Adrian

-----Original Message-----
From: Eligibility-discuss <[email-masked]> On Behalf Of Eliot Lear (elear)
Sent: 26 May 2019 10:59
To: S Moonesamy <[email-masked]>
Cc: Salz, Rich <[email-masked]>; [email-masked]
Subject: Re: [Eligibility-discuss] Virtual BoF for draft-moonesamy-recall-rev

Eliot

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Sun, 26 May 2019 12:00:41 +0000

Well.  Clearly I was wrong about the controversy part :-).  I would beg to differ on the current process having served us well. To say that it has would mean that all people who should have been removed were, and that no others were. I am aware of at least three cases where at least the former part of the predicate is false. In all three cases this was due not to a difference of opinion or technical incompetence or irascibility, but simply being derelict.  That in turn informs me that we have made the current process unwieldy for the most uncontroversial of situations.

Eliot

> On May 26, 2019, at 12:24, Adrian Farrel <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 26 May 2019 05:20:00 -0700

On Sun, May 26, 2019 at 3:23 AM Adrian Farrel <[email-masked]> wrote:

> Well, if a WG is needed/desirable, you have captured the process. Although
> (of course?) if EKR wants his draft to continue, he would need to request a
> BoF.
>

Well, maybe.. BOFs and WGs are scoped to a problem statement, not an
document, and Mike and my draft would be clearly in scope for a BOF on
"revisit the procedure for removing I* members", whether I request a BOF or
not.

I understand that impeachment is a popular topic in some quarters at the
> moment, but I believe that recall has served us well for many years and we
> don't need to replace it, just modify its scope to enable the recent
> changes in participation.
>

This is an odd assertion in view of the fact that there has never been an
actual recall and the one near-recall seems to have been made much more
difficult by the clunky mechanism we have presently.

> Again speaking personally, I don't think a working group is necessary to
> work the issue in SM's draft,

As I noted in my initial comments on SM's draft, it's not clear to me what
"the issue in SM's draft is" (or, for that matter, whether it's a real
issue) so the first thing that would be required is to flesh out the
problem statement.

-Ekr

and I would like to see some progress made on that work relatively soon. I
> understand that a face-to-face discussion may provide some focus, but I
> also think that we could make some progress (as we just did with the thread
> about whether registered remote participation is an easy attack vector).
>
> Best,
> Adrian
>
> I like the idea of a BoF on this topic. Were we to task the traditional
> questions to form a WG, I’m pretty confident that they would all
> (eventually) be answered in the affirmative.
>
> That doesn’t mean, SM, however, that I would agree that your draft is the
> correct starting point.  EKR’s draft covers many of my concerns, and from
> an incremental standpoint that is where I would prefer to start. Not that
> remote participation isn’t an important issue, but rather we have clear
> examples of where his draft could have helped, it is well scoped, and
> probably not THAT controversial.
>
> Eliot
>
> > If I am not mistaken, the Responsible Area Director for IASA2 determined
> that drafts which go beyond cosmetic updates are out of scope for that
> working group.
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 26 May 2019 13:22:58 +0100

I probably can't speak to the cases you describe.

I did once start to put together a recall petition for an AD (so long ago that we need not dwell on the details). I found that collecting cosignatories was slow, but for good reasons. People generally said "Yes, bad stuff is happening, but recall is pretty serious. Can we think about other ways of handling this?". And, indeed, once the seriousness got discussed a bit, the AD concerned modified their behaviour (coincidence is not causation).

The process did not seem unwieldy to me, but making it more wieldy (for example by reducing the number of signatures needed) does not seem to be a bad idea to me. In fact, it is part of SM's draft, IIRC. 

However, adding a new process that allows removal of a community appointment by other than the community looks like a way of just increasing the chances of appeals and additional recalls. I think it is a discussion we could have, but I also think it is independent of SM's proposals.

Cheers,
Adrian

-----Original Message-----
From: Eliot Lear (elear) <[email-masked]> 
Sent: 26 May 2019 13:01
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Eligibility-discuss] Virtual BoF for draft-moonesamy-recall-rev

Eliot

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 May 2019 11:29:45 -0400

--On Sunday, 26 May, 2019 05:20 -0700 Eric Rescorla
<[email-masked]> wrote:

>> Well, if a WG is needed/desirable, you have captured the
>> process. Although (of course?) if EKR wants his draft to
>> continue, he would need to request a BoF.

> Well, maybe.. BOFs and WGs are scoped to a problem statement,
> not an document, and Mike and my draft would be clearly in
> scope for a BOF on "revisit the procedure for removing I*
> members", whether I request a BOF or not.

And that is one of the places where we have controversy.  I
haven't seen SM's BOF proposal yet, but, if I were writing the
problem statement for it, it would reflect what he, I, and
others, have said multiple times: having people who are
qualified according to the qualifications for the Nomcom able to
seek to remedy problems using the recall procedure, while those
who participate actively, perhaps even more actively than those
who are Nomcom-eligible prevented from doing so, is unreasonable
and reduces the credibility of the IETF as providing open and
equal treatment to all participants.
draft-moonesamy-recall-rev, in this current form, addresses two
specific categories of participants who are not now eligible to
initiate recalls, those who attend too few f2f meetings to meet
the present  nomcom eligibility criteria and those whose
exclusion by those criteria is due to their holding specific
nomcom-selected positions.

Now that is (deliberately, I believe) a very narrow change and
discussion.  It is a change that is worth making if we care
about either fairness or the perception of unfairness with the
procedures we have.

It puts/leaves the following out of scope:

(i) Whether the recall model works well or poorly as a means for
IETF participants, especially those who are not part of the
leadership to seek to correct a nomcom decision that, in
retrospect, turned out to be a bad one.   If it works poorly,
whether we have proposals for a good alternative and what those
proposals are.

(ii_ Whether the current nomcom eligibility model, based
entirely on paying registration fees and showing up at meetings,
is fair and reasonable.  To the extent to which it is a
surrogate for participation and/or knowledge, I think we all
know that it is a rather poor one (and I suggest it is getting
worse).  In particular, the original assumption that the nomcom
would be a representative sample of the participant community,
based on who could and did volunteer, that assumption becomes
progressively more false as the number of remote participants
rises.   On the other hand, even if we conclude that those
eligibility criteria work poorly, I'm not aware of any serious
proposal for other approaches (even though there has been talk
from time to time about allowing mostly-remote participants to
qualify).

(iii) Whether it is desirable that the recall model, voluntary
resignations, and, presumably, death in office be the only
mechanisms for removing members of the leadership.  There are
clearly cases in which the community should be able to fast
track a removal.   Using the one public example we have, if it
is obvious to everyone who is paying attention that someone has
basically stopped functioning in a particular position, maybe we
need a procedure in which non-response to several attempts to
notify someone and get a statement from them constitutes a
resignation.  Maybe we need something closer to ekr's proposal
(although I'd hope, a lot more transparent and allowing
community input).  Maybe we need both.  But those would almost
certainly be in addition to the recall mechanism  (or some
equivalent, community-initiated one), not instead of it.

I think all of those would be worthy topics.  But they have
nothing to do with the scope of draft-moonesamy-recall-rev as
proposed or the very narrow problem it is intended to address,
nor does that proposal in any way preempt addressing any or all
of the above if an when the community decides to do that.

>...
>> Again speaking personally, I don't think a working group is
>> necessary to work the issue in SM's draft,
 
> As I noted in my initial comments on SM's draft, it's not
> clear to me what "the issue in SM's draft is" (or, for that
> matter, whether it's a real issue) so the first thing that
> would be required is to flesh out the problem statement.

See above.

best,
   john

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 May 2019 13:40:10 -0400

--On Sunday, 26 May, 2019 13:22 +0100 Adrian Farrel
<[email-masked]> wrote:

> I did once start to put together a recall petition for an AD
> (so long ago that we need not dwell on the details). I found
> that collecting cosignatories was slow, but for good reasons.
> People generally said "Yes, bad stuff is happening, but recall
> is pretty serious. Can we think about other ways of handling
> this?". And, indeed, once the seriousness got discussed a bit,
> the AD concerned modified their behaviour (coincidence is not
> causation).
>...

And that, IMO, is one of the reasons we have disagreements about
whether the recall mechanism "works".  While I wish I was more
confident that it could be carried all the way to its conclusion
of removing people if necessary -- and doing so in less than
nine months or a year -- there is a very real sense in which, if
starting the process results, even coincidentally, in an adjust
of behavior behavior in more positive directions (good) or a
resignation (less good but still effective), it is doing its
job.   That does not make the perception of fairness and
accessibility to all active IETF participants any less
important; indeed it may make it more important.

  john

---

From: S Moonesamy <[email-masked]>
Date: Sun, 26 May 2019 11:35:08 -0700

Hi John,
>problem statement for it, it would reflect what he, I, and

The problem statement is at 
https://mailarchive.ietf.org/arch/msg/eligibility-discuss/ftKFY8H0epI1zUxMeHr_B_Vll7c

Regards,
S. Moonesamy