Subject: Re: [Eligibility-discuss] AD Sponsorship of draft-moonesamy-recall-rev

From: Alissa Cooper <[email-masked]>
Date: Sun, 19 May 2019 20:32:57 +0000

Hi SM,

Per my previous email [1], Alexey, Warren, and Suresh are guiding discussions about this, so I’ll let them respond.

Alissa

[1] https://mailarchive.ietf.org/arch/msg/ietf/deIOPYDkptO30L9Adg0IfpQ03kQ

> On May 19, 2019, at 12:33 AM, S Moonesamy <[email-masked]> wrote:
> 
> Dear IETF Chair,
> 
> A few months ago, I submitted a short draft about the revision of the recall initiation model [1].  Last month, the recommendation of the IESG was to submit a BOF proposal [2].  I had an email exchange with one of the Area Directors about the request for an IAB shepherd.  If I am not mistaken, an IAB shepherd can provide a review of architectural consistency and integrity.  Does the short draft require that type of review?
> 
> The "we think" [2] from the IESG is expressed in one sentence.  Would it be possible for the IESG to explain its understanding of the in-depth problem statement so that there could be a discussion?
> 
> Regards,
> S. Moonesamy
> 
> 1. https://tools.ietf.org/html/draft-moonesamy-recall-rev-02
> 2. https://mailarchive.ietf.org/arch/msg/ietf/KrycBOdMJzyypqFynXi9t1S1n-w
>

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 24 May 2019 19:54:56 -0400

Hi SM,

> On May 18, 2019, at 8:33 PM, S Moonesamy <[email-masked]> wrote:
> 
> Dear IETF Chair,
> 

I am not talking for the whole IESG but I will tell you my opinion as a sitting IESG member on why I did not want to AD sponsor this draft in its current condition. I think the proposal in the draft sets the bar too low specifically on the Section 2.2 front. One of the things that has kept the recall petitions rare is that that the people who initiate the petition need to have some accountability for doing so (I would call this “skin in the game” [0] but it does not translate well across cultures). Otherwise there will be no bar to filing frivolous petitions. This brings me to the elephant in the room. It is fairly trivial for someone to sign up 10 remote participant identities to initiate a recall petition without incurring much effort, for the *sole purpose* of starting a recall petition. I would like to see some suggestions as to how we can ensure that this would not happen. 

> The "we think" [2] from the IESG is expressed in one sentence.  Would it be possible for the IESG to explain its understanding of the in-depth problem statement so that there could be a discussion?

There were some concerns that were brought up during the discussion on the [email-masked] list and I would like to see a proposal (or a revision) to resolve them. One of the other things that came up during the discussion was that some of us felt that a path to Nomcom eligibility for remote participants was a much better way of preventing disenfranchisement of remote participants. I think Barry stated this explicitly in one of his emails. Given that there are multiple potential way to go about achieving the goals, I do not see that harm in having further discussion to see what we should pick as a base.

Thanks
Suresh

[0] https://en.wikipedia.org/wiki/Skin_in_the_game_(phrase)

---

From: S Moonesamy <[email-masked]>
Date: Fri, 24 May 2019 18:17:18 -0700

Hi Suresh,
At 04:54 PM 24-05-2019, Suresh Krishnan wrote:
>I am not talking for the whole IESG but I will 
>tell you my opinion as a sitting IESG member on 
>why I did not want to AD sponsor this draft in 
>its current condition. I think the proposal in 
>the draft sets the bar too low specifically on 
>the Section 2.2 front. One of the things that 
>has kept the recall petitions rare is that that 
>the people who initiate the petition need to 
>have some accountability for doing so (I would 
>call this "skin in the game" [0] but it does 
>not translate well across cultures). Otherwise 
>there will be no bar to filing frivolous 
>petitions. This brings me to the elephant in the 
>room. It is fairly trivial for someone to sign 
>up 10 remote participant identities to initiate 
>a recall petition without incurring much effort, 
>for the *sole purpose* of starting a recall 
>petition. I would like to see some suggestions 
>as to how we can ensure that this would not happen.

Thank you for sharing your opinion openly.

There isn't a "skin in the game" hurdle for 
appeals.  It is trivial to file five frivolous 
appeals and get 15 Area Directors to respond to the appeals.

There is the following sentence in Section 3.1: 
"All signatories must have registered to attend 
and have participated physically or remotely at 
least three out of the previous five IETF 
meetings".  Those 10 remote participants (please 
see above) cannot just sign up  as that would be 
considered as attending a meeting.  If a person 
was participating remotely in a WG session, the 
WG Chair and some of the regular WG participants 
would likely know who the person is.

If the IETF community is uncomfortable with the 
"remote only" signatories, that could be 
addressed by setting a restriction on the number 
of signatories who are "remote only".

>There were some concerns that were brought up 
>during the discussion on the [email-masked] list 
>and I would like to see a proposal (or a revision) to resolve them. One of the

Could Alexey, Warren or you please list the 
concerns so that they can be addressed?

>other things that came up during the discussion 
>was that some of us felt that a path to Nomcom 
>eligibility for remote participants was a much 
>better way of preventing disenfranchisement of 
>remote participants. I think Barry stated this 
>explicitly in one of his emails. Given that 
>there are multiple potential way to go about 
>achieving the goals, I do not see that harm in 
>having further discussion to see what we should pick as a base.

Since Barry sent his email about Nomcom 
eligibility there hasn't been any draft about 
that topic.  There isn't anything which could be picked as base.

Regards,
S. Moonesamy

---

From: "Pete Resnick" <[email-masked]>
Date: Sat, 25 May 2019 17:33:38 -0500

On 24 May 2019, at 18:54, Suresh Krishnan wrote:

>  One of the things that has kept the recall petitions rare is that 
> that the people who initiate the petition need to have some 
> accountability for doing so (I would call this “skin in the game” 
> [0] but it does not translate well across cultures). Otherwise there 
> will be no bar to filing frivolous petitions. This brings me to the 
> elephant in the room. It is fairly trivial for someone to sign up 10 
> remote participant identities to initiate a recall petition without 
> incurring much effort, for the *sole purpose* of starting a recall 
> petition. I would like to see some suggestions as to how we can ensure 
> that this would not happen.

It is not "fairly trivial" to sign up 10 remote participants for 3 out 
of the last 5 meetings just to game the system; that takes at least a 
year's worth of planning. That requirement (which has always been in the 
document) seems plenty high to prevent completely frivolous petitions. 
And note that even if there were frivolous petitions (and I think it is 
highly unlikely), this would simply be a DOS attack on recall 
committees, not a way to remove an AD or IAB member.

Even if you think that the one year of planning is not enough to 
discourage silliness, there are other potential simple solutions (e.g., 
half of the petitioners must be non-remote registrants, etc.).

I think the concerns here are overdone.

pr
-- 
Pete Resnick http://www.episteme.net/
All connections to the world are tenuous at best

---

From: "Theodore Ts'o" <[email-masked]>
Date: Sat, 25 May 2019 19:08:25 -0400

On Sat, May 25, 2019 at 05:33:38PM -0500, Pete Resnick wrote:
> 
> It is not "fairly trivial" to sign up 10 remote participants for 3 out of
> the last 5 meetings just to game the system; that takes at least a year's
> worth of planning. That requirement (which has always been in the document)
> seems plenty high to prevent completely frivolous petitions. And note that
> even if there were frivolous petitions (and I think it is highly unlikely),
> this would simply be a DOS attack on recall committees, not a way to remove
> an AD or IAB member.
> 
> Even if you think that the one year of planning is not enough to discourage
> silliness, there are other potential simple solutions (e.g., half of the
> petitioners must be non-remote registrants, etc.).

Another thing perhaps to consider would be to start charging at least
some amount of money to register as a remote participation.  That
money can be used to fund and improve the remote participation tools.
(Since remote participants would become paying customers, there would
be an expectation that quality provided to the remote participants
would have meet a minimum quality bar --- which is a feature, not a
bug.)

People can disagree about how likely that redchan or gab.com
participants would try to game the system in the future (perhaps it's
not likely, but the Linux Kernel development community has not been
immune from their interest), but requiring a real registration fee
would no doubt decrease that risk.  Futhermore, since we've already
decided that it's OK to require a registration fee for in-person
attendance, requiring something similar for remote participants ---
since the claim is that they should have all of the rights and
responsibilities pertaining thereto --- would seem only fair.

Just a thought.

						- Ted

---

From: John C Klensin <[email-masked]>
Date: Sat, 25 May 2019 22:24:22 -0400

Ted,

FWIW, I've suggested this several times for a variety of
reasons, including suggestions that the fee be adjusted if
needed to reflect the differences between industrialized and
less- developed countries.  Money on the table is not a really
good measure of actual intent to participate (rather than, e.g.,
to troll) but it would certainly help.

  john

--On Saturday, 25 May, 2019 19:08 -0400 Theodore Ts'o
<[email-masked]> wrote:

>> It is not "fairly trivial" to sign up 10 remote participants
>> for 3 out of the last 5 meetings just to game the system;
>> that takes at least a year's worth of planning. That
>> requirement (which has always been in the document) seems
>> plenty high to prevent completely frivolous petitions. And
>> note that even if there were frivolous petitions (and I think
>> it is highly unlikely), this would simply be a DOS attack on
>> recall committees, not a way to remove an AD or IAB member.
>> 
>> Even if you think that the one year of planning is not enough
>> to discourage silliness, there are other potential simple
>> solutions (e.g., half of the petitioners must be non-remote
>> registrants, etc.).
> 
> Another thing perhaps to consider would be to start charging
> at least some amount of money to register as a remote
> participation.  That money can be used to fund and improve the
> remote participation tools. (Since remote participants would
> become paying customers, there would be an expectation that
> quality provided to the remote participants would have meet a
> minimum quality bar --- which is a feature, not a bug.)
> 
> participants would try to game the system in the future
> (perhaps it's not likely, but the Linux Kernel development
> community has not been immune from their interest), but
> requiring a real registration fee would no doubt decrease that
> risk.  Futhermore, since we've already decided that it's OK to
> require a registration fee for in-person attendance, requiring
> something similar for remote participants --- since the claim
> is that they should have all of the rights and

---

From: Loganaden Velvindron <[email-masked]>
Date: Sun, 26 May 2019 12:54:05 +0400

On Sun, May 26, 2019 at 3:09 AM Theodore Ts'o <[email-masked]> wrote:

> discourage
> [Speaking as the organizer of an ietf remote hub from Mauritius]

We've been contributed patches for TLS 1.3, IPv6, DNS, http451 in open
source
projects during the IETF hackathons. We're also working on a few drafts. We
have a lot
of high school and university students among ourselves.

We're OK with paying the registration fees provided that they are
reasonable.

There are countries such as Madagascar who are trying to organize their own
IETF
hubs but their Cost of living is lower than us. What is reasonable to us
might be expensive
to them.

Could there be a remote registration fee calculated per country ?

---

From: Iyedi Goma <[email-masked]>
Date: Sun, 26 May 2019 11:14:08 +0100

hello Loganaden
thanks for raising this point

Le dim. 26 mai 2019 à 09:55, Loganaden Velvindron <[email-masked]> a
écrit :

>> of
> projects during the IETF hackathons. We're also working on a few drafts.
> We have a lot
> There are countries such as Madagascar who are trying to organize their
> own IETF

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 May 2019 15:32:04 -0400

--On Saturday, 25 May, 2019 17:33 -0500 Pete Resnick
<[email-masked]> wrote:

>...
> for 3 out of the last 5 meetings just to game the system; that
> takes at least a year's worth of planning. That requirement
> (which has always been in the document) seems plenty high to
> prevent completely frivolous petitions. And note that even if
> there were frivolous petitions (and I think it is highly
> unlikely), this would simply be a DOS attack on recall

Agreed.  And, unless one is prepared to argue that remote
participants are somehow more inclined to frivolous petitions
than those who attend regularly (no matter whether they actually
participate actively or not), this is a case in which the huge
number of frivolous recall efforts we have had in the past,
especially those that have gone to the point of getting a recall
committee formed (and even back when the number of people it
took to initiate such an action was only one and with no
qualification restrictions) strongly suggests that this is not a
real fear.

> solutions (e.g., half of the petitioners must be non-remote

I'd oppose that type of restriction unless there is at least a
shred of evidence that remote participants are, as a group, more
silliness-prone than those who show up.  So far, there isn't and
the same "remote participants should not be treated as
second-class unless there is a clear reason to do so"
considerations should apply that motivated
draft-moonesamy-recall-rev in the first place.

   john

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 May 2019 17:42:22 -0400

Loganaden, Ted, and others,

Remote participation fees have been suggested on and off for
years, with the main motivations being providing a small bar
against various types of silliness, people posing as others or
as multiple people, etc.  I've been one of those suggesting them
for those and other reasons, including allowing a small bit more
authentication.  I don't recall any proposals that seriously
suggested such fees would provide significant secretariat
support and/or support for the costs of running Meetecho, etc.,
because most ways of calculating such fees would be enough to
drive most potential remote participants, even from
industrialized countries, away.   However, that has come up a
few times too. 

At no time have the IESG, the former IAD or IAOC, or others
seemed interested in taking the topic up.  Should they do so, we
can then have a conversation about formulas and charges.  I'd
predict those discussions would lead to a far more complex
formula than anyone really wants to deal with (e.g., something
based on cost of living or median income in various countries),
at least until things settled down on something with
encouragement for exceptions or exemptions when needed (much as
we have now).  Perhaps anticipation of that likely long and
painful discussion is one of the reasons why at least some of
those actors have not been interested in pursing such fees.
But, please, lets keep that discussion as separate as possible
from the rather narrow scope of  draft-moonesamy-recall-rev
(hence the change in the subject line).  If someone does feel
this is the time to take it up, let's see a proposal in I-D form.

best,
   john

--On Sunday, 26 May, 2019 12:54 +0400 Loganaden Velvindron
<[email-masked]> wrote:

>> requiring a real registration fee would no doubt decrease
>> that risk.  Futhermore, since we've already decided that it's
>> OK to require a registration fee for in-person attendance,
>> requiring something similar for remote participants --- since
>> the claim is that they should have all of the rights and
> We've been contributed patches for TLS 1.3, IPv6, DNS, http451
> in open source
> projects during the IETF hackathons. We're also working on a
> few drafts. We have a lot
> We're OK with paying the registration fees provided that they
> are reasonable.
> 
> There are countries such as Madagascar who are trying to
> organize their own IETF
> hubs but their Cost of living is lower than us. What is
> reasonable to us might be expensive
> to them.
>

---

From: "Pete Resnick" <[email-masked]>
Date: Mon, 27 May 2019 18:13:15 -0500

On 26 May 2019, at 14:32, John C Klensin wrote:

> ...unless one is prepared to argue that remote

To be fair, the concern was about someone making fake remote 
registrations in order for one or two folks to mount a recall. That 
said, I still don't think it is a serious concern.

pr

---

From: John C Klensin <[email-masked]>
Date: Mon, 27 May 2019 20:33:16 -0400

--On Monday, May 27, 2019 18:13 -0500 Pete Resnick
<[email-masked]> wrote:

>> than those who attend regularly (no matter whether they
>> actually participate actively or not), this is a case in
>> which the huge number of frivolous recall efforts we have had
>> in the past, especially those that have gone to the point of
>> getting a recall committee formed (and even back when the
>> number of people it took to initiate such an action was only
>> one and with no qualification restrictions) strongly suggests
>> that this is not a real fear.
> 
> registrations in order for one or two folks to mount a recall.
> That said, I still don't think it is a serious concern.

I think we are in complete agreement.  My comments, if anything,
were an attempt to demonstrate that the concern is even less
serious than your comments suggested.  I don't think that is a
contest or that it makes much difference who "wins".  IMO, if
there is any debate here it is about the size, coloration, and
taste of the red herring.

best,
   john

---

From: Michael StJohns <[email-masked]>
Date: Tue, 28 May 2019 16:35:41 -0400

Suggestion that I should have made 100 message ago:

This seems to be a "recall" proposal against the current recall 
process.   So - how about we see if there are 20 "eligible" people that 
are willing to sponsor this?  And if not, can we be done with it now?

AFAICT there are about 10 or so folk that have offered more than a 
single comment, but again AFAICT I didn't really see anyone expressing 
more than tepid interest in spending time on this.

FWIW, I think that it's probably OK to continue to have the "how much 
influence should a remote-only participant have over the IETF process 
discussion" but I also think that resolving that question before getting 
down into the "how many deck chairs on the titanic" type discussions for 
the recall process may be a much more productive approach that what I'm 
currently seeing.  And please - can it be time to move it off the IETF 
mailing list?

Later, Mike

PS - like it or not, meeting fees provide a substantial amount of the 
money for the general IETF budget specifically including standards 
publication.  If you are arguing for actions that reduce or tend to 
reduce or have the potential to limit the intake of funds from that 
model, I suggest you also come up with a more than handwaving proposal 
for how to replace those funds or explain which functions supported by 
the IETF we're going to eliminate to cover such shortfall.