Subject: Re: [Eligibility-discuss] Virtual BoF for draft-moonesamy-recall-rev

From: S Moonesamy <[email-masked]>
Date: Sat, 01 Jun 2019 20:53:28 -0700

Dear Area Directors,

Over a week ago, I sent you a proposal for a virtual BOF [1].  Would 
it be possibel to get some feedback from you?

Regards,
S. Moonesamy

1. Please see https://mailarchive.ietf.org/arch/browse/eligibility-discuss/

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 3 Jun 2019 23:22:07 -0400

HI SM,
  First of all, let me state that I am supportive of a proposal for a virtual BoF that covers the topics you mentioned. I have gone over the proposal and I think it needs to be refined further. In my mind, a virtual BoF proposal needs to have the same amount of thinking put into the problem statement, the deliverables, the questions to be answered as a in-person BoF proposal in order to be successful. i.e. As an AD I would expect the virtual BoF proposal to receive the same level of scrutiny as an in-person BoF proposal. 

The problem statement in your mail concerning the virtual BoF, IMHO, does not fully cover the intent of the draft. e.g. It does not talk about why you are reducing the number of signatories. I think some text is required in this regard. 

I would like the virtual BoF to clarify the following aspects

1) Does the community believe there is a problem to solve?
2) Which of the change proposals does the community support. I think some of the proposals in your draft are fairly non-controversial (e.g. reducing the number of signatories) while the others (e.g. Allowing I* to do so) might be more controversial.
3) What are the deliverables you expect to have?
4) How much support and energy is there in the community to make this change?

Also, mention whether you would like this to be a working group forming BoF or not. One other suggestion I would make is to put the virtual BoF request into 

https://trac.tools.ietf.org/bof/trac/ <https://trac.tools.ietf.org/bof/trac/>

So that it can be considered along with the other BoF proposals when the IESG and IAB meet to consider the proposals for the Montreal IETF on June 11.

Thanks
Suresh

> On Jun 1, 2019, at 11:53 PM, S Moonesamy <[email-masked]> wrote:
> 
> Dear Area Directors,
> 
> Over a week ago, I sent you a proposal for a virtual BOF [1].  Would it be possibel to get some feedback from you?
> 
> Regards,
> S. Moonesamy
> 
> -- 
> Eligibility-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eligibility-discuss

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 4 Jun 2019 03:26:56 +0000

Hi Adrian,

<No Hats>

> On May 26, 2019, at 8:22 AM, Adrian Farrel <[email-masked]> wrote:
> 
> I probably can't speak to the cases you describe.
> 
> I did once start to put together a recall petition for an AD (so long ago that we need not dwell on the details). I found that collecting cosignatories was slow, but for good reasons. People generally said "Yes, bad stuff is happening, but recall is pretty serious. Can we think about other ways of handling this?". And, indeed, once the seriousness got discussed a bit, the AD concerned modified their behaviour (coincidence is not causation).
> 
> The process did not seem unwieldy to me, but making it more wieldy (for example by reducing the number of signatures needed) does not seem to be a bad idea to me. In fact, it is part of SM's draft, IIRC. 

 I agree with you. I think this could be a fairly non-baseline improvement. 

> 
> However, adding a new process that allows removal of a community appointment by other than the community looks like a way of just increasing the chances of appeals and additional recalls.

I am not entirely sure about this. I think the body in question might have more information than the community at large in some cases. In these cases allowing the body to self-correct may be useful. But I do see the concerns about potential ways in which this can be abused.

> I think it is a discussion we could have, but I also think it is independent of SM's proposals.

Agree.

Thanks
Suresh

---

From: S Moonesamy <[email-masked]>
Date: Tue, 04 Jun 2019 12:49:01 -0700

Hi Suresh,
At 08:22 PM 03-06-2019, Suresh Krishnan wrote:
>Also, mention whether you would like this to be a working group 
>forming BoF or not. One other suggestion I would make is to put the 
>virtual BoF request into

Thank you for responding.

The advice from the IETF Chair was to have a BOF to process the 
draft.  I approached the Area Directors, as suggested by the IETF 
Chair, about the BOF.  Could Warren, Alexey or you provide some 
expert advice on whether a working group forming BoF should be requested?

Regards,
S. Moonesamy

---

From: John C Klensin <[email-masked]>
Date: Wed, 05 Jun 2019 10:10:54 -0400

Suresh (and Alexey and Warren),

It seems to me that there are two, quite different, possible BOF
proposals and that the community could use a little guidance
from the three of you about what the IESG is looking for.

One is the result of the direction in which Subramanian seems to
be heading and that reflects the actual content of
draft-moonesamy-recall-rev.  That is a very narrow set of
changes to fine-tune the existing recall procedure to allow a
set of people who do not meet the "Nomcom eligibility"
requirement because they do not attend sufficient f2f meeting no
matter how active they are in the IETF, to reduce the number of
signatures required to initiate a recall because the current
number is seen as burdensome (especially for people who can't
collect them by, e.g., passing a sheet of paper around at a
plenary), and by allowing people in the leadership to initiate
recall efforts (not only for the bodies on which they sit but
for other bodies).  The latter, which has almost nothing to do
with remote participants, could easily be dropped if there was
no support for it but I note that, draft-rescorla-istar-recall
is largely orthogonal to the change proposed in the present
draft: even if it were adopted, the proposed change would still
be worth careful consideration for cases in which, e.g., the
IESG felt there was a serious problem in the LLC Board.  The
proposal doesn't "fix" the recall procedure, it merely tunes its
first step a bit.

My personal opinion is that, if the scope is as narrow as the
"fine-tune the recall procedure in that way" implied above, a
BOF, virtual or otherwise, would be a waste of time -- there has
already been enough discussion to indicate community interest
and we should move forward to discussing the draft (and not
procedures for doing so).  If you are convinced that needs a
short-lived WG to, e.g., avoid getting sidetracked, we should be
working on a charter for that WG with the expectation that its
approval will be expedited, not going through an elaborate set
of rituals that are not required by IETF procedures.  On the
other hand, if you are convinced that a quick virtual BOF would
be helpful, let's get on with it.

At the other extreme, perhaps the posting of this draft has
convinced the IESG that it is time to open up the entire
candidate selection and removal process and review it.  That
would (or at least might) include the nomcom eligibility
criteria; questions about whether the nomcom model itself is
appropriate in a contemporary IETF for which the implied
assumption that most of the nomcom members would have personal
knowledge of most of the candidates is no longer valid;
questions of term lengths, limits (or preferences), and
incumbent preferences; questions of whether, as the number of
bodies and slots for which the nomcom is expected to make
appointments has risen, having a single body do all of that work
in a single cycle is still appropriate; examination of whether,
in the environment of the IETF LLC having the ISOC President and
CEO appoint the Nomcom (and Recall Committee) chairs is still
appropriate both practically and from the standpoint of optics;
whether we can devise a mechanism for mid-term removal of people
who have misbehaved that is faster and more plausible than the
present petition, chair appointment, and two consecutive
committee model (or whether no such procedure is needed); and
perhaps even some issues that overlap into the old NEWTRK
effort.   That is obviously not a complete list: I'm confident
that you could add some things to it and that, given a few
hours, I probably could too.   

If that is the BOF proposal/charter you and the rest of the IESG
want, then it probably would benefit from a f2f discussion and
some of us should see if we can get a proposal for a BOF in
Montreal together within the next 48 hours.  However, any of us
who have either tried writing I-Ds that propose adjustments in
those areas or who have been through opening up some of the
issues in WGs know that it will be a long, time and resource
intensive, trek with many passionately-expressed opinions.
Based on experience with POISSON, I think it would be
unrealistic to expect a WG with that task list to converge and
complete its work in less than two or three years. Even were
that much time to be available, it would be nearly impossible to
get to significant conclusions without enthusiastic IESG support
for reviewing things and making changes as needed, support that
would need to be independent of whatever changes the WG and
community select.   Unless you can assure us that the conviction
and enthusiasm exist, even holding a BOF, much less chartering a
WG, would, IMO, be a waste of time that the IETF could better
spend on technical work.

Even if a BOF proposal for this larger effort were wanted and if
only because how long that effort would take, I think there is a
very strong case for addressing the fine-tuning proposal now and
getting it done with.  They really are separate efforts even
though we might reasonably expect the larger one to make changes
that would obsolete some or all of the smaller and faster one.

So, what would you like to see and how are you and the IESG
thinking about this?

Just my opinion but, perhaps unfortunately, one that is informed
by experience.

   john

--On Tuesday, June 4, 2019 12:49 -0700 S Moonesamy
<[email-masked]> wrote:

>> Also, mention whether you would like this to be a working
>> group  forming BoF or not. One other suggestion I would make
>> is to put the  virtual BoF request into
> 
> The advice from the IETF Chair was to have a BOF to process
> the draft.  I approached the Area Directors, as suggested by
> the IETF Chair, about the BOF.  Could Warren, Alexey or you
> provide some expert advice on whether a working group forming
> BoF should be requested?
> 
> Regards,
> S. Moonesamy

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 6 Jun 2019 22:28:14 -0400

Hi SM,

> On Jun 4, 2019, at 3:49 PM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Suresh,
> The advice from the IETF Chair was to have a BOF to process the draft.  I approached the Area Directors, as suggested by the IETF Chair, about the BOF.  Could Warren, Alexey or you provide some expert advice on whether a working group forming BoF should be requested?

Just speaking for myself here. I think this depends on how you want to scope the discussion. If you can go with a fairly narrow set of goals with a defined scope and deliverables, I think a WG forming BoF would be a good idea. If you want to explore the problem space a bit, I think a non-WG forming BoF might be a better fit.

Thanks
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 6 Jun 2019 23:14:38 -0400

Hi John,

> On Jun 5, 2019, at 10:10 AM, John C Klensin <[email-masked]> wrote:
> 

Just speaking for myself here. I do have my preference (see below), but I will leave it up to the proponents to decide which way they want to go.

> be helpful, let's get on with it.

This would be my preference. As I said in my earlier mail, if we can separate the three pieces of the draft and see how the community feels about each of them, I think we will be in a good spot to looking at writing a narrowly scoped charter for a WG.
 
> hours, I probably could too.   

Just my personal opinion with no hats at all. I think this will be a “boil the ocean” effort and I am not at all confident about its odds of success.

> WG, would, IMO, be a waste of time that the IETF could better

I whole-heartedly agree with you that this would probably be a waste of time.

> Just my opinion but, perhaps unfortunately, one that is informed

Much appreciated. I agree with you that a tightly scoped effort is more likely to succeed. 

Thanks
Suresh

---

From: S Moonesamy <[email-masked]>
Date: Fri, 07 Jun 2019 10:53:51 -0700

Hi Suresh,
At 07:28 PM 06-06-2019, Suresh Krishnan wrote:
>Just speaking for myself here. I think this depends on how you want 
>to scope the discussion. If you can go with a fairly narrow set of 
>goals with a defined scope and
>  deliverables, I think a WG forming BoF would be a good idea. If 
> you want to explore the problem space a bit, I think a non-WG 
> forming BoF might be a better fit.

Thank you for the feedback.

The time commitment to explore the problem space would likely be too 
high for me to fit that into my current schedule.

Regards,
S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Tue, 11 Jun 2019 03:45:20 -0700

Hi Suresh,

Please see a revised version of the BOF proposal to address your comments:

Problem statement

      The current description of the process for initiating petitions 
for recalls
      for NomCom-appointed roles is described in RFC 7437 and is 
being updated in
      draft-ietf-iasa2-rfc7437bis.  The scope of this work addresses only three
      specific issues with the petition process; other parts of the 
recall model
      and other ways of removing Nomcom-appointees are explicitly out of scope.

      The three issues are:

      - Ineligibility of remote participants to seek redress through the
        recall process;

      - Reducing the number of signatories for a recall petition;

      - Ineligibility of IAB and IESG Members and other Nomcom
        Appointees to sign a recall petition.

The purpose of the BOF is to examine the above-mentioned issues and determine,
for each, whether it is sufficient interest and importance. 
draft-moonesamy-recall-rev
is a possible starting point for the effort.

Regards,
S. Moonesamy

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 11 Jun 2019 12:21:32 +0100

That's nice. I like the clarity.

I also like that the worms are kept firmly in their cans. It is without
doubt that a hundred other issues concerning the recall process could be
aired, and I am certain that many people have different hot issues. But I
firmly believe that addressing a few at a time is the best (only!) way to
make progress.

If it turns out that there is support for resolving any of these three
issues, they can be quickly picked off and we can move on to other issues if
there is interest. If there is no support for addressing these three
concerns, then they can be put to one side and work can start on other
issues if there is interest.

For my part, I think that all three issues should be addressed, and I think
that the approaches suggested in SM's draft are a good starting point for
discussion.

Thanks,
Adrian

-----Original Message-----
From: Eligibility-discuss <[email-masked]> On Behalf
Of S Moonesamy
Sent: 11 June 2019 11:45
To: Suresh Krishnan <[email-masked]>;
[email-masked]
Cc: John C Klensin <[email-masked]>; Warren Kumari <[email-masked]>;
Alexey Melnikov <[email-masked]>
Subject: Re: [Eligibility-discuss] Virtual BoF for
draft-moonesamy-recall-rev

Hi Suresh,

Problem statement

      The current description of the process for initiating petitions 
for recalls
      for NomCom-appointed roles is described in RFC 7437 and is 
being updated in
      draft-ietf-iasa2-rfc7437bis.  The scope of this work addresses only
three
      specific issues with the petition process; other parts of the 
recall model
      and other ways of removing Nomcom-appointees are explicitly out of
scope.

      The three issues are:

The purpose of the BOF is to examine the above-mentioned issues and
determine,
for each, whether it is sufficient interest and importance. 
draft-moonesamy-recall-rev
is a possible starting point for the effort.

Regards,
S. Moonesamy

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Jun 2019 04:37:33 -0700

H/mm..  These don't seem like "issues" so much as restatements of the
solution SM's draft proposes.

To take a specific one, what issue is addressed by reducing the number of
people required to sign the petition?

-Ekr

---

From: Eliot Lear <[email-masked]>
Date: Tue, 11 Jun 2019 14:21:21 +0200

> On 11 Jun 2019, at 13:37, Eric Rescorla <[email-masked]> wrote:
> 
> H/mm..  These don't seem like "issues" so much as restatements of the solution SM's draft proposes.
> 
> To take a specific one, what issue is addressed by reducing the number of people required to sign the petition?
> 

Fewer people would have to set themselves up as targets for retribution; the pool of people able to serve on the recall committee is marginally increased.

Eliot

> -Ekr
> 
> 
> On Tue, Jun 11, 2019 at 4:22 AM Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> From: Eligibility-discuss <[email-masked] <mailto:[email-masked]>> On Behalf
> Of S Moonesamy
> Sent: 11 June 2019 11:45
> To: Suresh Krishnan <[email-masked] <mailto:[email-masked]>>;
> [email-masked] <mailto:[email-masked]>
> Cc: John C Klensin <[email-masked] <mailto:[email-masked]>>; Warren Kumari <[email-masked] <mailto:[email-masked]>>;
> Alexey Melnikov <[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/eligibility-discuss <https://www.ietf.org/mailman/listinfo/eligibility-discuss>
> 
> --
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/eligibility-discuss <https://www.ietf.org/mailman/listinfo/eligibility-discuss>
> --

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Jun 2019 05:31:45 -0700

On Tue, Jun 11, 2019 at 5:21 AM Eliot Lear <[email-masked]> wrote:

> Fewer people would have to set themselves up as targets for retribution;
> the pool of people able to serve on the recall committee is marginally
> increased.
>

That's helpful, but I think it also suggests that the problem statement
that SM has written is not really right: for instance, we could solve the
problem of people being targets of retribution by having the signers be
secret [0].. And we could address the pool issue by letting them serve on
the committee.

OTOH, it seems to me that the purpose of these requirements is to have a
certain level of accountability for the people requesting the recall and to
have a certain minimum level of support. So, is it clear that we actually
want to relax those objectives?

in any case, I think this exchange suggests that the first thing that's
needed is a problem statement that's decoupled from the solutions being
proposed.

-Ekr

[0] I'm aware that there are challenges here in verifying eligibility. I
believe there are solutions here, though they are too small to be contained
in this message.

Eliot
>> Cc: John C Klensin <[email-masked]>; Warren Kumari <[email-masked]
>> >;

---

From: Eliot Lear <[email-masked]>
Date: Tue, 11 Jun 2019 14:38:52 +0200

> On 11 Jun 2019, at 14:31, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Tue, Jun 11, 2019 at 5:21 AM Eliot Lear <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>> On 11 Jun 2019, at 13:37, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> That's helpful, but I think it also suggests that the problem statement that SM has written is not really right: for instance, we could solve the problem of people being targets of retribution by having the signers be secret [0].. And we could address the pool issue by letting them serve on the committee.

I agree with your 2nd sentence, but not your first, at least entirely.  It’s just just about eligibility, but also about the recall committee being able to understand the concerns of those seeking to have someone removed.  But I think your general point is well made: there needs to be one or more crisp problem statements to start with, and then various approaches can be considered to address the matter(s).

Eliot

> 
> OTOH, it seems to me that the purpose of these requirements is to have a certain level of accountability for the people requesting the recall and to have a certain minimum level of support. So, is it clear that we actually want to relax those objectives?
> 
> in any case, I think this exchange suggests that the first thing that's needed is a problem statement that's decoupled from the solutions being proposed.
> 
> -Ekr
> 
> [0] I'm aware that there are challenges here in verifying eligibility. I believe there are solutions here, though they are too small to be contained in this message.
> 
> Eliot
> 
>> -Ekr
>> 
>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 11 Jun 2019 13:44:21 +0100

How about phrasing the problem as “You need too many people to sign a recall petition, and that makes it too hard to achieve a recall”?

We can agree or disagree about whether this is a problem and whether we want to work on it. That’s why we have BoFs and mailing lists.

We can debate the correct solution for each problem, but (usually, when we have a BoF) the discussion of the solutions is sequenced after the discussion of the problems and agreement that we want to work on the problems. 

Adrian

From: Eric Rescorla <[email-masked]> 
Sent: 11 June 2019 13:32
To: Eliot Lear <[email-masked]>
Cc: Adrian Farrel <[email-masked]>; Alexey Melnikov <[email-masked]>; S Moonesamy <[email-masked]>; [email-masked]; Suresh Krishnan <[email-masked]>; John C Klensin <[email-masked]>; Warren Kumari <[email-masked]>
Subject: Re: [Eligibility-discuss] Virtual BoF for draft-moonesamy-recall-rev

On Tue, Jun 11, 2019 at 5:21 AM Eliot Lear <[email-masked] <mailto:[email-masked]> > wrote:

On 11 Jun 2019, at 13:37, Eric Rescorla <[email-masked] <mailto:[email-masked]> > wrote:

 

-Ekr

Eliot

-Ekr

On Tue, Jun 11, 2019 at 4:22 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Thanks,
Adrian

-----Original Message-----
From: Eligibility-discuss <[email-masked] <mailto:[email-masked]> > On Behalf
Of S Moonesamy
Sent: 11 June 2019 11:45
To: Suresh Krishnan <[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]> 
Cc: John C Klensin <[email-masked] <mailto:[email-masked]> >; Warren Kumari <[email-masked] <mailto:[email-masked]> >;
Alexey Melnikov <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Eligibility-discuss] Virtual BoF for
draft-moonesamy-recall-rev

Hi Suresh,

Problem statement

      The three issues are:

Regards,
S. Moonesamy

---

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 11 Jun 2019 13:50:41 +0100

Hi John,

On Fri, Jun 7, 2019, at 4:14 AM, Suresh Krishnan wrote:
> Just speaking for myself here. I do have my preference (see below), but 
> I will leave it up to the proponents to decide which way they want to 
> go.
> 
> > 
> This would be my preference. As I said in my earlier mail, if we can 
> separate the three pieces of the draft and see how the community feels 
> about each of them, I think we will be in a good spot to looking at 
> writing a narrowly scoped charter for a WG.

I agree. When I read the draft I couldn't quite figure out why it included certain changes and not others. Instead of arguing about the whole collection of changes IETF community should decide which ones should be worked on. (If all of them ended up having rough consensus, that would be fine with me.).

> Just my personal opinion with no hats at all. I think this will be a 
> “boil the ocean” effort and I am not at all confident about its odds of 
> success.

Agreed. I am very happy to work on a small problem (or a small collection of related problems) once there is agreement to work on it.

> I whole-heartedly agree with you that this would probably be a waste of time.

+1.

> Much appreciated. I agree with you that a tightly scoped effort is more 

+1.

Best Regards,
Alexey

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Jun 2019 05:58:40 -0700

On Tue, Jun 11, 2019 at 5:45 AM Adrian Farrel <[email-masked]> wrote:

> How about phrasing the problem as “You need too many people to sign a
> recall petition, and that makes it too hard to achieve a recall”?
>

Without taking a position on the merits, that seems more like a problem
statement. An even crisper statement, perhaps, would be "It's too hard to
achieve a recall"

We can agree or disagree about whether this is a problem and whether we
> want to work on it. That’s why we have BoFs and mailing lists.
>

Yes.

We can debate the correct solution for each problem, but (usually, when we
> have a BoF) the discussion of the solutions is sequenced after the
> discussion of the problems and agreement that we want to work on the
> problems.
>

Agreed. That's what I'm hoping for here.

-Ekr

Adrian
>
>
>
> *From:* Eric Rescorla <[email-masked]>
> *Sent:* 11 June 2019 13:32
> *To:* Eliot Lear <[email-masked]>
> *Cc:* Adrian Farrel <[email-masked]>; Alexey Melnikov <
> [email-masked]>; S Moonesamy <[email-masked]>;
> [email-masked]; Suresh Krishnan <[email-masked]>;
> John C Klensin <[email-masked]>; Warren Kumari <[email-masked]>
> *Subject:* Re: [Eligibility-discuss] Virtual BoF for

---

From: S Moonesamy <[email-masked]>
Date: Tue, 11 Jun 2019 08:28:57 -0700

Dear Mr Rescorla,
At 04:37 AM 11-06-2019, Eric Rescorla wrote:
>To take a specific one, what issue is addressed by reducing the 
>number of people required to sign the petition?

The above is a good question.  I'll propose the following changes to 
the second and third issues:

    - The required number of signatories sets a very high barrier to initiate
      a recall petition

    - The ineligibility of a member of appointing bodies from being a signatory
      restricts the initiation of a recall petition in a timely manner.

Regards,
S. Moonesamy

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 Jun 2019 11:41:02 -0400

--On Tuesday, June 11, 2019 14:21 +0200 Eliot Lear
<[email-masked]> wrote:

>> H/mm..  These don't seem like "issues" so much as
>> restatements of the solution SM's draft proposes.
>> 
>> To take a specific one, what issue is addressed by reducing
>> the number of people required to sign the petition?
> 
> Fewer people would have to set themselves up as targets for
> retribution; the pool of people able to serve on the recall
> committee is marginally increased.

And, like the remote participants measure, if makes recall
initiation marginally more plausible, especially for remote
participants.

Thanks for mentioning the fear of retribution issue.  I've seen
it several times when people have felt unable to post negative
Last Call comments about documents in which one or more ADs are
involved as authors or by having significant skin in the game.
I had not considered it in the case of recall initiation, but it
is obviously going to be a concern.

It seems to me that, if a high level statement is needed, it
would be something like:

	"During the years since the Recall petitioning procedure
	was changed, with RFC 3777 in June 2004, to require
	Nomcom eligibility and 20 signatures it has become
	fairly clear that it is unusable in practice for any
	case that is not so completely obvious that a complex,
	time-consuming, multi-step, procedure should not be
	required.   It has also become progressively more unfair
	as the requirements exclude potential petitioners who
	are likely to be more knowledgeable than typical IETF
	f2f participants about particular types of abuses,
	whether because of the position those people hold or
	because as significant fraction of their participation
	is not f2f at IETF meetings.  It is also more burdensome
	for the latter group of participants than for those who
	are Nomcom-eligible under the normal rules, which is
	another source of unfairness.  The BoF is expected to
	address three specific aspects of those issues: the
	Nomcom eligibility requirement of physical meeting
	attendance, the number of signatures required on a
	petition, and the ineligibility of Nomcom-appointed
	members of leadership bodies to initiate petitions."

I remain concerned about broad statements opening up discussions
of the entire recall model (more about that in a note I have
written but hope I don't have to send), but perhaps something
like the above would respond to the need that others seem to be
feeling without significantly opening that door.

 best,
   john

---

From: Patrick McManus <[email-masked]>
Date: Tue, 11 Jun 2019 11:48:31 -0400

At least for the audience on this list,  I'm probably going to be in the
wilderness on this one.. I don't think a BoF here is the best use of IETF
energy..

There are really two questions. One is about the sweet spot of recall
difficulty - number of signers, etc... I believe that's an unimportant
question - leadership have short 2 year terms and its not like they possess
nuclear codes. Failsafes of some level of effectiveness exist already, and
the art of working around ineffective appointees is a common part of most
committee work that we should not expect to go away through rule tweaking.
Let's focus on tech, tech policy, and organizational outreach rather than
tuning the bureaucracy and the question proposed for the BoF is really just
what the right tuning is. Its not worth asking the plenary.

The larger question is about enfranchisement. but its not really about
recalls in any special way. This is an important question and, while the
various tradeoffs are apparent, the right answer is not obvious. More to
the point this is an important question in many contexts far more
significant than the recall process: nomcomm of course but perhaps the
entire question of leadership selection, hallway-track viability, interim
processes, funding, willingness to serve in leadership. etc. The definition
for recall is currently linked to the definition for nomcomm and that makes
a lot of sense. Let's discuss enfranchisement in a context where it will
actually have a meaningful impact and then apply the findings consistently
if changes are deemed appropriate.

-Patrick

On Tue, Jun 11, 2019 at 8:59 AM Eric Rescorla <[email-masked]> wrote:

>> To: Suresh Krishnan <[email-masked]
>> <suresh.krishnan@gmail..com>>;

---

From: Michael StJohns <[email-masked]>
Date: Tue, 11 Jun 2019 12:12:32 -0400

> feeling without significantly opening that door.

And I'd suggest that if we're going to expend any energy on this, we 
deal with the actual problems with the recall process rather than the 
deck chair counting.

Specifically, as currently described it's going to be something like a 
2-3 month process to start the recall, select the chair, form the 
committee, get them up to speed on the requirements for the position and 
reasonable reasons for recall, investigate the problem and finally have 
a vote.   That's a lot of time to leave a potential recallee in limbo 
and is probably not good for the IETF collaborative model.

And unlike the formation of the Nomcom and selection of the Nomcom 
chair, having the ISOC chair select the recall chair has a number of 
downsides including the possibility of the perception of selecting a 
chair for a desired result.

So instead of restating SM's conclusion as the goal of the BOF maybe use 
something like:

__________________________________

a) Evaluate the current recall model for changes;  whether other 
processes may be more appropriate for perceived needs; and whether the 
recall process should remain part of the management process for IETF 
leadership.

b) In light of (a) evaluate and possibly revise the initiation model for 
the recall process including the possibility of revising or supplanting 
the current petition based model; evaluate and possibly revise the model 
for selection of the recall committee and chair; evaluate and possibly 
revise the deliberation model for the recall committee and the rights of 
the proposed recallee during the process.

c) In light of the addition of the Ombudsman process, evaluate how the 
Ombudsman process should interact if at all with the recall process; for 
example should the Obudsteam be used to investigate charged wrong-doing 
asserted by a recall petition?

The BOF will report out one [or more] of the following:

a) Consensus is that no changes are necessary at this time.

b) We've come to consensus on the following changes:   {}  and we've 
been unable to come to consensus on the following topics {}.  These 
represent all of the topics considered by the group.  A draft covering 
the consensus items shall be forthcoming.

c) We've been unable to come to consensus, however the group has 
determined - through consensus - that there's enough interest to form a 
WG to address these topics.  We have X people who have agreed to 
participate actively. The charter is attached.

d) We've been unable to come to consensus and there is no consensus that 
further deliberation at this time will result in progress.

_____________________________________________

Or something like this.   As I asked earlier - do we actually have 10 or 
20 people who think they want to spend some time working this process or 
are we being DOS'd on a process question that few if any really care about?

We as the IETF have a hard problem of saying "no" at times - for WG 
creation, for the publication of limited impact documents, etc.  It may 
be time as a group to thank SM for his efforts and decline to proceed.

Later, Mike

---

From: Eliot Lear <[email-masked]>
Date: Tue, 11 Jun 2019 18:44:22 +0200

> On 11 Jun 2019, at 17:48, Patrick McManus <[email-masked]> wrote:
> 
> . One is about the sweet spot of recall difficulty - number of signers, etc... I believe that's an unimportant question - leadership have short 2 year terms and its not like they possess nuclear codes.

I think this very much depends on your business.  Knowing that the standard can be dinked right up until the IESG, if someone disappears from that process, your feature scheduling goes out the window.  Possibly your release planning as well.  Now some variability has to be allowed for in this process.  Weeks, maybe even small number of months.  Large #s of months or even years is not an acceptable #.

And that would encourage people to do work elsewhere.  And so it’s harmful to this organization when someone fails to show up for an extended period of time.

Eliot

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 Jun 2019 13:18:23 -0400

--On Tuesday, June 11, 2019 18:44 +0200 Eliot Lear
<[email-masked]> wrote:

>> . One is about the sweet spot of recall difficulty - number
>> of signers, etc... I believe that's an unimportant question -
>> leadership have short 2 year terms and its not like they
>> possess nuclear codes.
> 
> 
> I think this very much depends on your business.  Knowing that
> the standard can be dinked right up until the IESG, if someone
> disappears from that process, your feature scheduling goes out
> the window.  Possibly your release planning as well.  Now some
> variability has to be allowed for in this process.  Weeks,
> maybe even small number of months.  Large #s of months or even
> years is not an acceptable #.

It seem to me that this would apply even more strongly if
someone on, say, the IESG decided to adopt an obstructionist
position relative to your ideas, your company, or, noting your
earlier comment about retaliation, you as an individual.  In
such situations, the IESG has tools to move ahead in spite of
that AD, but they have proven in the past to be time-consuming
and to impede overall progress when the offender is obstinate,
so trade-offs get made, maybe trade-offs that would be less
necessary with a more effective recall mechanism.

Personally, I believe that the IETF is in need of a faster and
lighter-weight mechanism for getting rid of someone who has
disappeared then relying on the present recall process.
However, because I've seen little or no evidence that the
community is ready to deal with a redesign of the recall model,
or the nomination and selection models more generally, I
continue to hope that this discussion can be kept focused on the
particular issues in the petitioning process identified in
draft-moonesamy-recall-rev

best,
   john

> 
> And that would encourage people to do work elsewhere.  And so
> it's harmful to this organization when someone fails to show
> up for an extended period of time.
> 
> Eliot

---

From: S Moonesamy <[email-masked]>
Date: Tue, 11 Jun 2019 09:15:34 -0700

Hi Patrick,
At 08:48 AM 11-06-2019, Patrick McManus wrote:
>The larger question is about enfranchisement. but its not really 
>about recalls in any special way. This is an important question and, 
>while the various tradeoffs are

The intent was to put in an effort which is sustainable instead of 
tackling larger questions without any proposal in sight and which 
would require a huge effort.

Regards,
S. Moonesamy

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 11 Jun 2019 13:53:52 -0400

Given the IETF history (at least as seen through my narrow keyhole) on 
handling process changes, there is a BIG advantage to doing small things.

If we undertake the discussion proposed below, it will take a very long 
time, and likely end up in the typical distribution of a modest number 
of people strongly in favor (of something) a lot of people wondering 
what the fuss is about, and a roughly similar modest number of people 
strongly opposed (to whatever).

In contrast, the focused items SM has proposed strike me as something 
that can be discussed in a reasonable time, and if folks stop trying to 
generalize the issue, actually get resolved (one way or the other).

I don't care whether the mechanism is a BoF, email list sponsored by the 
IETF chair, or a rotting band of singers (all singing badly).

Yours,
Joel

---

From: S Moonesamy <[email-masked]>
Date: Tue, 11 Jun 2019 11:12:51 -0700

Hi Eliot,
>committee is marginally increased.

Thank you for mentioning the above.

It is not easy to argue against a proposal which is authored by the 
"leadership".  There is a perception that there could be retribution 
against the persons listed as signatories.  How many IETF 
participants are willing to face that?

Regards,
S. Moonesamy

---

From: Eliot Lear <[email-masked]>
Date: Tue, 11 Jun 2019 21:16:13 +0200

Hi Mike,

With regard to your BoF proposal below, I think it’s fine, but it looks more like a WG charter.  I propose we use it as a starting point as such.  I would add some scoping so that this doesn’t stretch beyond recalls.

Eliot

> On 11 Jun 2019, at 18:12, Michael StJohns <[email-masked]> wrote:
> 
> And I'd suggest that if we're going to expend any energy on this, we deal with the actual problems with the recall process rather than the deck chair counting.
> 
> Specifically, as currently described it's going to be something like a 2-3 month process to start the recall, select the chair, form the committee, get them up to speed on the requirements for the position and reasonable reasons for recall, investigate the problem and finally have a vote.   That's a lot of time to leave a potential recallee in limbo and is probably not good for the IETF collaborative model.
> 
> And unlike the formation of the Nomcom and selection of the Nomcom chair, having the ISOC chair select the recall chair has a number of downsides including the possibility of the perception of selecting a chair for a desired result.
> 
> 
> So instead of restating SM's conclusion as the goal of the BOF maybe use something like:
> 
> a) Evaluate the current recall model for changes;  whether other processes may be more appropriate for perceived needs; and whether the recall process should remain part of the management process for IETF leadership.
> 
> b) In light of (a) evaluate and possibly revise the initiation model for the recall process including the possibility of revising or supplanting the current petition based model; evaluate and possibly revise the model for selection of the recall committee and chair; evaluate and possibly revise the deliberation model for the recall committee and the rights of the proposed recallee during the process.
> 
> c) In light of the addition of the Ombudsman process, evaluate how the Ombudsman process should interact if at all with the recall process; for example should the Obudsteam be used to investigate charged wrong-doing asserted by a recall petition?
> 
> b) We've come to consensus on the following changes:   {}  and we've been unable to come to consensus on the following topics {}.  These represent all of the topics considered by the group.  A draft covering the consensus items shall be forthcoming.
> 
> c) We've been unable to come to consensus, however the group has determined - through consensus - that there's enough interest to form a WG to address these topics.  We have X people who have agreed to participate actively. The charter is attached.
> 
> d) We've been unable to come to consensus and there is no consensus that further deliberation at this time will result in progress.
> 
> Or something like this.   As I asked earlier - do we actually have 10 or 20 people who think they want to spend some time working this process or are we being DOS'd on a process question that few if any really care about?
> 
> We as the IETF have a hard problem of saying "no" at times - for WG creation, for the publication of limited impact documents, etc.  It may be time as a group to thank SM for his efforts and decline to proceed.
> 
> Later, Mike
> 
> 
> 
> --

---

From: Patrick McManus <[email-masked]>
Date: Tue, 11 Jun 2019 18:42:00 -0400

Hi Eliot,

The reason I made a comment on this topic is because the amount of
discussion related to recall struck me as embarrassing.

I am reminded of kids in a clubhouse, no doubt bearing a keep out sign,
discussing whether the secretary or treasurer would take over in the wake
of the simultaneous death of the co-presidents (who couldn't agree on who
would be president in the first place). In short - its a process discussion
obsessed with trappings and machinery and meta-talk. It exists only to
serve itself. At least the kids in the clubhouse have nothing better to do.
A BoF is just endorsement that its important, when it is not.

WRT clear and non-controversial cases such as AWOL - there already is a
process that has been prepared in contingency in the past and not needed
yet. That seems fine.

WRT less obvious cases - referring them to a committee is not how one
effectively resolves complicated questions. In the case of a multi
stakeholder organization like ours those questions will inevitably be
tinged with market and political forces - its the nature of the beast.
Keeping terms short creates an accountability loop while also allowing the
office holder space to fulfill their duties day to day. A totally
reasonable situation - half the leadership stands for appointment every
year already.

-P

---

From: Eliot Lear <[email-masked]>
Date: Wed, 12 Jun 2019 09:39:45 +0200

Patrick,

I’ll respond since you addressed this to me, but you replied to John’s message.  I cannot tell if you are saying that there isn’t a problem to be solved or whether you are arguing over its scope.  If you are saying that we have a process that deals with AWOL people, it clearly hasn’t functioned properly in the past.  If you are saying that you are okay dealing with the AWOL problem, but would prefer not expanding to address the more general case, ok.  But your analogy is not appropriate.  Please allow for the possibility that there are those of us have been materially impacted, and who have seen the impact on this organization.  Perhaps you don’t see it because it hasn’t hit the area in which you work.

Eliot

> On 12 Jun 2019, at 00:42, Patrick McManus <[email-masked]> wrote:
> 
> Hi Eliot,
> 
> The reason I made a comment on this topic is because the amount of discussion related to recall struck me as embarrassing.
> 
> I am reminded of kids in a clubhouse, no doubt bearing a keep out sign, discussing whether the secretary or treasurer would take over in the wake of the simultaneous death of the co-presidents (who couldn't agree on who would be president in the first place). In short - its a process discussion obsessed with trappings and machinery and meta-talk. It exists only to serve itself. At least the kids in the clubhouse have nothing better to do. A BoF is just endorsement that its important, when it is not.
> 
> WRT clear and non-controversial cases such as AWOL - there already is a process that has been prepared in contingency in the past and not needed yet. That seems fine.
> 
> WRT less obvious cases - referring them to a committee is not how one effectively resolves complicated questions. In the case of a multi stakeholder organization like ours those questions will inevitably be tinged with market and political forces - its the nature of the beast. Keeping terms short creates an accountability loop while also allowing the office holder space to fulfill their duties day to day. A totally reasonable situation - half the leadership stands for appointment every year already.
> 
> -P
> 
> 
> 
> On Tue, Jun 11, 2019 at 1:18 PM John C Klensin <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> >
> >
> >> On 11 Jun 2019, at 17:48, Patrick McManus
> >> <[email-masked] <mailto:[email-masked]>> wrote:
> >>

---

From: John C Klensin <[email-masked]>
Date: Wed, 12 Jun 2019 04:27:52 -0400

--On Tuesday, June 11, 2019 18:42 -0400 Patrick McManus
<[email-masked]> wrote:

> Hi Eliot,
> 
> The reason I made a comment on this topic is because the
> amount of discussion related to recall struck me as
> embarrassing.

It strikes me as embarrassing too, but for a rather different
reason.

> I am reminded of kids in a clubhouse, no doubt bearing a keep
> out sign, discussing whether the secretary or treasurer would
> take over in the wake of the simultaneous death of the
> co-presidents (who couldn't agree on who would be president in
> the first place). In short - its a process discussion obsessed
> with trappings and machinery and meta-talk. It exists only to
> serve itself. At least the kids in the clubhouse have nothing
> better to do. A BoF is just endorsement that its important,
> when it is not.

Please remember that draft-moonesamy-recall-rev was proposed as
a very small set of patches to address perceived process
unfairness to a collection of IETF participants who, as the IETF
evolves, is growing more numerous and perhaps even more
important.  I was responsible for adding a decade-old loose end
to the patch list because it would be convenient.  That was
probably a mistake.   The authors thought that these patches
were sufficiently minor and focused that they could easily be
handled by going directly to IETF Last Call or, at worst, to a
very focused and short-lived WG.  Far more significant process
changes in this particular area were handled that way.  For
better or worse, had that occurred, we wouldn't be trying to
negotiate the terms of a BOF, we would not be intertwining
discussions of those patches with discussions of the
appropriateness of recalls and alternate models, etc.: exactly
the type of process discussion you are complaining about.  But
the IESG decided it wanted to open the door to broader
discussions and iterations on problem statements, so here we
are.  The usual refrain at this point is "if you don't like it,
tell it to the Nomcom".

> WRT clear and non-controversial cases such as AWOL - there
> already is a process that has been prepared in contingency in
> the past and not needed yet. That seems fine.

Actually, I'm not sure I know what you are talking about.  I was
active in POISED and even chaired one of its successor WGs.  I
don't even remember a discussion of recall as a mechanism for
dealing with what I think you are referring to as "AWOL".   If
it had been discussed, I'd like to believe we would have done
much better because the recall procedure is far too expensive
and time-consuming to deal with a person who has left but not
formally resigned.  For that situation, we shouldn't need much
more than a formal way of confirming the disappearance and
resigning for them, i.e., a way to define and fill a vacancy
without a formal resignation from the person.  Collecting
signatures, appointing a recall committee chair, going through
the process of getting volunteers for and selecting a recall
committee, and then having that committee say "yep, he or she
has disappeared" is almost certainly a far larger waste of time
than what you are complaining about in this discussion.  So to
claim that there is a process prepared for that case and
suggesting it is fine is, umm, strange to me.

That said, it seems to me that you are doing what you are
complaining about by introducing an issue that was not on the
table and expanding the scope of the discussion well beyond the
narrow focus of  the I-D and the discussion around it.  To me,
"trappings and machinery and meta-talk" pretty well cover that
situation.  YMMD, but, if so, I'd like to understand how and why.

> WRT less obvious cases - referring them to a committee is not
> how one effectively resolves complicated questions. In the
> case of a multi stakeholder organization like ours those
> questions will inevitably be tinged with market and political
> forces - its the nature of the beast. Keeping terms short
> creates an accountability loop while also allowing the office
> holder space to fulfill their duties day to day. A totally
> reasonable situation - half the leadership stands for
> appointment every year already.

And, again, those of us who want to keep the discussion narrowly
focused don't consider the less obvious cases or complicated
questions to be in scope.  From that point of view, the above is
either a distraction or a no-op.  On the other hand, I agree
with Eliot: your assumption that there is no leadership
performance or non-performance problem so severe that it cannot
wait a year or two without causing harm is inconsistent with my
experience as well.  It is also incorrect unless we have
concluded that things have changed and that old notions of
"Internet time" as moving very quickly are no longer applicable.

best,
    john