Subject: [Eligibility-discuss] Surprising lack of company diversity this year

From: Ted Lemon <[email-masked]>
Date: Mon, 13 Jul 2020 19:12:03 -0400

> 65. Dirk Kutscher, University of Applied Sciences Emden/Leer 
> 114. Ketan Jivan Talaulikar, Cisco Systems, India 
> 127. Christopher Wood, Cloudflare 
> 38. Xuesong Geng, Huawei 
> 121. Rüdiger Volk, no affiliation 
> 86. Gabriel Montenegro, Independent 
> 18. Pablo Camarillo, Cisco Systems 
> 58. LUIGI IANNONE, Huawei
> 13. Chris Bowers, Juniper Networks 
> 94. Tony Przygienda, Juniper
> 
> Disqualified selections are noted below:
> 96. Reshad Rahman, Cisco (Maximum Number of 2 for Cisco reached) - 10th in randomness order
> 85. Tal Mizrahi, Huawei (Maximum Number of 2 for Huawei reached) - 11th in randomness order

This is a surprising number of two-per-company random picks, and notice that two of those companies could have had /three/ nomcom members if not for the two-person rule. I suspect that the volunteer pool has been becoming less diverse over the past four years—this is the least company-diverse nomcom of the past four years.  It may just be random chance, but honestly it makes me want to make the rule one-person-per-company, not two-per-company. Regardless, it definitely emphasizes the importance of the work we are doing here.

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 14 Jul 2020 12:53:06 -0500

On 13 Jul 2020, at 18:12, Ted Lemon wrote:

> This is a surprising number of two-per-company random picks, and 
> notice that two of those companies could have had /three/ nomcom 
> members if not for the two-person rule. I suspect that the volunteer 
> pool has been becoming less diverse over the past four years—this is 
> the least company-diverse nomcom of the past four years.  It may just 
> be random chance, but honestly it makes me want to make the rule 
> one-person-per-company, not two-per-company. Regardless, it definitely 
> emphasizes the importance of the work we are doing here.

I haven't had a chance to look for it, but Mike St. Johns sent a message 
not too long ago with a nice "probability of getting 1 or 2 spots given 
number of volunteers" chart. I believe the results we got were very 
predictable.

I think this (like Bron's comment) is something worth examining, but 
like Bron's suggestion, this is a "post eligibility to be on the list" 
issue, which is a bit different than the current issue being addressed. 
The reason I suggested to Bron to bring it here (and to gendispatch) was 
to see if there's enough interest to examine these sorts of issues after 
we get the current document dealt with.

(FWIW: I disagree with Brian that IETF Area diversity -- or perhaps 
better, IETF technical expertise diversity -- is not the main concern. 
It, along with company-diversity, seems at least as important a concern 
as any others, given the distorted outcome it could have on the makeup 
of the IESG and IAB.)

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 14 Jul 2020 14:19:10 -0400

I think the lack of area diversity (as sometimes occurs) is a very 
different issue from the lack of corporate diversity.
While areas have interests and approaches, the biases of participants in 
an IETF area vary widely.  The issue for lack of area diversity is in my 
view more that it creates additional challenges for the nomcom, as they 
have to work harder to understand the area and its issues.  But they are 
likely to know they have that gap, and to address it  (in one or more of 
many possible ways.)

In contrast, while people from corporations vary widely, corporations 
often pressure their people for certain results, and often have a 
"corporate culture".  No, it is not an overwhelming bias.  Which is why 
I am personally comfortable with the current "no more than 2 from an 
affiliation" rule.

Also, people participate in more than one area.  And to different 
degrees in different areas.  And with different degrees of expertise in 
the areas they participate in.  Trying to quantify any of that in order 
to create a meaningful, useful, and clear nomcom qualification rule 
strikes me as a task well beyond what we can achieve.

Yes, one of the effects of randomness is that one gets apparently 
non-random results.  (The old story about the probability professor 
asking students to either flip 100 coins or to write down what they 
think is a random sequence; and then identifying which are which; seems 
applicable.)  Unless the effect of this clumping is a serious problem, I 
would prefer to be careful about fixes.

Yours,
Joel

---

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Jul 2020 14:30:44 -0400

On Jul 14, 2020, at 1:53 PM, Pete Resnick <[email-masked]> wrote:
> I think this (like Bron's comment) is something worth examining, but like Bron's suggestion, this is a "post eligibility to be on the list" issue, which is a bit different than the current issue being addressed. The reason I suggested to Bron to bring it here (and to gendispatch) was to see if there's enough interest to examine these sorts of issues after we get the current document dealt with.

I don’t actually agree that this is a post-eligibility issue. That the pool is this biased to begin with is an artifact of our eligibility process. Correcting this after selection is better than not correcting it at all, but if we had a really big pool to pick from, which wasn’t mostly people from a few big companies, we wouldn’t be seeing this output to the random selection process. Or, to Joel’s point in the next message, it would be far less likely than it is at present.

Is there an action item here? That’s less clear. But this goes to my point earlier about how we don’t really know what the pool would look like if we made more participants who are not authors and can’t travel eligible.  We don’t actually /know/ if we can do better. It seems clear to me that we need to.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2020 09:02:36 +1200

On 15-Jul-20 05:53, Pete Resnick wrote:
...
> as any others, given the distorted outcome it could have on the makeup 

FWIW, I didn't mean to say that isn't important; just that all kinds of
diversity are important.

In particular, I'd like to see a *lot* more people with an operations
background in the IETF as a whole, the I*, and of course NomCom.

   Brian

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 15 Jul 2020 20:54:03 +1000

> Is there an action item here? That’s less clear. But this goes to my point earlier about how we don’t really know what the pool would look like if we made more participants who are not authors and…

One "lay of the land" issue here - I'm already taking on the "risk" of a significant commitment by volunteering for consideration to be on the nomcom.  My board has given me a really solid indication that they don't support me taking on a leadership role in the IETF beyond WG chair with my current responsibilities, and fair enough!  I can only dedicate a small fraction of my time to my IETF work, and even then I could certainly do better at the job than I do (particularly with my own drafts!  I have two of them sitting in expired status waiting for me to bring them back to life, and never find the time to do it)

Many people who work at smaller companies or for themselves have that problem - they can't afford to pay multiple people to work 100% on standards, and even if they could - people who are also good at standards work can often be deployed for other, more valuable things.  It's only once you get quite big that you can afford (and get value from!) a big standards group.  So taking on a place on the nomcom is a significant risk/cost.

There's no "moral" to this, other than to say that the fact that we have a pool that includes many people from a few big companies is expected and normal.  It's a natural result of how reality works.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 Jul 2020 09:43:11 -0400

That’s a conjecture, Bron. Might be correct, but one anecdote does not a trend make. I am also exposing myself to risk by signing up for nomcom even though I work at a big company. I used to work at a small company where it would have been no problem at all. 

We really just don’t know who would volunteer if we were better able to count something other than showing up and writing documents as contributions. Conjecturing about it seems like a distraction. 

> On Jul 15, 2020, at 06:54, Bron Gondwana <[email-masked]> wrote:
>

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Jul 2020 14:36:20 -0400

--On Wednesday, July 15, 2020 20:54 +1000 Bron Gondwana
<[email-masked]> wrote:

>> Is there an action item here? That's less clear. But this
>> goes to my point earlier about how we don't really know
>> what the pool would look like if we made more participants
>> who are not authors and can't travel eligible.  We don't
>> actually /know/ if we can do better. It seems clear to me
>> that we need to.
> 
> One "lay of the land" issue here - I'm already taking on the
> "risk" of a significant commitment by volunteering for
> consideration to be on the nomcom.  My board has given me a
> really solid indication that they don't support me taking on a
> leadership role in the IETF beyond WG chair with my current
> responsibilities, and fair enough!  I can only dedicate a
> small fraction of my time to my IETF work, and even then I
> could certainly do better at the job than I do (particularly
> with my own drafts!  I have two of them sitting in expired
> status waiting for me to bring them back to life, and never
> find the time to do it)
> 
> Many people who work at smaller companies or for themselves
> have that problem - they can't afford to pay multiple people
> to work 100% on standards, and even if they could - people who
> are also good at standards work can often be deployed for
> other, more valuable things.  It's only once you get quite big
> that you can afford (and get value from!) a big standards
> group.  So taking on a place on the nomcom is a significant
> risk/cost..
> 
> There's no "moral" to this, other than to say that the fact
> that we have a pool that includes many people from a few big
> companies is expected and normal.  It's a natural result of
> how reality works.

Bron,

While I agree and have often found myself in a similar position
of having limited time for the IETF and having to pick carefully
how and where to invest it (and probably get that wrong fairly
often), I'm not sure that the only answer is "accept this as
normal".   If we believe that the Internet and/or the IETF would
be better served if people with, e.g., a broad range of time
availability would show up on the Nomcom, then the solution is
to look for ways to reduce the Nomcom work load and time
commitment so that more people with limited time who are
otherwise eligible will feel able to volunteer.  

More generally, it seems clear to me after recent discussions
that, if we want more diversity (or all kinds) on the Nomcom
itself, we need pay as much attention to incentives (or
disincentives) to volunteer given eligibility as we do to
eligibility criteria.

   john