Subject: Re: [EME] EME charter

From: "Fergie" <[email-masked]>
Date: Mon, 13 Nov 2006 06:10:34 GMT

-- Yangwoo Ko <[email-masked]> wrote:

>I agree with the argument that "transparency" is problematic.
>By the way, if they are not transparent, why should we call
>them as "middleboxes" ? Aren't they just end-points? It seems
>to be necessary to differentiate middleboxes that are well
>identified and explicitly exploited by end-points and that
>are trying to be transparent.

Well, I would argue the fact of whether middleboxes are "problematic"
or not is an academic discussion -- and whether they are actually
problematic depends on how you define "problematic". :-)

Having said that, I would tend to think that endpoints can defined
as the source (originator) & destination addresses in any IP
packet.

- ferg

--
"Fergie", a.k.a. Paul Ferguson
 Engineering Architecture for the Internet
 fergdawg(at)netzero.net
 ferg's tech blog: http://fergdawg.blogspot.com/

_______________________________________________
EME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/eme

---

From: Melinda Shore <[email-masked]>
Date: Mon, 13 Nov 2006 10:59:10 -0500

> as the source (originator) & destination addresses in any IP

One layer's endpoint is another layer's middlebox.  For example,
relays are, unfortunately, increasingly common in VoIP networks
and while they're effectively transparent to the application
peers they are being addressed directly.

Melinda

---

From: Joe Touch <[email-masked]>
Date: Mon, 13 Nov 2006 08:22:34 -0800

> peers they are being addressed directly.

Agreed. I've had a definition for a while derived from the well-known:

 	hardware: that which can be kicked

	software: everything else

------

My definition of "endpoint":

	endpoint: that which *I* can kick

	middle: everything else

Joe

---

From: Saikat Guha <[email-masked]>
Date: Mon, 13 Nov 2006 13:27:53 -0500

> as the source (originator) & destination addresses in any IP

What about IP source route where the destination keeps changing :-p

From the perspective of the IP, it makes sense to define the IP endpoint
as the source or destination of a datagram. This definition on its own
causes problems in the presence of mobility and multi-homing.

From a broader perspective, one potential definition 
may be: 
      the application instances that are trying to 
      communicate over the Internet. 

For example, a web browser and a web server are application instances
trying to communicate -- HTTP endpoints. The Internet enables these
endpoints to communicate by, under the hood, managing multiple IP
addresses, picking TCP or SCTP or other appropriate transports,
discovering and invoking in-network middlebox functionality such as NAT
and firewalls as directed by local network administrators, etc.

-- 
Saikat

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 13 Nov 2006 12:53:58 -0800

Melinda Shore wrote:

>For example,

VoIP back to back user agents (B2BUA) are anything but transparent and
they will break SIP routing and security completely. B2BUA will most
likely also break SIP endpoint applications that they don't understand.

It took quite a number of years to develop ICE for NAT traversal, so now
how many hears will it take to traverse B2BUA?

The is the worst form of job security :-)

Thanks, Henry

-----Original Message-----
From: Melinda Shore [mailto:[email-masked]] 
Sent: Monday, November 13, 2006 9:59 AM
To: Fergie
Cc: [email-masked]
Subject: Re: [EME] EME charter

Melinda