Subject: RE: [Emu] Duplicate integrity protection on Protected Payload datain GPSK

From: "Joseph Salowey \(jsalowey\)" <[email-masked]>
Date: Tue, 15 Aug 2006 19:29:17 -0700

AES-CBC seems like a good choice.   

Joe 

> -----Original Message-----
> From: Charles Clancy [mailto:[email-masked]] 
> Sent: Sunday, July 16, 2006 5:52 PM
> To: Lakshminath Dondeti
> Cc: [email-masked]
> Subject: Re: [Emu] Duplicate integrity protection on 
> Protected Payload datain GPSK
> 
>  > My reading of the GPSK draft is that the Protected Payload 
> data will  > be integrity protected using the MAC from the 
> combined mode and there  > is the integrity checksum over the 
> entire GPSK-Message.  I think we  > should avoid the multiple MACs.
> 
> ...
> 
>  > I am curious about others' opinions on EAX vs. CCM.
> 
> We could replace AES-EAX with AES-CBC.  Would address both 
> your concerns?
> 
> --
> t. charles clancy, ph.d.  |  [email-masked]  |  www.cs.umd.edu/~clancy
> 
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/emu
> 

_______________________________________________
Emu mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/emu

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 15 Aug 2006 20:00:43 -0700

>AES-CBC seems like a good choice.

This might also be a decent choice for the EAP-TLS mandatory-to-implement 
ciphersuite (unless the issues with 3DES can be ironed out).