Subject: RE: [Emu] Proposed Resolution to multiple Peer-Id/Server-Id Issue

From: Bernard Aboba <[email-masked]>
Date: Wed, 6 Jun 2007 14:21:15 -0700

Also, it has been pointed out that the purpose of the Peer-Id/Server-Id may not be fully explained, so that the following sentence may also need to be added to Section 5.2:  

"Together the Peer-Id and Server-Id name the entities involved in
deriving the MSK/EMSK. "

________________________________
> From: [email-masked]
> To: [email-masked]
> Date: Tue, 5 Jun 2007 22:04:56 -0700
> Subject: [Emu] Proposed Resolution to multiple Peer-Id/Server-Id Issue
> 
> It has been pointed out that an EAP-TLS certificate can contain multiple subject or subjectAltName fields.
> To address this, I propose that we add the following text to Section 5.2:
> It is possible for more than one subjectAltName field to be present
> in a peer or server certificate.  Where more than one subjectAltName
> field is present in a certificate, EAP-TLS implementations SHOULD
> export all the subjectAltName fields within Peer-Ids or
> Server-Ids; all of the exported Peer-Ids and
> Server-Ids are considered valid.
> Similarly, if more than one subject field is present in a peer or
> server certificate, and no subjectAltName field is present, then
> EAP-TLS implementations SHOULD export all of the subject fields
> within Peer-Ids and Server-Ids;   all of the exported Peer-Ids and
> Server-Ids are considered valid.

_______________________________________________
Emu mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/emu

---

From: Ryan Hurst <[email-masked]>
Date: Wed, 6 Jun 2007 14:22:10 -0700

I think this is a good clarification.

-----Original Message-----
From: Bernard Aboba [mailto:[email-masked]] 
Sent: Wednesday, June 06, 2007 2:21 PM
To: [email-masked]
Subject: RE: [Emu] Proposed Resolution to multiple Peer-Id/Server-Id
Issue

Also, it has been pointed out that the purpose of the Peer-Id/Server-Id
may not be fully explained, so that the following sentence may also need
to be added to Section 5.2:  

> It has been pointed out that an EAP-TLS certificate can contain
multiple subject or subjectAltName fields.

---

From: "Joseph Salowey \(jsalowey\)" <[email-masked]>
Date: Wed, 6 Jun 2007 15:56:25 -0700

I believe this is accurate.  Is there a particular ambiguity this is
clearing up?

Thanks,

Joe 

> Subject: RE: [Emu] Proposed Resolution to multiple 
> Peer-Id/Server-Id Issue
> 
> 
> Also, it has been pointed out that the purpose of the 
> Peer-Id/Server-Id may not be fully explained, so that the 
> following sentence may also need to be added to Section 5.2:  
> 
> "Together the Peer-Id and Server-Id name the entities 
> involved in deriving the MSK/EMSK. "
> 
> 
> 
> > It has been pointed out that an EAP-TLS certificate can 
> contain multiple subject or subjectAltName fields.
> > It is possible for more than one subjectAltName field to be 
> present in 
> > a peer or server certificate.  Where more than one subjectAltName 
> > export all the subjectAltName fields within Peer-Ids or Server-Ids; 
> > all of the exported Peer-Ids and Server-Ids are considered valid.