Subject: [Emu] LAST CALL: draft-ietf-emu-eaptunnel-req-06.txt

From: Stephen McCann <[email-masked]>
Date: Tue, 1 Jun 2010 13:52:56 +0100

Alan,
       I've reviewed this document and it appears fine to me.

Couple of small comments:

1) Can a reference be made to the definitions of "good", "strong" and
"weak", regarding cryptographic strength; although section 6.1 does
define "weak" quite well.

2) Within sections 4.2.1.1.2 amd 4.2.1.1.3, its not immediately clear
what "one mandatory" is referring to. Is this a "mandatory algorithm"
or a "mandatory feature"? It could perhaps do with a little
clarification.

Kind regards

Stephen McCann

On 20 May 2010 15:33, Alan DeKok <[email-masked]> wrote:
>  The current version of the document has addressed all open concerns.
> We will therefore be having a last call lasting for two weeks, until
> June 4, 2010.
>
>  Please take the time to review the document for any issues.  Reviews
> should be posted to the list, and should contain technical and editorial
> comments.
>
>  If there are no objections, we will start the publication process.  If
> all goes well, the document should be in process by the next IETF meeting.
>
>  Alan DeKok.
>
>
> [email-masked] wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the EAP Method Update Working Group of the IETF.
>>
>>
>>       Title           : Requirements for a Tunnel Based EAP Method
>>       Author(s)       : K. Hoeper, et al.
>>       Filename        : draft-ietf-emu-eaptunnel-req-06.txt
>>       Pages           : 24
>>       Date            : 2010-05-14
>>
>> This memo defines the requirements for a tunnel-based Extensible
>> Authentication Protocol (EAP) Method.  This method will use Transport
>> Layer Security (TLS) to establish a secure tunnel.  The tunnel will
>> provide support for password authentication, EAP authentication and
>> the transport of additional data for other purposes.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-emu-eaptunnel-req-06.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> Emu mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/emu
>
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu
>

---

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Wed, 16 Jun 2010 22:17:16 -0700

Hi Stephen,

Thanks for the review.  Comments inline below:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Stephen McCann
> Sent: Tuesday, June 01, 2010 5:53 AM
> To: [email-masked]
> Subject: [Emu] LAST CALL: draft-ietf-emu-eaptunnel-req-06.txt
> 
> Alan,
[Joe] I think most places where we use the word strong or good it doesn't add anything so it can be removed and other places it can refer to section 6.1.  I'll go through the document and fix these. 

> or a "mandatory feature"? It could perhaps do with a little
[Joe] The intent is to say require implementations to provide a common set of algorithms that meet a minimum set of requirements.  A TLS cipher suite is a set of algorithms so a mandatory to implement cipher suite is a mandatory to implement set of algorithms.  Does this clear up your issue, or is there something else that needs to be clarified?

---

From: Stephen McCann <[email-masked]>
Date: Thu, 17 Jun 2010 07:23:24 -0500

Joe,
       clarifications are good. Thanks.

Kind regards

Stephen