Subject: [Emu] Mutual Authentication with ..

From: bakyt eshmurzaev <[email-masked]>
Date: Mon, 23 May 2011 02:40:44 -0700 (PDT)

Mutual Authentication with EAP-MD5 

Dear all, 

I hope it is right place to ask this question. 
In these days, I am learning a protocol verification tool and trying to verify 
EAP methods. 

I want to see if the tool can find known attacks that can be launched to these 
protocols. 

And started with basic one - EAP-MD5.  

The [rfc1994 CHAP 1996] states CHAP protocol is only one-way authentication. 
But by negotiating CHAP in both directions the same secret set may easily be 
used for mutual authentication.

In [rfc3748 EAP 2004] it is said that the sequence of Requests and Responses 
continues as long as needed.
The Request packet is sent by the authenticator to the peer. 

My questions are: 
1) Is it possible to mutually authenticate Peer and Server using EAP-MD5 ?
2) If it is possible then how will messages exchange ? 
3) is it possible that peer also can send request (Or may the Peer can send a 
challenge in the Respond packet) ? 

4) Can it be like following : 

P <-- S :    Request_Id
P --> S :    Respond_Id.User_Id

P <-- S :    Server_Challenge, Server_Id
P --> S :    Hash(User_Id.Secret.Server_Challenge), User_Challenge
P <-- S :     Hash(Server_Id.Secret.User_Challenge), EAP_Success                 
        % or EAP_Failure 

where
P            : Peer
S            : Server
Secret         : Password (symmetric key) 
Hash         : One-way hash function 

I'm very not sure, 
Please correct me 

Your help would be greatly appreciated

Thank you very much 

P.S.  I think I explained what my problem is. My English is not good.

---

From: Stefan Winter <[email-masked]>
Date: Mon, 23 May 2011 11:50:13 +0200

Hi,

you may want to look at MSCHAPv2, RFC2759. From its introduction:

   *  MS-CHAP-V2 provides mutual authentication between peers by
      piggybacking a peer challenge on the Response packet and an
      authenticator response on the Success packet.

which seems to be roughly what you described below.

Greetings,

Stefan Winter

Am 23.05.2011 11:40, schrieb bakyt eshmurzaev:
> In these days, I am learning a protocol verification tool and trying
> to verify EAP methods.
> I want to see if the tool can find known attacks that can be launched
> to these protocols.
> But by negotiating CHAP in both directions the same secret set may
> easily be used for mutual authentication.
>
> In [rfc3748 EAP 2004] it is said that the sequence of Requests and
> Responses continues as long as needed.
> 3) is it possible that peer also can send request (Or may the Peer can
> send a challenge in the Respond packet) ?
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473