Subject: [Emu] Issue 33: Certificate enrollment

From: Joe Salowey <[email-masked]>
Date: Wed, 29 Feb 2012 21:57:17 -0800

The current tunnel method draft contains TLVs for PKCS#10 and PKCS#7 TLVs.  

The purpose of either of these TLVs is not well described.   I think we need to describe the purpose of these TLVs better or remove them.  

The PKCS#10 TLV makes a brief reference to the Simple PKI request of CMS (RFC 5272), but does not provide much more description than that reference.

The PKCS#7 TLV doesn't really describe it usage.  It could be used to carry the enrollment response, or it could be used to send a root certificate to the peer in the case where an inner method is used to authenticate the tunnel.  

It doesn't seem that either of these is a complete enough specification.  

Does someone care enough about this functionality to provide better and more complete test for it? 

Thanks,

Joe

---

From: "Dan Harkins" <[email-masked]>
Date: Wed, 29 Feb 2012 22:09:24 -0800 (PST)

On Wed, February 29, 2012 9:57 pm, Joe Salowey wrote:
> The purpose of either of these TLVs is not well described.   I think we
> need to describe the purpose of these TLVs better or remove them.
>
> The PKCS#10 TLV makes a brief reference to the Simple PKI request of CMS
> (RFC 5272), but does not provide much more description than that
> reference.
>
> The PKCS#7 TLV doesn't really describe it usage.  It could be used to
> carry the enrollment response, or it could be used to send a root
> certificate to the peer in the case where an inner method is used to
> authenticate the tunnel.
>

  I care about this functionality and will be willing to describe
the syntax of these messages but what test are you talking about?

  Dan.

---

From: Joe Salowey <[email-masked]>
Date: Wed, 29 Feb 2012 22:29:29 -0800

> the syntax of these messages but what test are you talking about?

[Joe] Thanks Dan, I was thinking of walking on hot coals...  Ooops, I meant text.