Subject: Re: [Emu] Session identifiers for fast re-authentication

From: John Mattsson <[email-masked]>
Date: Sun, 3 Feb 2019 13:43:54 +0000

Looks good!

I only have editorial comments

- "defintion"

- "implemementations"

- "     Session-Id = 0x19 || client.random || server.random).
   This definition is already in wide-spread use in multiple PEAP"

   Should remove ")." and add a blank line.

- I noticed that this draft and draft-ietf-emu-rfc5448bis uses slightly different notation (decimal vs. hexadecimal). Should be aligned.

   https://tools.ietf.org/html/draft-ietf-emu-rfc5448bis-04

      Session-Id = 50 || NONCE_S || MAC

   https://tools.ietf.org/html/draft-dekok-emu-eap-session-id-00

      Session-Id = 0x17 || NONCE_S || MAC

   All examples I can find (RFC 5247, RFC 5216) use hexadecimal notation, so I suggest that draft-ietf-emu-rfc5448bis is updated to avoid any confusion for implement:

     OLD: "Session-Id = 50 || RAND || AUTN"
     NEW: "Session-Id = 0x32 || RAND || AUTN"

     OLD: "Session-Id = 50 || NONCE_S || MAC"
     NEW: "Session-Id = 0x32 || NONCE_S || MAC"

Cheers,
John

---

From: Alan DeKok <[email-masked]>
Date: Sun, 3 Feb 2019 09:24:31 -0500

>   Should remove ")." and add a blank line.

  Fixed, thanks.

  I'll do some more touchups and issue a new draft next week.

  Alan DeKok.