Subject: Re: [Emu] TLS 1.3 and other EAP methods

From: John Mattsson <[email-masked]>
Date: Sun, 3 Feb 2019 12:46:11 +0000

Based on this discussion I suggest changing the title and the scope of draft-ms-emu-eaptlscert 

OLD: "Handling Large Certificates and Long Certificate Chains in EAP-TLS"
NEW: "Handling Large Certificates and Long Certificate Chains in TLS-based EAP Methods"

The problem description, discussion, and solutions are the same for all TLS-based EAP Methods, so it would be good to make it clear to readers that the information is useful for other TLS-based EAP Methods such as TTLS / FAST / PEAP / TEAP as well. The only thing that would change is "EAP-TLS" replaced with " TLS-based EAP Methods" in a number of places. All the technical content would be the same.

Cheers,
John

---

From: Alan DeKok <[email-masked]>
Date: Sun, 3 Feb 2019 07:59:52 -0500

> The problem description, discussion, and solutions are the same for all TLS-based EAP Methods, so it would be good to make it clear to readers that the information is useful for other TLS-based EAP…

  I think that's good, thanks.

  Alan DeKok.

---

From: Mohit Sethi M <[email-masked]>
Date: Tue, 5 Feb 2019 05:28:08 +0000

Hi John, Alan, and others,

The recommendations in this document may be used by all TLS-based EAP 
methods. However, fragmenting large certificates and certificate chains 
into many small messages is less of a problem when only one side 
(server) is authenticating with certificates.

--Mohit

On 2/3/19 2:46 PM, John Mattsson wrote:
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu

---

From: Alan DeKok <[email-masked]>
Date: Tue, 5 Feb 2019 08:18:47 -0500

> (server) is authenticating with certificates.

  Other TLS-based EAP methods allow the use of client certificates, too.  While not the normal use-case, it is a well-known and deployed use-case.

  The document should add a note that the issue is less of a concern when client certificates are not used.

  Alan DeKok.