Subject: Re: [Emu] EAP and Fragmentation

From: John Mattsson <[email-masked]>
Date: Fri, 15 Mar 2019 16:44:14 +0000

Alan wrote:

>I've done a quick check.  On reception, FreeRADIUS accepts the L bit for any type of message.  It doesn't care >about fragments, just that the length is correct.
>
 >For sending packets, FreeRADIUS sets the L bit only if it is sending fragments.

That is probably the correct behavior to standardize, i.e., something like

"Implementations MUST NOT set the L bit in unfragmented messages, but MUST accept unfragmented messages with and without the L bit set."

Cheers,
John

---

From: slon v sobstvennom palto <[email-masked]>
Date: Fri, 15 Mar 2019 18:51:34 +0200

John wrote:

>"Implementations MUST NOT set the L bit in unfragmented messages, but MUST
accept unfragmented messages with and without the L bit set."

I'm for the strict approach. Anyway some implementations don't adhere it.
The sentence above narrows the behaviour to a non-ambiguous while requires
to support all kinds of existing behaviours thus it looks like the most
exact form of the requirement.

Cheers,
Oleg

On Fri, Mar 15, 2019 at 6:44 PM John Mattsson <[email-masked]>
wrote:

> Alan wrote:
>
> >I've done a quick check.  On reception, FreeRADIUS accepts the L bit for
> any type of message.  It doesn't care >about fragments, just that the
> length is correct.
> >
> "Implementations MUST NOT set the L bit in unfragmented messages, but MUST
> accept unfragmented messages with and without the L bit set."
>
> Cheers,
> John
>
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu
>

---

From: Alan DeKok <[email-masked]>
Date: Fri, 15 Mar 2019 12:53:52 -0400

On Mar 15, 2019, at 12:51 PM, slon v sobstvennom palto <[email-masked]> wrote:
> I'm for the strict approach. Anyway some implementations don't adhere it. The sentence above narrows the behaviour to a non-ambiguous while requires to support all kinds of existing behaviours thus it looks like the most exact form of the requirement. 

  I agree.

  Alan DeKok.