Subject: Re: [Emu] EAP-AKA' and Re: WG adoption call for draft-arkko-eap-aka-pfs

From: Joseph Salowey <[email-masked]>
Date: Thu, 27 Jun 2019 09:51:06 -0700

Significant time has passed and no alternate proposals have surfaced.  We
need to decide whether to accept this document into the working group or
not.  It seems that we have support for the view that working on this
informational document in the working group is preferable to the
independent submission track.

Do working group members still have objections to taking this draft into
the working group?   Please respond on this thread by July 5, 2019.

Thanks,

Joe

On Wed, Apr 3, 2019 at 4:59 AM Alan DeKok <[email-masked]> wrote:

> On Apr 3, 2019, at 1:37 AM, Joseph Salowey <[email-masked]> wrote:
> >
> > Thanks for reviving this thread.  I agree this is important work, but we
> need to have consensus to bring the item into the working group.  I think
> the IPR issue is the main sticking point.
> >
> > I'll note that RFC 5448 has a similar IPR declaration and both documents
> are targeted as informational.   Some possible ways forward:
> >
> > 1. Come up with an alternative proposal.  Since no one has already
> stepped forward I don't think this is realistic.
> > 2. Accept the document into the working group.
> > 3. Reject the document, which will force the work to go through the
> independent submission process, which will probably result in less broad
> and thorough review.
> > 4. Amendment to the license terms of the IPR - I have received no
> indication that this will happen
> >
> > The document will likely get published in either case 2 or 3 above.  I'd
> like to work through this discussion over the next few weeks so please
> voice your views on this thread.
>
>   Despite my misgivings, I think (2) is necessary here.
>
>   It would be helpful for the IETF as a whole to acknowledge the
> importance of Open Source in the IETF process.  And, that "RAND" licensing
> isn't necessarily RAND when fees are involved.
>
>   e.g. "Reasonable and Non-Discriminatory License to All Implementers with
> Possible Royalty/Fee"
>
>   OK, *what* is that fee?  A million dollars for a 5G operator / vendor?
> How much should an Open Source implementation pay?
>
>   Alan DeKok.
>
>

---

From: Alan DeKok <[email-masked]>
Date: Thu, 27 Jun 2019 13:55:29 -0400

On Jun 27, 2019, at 12:51 PM, Joseph Salowey <[email-masked]> wrote:
> 
> Significant time has passed and no alternate proposals have surfaced.  We need to decide whether to accept this document into the working group or not.  It seems that we have support for the view that working on this informational document in the working group is preferable to the independent submission track.  

  Yes.

> Do working group members still have objections to taking this draft into the working group?   Please respond on this thread by July 5, 2019. 

  I have misgivings, but no objections.

  Alan DeKok.