Subject: [Emu] I-D Action: draft-dekok-emu-eap-session-id-01.txt

From: [email-masked]
Date: Tue, 23 Jul 2019 16:45:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the EAP Method Update WG of the IETF.

        Title           : EAP Session-Id Derivation
        Author          : Alan DeKok
	Filename        : draft-dekok-emu-eap-session-id-01.txt
	Pages           : 9
	Date            : 2019-07-23

Abstract:
   EAP Session-Id derivation has not been defined for EAP-SIM, EAP-AKA,
   and EAP-AKA' when using the fast re-authentication exchange instead
   of full authentication.  This document updates [RFC5247] to define
   those derivations for EAP-SIM, and EAP-AKA.  Since [AKAP] defines the
   Session-ID for EAP-AKA', the definition for EAP-AKA' is not included
   here.  [RFC5247] also does not define Session-Id derivation for PEAP.
   A definition is given here which follows the definition for other
   TLS-based EAP methods.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-dekok-emu-eap-session-id/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-dekok-emu-eap-session-id-01
https://datatracker.ietf.org/doc/html/draft-dekok-emu-eap-session-id-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-dekok-emu-eap-session-id-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: John Mattsson <[email-masked]>
Date: Thu, 25 Jul 2019 11:34:28 +0000

Hi,

Minor comments on the 01 version. Otherwise I think the document is ready for WGLC.

- I agree with Mohit that the title should be changed to something like
"EAP Session-Id Derivation for EAP-SIM, EAP-AKA, and PEAP"

- Abstracts in RFCs cannot have references. [RFC5247] and [AKAP] need to be removed.

- The following sentences in the abstract and intro will have to change
  before publishing.

  "EAP Session-Id derivation has not been defined for EAP-SIM, EAP-AKA,
  and EAP-AKA' when using the fast re-authentication exchange instead
  of full authentication."

  I suggest to just remove EAP-AKA' (The document already talks about RFC5448bis). 

  "EAP Session-Id derivation has not been defined for EAP-SIM and EAP-AKA,
   when using the fast re-authentication exchange instead
   of full authentication."

- The sentence in the abstract about EAP-AKA' should be in the document body as well.

  "Since [AKAP] defines the Session-ID for EAP-AKA', the definition for
  EAP-AKA' is not included here."

- "TLS 1.2 or earlier is used" -> "TLS 1.2 is used"

   The TLS wg document draft-ietf-tls-oldversions-deprecate (Submitted to IESG
	for Publication) formally prohibits negotiation and use of TLS 1.0
	and TLS 1.1. It also updates all RFCs that use TLS.

- "deriviation" -> "derivation"

- "EAP-SIM, and EAP-AKA" -> "EAP-SIM and EAP-AKA"

Cheers,
John

-----Original Message-----
From: Emu <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Wednesday, 24 July 2019 at 01:47
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Emu] I-D Action: draft-dekok-emu-eap-session-id-01.txt

    
    Abstract:

    

    
    _______________________________________________
    Emu mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/emu

---

From: Alan DeKok <[email-masked]>
Date: Thu, 25 Jul 2019 11:26:42 -0400

> Minor comments on the 01 version. Otherwise I think the document is ready for WGLC.

  Thanks.

> "EAP Session-Id Derivation for EAP-SIM, EAP-AKA, and PEAP"

  Done.

> - Abstracts in RFCs cannot have references. [RFC5247] and [AKAP] need to be removed.

  The names still need to be there, I think.  But they shouldn't be references.

>   when using the fast re-authentication exchange instead

  Done.

>  EAP-AKA' is not included here."

  Done with some minor word smithing.

> 	and TLS 1.1. It also updates all RFCs that use TLS.

  I suppose so. I do suspect, tho, that there are millions of end user devices doing EAP which don't support TLS 1.2.

> - "EAP-SIM, and EAP-AKA" -> "EAP-SIM and EAP-AKA"

  Fixed, thanks.

  Alan DeKok.