Subject: Re: [Emu] POST WGLC Comments draft-ietf-emu-eap-tls13

From: John Mattsson <[email-masked]>
Date: Mon, 7 Oct 2019 06:32:44 +0000

Joseph Salowey <[email-masked]> wrote:

> Is the current published version up to date with the rest of the comments?

Yes, to my knowledge, the current draft handles all the other comments. If we decide to leave EAP-TLS PSK discussions for another draft, I think draft-ietf-emu-eap-tls13-07 is ready to move forward in the publication process.

Cheers,
John

---

From: Alan DeKok <[email-masked]>
Date: Mon, 7 Oct 2019 09:10:55 -0400

> Yes, to my knowledge, the current draft handles all the other comments. If we decide to leave EAP-TLS PSK discussions for another draft, I think draft-ietf-emu-eap-tls13-07 is ready to move forward…

  I agree.

  My one worry is that if we update EAP-TLS without also updating PEAP and TTLS, then bad things will happen.

  My $0.02 is to remove the discussion of FAST and TEAP from draft-dekok-emu-tls-eap-types, as the remaining items are not controversial.  The document should then be published simultaneously with the EAP-TLS updates.

  Alan DeKok.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 7 Oct 2019 16:55:38 +0200

> On 7 Oct 2019, at 15:10, Alan DeKok <[email-masked]> wrote:
> 

If we evolve draft-lear-eap-teap-brski into a more generic TEAP update we could cover TLS 1.3 there.

Eliot

---

From: Alan DeKok <[email-masked]>
Date: Mon, 7 Oct 2019 12:28:45 -0400

> If we evolve draft-lear-eap-teap-brski into a more generic TEAP update we could cover TLS 1.3 there.

  Given Jouni's experience with implementing TEAP, that may be best.

  i.e. TEAP cannot be implemented as-is.  The spec needs to be updated so that we can create inter-operable versions.

  Alan DeKok.