Subject: [Emu] TEAP Errata 5768

From: Joseph Salowey <[email-masked]>
Date: Mon, 7 Oct 2019 21:45:01 -0700

We need to come to resolution on how to resolve these errata.  I hope there
has been enough time for implementors to catch up with
Jouni's implementation.

The Crypto-Binding TLV is fixed at 20 octets and the draft does not say how
to handle longer MACs.

The discussion seems to indicate that we should make the TLV variable
length to handle longer MACs.

Is anyone else taking this approach with their implementation?

Is there any objection to move forward with making the MAC variable
length?

Cheers,

Joe

---

From: Alan DeKok <[email-masked]>
Date: Tue, 8 Oct 2019 07:03:42 -0400

On Oct 8, 2019, at 12:45 AM, Joseph Salowey <[email-masked]> wrote:
> 
> We need to come to resolution on how to resolve these errata.  I hope there has been enough time for implementors to catch up with Jouni's implementation.  

  Me and my team have been busy, so no progress here.

> The Crypto-Binding TLV is fixed at 20 octets and the draft does not say how to handle longer MACs.  
> 
> The discussion seems to indicate that we should make the TLV variable length to handle longer MACs.  
> 

  I will, and I think it's a good idea.

> Is there any objection to move forward with making the MAC variable length?  

  No.

  Alan DeKok.