Subject: Re: [Emu] Working Group Call For adoption of draft-aura-eap-noob-08.txt

From: Eduardo Ingles UM <[email-masked]>
Date: Sun, 3 May 2020 23:21:21 +0200

Dear all,

I support the adoption of this document.

We are currently working on IoT bootstrapping security and we 
implemented EAP-NOOB [1] on Zolertia Firefly motes with CoAP-EAP [2]. 
Here you can see a video demonstration of EAP-NOOB with Firefly motes 
and blinking lights:
https://youtu.be/rPuFKoihl5E

The implementation of CoAP-EAP as EAP Lower Layer is based on the 
previous work of my colleagues at the University of Murcia Rafa 
Marin-Lopez and Dan Garcia-Carrillo.

Best regards.

[1] EAP-NOOB source code: https://github.com/eduingles/coap-eap-noob
[2] CoAP-EAP source code: https://github.com/eduingles/coap-eap-controller

El 18/04/2020 a las 22:13, Joseph Salowey escribió:
> This is a call for adoption of draft-aura-eap-noob-08.txt [1] as a 
> working group item.  This draft has been discussed in several IETF 
> meetings and would be the starting point for the working group 
> deliverable for an EAP method based on "mutual authentication between 
> a peer and a server that is based on an out-of-band channel."  Please 
> review the draft and indicate whether you support adoption or not by 
> May 4, 2020.
> Thanks,
>
> Joe
>
> [1] https://datatracker.ietf.org/doc/draft-aura-eap-noob/
>
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu

-- 
Eduardo Inglés Sánchez
[email-masked]

Department of Information and Communication Engineering
Faculty of Computer Science
University of Murcia
30100 Murcia, Spain

---

From: Rafa Marin-Lopez <[email-masked]>
Date: Mon, 4 May 2020 11:18:54 +0200

Dear all:

I support the adoption of this document as well. 

I have been following this work from the beginning since I have been interested in the usage in EAP in IoT scenarios for bootstrapping for several years. As Eduardo has just mentioned we worked in an EAP lower-layer based on CoAP for IoT some time ago. 

https://tools.ietf.org/html/draft-marin-ace-wg-coap-eap-06 <https://tools.ietf.org/html/draft-marin-ace-wg-coap-eap-06>
https://www.mdpi.com/1424-8220/16/3/358 <https://www.mdpi.com/1424-8220/16/3/358>

One of the missing pieces we noticed was an EAP method adapted for IoT bootstrapping. EAP-NOOB covers this need. 

Best Regards.

> El 3 may 2020, a las 23:21, Eduardo Ingles UM <[email-masked]> escribió:
> 
> Dear all,
> 
> We are currently working on IoT bootstrapping security and we implemented EAP-NOOB [1] on Zolertia Firefly motes with CoAP-EAP [2]. Here you can see a video demonstration of EAP-NOOB with Firefly motes and blinking lights:
> https://youtu.be/rPuFKoihl5E <https://youtu.be/rPuFKoihl5E>
> 
> The implementation of CoAP-EAP as EAP Lower Layer is based on the previous work of my colleagues at the University of Murcia Rafa Marin-Lopez and Dan Garcia-Carrillo.
> 
> Best regards. 
> 
> [1] EAP-NOOB source code: https://github.com/eduingles/coap-eap-noob <https://github.com/eduingles/coap-eap-noob> 
> [2] CoAP-EAP source code: https://github.com/eduingles/coap-eap-controller <https://github.com/eduingles/coap-eap-controller> 
> 
> 
> 
> 
>> This is a call for adoption of draft-aura-eap-noob-08.txt [1] as a working group item.  This draft has been discussed in several IETF meetings and would be the starting point for the working group deliverable for an EAP method based on "mutual authentication between a peer and a server that is based on an out-of-band channel."  Please review the draft and indicate whether you support adoption or not by May 4, 2020.  
>> Thanks,
>> 
>> Joe
>> 
>> [1] https://datatracker.ietf.org/doc/draft-aura-eap-noob/ <https://datatracker.ietf.org/doc/draft-aura-eap-noob/>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/emu <https://www.ietf.org/mailman/listinfo/emu>
> -- 
> Eduardo Inglés Sánchez
> [email-masked] <mailto:[email-masked]>
> 

-------------------------------------------------------
Rafa Marin-Lopez, PhD
Dept. Information and Communications Engineering (DIIC)
Faculty of Computer Science-University of Murcia
30100 Murcia - Spain
Telf: +34868888501 Fax: +34868884151 e-mail: [email-masked]
-------------------------------------------------------

---

From: Eliot Lear <[email-masked]>
Date: Mon, 4 May 2020 11:55:08 +0200

Hi Mohit

> 
> The chairs had an email discussion which hadn't concluded. The main 
> sticking point was that both Joe and I prefer TEAP being addressed in a 
> separate update document that fixes all other TEAP errata as well. 
> However, this can be discussed after adoption.

Oleg has addressed the TEAP errata and it would be very helpful if Joe and Jouni could give it a stare.  I also posted one issue relating to the use of Request-Action, which may require an additional TLV to correct.  Also, I am aware of one additional erratum that I will open shortly that is minor (conflicting terms in the Request-Action frame).

If we can collect all of these, then it would be good for the group to decide what else needs to be updated.  FWIW, I see a TLS 1.3 update for TEAP as raising some questions around the way that restart is incorporated into 7170.  We could simply rule out restart for 1.3, or do something smarter.  I dunno yet.

Eliot

> 
> 
> A working group adoption call is now issued and we intend to move this 
> document forward rapidly.
> 
> --Mohit
> 
>> 
>>  Alan DeKok.
>>