Subject: I-D ACTION:draft-ietf-entmib-v2-01.txt

From: [email-masked]
Date: Mon, 09 Nov 1998 11:35:27 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Entity MIB Working Group of the IETF.

	Title		: Entity MIB using SMIv2 (Version 2)
	Author(s)	: K. McCloghrie, A. Bierman
	Filename	: draft-ietf-entmib-v2-01.txt
	Pages		: 53
	Date		: 06-Nov-98
	
This memo defines an experimental portion of the Management Information
Base (MIB) for use with network management protocols in the Internet
community.  In particular, it describes managed objects used for
managing multiple logical and physical entities managed by a single SNMP
agent.

Internet-Drafts are available by anonymous FTP.  Login with the username
"anonymous" and a password of your e-mail address.  After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-entmib-v2-01.txt".
A URL for the Internet-Draft is:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-entmib-v2-01.txt

Internet-Drafts directories are located at:

	Africa:	ftp.is.co.za
	
	Europe: ftp.nordu.net
		ftp.nis.garr.it
			
	Pacific Rim: munnari.oz.au
	
	US East Coast: ftp.ietf.org
	
	US West Coast: ftp.isi.edu

Internet-Drafts are also available by mail.

Send a message to:	[email-masked].  In the body type:
	"FILE /internet-drafts/draft-ietf-entmib-v2-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Randy Jones <[email-masked]>
Date: Mon, 09 Nov 1998 17:33:21 -0500

Hi,
I like the addition of the entPhysicalSoftwareRev object to the physical entity
table but I have a couple of questions/concerns. Many network elements will
contain physical entities with multiple software storage banks. For example, a
physical entity of the "module(9)" class  could have a boot bank and N (where N
is frequently 2) storage banks. One of the N bank's would store the software
which is currently running on the entity and the rest would contain software
that the entity was upgraded from or perhaps is about to be upgraded to. I'm
aware of implementations which also have the notion of a register which contains
the bank number of the application to run following the next upgrade. Being able
to retrieve the software revision of the boot bank, each of the N banks, and the
bank which will be used following the next upgrade would be a useful function in
planning for software upgrades.

With the existing definitions, is it possible to get the entPhysicalSoftwareRev
information for all banks on a physical entity which has more than 1? If not, is
there an alternate way of doing so?

Assuming there is a need to support the retrieval of software revision
information for more than one load on a physical entity (and I haven't missed
something), we could consider;
a) adding an object to the entPhysical table which indicates the number of
software banks on the entity,
b) adding an object to the entPhysical table which indicates the bank number of
the next load to run on that entity following upgrade,
c) refining the meaning of the entPhysicalSoftwareRev definition to indicate the
"currently running software revision",
d) adding a new table which is indexed by entPhysicalIndex and software bank
number to retrieve the software revision for each bank.

I appologize in advance if this issue was already addressed in a previous
discussion or beyond the mandate of the entmib group.

Best Regards,
Randy Jones

[email-masked] wrote:
>                                                   --------------------------------------------------------------------------------
> Content-Type: text/plain
> Content-ID:     <[email-masked]>

-- 
_____________________________________________________________
Randy Jones,            Voice:+1 613 591-3600
Newbridge Networks      FAX:  +1 613 599-2903
600 March Rd            email: [email-masked]
Kanata, Ontario
Canada K2K 2E6

---

From: Andy Bierman <[email-masked]>
Date: Tue, 10 Nov 1998 10:02:13 -0800

Hi,

The WG could not agree on a field separator, which would be
used to distinuigh multiple revisions within 1 revision string.
Therefore, it is an implementation-specific matter as to
how multiple revisions are field-separated.

Andy