Subject: Re: New version of the Entity MIB I-D (fwd)

From: Keith McCloghrie <[email-masked]>
Date: Thu, 11 Feb 1999 00:49:39 -0800 (PST)

The WG Last Call closed a week or so ago.  The only comments were
Randy's which Andy has replied to (below).  So, if we can agree on the 
only outstanding issue (issue #4 below), then we'll be done.

So, I propose that the WG agree to remove all occurrances of the
text "an agent may omit such instances of this object".  If you have
any objections, please respond before the weekend.

Thanks,
Keith.
-----------
Forwarded message:
> From [email-masked] Tue Feb  9 23:08:13 1999
> Message-ID: <[email-masked]>
> Date: Wed, 10 Feb 1999 06:39:28 +0000
> From: Andy Bierman <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> CC: [email-masked]
> Subject: Re: New version of the Entity MIB I-D
> 
> Randy Presuhn wrote:
> >....
> > 
> > A couple of quick comments:
> > 
> >     1)  the dates aren't consistant (November / December / expiration)
> 
> this was due to a delay in publication. The next rev will be correct.
> 
> >     2)  REVISION clause missing
> 
> okay -- I'll add this.
> 
> >     3)  suggest replacing "null string" with "empty string" or
> >         "zero-length string"
> 
> okay -- zero length string.
> 
> >     4)  In a couple of spots there's text like
> > |           or this information is unknown to the agent, then this        |
> > |           object will contain a zero-length string, or the agent may    |
> > |           omit such instances of this object."                          |
> >         Do we really want to do this?  Providing a zero-length string
> >         is unambiguous.  Omitting an instance can't be distinguished
> >         from cases where access control has prevented access to it.
> 
> I am willing to change it back, if this is what the WG wants.
> That is, all occurrances of the text "an agent may omit such instances 
> of this object" will be removed from the next draft.  
> 
> >     5)  some of the layout needs fixing (look near change bars for
> >         odd line breaks.
> 
> I'll look for these and try to clean up the formatting.
> 
> The only other change will be an update to the I-D template.
> 
> >  Randy Presuhn           Email: [email-masked] http://www.bmc.com
> 
> thanks,
> Andy
>

---

From: Andrew Smith <[email-masked]>
Date: Thu, 11 Feb 1999 09:32:36 -0800

I'll second that change - zero-length strings are much less ambiguous.

Andrew

> -----Original Message-----
> From: Keith McCloghrie [mailto:[email-masked]]
> Sent: Thursday, February 11, 1999 12:50 AM
> To: [email-masked]
> Subject: Re: New version of the Entity MIB I-D (fwd)
> 
>