Subject: [Entmib] Fwd: RE: Referential integrity across reboots

From: Margaret Wasserman <[email-masked]>
Date: Tue, 06 Aug 2002 10:40:15 -0400

Hi All,

There is a discussion thread on the [email-masked] list that 
had brought up an issue that we need to solve in the Entity
MIB (see attached).

Specifically, the Entity MIB indexes are currently constructed
so that there is no guarantee of referential integrity across
system reboots, and we should be doing something to correct
this.

Does anyone have any thoughts on what we should do?  Is it
simply a matter of changing the description clause, or do we
need to make some actual changes to the MIB?

Margaret

>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Version 4.3.2
>Date: Tue, 06 Aug 2002 02:25:22 -0700
>To: "Wijnen, Bert (Bert)" <[email-masked]>
>From: Andy Bierman <[email-masked]>
>Subject: RE: Referential integrity across reboots
>Cc: "David T. Perkins" <[email-masked]>, [email-masked]
>X-Spam-Status: No, hits=-2.3 required=5.0
>         tests=IN_REP_TO,DOUBLE_CAPSWORD
>         version=2.31
>X-Spam-Level: 
>Sender: [email-masked]
>
>At 10:54 AM 8/6/2002 +0200, Wijnen, Bert (Bert) wrote:
> >> yes -- I agree 100%.  Experience has demonstrated that the ifIndex
> >> and entPhysicalIndex type of MIB design is flawed. (This is 
> >> yet another reason why CLI much more useful than MIBs for 
> >> configuration.)  It is critical that persistent resources retain
> >> the same identity across reboots.  I guess the IF-MIB, Entity MIB,
> >> and any other similarly flawed MIB should be fixed.
> >> 
> >So...
> >- The entmib WG is currently working on a revision of the entity MIB.
> >  May I assume you will pick it up there and come with proposals
> >  on how to fix it?
>
>yes.
>
> >- What proposals (if any) do we have for the IF-MIB.
> >  And if we have some, can we revive the IFMIB WG (It does
> >  still exist as far as I know) to get it fixed there as well.
>
>Others will quickly point out that it is illegal (by SMIv2 rules)
>to change the semantics/implementation requirements of ifIndex.
>However the only practical (i.e. usable in the real world) solution
>is to do exactly that.  There are so many OID pointers and
>subordinate tables that use ifIndex, that it will be pointless
>to create a new ifTable with a new index.
>
> >- Who is willing to work (I know thet Juergen once started)
> >  on a replacement for StorageType that WILL be implementable
> >  on most systems and that WILL be usable and workable.,
>
>I would participate in the WG, especially if Juergen volunteered 
>to be the Editor.
>
>
> >Bert
>
>Andy

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 06 Aug 2002 10:40:15 -0400

Hi All,

Margaret