Subject: RE: [Entmib] entity mib support for tcif

From: "C. M. Heard" <[email-masked]>
Date: Sun, 7 Sep 2003 12:45:40 -0700 (PDT)

On Sun, 7 Sep 2003, Faye Ly wrote:
> Just playing the devil's advocate!  On the other hand, CLEI code
> is a fixed string and although it is more elegant to maintain an
> OID registry per vendor but this might grow for a NMS that
> manages multiple vendors. A fixed string as an augmented table
> to the physical entity table is more straightforward to support.

I don't think this is really an issue.  You don't need one OID
prefix per vendor, just one prefix that identifies the OID as one
that contains an embedded CLEI.

Mike

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "C. M. Heard" <[email-masked]>
Date: Sun, 7 Sep 2003 12:45:40 -0700 (PDT)

Mike

---

From: "Faye Ly" <[email-masked]>
Date: Sun, 7 Sep 2003 11:03:16 -0700

Just playing the devil's advocate!  On the other hand, CLEI code is a
fixed string and although it is more elegant to maintain an OID registry
per vendor but this might grow for a NMS that manages multiple vendors.
A fixed string as an augmented table to the physical entity table is
more straightforward to support.

-faye

-----Original Message-----
From: C. M. Heard [mailto:[email-masked]] 
Sent: Sunday, September 07, 2003 12:59 AM
To: [email-masked]; Kaj Tesink; Giamboi, Anthony; Lam, Hing-Kam (Kam);
Faye Ly; Juergen Schoenwaelder; Margaret Wasserman; David T. Perkins;
Wijnen, Bert (Bert); [email-masked]
Subject: Re: [Entmib] entity mib support for tcif

On Sat, 6 Sep 2003, David T. Perkins wrote:
> I believe that adding a CLEI code (common langauge equipment
> identifier code) is completely redundant with the object
> entPhysicalVendorType and should not be added.
> A CLEI code is a globally unique value that is purchased
> from Telcordia. It costs approximately $100 to get the
> document from Telcordia that defines CLEI codes, and
> it costs per assigned code.
> 
> If a vendor wants to use CLEI codes, it is a simple matter
> to construct the OID value for entPhysicalVendorType from
> any CLEI code.
> 
> The only proposal that I would support is to define a standard
> OID prefix, and encoding of the suffix of the OID.
> 
> For example, assume and OID value is assigned with descriptor
> "entPhysicalVendorTypeCLIE", and the encoding is a sub-identifer
> of the decimal value of per character in the CLIE code.

I think this is a VERY GOOD idea.

In previous off-line discussions entPhysicalModelName was suggested
as one place where a CLEI code might live.  While there is nothing
wrong with putting a CLEI code there (especially if it's on a bar
code on the label), there would be no guarantee that any particular
manufacturer did this, nor is there a sure-fire way for a management
application to tell if what's there is actually a CLEI code, if it
happens to be 10 octets long.  But entPhysicalVendorType contains an
OID, which is self-describing.  Very elegant.

I wish there were as neat a solution for entPhysicalMfgDate :-(

Mike

---

From: "David T. Perkins" <[email-masked]>
Date: Sun, 7 Sep 2003 15:29:08 -0700 (PDT)

HI,

In addition to the redundancy of objects, I have big issue
with including in a standards track MIB module, support for
a proprietary network management platform, and one where
there is significant costs for device vendors.

Here is a FAQ on CLEIs from telcordia:
http://www.telcordia.com/resources/commonlang/productshowroom/showroom/equip_id/carriers/faq.html

I could not find the costs for each assignment of a CLEI, and
it appears from the Telcordia WEB site that the cost is variable -
that is you need to "talk with a friendly sales representative".

Before we take any further steps on this, I believe that an
official representative from Telcordia needs to provide full
disclosure of the the costs of using CLEI codes. And the openness
and accessibility of the CLEI assignments.

And responding to Faye's question....
If a well know prefix is used, this does not create any additional
work for vendors. That is, they already have to "create an OID registry"
to support object entPhysicalVendorType. And for management platforms
that want to use CLEI codes, a standard prefix (and encoding rules)
allows them to "extract" a CLEI code from the value of
entPhysicalVendorType, and all other management platforms to be
blissfully unaware of CLEI codes.  

> I wish there were as neat a solution for entPhysicalMfgDate :-(
Regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Sun, 7 Sep 2003 15:29:08 -0700 (PDT)

HI,

Regards,
/david t. perkins

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 12 Sep 2003 21:44:43 -0700 (PDT)

> http://www.telcordia.com/resources/commonlang/productshowroom/showroom/equip_id/carriers/faq.html

[ ... remainder snipped ... ]

It may be worth pointing out that CLEI codes (along with other
Telcordia Common Language(TM) products) have been adopted as
identifiers in ANSI standards, and there is a proposal on the table
to add mappings of these ANSI standards to ITU-T Rec. M.1401.  See
T1M1.3/2003-032, a URL for which is in the attached message from the
T1M1.3 mail exploder.

Mike Heard

Subject: [T1M1.3] New Files Uploaded
From: [email-masked]
To: [email-masked]
Date: Fri, 12 Sep 2003 23:57:22 -0500

Files Uploaded on: 09/12/2003 for T1M1.3

CONTRIBUTION#: T1M1.3/2003-032 (3M130320)
LINK: http://www.t1.org/FileMgr/GetOneFile.taf?FileName=3M130320&NW=Y
TITLE: Proposal for mapping T1 American National Standards to proposed 
ITU-T Rec. M.1401
DESC: Provides proposed mappings of American National Standards (ANS) 
for Telecommunications - Information Interchange to ITU-T Rec. M.1401.  
These T1 standards, based on Telcordia Technologies COMMON LANGUAGE‚ 
Products, primarily provide structures and formats for identifying 
network resources.
CONTACT(S): Paul Levine ([email-masked] (732) 873-8496)
SOURCE: Telcordia Technologies

CONTRIBUTION#: T1M1.3/2003-033 (3M130330)
LINK: http://www.t1.org/FileMgr/GetOneFile.taf?FileName=3M130330&NW=Y
TITLE: T1M1.3 WG (CLDR) Sept. 12, 2003 Meeting Report
DESC: Documents the proceedings of the September 12, 2003 
teleconference call meeting of the T1M1.3 WG (CLDR).
CONTACT(S): Paul Levine ([email-masked] (732) 873-8496)
SOURCE: T1M1.3 WG Chair

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 12 Sep 2003 21:44:43 -0700 (PDT)

Mike Heard

---

From: Kaj Tesink <[email-masked]>
Date: Sun, 14 Sep 2003 12:30:44 -0400

>T1M1.3/2003-032, a URL for which is in the attached message from the

Yup, that is right; Telcordia is actually the designated maintenance agent 
for the ANSI document T1.213,
Coded Identification of Equipment Entities of the North American 
Telecommunications System for
Information Exchange. This document provides the format and structure for 
the CLEI code.
For details see http://www.atis.org/doccenter.shtml.

Telcordia assigns CLEI codes on a request basis from a supplier for their 
communications equipment.
For example, these codes are then placed on a linear bar code label which 
is affixed onto the plug-in card as well as
the container for that plug-in card. What we're talking about here is to 
make that information
accessible for network management ssystems.

kaj

>Mike Heard
>Return-Path: <[email-masked]>
>Received: from psmtp.com (exprod6mx17.postini.com [12.158.35.157])
>         by shell4.bayarea.net (8.11.6/8.11.6) with SMTP id h8D3tOu13177
>         for <[email-masked]>; Fri, 12 Sep 2003 20:55:24 -0700
>Received: from source ([205.219.84.13]) by exprod6mx17.postini.com 
>([12.158.35.251]) with SMTP;
>         Fri, 12 Sep 2003 23:55:24 EDT
>Received: from psmtp.com (exprod6mx37.postini.com [12.158.35.177])
>         by postman.bayarea.net (8.12.8p1/8.12.8) with SMTP id h8D3tNKH097287
>         for <[email-masked]>; Fri, 12 Sep 2003 20:55:23 -0700 (PDT)
>Received: from source ([216.65.124.72]) by exprod6mx37.postini.com 
>([12.158.35.251]) with SMTP;
>         Fri, 12 Sep 2003 20:55:23 PDT
>Received: from t1.rxcpi.com (T1.RXCPI.COM[208.30.94.3])
>         by orb.pobox.com (Postfix) with ESMTP id CBAE21561BB
>         for <[email-masked]>; Fri, 12 Sep 2003 23:55:22 -0400 (EDT)
>Received: (from daemon@localhost)
>         by t1.rxcpi.com (8.9.3/8.9.3) id AAA26208
>         for <[email-masked]>; Sat, 13 Sep 2003 00:27:18 -0400
>Received: (from root@localhost)
>         by t1.rxcpi.com (8.9.3/8.9.3) id AAA11541
>         for t1m13-outgoing; Sat, 13 Sep 2003 00:25:53 -0400
>Received: (from daemon@localhost)
>         by t1.rxcpi.com (8.9.3/8.9.3) id AAB11533
>         for <[email-masked]>; Sat, 13 Sep 2003 00:25:52 -0400
>Received: from t1.org (www.t1.org [63.137.53.132])
>         by t1.rxcpi.com (8.9.3/8.9.3) with SMTP id AAA11444
>         for [email-masked]; Sat, 13 Sep 2003 00:25:52 -0400
>Message-Id: <[email-masked]>
>Cc:
>X-AntiVirus: scanned for viruses by Computer Pharmacy Inc. 
>(http://www.computerpharmacy.com/)
>Sender: [email-masked]
>Precedence: bulk
>Reply-To: [email-masked]
>X-AntiVirus: scanned for viruses by Computer Pharmacy Inc. 
>(http://www.computerpharmacy.com/)
>MIME-Version: 1.0
>X-MIME-Autoconverted: from 8bit to quoted-printable by 
>smtpout1.bayarea.net id h8D4lmJb014712
>

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. Inc.
331 Newman Springs Road
Red Bank, NJ 07701
Email: [email-masked]
Tel: (732) 758-5254
Fax: (732) 758-4177

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Kaj Tesink <[email-masked]>
Date: Sun, 14 Sep 2003 12:30:44 -0400

kaj

Kaj Tesink

---

From: "David T. Perkins" <[email-masked]>
Date: Sun, 14 Sep 2003 18:31:09 -0700 (PDT)

HI,

Can you provide us with pricing. Say, if SNMPinfo created
a product that had a chassis, and 3 field replacable components,
than how much would it cost SNMPinfo to obtain CLEI codes
from Telcordia?

Also, the link below, http://www.atis.org/doccenter.shtml, is
to an organization that provides copies of docs for a fee.
I don't see how it answers any questions. It does provide
a way for me to pay US$58 for an electronic copy of document
T1.213. (It doens't specify the page count.) Can you provide
a copy of the document to us for review?

Regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Sun, 14 Sep 2003 18:31:09 -0700 (PDT)

HI,

Regards,
/david t. perkins

---

From: Kaj Tesink <[email-masked]>
Date: Mon, 15 Sep 2003 09:55:53 -0400

>than how much would it cost SNMPinfo to obtain CLEI codes

i can get that for you & send directly if you're interested
(i dont think we should use this list in a debate about
product pricing). i believe its something like
a few $100 for a code to be used for as many copies of
the product as the manufacturer chooses. thus in your example,
it would depend whether the 3 field replacable components
are identical products or not.

>T1.213. (It doens't specify the page count.)

17

>Can you provide

i think that T1 documents are sold for a fee, so it would
be inappropriate to post one. google found this link:
http://www-comm.itsi.disa.mil/t1/213.html
unfortunately that is only an amendment but at least it shows
the rough outline of the CLEI and helps to show what
we're talking about,

kaj

Kaj Tesink

---

From: Kaj Tesink <[email-masked]>
Date: Mon, 15 Sep 2003 09:55:53 -0400

17

kaj

Kaj Tesink

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 15 Sep 2003 13:58:43 -0700 (PDT)

HI,

OK, so you want to add a field to the entity MIB so that all
that implement it can pay a "tax" to Telcordia to use technology,
CLEI codes, that is flawed and proprietary and is limited in
use to device vendors that sell equipment to north american
phone companies? And this is a better approach than specifying
an encoding scheme for CLEI code values as OIDs, which means
no change to the existing MIB module and no requirement to
pay the Telcordia tax?

So, again, would like to know 
 1) realistic cost estimates
 2) time for assignments
 3) policy on publishing assignments
 4) why the encoding as an OID value using the existing
    MIB object is insufficient

Regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 15 Sep 2003 13:58:43 -0700 (PDT)

HI,

Regards,
/david t. perkins

---

From: Kaj Tesink <[email-masked]>
Date: Mon, 15 Sep 2003 18:52:37 -0400

At 01:58 PM 9/15/2003 -0700, David T. Perkins wrote:
>CLEI codes,

dave, this is not the way i would characterize it.
we have standardized lots of objects in the ietf, and they're
all for things and products that people pay for.
there is no tax involved, and nobody is required to buy it.

>that is flawed

i dont know why you say that; i havent standardized those codes;
others did. they're apparently liked it enough that they're
widely used and standardized.
i'm not sure why we need to discuss the merits of particular standards
on this forum.

>and proprietary

they're adopted as standard by ANSI; Telcordia is designated
as the maintenance agent and assigns codes.

>and is limited in
>phone companies?

they're open for anybody to use, and have been used well outside
the n.a. phone companies (your favorite router company is likely
to use them). btw, T1s are also largely a n.a. phenomena
and we write mibs for those too.
putting this in a mib module doesnt force anybody to use it;
all thats being asked is for systems that use CLEIs and that want
management access to it there needs to be a suitable object to use it.

>And this is a better approach than specifying

you may have noticed that i did not comment yet on the merits
of your OID proposal; i'm not yet ready to do that but
i do think that your proposal does have merit and is elegant.
it needs to be weighed against the merits of a separate object.

>  3) policy on publishing assignments

i dont think we should base standardization of mib objects
on their cost; that would be an interesting precedent

>     MIB object is insufficient

thats a fair question; i'll respond as soon as possible,

kaj

Kaj Tesink

---

From: Kaj Tesink <[email-masked]>
Date: Mon, 15 Sep 2003 18:52:37 -0400

kaj

Kaj Tesink