Subject: [Entmib] Re: entity mib support for tcif

From: Kaj Tesink <[email-masked]>
Date: Wed, 03 Sep 2003 14:39:24 -0400

At 02:16 PM 9/3/2003 -0400, you wrote:
>Hi Kaj,
>  a very small question, shouldn't it be   entPhysicalCLEICode
>(not CLIE)?   and in fact CLEI throughout the text
>description also?

amanda, you're absolutely right; thanks for pointing it out
and sorry for the confusion,

kaj

>amanda.
>
>
>
>Kaj Tesink wrote:
>>entity mib wg,
>>
>>attached is a discussion on accommodating
>>some TCIF information elements in an appropriate
>>MIB module.
>>the entity mib would be a good candidate, but
>>we understand that the timing may be problematic
>>since it's going to draft right now.
>>
>>we're talking about 6 data elements (see
>>TCIF-02-004, 09/11/2002). most can probably be mapped to existing
>>objects, but not all.
>>
>>so it appears that we have several options:
>>a) extend the entity mib with the 'missing' objects (see attached strawman)
>>b) write a 'supplemental' mib module for the 'missing' objects
>>c) find another suitable mib module
>>
>>while a) seems most desirable the current state of the entity mib may make
>>it problematic(?). (b) seems somewhat overkill.
>>(c) seems suboptimal.
>>
>>the new objects would only be required for systems that support management
>>access to this information.
>>
>>any comments? particulars attached,
>>pl copy Cc list above,
>>
>>kaj, tony,
>>
>>============================================================
>>
>>TCIF Required MIB objects:
>>- CLEI Code
>>     Suggested to use: new object
>>     Reference: TCIF-02-004, 09/11/2002
>>     Reference: ANSI T1.213-2001 and T1.213a-2001, T1M1.3
>>- Unique Serial Identification (USI)
>>     Suggested to use: entPhysicalSerialNum
>>- Software Version
>>     Suggested to use: entPhysicalSoftwareRev
>>- Manufacture Date
>>     Suggested to use: new object
>>TCIF Optional MIB objects:
>>- Manufacturer Identification
>>     Suggested to use: entPhysicalMfgName
>>- Manufacturer Product Identification
>>     Suggested to use: entPhysicalModelName
>>
>>=============================================================
>>new objects:
>>
>>entPhysicalCLIECode   OBJECT-TYPE
>>       SYNTAX      SnmpAdminString (SIZE (0..10))
>>       MAX-ACCESS  read-write
>>       STATUS      current
>>       DESCRIPTION
>>               "The CLIE Code for the physical entity. If a CLIE Code
>>               is unknown or non-existent, the entPhysicalCLIECode will
>>               be set to a zero-length string instead."
>>       ::= { entPhysicalEntry xx }
>>       REFERENCE "TCIF-02-004, Guideline for data elements
>>               included in the Management Information Base,
>>               Telecommunications Industry Forum (TCIF), 09/11/2002.
>>               ANSI T1.213-2001, Coded identification of equipment entities
>>               of the North American telecommunications system for
>>               information exchange, ANSI.
>>               ANSI T1.213a-2001, Supplement to T1.213-2001,
>>               Coded identification of equipment entities of the North
>>               American telecommunications system for information exchange,
>>               to correct the representation of the Basic Code in
>>               Figure B.1, ANSI."
>>
>>entPhysicalMfgDate   OBJECT-TYPE
>>       SYNTAX      DateAndTime
>>       MAX-ACCESS  read-only
>>       STATUS      current
>>       DESCRIPTION
>>               "The manufacturing date for the physical entity."
>>       ::= { entPhysicalEntry xx }
>>
>>========================================================================
>>
>>  >Subject: RE: Object Identifiers for MIB information
>>  >Date: Wed, 6 Aug 2003 12:58:48 -0700
>>  >X-MS-Has-Attach:
>>  >X-MS-TNEF-Correlator:
>>  >Thread-Topic: Object Identifiers for MIB information
>>  >Thread-Index: AcNcQaap13s3mWdMQsuSf53LJiptygAEzb+Q
>>  >From: "Faye Ly" <[email-masked]>
>>  >To: "C. M. Heard" <[email-masked]>,
>>  >         "Giamboi, Anthony" <[email-masked]>
>>  >Cc: "Lam, Hing-Kam (Kam)" <[email-masked]>,
>>  >         "Lee, Shyhyann" <[email-masked]>,
>>  >         "Fox, Robert H." <[email-masked]>,
>>  >         "Kaj Tesink" <[email-masked]>,
>>  >         "Wijnen, Bert (Bert)" <[email-masked]>
>>  >X-RAVMilter-Version: 8.4.2(snapshot 20021217) (thumper)
>>  >
>>  >It sounds like ENTITY-MIB is only missing the Manufacture date and
>>  >CLEI? Why don't we bring them up to the ENTITY-MIB WG?
>>  >
>>  >-faye
>>  >
>>  >-----Original Message-----
>>  >From: C. M. Heard [<mailto:[email-masked]>mailto:[email-masked]]
>>  >Sent: Wednesday, August 06, 2003 10:39 AM
>>  >To: Giamboi, Anthony
>>  >Cc: Faye Ly; 'Lam, Hing-Kam (Kam)'; Lee, Shyhyann; Fox, Robert H.; 'Kaj
>>  >Tesink'; 'Wijnen, Bert (Bert)'
>>  >Subject: RE: Object Identifiers for MIB information
>>  >
>>  >On Wed, 6 Aug 2003, Giamboi, Anthony wrote:
>>  > > I asked the initial question.
>>  > >
>>  > > The issue is:
>>  > >
>>  > > The Telecommunications Industry Forum (TCIF) has issued a document
>>  > > (TCIF.02.004 Guideline for Data Elements Included in the Management
>>  > > Information Base (MIB)). This document states that there are 4 data
>>  > > elements that must be included in a MIB and they are:
>>  > >
>>  > > CLEI code
>>  > > Unique Serial Number
>>  > > Software version that is running
>>  > > Date of Manufacture
>>  > >
>>  > > In order for a manufacturer to load this information in the MIB we
>>  > > wanted to know if there was a standard way to identify these data
>>  > > elements within the MIB. If there is, great, if there isn't, maybe
>>  > > there should be? We are looking for your guidance on this issue.
>>  >
>>  >As of today, a vendor can represent these items either by proprietary
>>  >MIB objects or by a combination of standard objects in the ENTITY-MIB
>>  >and some proprietary objects. The details will be vendor- and
>>  >equipment-specific.
>>  >
>>  >If the TCIF is happy with that -- i.e., if their requirement is just to
>>  >have the information represented in some way, not necessarily the same
>>  >way for each vendor/device -- then there is no need to worry about
>>  >standardizing another MIB module. If they want a vendor- and
>>  >device-independent way of getting this information, then more work is
>>  >needed.
>>  >
>>  >For what it's worth, here's the stuff that the ENTITY-MIB already has:
>>  >
>>  >entPhysicalHardwareRev
>>  >entPhysicalFirmwareRev
>>  >entPhysicalSoftwareRev
>>  >entPhysicalSerialNum
>>  >entPhysicalMfgName
>>  >entPhysicalModelName
>>  >
>>  >As noted previously, entPhysicalModelName could be used for CLEI code,
>>  >but other things could appear there.  As far as I know, there is no
>>  >object for Date of Manufacture, that would have to be in a proprietary
>>  >MIB extension.
>>  >
>>  >I hope this helps more than it confuses :-)
>>  >
>>  >Mike
>>
>>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>>
>>Kaj Tesink
>>Telcordia Technologies. Inc.
>>331 Newman Springs Road
>>Red Bank, NJ 07701
>>Email: [email-masked]
>>Tel: (732) 758-5254
>>Fax: (732) 758-4177
>>
>>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>>
>>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>>
>>Kaj Tesink
>>Telcordia Technologies. Inc.
>>331 Newman Springs Road
>>Red Bank, NJ 07701
>>Email: [email-masked]
>>Tel: (732) 758-5254
>>Fax: (732) 758-4177
>>
>>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>
>--
>Amanda Brown                   UE9000MG          ESN  351-7715
>[email-masked]   NORTEL NETWORKS    (919) 991-7715
>"Dogs' lives are too short.  Their only fault, really." -- Agnes Sligh 
>Turnbull
>

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. Inc.
331 Newman Springs Road
Red Bank, NJ 07701
Email: [email-masked]
Tel: (732) 758-5254
Fax: (732) 758-4177

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Kaj Tesink <[email-masked]>
Date: Wed, 03 Sep 2003 14:09:03 -0400

entity mib wg,

kaj, tony,

 >From: C. M. Heard [mailto:[email-masked]]

Kaj Tesink

Kaj Tesink

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Kaj Tesink <[email-masked]>
Date: Wed, 03 Sep 2003 14:39:24 -0400

kaj

Kaj Tesink