Subject: [Entmib] FW: [psg.com #307] AutoReply: 'notSupported' is semantically wron g

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 11 Feb 2004 13:50:46 -0500

The following is the proposed resolution to entstate-307. The issue will be
considered closed pending the proposed edit being done.

Replace the enumeration 'notSupported' with 'notReportable' in each of the
TCs and any references within the text.

For each of the (TC, object definition) pairs, move the following sort of
text from the object definition to the textual convention:

"A value 
of 'notApplicable' means that this resource is unable to report [this] 
state." 

Sharon

-----Original Message-----
From: entity-state [mailto:[email-masked]] 
Sent: Tuesday, January 13, 2004 2:50 AM
To: Chisholm, Sharon [CAR:0S00:EXCH]
Subject: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

<clip>

-------------------------------------------------------------------------
Keith McCloghrie [[email-masked]]

"
>   'notSupported' is semantically wrong, because a compliant
implementation
>   obviously supports the MIB, but it can return 'notSupported' for
>   every object in the MIB.  Presumably, the intended semantics is that
>   the agent would return the right value if only it knew the right
value;
>   i.e., 'unknown' is the desired semantics.  Also, why is each
definition
>   of 'notSupported' defined in an object's DESCRIPTION, not in the
TC's
>   DESCRIPTION ?"

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 11 Feb 2004 13:50:46 -0500

"A value 

Sharon

-----Original Message-----
From: entity-state [mailto:[email-masked]] 
Sent: Tuesday, January 13, 2004 2:50 AM
To: Chisholm, Sharon [CAR:0S00:EXCH]
Subject: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

<clip>

"
implementation
value;
definition
TC's

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 11 Feb 2004 13:53:25 -0500

Hi

That last bit should read 

""A value 
of 'notReportable' means that this resource is unable to report [this] 
state." 

Sharon

-----Original Message-----
From: Chisholm, Sharon [CAR:0S00:EXCH] 
Sent: Wednesday, February 11, 2004 1:51 PM
To: [email-masked]'
Subject: FW: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

"A value 

Sharon

-----Original Message-----
From: entity-state [mailto:[email-masked]] 
Sent: Tuesday, January 13, 2004 2:50 AM
To: Chisholm, Sharon [CAR:0S00:EXCH]
Subject: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

<clip>

"
implementation
value;
definition
TC's

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 11 Feb 2004 13:53:25 -0500

Hi

""A value 

Sharon

-----Original Message-----
From: Chisholm, Sharon [CAR:0S00:EXCH] 
Sent: Wednesday, February 11, 2004 1:51 PM
To: [email-masked]'
Subject: FW: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

"A value 

Sharon

-----Original Message-----
From: entity-state [mailto:[email-masked]] 
Sent: Tuesday, January 13, 2004 2:50 AM
To: Chisholm, Sharon [CAR:0S00:EXCH]
Subject: [psg.com #307] AutoReply: 'notSupported' is semantically wrong

<clip>

"
implementation
value;
definition
TC's