Subject: [Entmib] Re: Entity mib support for tcif

From: Kaj Tesink <[email-masked]>
Date: Thu, 05 Feb 2004 15:06:54 -0500

all,

attached is the supplemental entity miblet
discussed a while ago, supporting
- manufacturing date
- additional entity info
the latter uses the method proposed by dave
to convey information such as CLEIs.
i do recall that there were some different
views on whether to use an opaque encoding
method versus using a dedicated object, but
please read it over and provide any comments.

kaj

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. Inc.
331 Newman Springs Road
Red Bank, NJ 07701
Email: [email-masked]
Tel: (732) 758-5254
Fax: (732) 758-4177

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Kaj Tesink <[email-masked]>
Date: Thu, 05 Feb 2004 15:06:54 -0500

all,

kaj

Kaj Tesink

---

From: Kaj Tesink <[email-masked]>
Date: Tue, 10 Feb 2004 11:48:28 -0500

all,

the draft i sent to the list last week is now available at
http://www.ietf.org/internet-drafts/draft-tesink-entity-supplmib-00.txt

pl note that the file name was changed (my error).
in order to move this forward the WG would need
to accept this as a formal work item.

so we'd appreciate comments on
a) whether there is support/objection to do this work
b) any technical comments
while the minneapolis meeting already indicated some
tentative support, restating this or any new/additional
views would be helpful

kaj

>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Version 4.3.2
>Date: Thu, 05 Feb 2004 15:06:54 -0500
>To: [email-masked]
>From: Kaj Tesink <[email-masked]>
>
>
>all,
>

Kaj Tesink

---

From: Kaj Tesink <[email-masked]>
Date: Tue, 10 Feb 2004 11:48:28 -0500

all,

kaj

Kaj Tesink

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 10 Feb 2004 22:03:44 +0200

Kaj,

I was among the ones who supported doing this work. I did not change my mind.

Two comments:
1. I would like the title of the document to be more explicit about what is really provided by this MIB. 'Supplemental' is really too generic a title - what about something like 'Entity MIB Extensions for manufacturing and physical modules identification'?
2. Some of the concerns expressed in the meeting (not by me) were related to the availability and the proprietary nature of the CLEI codes. Can you comment on these? Are the documents mentioned in the REFERENCE clause of the cleiCode object freely available?

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Kaj Tesink
> Sent: 10 February, 2004 6:48 PM
> To: [email-masked]
> Subject: Fwd: [Entmib] Re: Entity mib support for tcif
> 
> 
> all,
> 

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 10 Feb 2004 22:03:44 +0200

Kaj,

Two comments:

Thanks and Regards,

Dan

---

From: Kaj Tesink <[email-masked]>
Date: Wed, 11 Feb 2004 10:25:19 -0500

Hi Dan,

At 10:03 PM 2/10/2004 +0200, Romascanu, Dan (Dan) wrote:
>1. I would like the title of the document to be more explicit about what 
>is really provided by this MIB. 'Supplemental' is really too generic a 
>title - what about something like 'Entity MIB Extensions for manufacturing 
>and physical modules identification'?

I see what you're trying to do. While this would more accurately reflect
the content, there is the issue of future compatibility. The problem with 
adding
new objects to MIBs over time is that
a) either you add to the original spec; but this means there's a problem
    with advancing the spec over time
b) or you define supplemental specs; the problem here is that you dont want
    all sorts of miblets around; you want to minimize the number
So, similar as what we did for ATM, and attempted for DS1s, the tactic was to
use this generic title, so that additional functions could still be added
for a while. I agree its not perfect. I also thought that in previous 
discussions
there were some thoughts about some additional functions(?).

>2. Some of the concerns expressed in the meeting (not by me) were related 
>to the availability and the proprietary nature of the CLEI codes. Can you 
>comment on these? Are the documents mentioned in the REFERENCE clause of 
>the cleiCode object freely available?

You're right, some of that did come up before.
My understanding is the following:
- the references point to documents by different standards groups,
   and i think are available for a small fee at www.atis.org
- CLEI codes are defined in those standards;
   Telcordia is the registrar to obtain an actual code
In previous discussion it was pointed out that
while CLEIs are in wide use, there is no obligation to
use them; I've tried to reflect that in the draft
in two ways: (a) use an opaque object instead of a dedicated
object as proposed by Dave, and (b) language for the case
that the whole thing (no CLEI nor any other application
of the object) is not supported.

Kaj

Kaj Tesink

---

From: Kaj Tesink <[email-masked]>
Date: Wed, 11 Feb 2004 10:25:19 -0500

Hi Dan,

Kaj

Kaj Tesink