Subject: RE: REMINDER: [Entmib] WG Last Call: Entity State MIB

From: Margaret Wasserman <[email-masked]>
Date: Sun, 08 Feb 2004 17:56:10 -0500

We originally considered doing the state/status extensions as
part of the Entity MIB, and those first discussion did mention
a single object.  However, by November 2002 we had a much more
complex model and agreed that it would be better to do this as
a separate MIB.

We agreed to accept the Entity State MIB as a WG document before
March 2003, and at that time it was at least as complex as it is
now.  We've been working on this MIB for over a year, and I
believe that it should take WG consensus to make a major
change to it now.  Do others agree?

In Minneapolis, the complexity of this MIB was raised as an issue.
There was a general sense of the room that the MIB was too
complex, but many people who were involved in earlier discussions,
including the editor, weren't present.  When the discussion was
brought to the mailing list, I did not see clear consensus that
we need to reduce the complexity of the MIB.

Sharon did try to address concerns about the complexity of this
MIB in the latest version by simplifying and streamlining the
description.

So, where do we stand on this issue?

Are there others who have read the current MIB and strongly
believe that it needs to be simplified?  Or not?

Margaret

At 02:28 PM 2/6/2004 -0500, Sharon Chisholm wrote:
>Hi
>
>I don't understand where the impression that we were only planning on adding
>a single object that gave operational status came from. My early
>presentations on this topic outlined a large number of state objects that
>could be defined and from that we whittled down to what we thought was a
>reasonable set. Some people wanted more and some people wanted less.
>
>Sharon
>
>-----Original Message-----
>From: Andy Bierman [mailto:[email-masked]]
>Sent: Friday, February 06, 2004 11:27 AM
>To: Wijnen, Bert (Bert)
>Cc: 'Margaret Wasserman'; [email-masked]
>Subject: RE: REMINDER: [Entmib] WG Last Call: Entity State MIB
>
>
>At 03:30 AM 2/6/2004, Wijnen, Bert (Bert) wrote:
> >> Given that this is a second WG Last Call for this document, that
> >> several people reviewed it during the previous WG Last Call, and that
> >> Sharon did a great job of maintaining an issue list and documenting
> >> the resolution of each issue, I am planning to interpret silence as
> >> agreement to send this document to the IESG.
> >>
> >I do not want to step on the toes of our WG chair, but yet... I would
> >actually appreciate if the people who spoke up (a while ago) that the
> >MIB was too complex, that they do state if they are now OK with this
> >version!
> >
> >PLEASE PARTICIPATE and express your opinion.
>
>okay, okay...
>
>I do not approve of, or object to, the Entity State MIB
>going forward.
>
>My concerns are regarding the intent of the MIB -- the
>actual problem being addressed.  So I looked to the
>Entmib WG charter page for guidance.  This is all it
>says about the Entity State MIB:
>
>  Done    Publish state/status extensions as a WG I-D
>
>  Mar 04  Submit Entity State MIB to the IESG for Proposed Standard
>
>Not a word about the problem being addressed.
>
>I thought we set out to add an 'operStatus' object for
>physical entities -- a simple ( green, yellow, red )
>status indicator.  Applications would still need to
>know how to use other MIBs to diagnose or correct a fault.
>IMO, there's not much value in a generic indicator beyond
>this, so it's best to keep it simple.
>
>  From the draft:
>
>   "Objects are defined to capture administrative, operational and usage
>    states. In addition there are further state objects defined to
>    provide additional information for these three basic states."
>
>The document clearly attempts to provide more functionality than a simple
>'operStatus' object.  The authors have done a fine job defining and
>documenting this functionality.
>
>In order to discuss how well a MIB addresses its intended function, we have
>to agree on the intended function.
>
>
> >Bert
>
>Andy
>
>
> >> So, if you have any objection to submitting this document for
> >> publication as a Proposed Standard, please make that clear by Friday.
> >>
> >> Thanks,
> >> Margaret
> >>
> >>
> >> >Date: Fri, 23 Jan 2004 17:00:59 -0500
> >> >To: [email-masked]
> >> >From: Margaret Wasserman <[email-masked]>
> >> >
> >> >Hi All,
> >> >
> >> >This is a two week WG Last Call for submitting the Entity State MIB
> >> >to the IESG for publication as a Proposed Standard.  The latest
> >> >version of this document can be found at:
> >> >
> >> >http://www.ietf.org/internet-drafts/draft-ietf-entmib-state-02.txt
> >> >
> >> >This WG Last Call will end on Friday, February 6th at 5pm EST.
> >> >
> >> >Please review the document and forward substantive comments to
> >> >the mailing list.   Editorial comments can be sent directly
> >> >to the authors.
> >> >
> >> >Thanks,
> >> >Margaret
> >> >
> >> >
> >> >
> >> >_______________________________________________
> >> >Entmib mailing list
> >> >[email-masked] https://www1.ietf.org/mailman/listinfo/entmib
> >>
> >>
> >> _______________________________________________
> >> Entmib mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/entmib
> >>
> >
> >_______________________________________________
> >Entmib mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/entmib
>
>
>_______________________________________________
>Entmib mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/entmib
>
>_______________________________________________
>Entmib mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/entmib

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Andy Bierman <[email-masked]>
Date: Sun, 08 Feb 2004 20:07:59 -0800

>we need to reduce the complexity of the MIB.

I don't disagree with you about the WG consensus.
I'm not objecting to the MIB going forward.  But I wouldn't
be surprised if application developers end up writing
a complex function to convert an entStateEntry to
a simple LED-type enum for the entity.

>So, where do we stand on this issue?

I'd say it's closed.
The WG doesn't think a simple operStatus type
of object is sufficient. 

>believe that it needs to be simplified?  Or not?

I didn't ask for the MIB to be simplified.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Sun, 08 Feb 2004 20:07:59 -0800

I'd say it's closed.

Andy