Subject: Re: [ESDS] ESDS Digest, Vol 9, Issue 1

From: "Stuart Bailey" <[email-masked]>
Date: Thu, 8 May 2008 09:26:41 -0700

WARNING: contains banned part

Subject: RE: ESDS Digest, Vol 9, Issue 1
From: "Stuart Bailey" <[email-masked]>
To: <[email-masked]>
Date: Thu, 8 May 2008 09:26:41 -0700

Hello,

I am a co-editor for a new open specification from Trusted Computing Group (TCG) called IF-MAP.  It would appear to me that the CIB may be functionally equivalent to what we have defined as a Metadata Access Point (MAP).

The protocol, IF-MAP, defines a simple publish/search/subscribe interface to the MAP.  The MAP is a common metadata database.  Within the MAP, metadata automatically aggregates with respect to common unique keys (i.e. identifiers).  

While IF-MAP's initial use-cases are in coordinated security, it was designed to meet other coordinated computing use-cases and may be appropriate for ESDS.  The ESDS use-cases may be met simply by defining metadata labels appropriate for the use-case using XML Schema.  IF-MAP was designed to be modular in this way.

The binding to SOAP/HTTPS defined in IF-MAP 1.0 also makes adoption simple.

The spec can be downloaded here:
https://www.trustedcomputinggroup.org/specs/TNC/TNC_IFMAP_v1_0_r25.pdf

A white paper form InteropLabs can be downloaded here:
http://www.opus1.com/nac/teamwhitepapers/2008-06MAP.pdf

Thoughts?

Stu

_______________________________________________
ESDS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/esds

---

From: "Stuart Bailey" <[email-masked]>
Date: Thu, 8 May 2008 09:28:39 -0700

Subject: IF-MAP introduction
From: "Stuart Bailey" <[email-masked]>
To: <[email-masked]>
Date: Thu, 8 May 2008 09:28:39 -0700

I apologize for the uninformative subject line on my last post.  I should have read "IF-MAP Introduction".  Here are the links again:

Spec:

Whitepaper:

Stu