Subject: [EToSat] Side-meeting on QUIC over high BDP ?

From: Kuhn Nicolas <[email-masked]>
Date: Thu, 3 Oct 2019 08:10:52 +0000

Hi,

We are planning a side-meeting at next IETF on "Performance evaluation of QUIC in various environments".
The main idea is to gather people evaluating QUIC when it comes to exploit paths with various characteristics - with a slight focus for high BDP networks.

Evaluations of QUIC over satellite has been presented in multiple IETF sessions [1-5], but a dedicated session would enable to gather whoever is interested in this activity.

Is anyone interested in presenting experimental results and/or attend such meeting ?

Cheers,

Nico, on the behalf of John, Gorry and Emile

[1] https://datatracker.ietf.org/meeting/103/materials/slides-103-maprg-quic-and-satcom-nicolas-kuhn-01
[2] https://datatracker.ietf.org/meeting/104/materials/slides-104-maprg-satellite-internet-performance-measurements-jorg-deutschmann-01
[3] https://datatracker.ietf.org/meeting/105/materials/slides-105-maprg-measuring-quic-dynamics-over-a-high-delay-path-01
[4] https://datatracker.ietf.org/meeting/105/materials/slides-105-panrg-quic-over-satellite-00
[5] https://datatracker.ietf.org/meeting/105/materials/slides-105-panrg-quic-over-in-sequence-paths-with-different-characteristics-00

---

From: Joerg Deutschmann <[email-masked]>
Date: Wed, 9 Oct 2019 17:07:10 +0200

Dear Nicolas,

I'd like to join but probably can't make it to Singapore. We have some limited results which I just sent to this mailing list...

Best regards,
Joerg

On 03.10.19 10:10, Kuhn Nicolas wrote:
> Hi,
> 
> We are planning a side-meeting at next IETF on “Performance evaluation 
> of QUIC in various environments”.
> 
> The main idea is to gather people evaluating QUIC when it comes to 
> exploit paths with various characteristics – with a slight focus for 
> high BDP networks.
> 
> Evaluations of QUIC over satellite has been presented in multiple IETF 
> sessions [1-5], but a dedicated session would enable to gather whoever 
> is interested in this activity.
> 
> [1] 
> https://datatracker.ietf.org/meeting/103/materials/slides-103-maprg-quic-and-satcom-nicolas-kuhn-01 
> 
> 
> [2] 
> https://datatracker.ietf.org/meeting/104/materials/slides-104-maprg-satellite-internet-performance-measurements-jorg-deutschmann-01 
> 
> 
> [3] 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-maprg-measuring-quic-dynamics-over-a-high-delay-path-01 
> 
> 
> [4] 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-panrg-quic-over-satellite-00
> 
> [5] 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-panrg-quic-over-in-sequence-paths-with-different-characteristics-00 
> 
>

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 09 Oct 2019 16:14:14 +0100

Hi,

Could you share the topic with us (what version of QUIC; what aspect 
were you testing) - so we can plan ahead and coordinate.

Gorry

On 09/10/2019, 16:07, Joerg Deutschmann wrote:
> _______________________________________________
> EToSat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/etosat

---

From: Joerg Deutschmann <[email-masked]>
Date: Wed, 9 Oct 2019 21:51:24 +0200

Hi,

in our latest measurements [1] we black-box tested different QUIC implementations and different European satellite operators. The QUIC implementations are quicly and ngtcp (both draft-22) and Chromium QUIC (Q046). The operators are Astra, Avanti and Tooway. We also added one testbed setup based on dummynet.

We requested a single 1 Mbyte object and plotted time-sequence diagrams (a) without packet losses and (b) with 1% random packet loss. We decrypted pcap traces (quicly and ngtcp) or used log files (Chromium Q046) to plot offset numbers and see retransmissions. Packet losses have a very negative impact which was already mentioned at previous meetings. There are performance differences among implementations as well as operators. Please refer to [1] for the graphs.

I think testing different implementations and operators is fine, but these black-box tests are somehow unsatisfying because they do not explain *why* there are differences. Especially while the implementations are work in progress. A more detailed analysis would be great, but we currently have very limited time available for the QUIC over satellite topic.

[1] www7content.cs.fau.de/~deutschmann/KaConf2019/KaConf2019_QUICoverSatellite_paper.pdf
(section 4 and 5)

Best regards,
Joerg

On 09.10.19 17:14, Gorry Fairhurst wrote:
>> I'd like to join but probably can't make it to Singapore. We have some 
>> limited results which I just sent to this mailing list...
>>
>> Best regards,
>> Joerg
>>
>>
>>

---

From: <[email-masked]>
Date: Thu, 10 Oct 2019 06:40:12 +0000

Hi
We may arrange remote participation
Emile

-----Message d'origine-----
De : EToSat [mailto:[email-masked]] De la part de Joerg Deutschmann
Envoyé : mercredi 9 octobre 2019 17:07
À : [email-masked]
Cc : Kuhn Nicolas
Objet : Re: [EToSat] Side-meeting on QUIC over high BDP ?

Dear Nicolas,

Best regards,
Joerg

On 03.10.19 10:10, Kuhn Nicolas wrote:
> exploit paths with various characteristics - with a slight focus for 
> high BDP networks.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Joerg Deutschmann <[email-masked]>
Date: Mon, 14 Oct 2019 11:58:45 +0200

Hi Emile,

for me it is not necessary to have remote participation. Some minutes of 
the meeting would be great, though.

Joerg